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The information in this document is current as of August, 2000. The information is subject to 
change without notice.  For actual design-in, refer to the latest publications of NEC's data sheets or 
data books, etc., for the most up-to-date specifications of NEC semiconductor products.  Not all 
products and/or types are available in every country.  Please check with an NEC sales representative 
for availability and additional information.
No part of this document may be copied or reproduced in any form or by any means without prior       
written consent of NEC.  NEC assumes no responsibility for any errors that may appear in this document.
NEC does not assume any liability for infringement of patents, copyrights or other intellectual property rights of 
third parties by or arising from the use of NEC semiconductor products listed in this document or any other 
liability arising from the use of such products.  No license, express, implied or otherwise, is granted under any 
patents, copyrights or other intellectual property rights of NEC or others.
Descriptions of circuits, software and other related information in this document are provided for illustrative 
purposes in semiconductor product operation and application examples. The incorporation of these 
circuits, software and information in the design of customer's equipment shall be done under the full 
responsibility of customer. NEC assumes no responsibility for any losses incurred by customers or third 
parties arising from the use of these circuits, software and information.
While NEC endeavours to enhance the quality, reliability and safety of NEC semiconductor products, customers 
agree and acknowledge that the possibility of defects thereof cannot be eliminated entirely.  To minimize 
risks of damage to property or injury (including death) to persons arising from defects in NEC 
semiconductor products, customers must incorporate sufficient safety measures in their design, such as 
redundancy, fire-containment, and anti-failure features.
NEC semiconductor products are classified into the following three quality grades:
"Standard", "Special" and "Specific".  The "Specific" quality grade applies only to semiconductor products 
developed based on a customer-designated "quality assurance program" for a specific application.  The 
recommended applications of a semiconductor product depend on its quality grade, as indicated below.  
Customers must check the quality grade of each semiconductor product before using it in a particular 
application.
 "Standard": Computers, office equipment, communications equipment, test and measurement equipment, audio

and visual equipment, home electronic appliances, machine tools, personal electronic equipment
and industrial robots

"Special": Transportation equipment (automobiles, trains, ships, etc.), traffic control systems, anti-disaster
systems, anti-crime systems, safety equipment and medical equipment (not specifically designed
for life support)

"Specific": Aircraft, aerospace equipment, submersible repeaters, nuclear reactor control systems, life
support systems and medical equipment for life support, etc.

The quality grade of NEC semiconductor products is "Standard" unless otherwise expressly specified in NEC's 
data sheets or data books, etc.  If customers wish to use NEC semiconductor products in applications not 
intended by NEC, they must contact an NEC sales representative in advance to determine NEC's willingness 
to support a given application.
(Note)
(1) "NEC" as used in this statement means NEC Corporation and also includes its majority-owned subsidiaries.
(2) "NEC semiconductor products" means any semiconductor product developed or manufactured by or for

NEC (as defined above).

•

•

•

•

•

•
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Regional Information
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•  Device availability

•  Ordering information
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INTRODUCTION

Target Readers This manual is intended for user engineers who design and develop application

systems of the 78K/0S and 78K/0 Series.

Purpose This manual explains the functions of the SM78K0S and SM78K0 in the following

organization.

Organization This manual consists of the following chapters:

• General

• Installation

• Starting and exiting

• Functions of SM78K0S and SM78K0

• Association with project manager

• Window reference

How to Use This Manual It is assumed that the readers of this manual have a general knowledge of electrical

engineering, logic circuits, microcontrollers, C language, and assemblers.

To understand the functions of the 78K/0S and 78K/0 Series

→ Refer to User’s Manual — Hardware  for each product.

To understand the instruction functions of the 78K/0S and 78K/0 Series

→ Refer to 78K/0S, 78K/0 Series User’s Manual — Architecture .

Caution Unless specified otherwise, “SM78K0” is used to describe items

common to both the SM78K0S and SM78K0.

Conventions Data significance: Higher digits on the left and lower digits on the right

Note Footnote for item marked with Note  in the text

Caution Information requiring particular attention

Remark Supplementary information

Numeric notation Binary… ×××× or ××××B

Decimal… ××××
Hexadecimal…××××H

Prefixes indicating power of 2 (address space, memory capacity):

K (kilo): 210 = 1,024

M (mega): 220 = 1,0242

G (giga): 230 = 1,0243

Key descriptions: The key descriptions in this manual are explained in

terms of the PC-9821 series keyboard.  When using a

keyboard whose key descriptions differ from the above,

use the keys in accordance with the descriptions in

APPENDIX  D   KEY  FUNCTION  LIST .
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Related Documents The documents related to this manual are listed below.

The related documents indicated in this publication may include preliminary versions.

However, preliminary versions are not marked as such.

Documents related to development tools for 78K0S and 78K0 (user’s manuals)

Document Name Document Number

Operation U11816ECC78K0S (C compiler)

Language U11817E

Operation U11517ECC78K0 (C compiler)

Language U11518E

Operation U11622E

Language U11599E

RA78K0S (assembler package)

Structured Assembler Language U11623E

Operation U11802E

Language U11801E

RA78K0 (assembler package)

Structured Assembler Language U11789E

SM78K0S, SM78K0 (system simulator) Operation Windows Based This manual

SM78K Series (system simulator) External Part User Open Interface

Specifications

U10092E

ID78K0S-NS (integrated debugger) Reference Windows Based U12901E

ID78K0-NS (integrated debugger) Operation Windows Based U14379E

ID78K0 (integrated debugger) Reference Windows Based U11539E

Fundamentals U11537E78K/0 Series real-time OS

Installation U11536E

MX78K0S (78K/0S Series OS) Fundamental U12938E

MX78K0 (78K/0 Series OS) Fundamental U12257E
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CHAPTER  1    GENERAL

1.1  Overview

The SM78K0 system simulator (hereafter referred to as “SM78K0”) is a software tool, developed for NEC’s 78K/0

Series 32-bit microcontroller for embedded control applications, to simulate the user programs efficiently.

The SM78K0 features an easy-to-understand GUI (Graphical User Interface) on a host machine using Windows as

the operating system.

Moreover, the commands that are frequently used can be started by clicking the mouse, providing an environment

with excellent operability.

1.2  Features

The features of the SM78K0 are as follows.

(1) Evaluation without target

By simulating the operations of the target device including the internal peripheral unit operation and interrupt

servicing as well as the operation of CPU itself, the logic of the user program can be debugged without an in-

circuit emulator at an early stage.

(2) Supports integrated debugging environment

While maintaining the same operability as an in-circuit emulator.

(3) Various simulation functions

(a) External components

By using standard “external components” of peripheral I/Os and I/O blocks used as GUI, such as LEDs,

key matrixes, and motors, the simulated environment of the target system can be easily organized.  The

external components can input or output data during simulation.

(b) Architecture of user target system

The user logic section in the target system allows user-based architecture (programming) by means of a

user-open interface.

(c) Data input function

Data with timing information created with two types of input editors can be input during simulation.  The

output result can be displayed as timing charts.

(d) SFR event and action setting functions

Interrupts can be generated and data can be set at any time by using events set to SFRs and addresses.
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1.3  System Configuration

The SM78K0 can debug user programs developed for the 78K/0 Series by simulating the operation of the target

device without an in-circuit emulator.

Moreover, standard “parts” to simulate the target system are also provided with the SM78K0, so that you can

develop the software without having to wait for the completion of production of the target system.

(1) Example of system configuration

Figure 1-1 shows an example of system configuration of the SM78K0.

Figure 1-1.  SM78K0 System Configuration Example

SM78K0

Host machine

Device
file

(2) Configuration of SM78K0

The SM78K0 consists of the following 2 parts.

• Debugger section

• Simulator section

When the SM78K0 is started up, the debugger section and simulator section main windows are automatically

opened (as buttons on the taskbar).

All windows and dialog boxes are activated from these main windows.
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1.4  Operating Environment

To use the SM78K0, the following hardware and software environments are necessary.

1.4.1  Hardware environments

(1) Host machine

• PC-9821 series

• PC98-NX series

• IBM PC/ATTM or compatibles

(2) CPU

• Pentium™ 100 MHz or faster (120 MHz or faster recommended)

(3) Memory

• RAM: 32 MB or more (64 MB or more recommended)

1.4.2  Software environments

(1) OS

Windows 95, Windows NT™ (Ver. 4.0), and Windows 98

(2) Device file

Device file of target device to be used

1.5  Note for Debugging at Source Level

When debugging at source level, add an option (-g option) that creates debugging information after the source files

have been compiled.  If this is not done, debugging cannot be performed in the source level.
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CHAPTER  2    INSTALLATION

This chapter explains how to install/uninstall the SM78K0 and to customize the environment setting file of it.

2.1  Installing SM78K0

Before using the SM78K0, it is necessary to install the SM78K0 and a device file.

2.1.1  Device file

To install the device file, use the dedicated installer "DFINST.EXE" supplied with the SM78K0.  This installer allows

the device file to be installed in the Win32 environment.

The installer "SETUP.EXE" on the disk of the device file is compatible with the Win16 environment and registers

the device file information in "NECDEV.INI".  In the Win32 environment of the SM78K0, be sure to use "DFINST"

because it is necessary to register the device file information in the registry.

The procedure for installing the device file is explained below.

<1> Start "DFINST.EXE".  To install a new device file, click  install  on the opening screen that is displayed after

the installer has been started, and select the install information file "NECSETUP.INI" from the device file

product disk.

To move a device file already registered in "NECDEV.INI" to the Win32 environment, select "Select Source"

in DFINST and specify "NECDEV.INI".  Select a model from those displayed in the "Source" field, and click

 Move .

To uninstall the device file, select a model from those displayed in the "Registry" field in DFINST, check

"Delete File", and then click  UnRegister .

2.1.2  SM78K0

(1) Notes on installation

<1> Create a backup of the system disk before installation.  Because it may be necessary to restart the

computer after installation, terminate all other applications.

<2> Do not install SM78K0 V2.xx in a directory in which SM78K0 V2.xx or earlier is installed.  Because the

versions before V2.xx support Win16, if SM78K0 V2.xx, which supports Win32, exists in the same

location as an old version, the software may not operate correctly.

<3> To reinstall the SM78K0, uninstall the copy of the SM78K0 already installed.  If the SM78K0 is installed

in a different directory without uninstalling the first copy of the SM78K0, the first copy of the SM78K0

already installed cannot be uninstalled.
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<4> Do not install the SM78K0 in a directory with a name containing a space, otherwise the related tools,

such as the project manager, that are installed in the same directory as this product may not be

correctly executed, depending on their version.

<5> The following file will be created after the SM78K0 has been installed.  This file is necessary for

uninstalling the SM78K0 and must not be deleted (the installation destination is assumed to be

C:\NECTools32).

C: \NECTools32\SETUP\*. *

<6> "comctl32.dll 4.72 install" (40comupd.exe) is registered in the program folder in which the SM78K0

has been installed.  This program is used to update the comctl32.dll file used by the SM78K0.  If

problems such as application errors or incorrectly displayed dialog boxes occur when using the

SM78K0, install comctl32.dll by using "comctl32.dll 4.72 install".  This program, however, is not

necessary if Windows 98 and Microsoft Internet Explorer 3.0 or later are installed.

2.1.3  Installation procedure

This section explains the installation procedure, assuming that Windows is installed in the directory "C:\Windows"

and that the floppy disk is drive 'A'.

<1> Turn on power to the host machine (PC-9821 or IBM PC/AT) and start Windows.

<2> <When the medium is a 3.5” FD>

Insert SM78K0 system disk #1 into the floppy disk drive (drive A) and run "setup.exe".

<When the medium is a CD-ROM>

Insert the CD-ROM in the CD-ROM drive. The installer is started automatically.

If it does not start automatically, start the program “SM78K0/DISK1/setup.exe” from directory DISK1.
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<3> The setup program will be started after setup initialization.  Click  Next > .  To stop installation, click

 Cancel .

<4> To install the SM78K0, click  Yes  when the software license agreement screen is displayed.  To stop

installation, click  No .  To return to the previous screen, click  < Back .
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<5> Enter the serial number. The serial number is shown on the CD package or FD label.

<6> Select the item to be installed and the drive and directory for installation.  Uncheck the components that are

not to be installed.  The drive and directory in which the SM78K0 is to be installed are C:\NECTools32 by

default.  It is recommended that the default drive and directory be used, especially when the other NEC

tools are used.  To change the drive or directory, click  Browse… .  After completing all settings, click

 Next > .  To stop installation, click  Cancel .  To return to the previous screen, click  < Back .
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<7> To install the SM78K0 for the first time, or after uninstalling a previously installed version of the SM78K0,

proceed to step <8>.

(a) If the SM78K0 has been already installed in the directory specified in <6>, the following message is

displayed:

If  Next >  is clicked, the following dialog box is displayed.  To uninstall the SM78K0, click  Yes .

If  No  is clicked, the SM78K0 is not uninstalled and the screen shown in step <8> below is displayed.
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(b) If the SM78K0 has been already installed in a directory other than that specified in step <6>, the

following message is displayed.

If  Next >  is clicked, the screen shown in step <8> below is displayed, and the uninstaller is not

executed.

<8> Specify the name of a folder in which the icons are to be registered.  The default folder name is

"NECTools32".  After specifying the folder name, click  Next > .  To stop installation, click  Cancel .  To

return to the previous screen, click  < Back .
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<9> The final confirmation before starting installation is displayed.  Click  Next >  if it is all right to start

installation with the settings made in steps <6> through <8> above.  If there are any problems, click

 < Back .  To stop installation, click  Cancel .
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<10> Copying the files is started.

<When the medium is a 3.5” FD>

A dialog box prompting you to replace the system disk will be displayed.  Replace the system disk with the

second disk, and click  OK .  Repeat the above procedure until the contents of system disk #5 have been

installed.

<When the medium is a CD-ROM>

This dialog box will not open.  The contents of directories “DISK1” through “DISK5” will automatically be

copied.

<11> Skip this step and proceed to <12> if no Win16-compatible versions of the NEC development tool

environment (default directory: NECTOOLS) exist on the host machine.

If a Win16-compatible development tool exists, the following dialog box is displayed.

If  Yes  is clicked, the device files used in the Win16-compatible development tool environment are

transferred to the Win32-compatible development tool environment (SM78K0 Ver.2.xx).  If  No  is clicked,

execute the device file installer "DFINST.EXE" to transfer the device files after the SM78K0 has been

installed.  Unless the device files are transferred, the SM78K0 will not execute correctly.

Display of

installation status

Message to exchange

the system disks
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<12> After the files have been copied, a dialog box indicating completion of setup will be displayed.  Click  OK .

This completes installation of the SM78K0.

<13> When the system disks have all been copied, the SM78K0 icon will be registered in the “NEC Tools” group.
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2.2  Uninstalling the SM78K0

This section explains how to uninstall the SM78K0, using “C:\WINDOWS” as the directory in which Windows is

installed.

<1> Turn on power to the host machine (PC-9821 or IBM PC/AT) and start Windows.

<2> Activate “Add/Remove Programs” from the control panel.

<3> Select “NEC SM78K0S 78K0S System Simulator Ex.xx” from the list displayed in “Install/Uninstall” and click

 Add/Remove… .
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<4> A dialog box for confirming the deletion of files will be displayed.  Click  Yes .

Deletion of the files will be started.

<5> While files are being deleted, you will be asked to confirm whether to remove certain files.

Click  Yes To All  in response .  (If you click  Yes , you may need to repeat this many times.  Even if  No  is

selected at this time and the file is not deleted, the file will be overwritten with the latest version when

SM78K0 is installed again.)
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<6> When the completion message is displayed, click  OK .

This completes uninstalling the SM78K0.
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CHAPTER  3    STARTING  AND  EXITING

This chapter explains how to start and exit the SM78K0.

3.1  Starting

The start method is as follows:

<1> Start Windows.

<2> Double-click the shortcut icon of the SM78K0 on the desk top to start up the SM78K0 (See Figure 3-1 ).

The Configuration dialog box will be displayed (See Figure 3-2 ).

Figure 3-1.  SM78K0 Icon

Figure 3-2.  Configuration Dialog Box on Starting

<3> Operating environment parameters for the SM78K0 are set in this dialog box (For details, refer to

CHAPTER 6  WINDOW REFERENCE).  After setting the parameters, click  OK  on the dialog box.
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<4> The Main window will then be opened (See Figure 3-3 ).

Furthermore, the 78K/0 Simulator GUI button will be displayed on the Windows taskbar (See Figure 3-4 ).

Clicking this button will open the simulator section’s main window (78K/0 Simulator GUI window).

Operations concerning peripheral simulation and external parts are all carried out from this window.

Figure 3-3.  Main Window

Figure 3-4.  78K/0 Simulator GUI Button

Caution Problems such as the occurrence of application errors and dialog boxes not displaying

data correctly are sometimes experienced when the SM78K0 is started up, or while it is in

use.  One cause of such problems may be that an old version of comctl32.dll, which comes

with Windows 95, is being used.  If this is the case, it will be necessary to update

comctl32.dll using the comctl32.dll 4.72 Installer (40comupd.exe) included in the system

disks.

Note that if Microsoft Internet Explorer 3.X or 4.X has been installed, this update is

unnecessary.

Figure 3-5.  comctl32.dll 4.72 Installer

Tool Bar Menu bar

Window Display Area

Status Display Area
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3.2  Exiting

The exit method of SM78K0 is as follows:

<1> In the main window, select [File] → [Exit] or in the SM78K0 main window, select [File] → [Exit]

→ The following Exit Debugger dialog box will be displayed.

Figure 3-6.  Exit Debugger Dialog Box

<2> To save the current debugging environment in the project file, check the check box “� Save Project file”.

<3> Click  OK .

If the check box is checked in (2), the Save As dialog box is opened, the current debugging environment is

saved in the project file, all the windows are closed, and then the SM78K0 is exited.

If the check box is not checked, all the windows are closed and then the SM78K0 is exited.
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CHAPTER  4    FUNCTION  OF  SM78K0

This chapter details the functions of SM78K0 simulation (external parts, data input function, SFR event & action

function) and of debugging.

4.1  External Parts

The SM78K0 supplies standard “external parts” such as peripheral I/Os and I/O blocks as icons. Using these parts,

a dummy target system can be organized.

Figure 4-1.  Example of SM78K0 External Parts

Button Key matrix LED Level gauge 14-segment LED

7-segment LED
DC motor

Buzzer
Reset button

Internal interrupt button

Serial GUI window
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The SM78K0 supplies the following external parts:

Table 4-1.  External Parts Supplied with SM78K0

External Part Name Description

Button A button can be connected to any pin.  By pressing the displayed button, an input value can be

given to the pin.

Key matrix A key matrix can be connected to any pin, so that data can be input by pressing two or more keys.

Internal LCD Can display the output status of a pin connected to the LCD controller/driver incorporated in the

device to be debugged in pictures or characters.

Internal FIP Can display the output status of a pin connected to the FIP controller/driver incorporated in the

device to be debugged in pictures or characters.

LED An LED can be connected to any pin to indicate the output of the pin by lighting or extinguishing.

Level gauge Any value in a specified range can be given to a pin connected to the A/D converter.

7-segment LED Any eight pins (seven pins for displaying numerals and one pin for the decimal point) are allocated

to a 7-segment LED and one pin is allocated to a digit signal, so that the display of the 7-segment

LED changes depending on the value of each pin.

The corresponding 7-segment LED lights or extinguishes if the output of the pin allocated to the

digit signal is active.

DC motor A DC motor can be connected to any pin, and revolution or stopping of the DC motor shows the

output value of the pin.  The total time during which an active value is output is counted from the

beginning of simulation and is displayed.

BuzzerNote A buzzer can be connected to any pin, and the output status can be indicated by the buzzer sound

or by a change in the bitmap.

Reset button Hardware reset is executed by clicking the displayed reset button.

14-segment LED Any 15 pins (14 pins for displaying numerals and one pin for the decimal point) are allocated to a

14-segment LED and one pin is allocated to a digit signal, so that the display of the 14-segment

LED changes depending on the value of each pin.

The corresponding 14-segment LED lights or extinguishes if the output of the pin allocated to the

digit signal is active.

Internal interrupt button Any internal interrupt can be connected to a button.  By pressing the displayed button, the internal

interrupt can be generated.

Pull-up/pull-down setting Whether a pin is connected to a pull-up/pull-down resistor

Serial GUI The operation mode and I/O information of the serial interface can be displayed.

Note To issue a buzzer sound, however, a sound board and a speaker are necessary.

Remark Depending on the device to be debugged, some external parts are unable to be selected.
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4.1.1  Creating external parts

The external parts are created in the Parts window (p.385).

Connection between the external parts and pins are made in the dialog box that is opened by the [Parts] menu on

the Parts window, or by clicking buttons on the tool bar

For the details of setting, refer to the explanation on each dialog box.

Figure 4-2.  Parts Window

4.1.2  Displaying I/O manipulation and I/O results with external parts

External parts whose setting has been completed on each dialog box are displayed on the Parts window and serve

as an inlet for signals during simulation.

By using these displayed parts, the I/O results can be checked and input values can be given to the simulator.

For details of the I/O manipulation of each external part, refer to the description of the setting dialog box for each

part.  I/O manipulation is executed with the Parts window in the execution mode.
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4.1.3  Operations of external parts at CPU reset

Table 4-2 shows the operations of the respective external parts when a CPU reset is generated from the debugger.

Table 4-2.  Operations of External Parts at CPU Reset

External Parts Operation at CPU Reset

Button Inactive status

Key Not pressed

LCD All enter the white display state when Bit Image is selected, and all enter the

no-display state when Customize is selected.

FIP All enter the white display state when Bit Image is selected, and all enter the

no-display state when Customize is selected.

LED Inactive status

7-/14-segment LED Displayed in white

Level gauge Input value of 0.  Scroll sum of scroll bar is at leftmost position, and operation

point of dial is at lower left.

DC motor Inactive status with total number of clocks being 0

Buzzer Inactive status

Internal interrupt button Not pressed

Serial GUI Initial status

4.1.4  Editing on Parts window

On the Parts window, parts can be moved, characters, lines, and rectangles can be written, and the bitmap of the

external parts can be changed.  For editing, select [Mode] → [Edit] on the Parts window.  As a result, the Parts

window is set in the edit mode in which editing can be carried out.

In the edit mode, the mouse cursor changes to “+”, and a window that indicates the pointer position of the mouse

with coordinates (x, y) pops up, and editing is enabled.

For the details of editing operations, refer to the description of the Parts window (p.385).
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4.2  Data Input Function

The SM78K0 can input data with timing information to input pin created by using two types of input editors, during

simulation.  The result output from the simulator can be saved, and can be displayed as a timing chart.

4.2.1  Creating/editing input data

The data file with timing information is created or edited in the Input 0/1 Editor window or Input timing Chart Editor

window.

(1) Input 0/1 Editor window (see p.361)

Data to be input to a pin at any timing is set as a numeric value in 1 bit units.  A wait value (input timing) or

data input can be set by using a loop.

Figure 4-3.  Input 0/1 Editor Window
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(2) Input timing Chart Editor window (see p.367)

Input timing and input data are set as a timing chart. Data can be set by setting wait values (input timing) or

by using a time axis.

Figure 4-4.  Input timing Chart Editor Window

The created data are saved as input data files.  Specify any of the following extensions when saving the data and

specify the timing of the wait value.

.i_0 ... File in which the timing of data input is described at the execution timing of an instruction that accesses a

specific pinNote.

.i_1 ... File in which the timing of data input is described in CPU clock units.

.i_2 ... File in which the timing of input data is described in units of 1/4 main clock.

.i_3 ... File in which the timing of input data is described in units of main clock.

Note In this file, the wait value which has been set is ignored.
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4.2.2  Downloading of input data file

An input data file is downloaded in the Down Load dialog box (see p.374).

Figure 4-5.  Down Load Dialog Box

By downloading the input data file (.i_x), an input signal from an external source is set to a pin.

When the input data file is downloaded, a file having the same file name except the file identifier can be

downloaded at the same time for simulation.  Up to five files can be downloaded including event condition file (see

p.48).

Files can be downloaded at any time, unless the CPU is operating. The priority of input data is higher if the data is

input laterNote.

Note If an input data file is downloaded while an input external part is displayed, input from the input data file

takes precedence.  If an external part for input is displayed while an input data file is downloaded, input

from the external part takes precedence.
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4.2.3  Processing when input data is not set

If a pin which is not described in an input data file (.i_x), and whose value is undefined because pull-up processing

is not performed, is accessed during program execution, initialize the value of the pin to 0.  In this case, the initial

value message will be displayed in message area of the simulator main window.

The pull-up/pull-down processing can be set in advance by the Pull-Up/Pull-Down window (see p.453).

Figure 4-6.  Pull-Up/Pull-Down Window

4.2.4  Output to output data file and data display

The output status can be output to a file in the Output Setting dialog box (see p.376).  If the timing chart output is

checked in the Output Setting dialog box, the Output Timing Chart window (see p.378) is opened, and the output

status can be displayed on a timing chart.

An identifier (.out) is automatically appended to the output file.

Figure 4-7.  Output Timing Chart Window

Because the data input to the SFRs, as well as the output data from the SFRs, can be also saved to the output file,

the I/O status can be later checked.
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4.3  SFR Event & Action Setting Function

The SM78K0 can generate an interrupt at any timing, or set any data to any address, SFR, or pin after a specified

event condition has been satisfied, by specifying an event set to any SFR or address as a trigger.  These settings are

reflected during simulation.

4.3.1  Setting event and action

An event condition and the operation (action) to be performed after the event condition has been satisfied are set in

the SFR Event & Action window (see p.357).

Figure 4-8.  SFR Event & Action Window

As an event condition, any address, register name, access status, or access size, or data condition or mask

condition can be specified.

As an action, an interrupt can be generated at specified timing, or any data can be set to a specified address

(address, SFR, or pin).

The specified event condition and action are saved to an event condition file (.evn).
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4.3.2  Downloading event condition file

The specified event condition file is downloaded in the Down Load dialog box (see p.374).

Figure 4-9.  Down Load Dialog Box

By downloading the event condition file (.evn), an event is registered to the simulator, and the event can be

checked during simulation.
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4.4  Debugging Functions of SM78K0

The debugging functions of the SM78K0 are almost the same as those of the ID78K0.  However, they are slightly

different because the SM78K0 implements debugging through software, without using an in-circuit emulator.

(1) Differences in mapping functions

The SM78K0 virtually manages a contiguous memory space same as that of the target device specified on

the Configuration dialog box, by allocating an alternate memory on the host machine.

In this way, the size of the internal ROM/RAM area can be changed, or any memory area can be mapped as

an emulation ROM/RAM area.

Figure 4-10 shows the target memory space when the µPD78001 is specified as the CPU in the

Configuration dialog box.

Figure 4-10.  Memory Space Managed by SM78K0 ( µµµµPD78001)
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(2) Differences in event functions

This function has the following features.

• An event condition of the same name can be set to two or more event conditions.

• Up to 80 break event conditions can be set.

• Setting of external sense data is invalid.

• Pass count can be set.

(3) Differences in break function

• A software break event condition cannot be set.

(4) Differences in timer function

This function has the following features.

• Eight timer event conditions can be set.

• The average/maximum/minimum/estimated simulation time in a zone specified by a timer event condition

can be measured.

(5) Differences in trace function

This function has the following features.

• The size of the trace capacity can be specified.

• 0 frames to 16M frames

• Display of block information

• Display type of trace mode

A ... All trace or section trace

Q ... Qualify trace

S ... Step execution trace

• Display of branch destination address
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CHAPTER  5    ASSOCIATION  WITH  PROJECT  MANAGER

This chapter explains the procedure and notes on using the functions associated with the Project Manager.  The

SM78K0 can automatically perform a sequence of tasks such as creating a program, compiling, debugging, and

correcting the program, in association with the Project Manager  (PM).

To debug a load module file created in the PM at the source level, confirm that the item [Option] → [Debug] is

checked for building.

Caution When a load module file is created by using an MS-DOS TM prompt, the functions of the SM78K0

associated with the PM cannot be used.

5.1  Debugger Registration in PM Project

Either of the debuggers for SM78K0/ID78K0 can be specified for each project in the PM.

The selection procedure is explained below.

5.1.1  Debugger selection

The procedure for selecting the debugger is as follows.

<1> Select [Project] → [New] in the PM and create the new project for PM.  Alternatively, read an existing PM

project by selecting [Project] → [Open…]

→ For details of the setting items, refer to the online help or User’s Manual.

<2> Select [Option] → [Select debugger…] from the PM menu bar.

→ This opens the Select debugger dialog box.  Figure 5-1 shows the Select debugger dialog box.

Figure 5-1.  Select Debugger Dialog Box (PM)
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<3> Either select “78K/0 System Simulator” from the debugger list, or specify the execution file name

(SMK032.EXE) for the debugger file name.

<4> Click  OK .

→ SM78K0 will now be registered as the project debugger of the open PM.

The SM78K0 icon will also be displayed on the PM tool bar.

5.2  Starting Up SM78K0 from PM

One of the following 3 methods can be used to start up the SM78K0 from the PM.

(1) Click the SM78K0 startup button on the PM toolbar.

(2) Select [Build] →  [Debug] from the PM menu bar.

(3) Alternatively, click the batch-processing button on the PM tool bar (however, the SM78K0 will start up only if

Build has finished normally).

5.2.1  Reproducing the debug environment

By following the procedure shown below, it is possible to reproduce the debug environment of the previous time the

SM78K0 was started up from the PM.

<1> Create a new project fileNote with the PM (eg: aaa.prj).

Note Use the project file to save and reference the environment data for the debugger (SM78K0, ID78K0)

and the PM.  The project file extension when dealing with the debugger and PM is prj.  Refer to the

online help or user’s manual of each product regarding the data that is saved and reproduced using a

project file.

<2> Start up the SM78K0 from the PM.

<3> Debug the target device with the SM78K0.

<4> When the SM78K0 has finished debugging, check [Save project file] in the Exit Debugger dialog box and

exit the SM78K0.

→ The debug environment at the completion of SM78K0 debugging is saved to the aaa.prj file (the debug

environment can also be saved to the aaa.prj file at times other than the completion of SM78K0

debugging).

<5> When the SM78K0 is next started up after the aaa.prj file is read by the PM, the debug environment saved

in <4> above is automatically reproduced.

→ The project file currently being used by the PM (aaa.prj) is automatically read when the SM78K0 is

started up.
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5.3  Correction and Auto Load of Source File

If a bug is found as a result of debugging using the SM78K0, compiling and re-downloading can be automatically

executed as well as editing the source file with the SM78K0 started with the following procedure.

Caution If [Option] →→→→ [Project Manager Options...] is selected in the PM, and if an editor other than the

standard editor is selected, this processing cannot be performed.

<1> Read the source file to correct with the SM78K0 to the Source window.  With the Source window displayed

at the foremost position, select [File] →[Open] on the main window to specify the corresponding file (if the

corresponding file has already been displayed in the Source window, activate the window).

→ The corresponding file is displayed in the Source window.

<2> Select [Edit] → [Edit Source] in the SM78K0 main window.

→ The corresponding file is automatically read to the standard editor and is opened.

<3> Correct the source file in the editor.

<4> Select [File] → [Save] in the editor and save the file.

<5> Select [File] → [Exit idea L] in the editor to terminate the editor.

→ As a result, the PM automatically executes compiling, assembling, and linking in accordance with the

settings of the project.  When these operations have been completed normally, the created load module

file is automatically downloaded to the SM78K0.

Cautions 1. If building is performed from the PM, the SM78K0 unconditionally executes symbol

reset.

2. The debug window, which was opened when the editor was called, and all event

settings are restored.  However, if the previously used lines and symbols have been

deleted because of source file correction, an error message will be displayed, and the

event corresponding to these lines and symbols cannot be used.
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[MEMO]
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CHAPTER  6    WINDOW  REFERENCE

This chapter explains in detail the functions of the windows and dialog boxes of the SM78K0.  For the configuration

and details of the types of the windows and dialog boxes, refer to APPENDIX B  TERMINOLOGY .

6.1  Window List

Table 6-1 lists the windows of the SM78K0 debugger.

Table 6-1.  Windows of SM78K0 Debugger (1/2)

Window Name Outline Page

Main window This window is displayed first when the simulator is started.

It controls execution of the user program.  In addition, various windows are opened

from this window.

p.59

Configuration dialog box Sets/display simulator environment. p.85

Extended Option dialog box Sets/display each extended option. p.89

Debugger Option dialog box This is where each option is displayed and set. p.94

Font dialog box This is where the type and size of the display font in the Source window is set. p.101

Project File Load dialog box Reads debugging environment. p.104

Project File Save dialog box Saves debugging environment. p.107

View File Load dialog box This is where the display files of each window and the source text and event

setting files are read.

p.110

View File Save dialog box This is where the display files of the current window and the event setting files are

saved.

p.113

Download dialog box This is where the object files, binary files, and coverage results are downloaded. p.118

Upload dialog box This is where the memory or coverage contents are saved to a file. p.122

Browse dialog box This is where the files to be set in the Debugger Option Setting or Source Search

dialog boxes are selected.

p.125

Source Move dialog box This is where the files to be displayed in the Source window and the display start

position are specified.

p.127

Address Move dialog box This is where the display start address for the Memory, Assemble, and Coverage

windows is specified.

p.130

Trace Move dialog box This is where the display start position for the Trace View window is specified. p.133

Symbol To Address dialog box This is where the addresses and symbol values of variables and functions are

displayed.

p.136

Source window Displays source text and source file. p.139

Source Search dialog box This is where a character string in a source file is searched. p.153

Assemble window Displays disassemble text and executes online assemble. p.156

Assemble Search dialog box This is where the contents of the Assemble window are searched. p.168

Memory window Displays/changes memory contents. p.171

Memory Search dialog box This is where the contents of the Memory window are searched. p.175

Memory Fill dialog box This is where the memory contents are initialized by specified data. p.178
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Table 6-1.  Windows of SM78K0 Debugger (2/2)

Window Name Outline Page

Memory Copy dialog box Copies memory contents. p.180

Memory Compare dialog box Compares memory contents. p.182

Memory Compare Result dialog

box

Displays result of comparison of memory contents. p.184

Watch window This is where variables are displayed and changed. p.186

Quick Watch dialog box This is where variable values are temporarily displayed and changed. p.191

Add Watch dialog box This is where variables to be displayed in the Watch window are registered. p.195

Register window This is where the contents of registers (program register, system register) are

displayed and changed.

p.198

SFR window Displays/changes contents of SFR. p.204

SFR Select dialog box This is where SFRs and I/O ports to be displayed in the SFR window are selected. p.208

Add I/O Port dialog box This is where I/O ports to be displayed in the SFR window are registered. p.212

Local Variable window Displays/changes local variable in current function. p.215

Stack window This is where the stack contents of the current user program are displayed and

changed.

p.217

Trace View window Displays trace result. p.221

Trace Search dialog box This is where trace data is searched. p.230

Trace Data Select dialog box This is where items to be displayed in the Trace View window are selected. p.237

Coverage window Displays coverage result. p.240

Coverage Search dialog box This is where coverage results are searched. p.245

Coverage - Clear dialog box This is where the coverage results are cleared. p.248

Coverage - Condition Setting

dialog box

This is where the coverage efficiency measurement range is set. p.250

Coverage - Efficiency View

dialog box

This is where the coverage results are displayed in terms of efficiency. p.254

Event Manager This is where each event is displayed, switched between enabled and disabled,

and deleted.

p.257

Event dialog box Registers/displays event condition. p.266

Event Link dialog box Registers/displays event link condition. p.280

Break dialog box Registers/sets/displays break event condition. p.291

Trace dialog box Registers/sets/displays trace event condition. p.299

Snap Shot dialog box Registers/sets/displays snap event condition. p.312

Stub dialog box Registers/sets/displays stub event condition. p.327

Timer dialog box Displays result of simulation time measurement and registers/sets/displays timer

event condition.

p.335

Timer Result dialog box This is where the results of the executed measurement are displayed. p.346

Reset Debugger dialog box Initializes SM78K0 and target CPU and symbol information. p.348

About dialog box Displays version of SM78K0. p.350

Exit Debugger dialog box Ends SM78K0. p.351
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The SM78K0 simulator section window list is shown in Table 6-2 below.

Table 6-2.  SM78K0 Simulator Section Window List

Window Name Outline Page

78K/0 Simulator GUI window Main window of simulator (SM78K0). p.353

SFR Event & Action window Sets/displays event and action for SFR and any address. p.357

Input 0/1 Editor window Sets input value to input pin (0/1 format). p.361

Input timing Chart Editor window Sets input value to input pin (timing chart format). p.367

Pin Setting dialog box Sets pin names displayed in the Input 0/1 Editor window, Input timing Chart Editor
window, and Output Timing Chart window.

p.372

Down Load dialog box This is where the input data files and event condition files are downloaded. p.374

Output Setting dialog box Saves file of output result from the output pin and displays timing chart. p.376

Output Timing Chart window This is where the pin I/O data and interrupt signal timing charts are displayed. p.378

Search window Searches I/O data. p.382

Parts window Sets/displays external parts. p.385

Buttons window Sets connection information on button and pin displayed in the Parts window. p.398

Key Matrixes window Sets connection information on key matrix and pin displayed in the Parts window. p.401

LCDs window Sets the built-in LCD display. p.404

LCD Panel window Displays the LCD bitmap image. p.407

Set LCD Pin dialog box Sets connection information on drawings and pins displayed in the LCD Panel
window.

p.416

FIPs window Sets the built-in FIP display. p.419

FIP Panel window Displays the FIP bitmap image. p.422

Set FIP Pin dialog box Sets connection information on drawings and pins displayed in the FIP Panel
window.

p.431

LEDs dialog box Sets connection information on LED and pin displayed in the Parts window. p.434

7seg LEDs window Sets connection information on 7-segment LED and pin displayed in the Parts window. p.437

Level Gauges window Sets connection information on level gauge and pin displayed in the Parts window. p.440

DC Motors window Sets connection information on DC motor and pin displayed in the Parts window. p.443

Buzzers window Sets connection information on buzzer and pin displayed in the Parts window. p.446

14seg LEDs window Sets connection information on 14-segment LED and pin displayed in the Parts
window.

p.448

Internal Interrupt Button window Sets connection information on internal interruption button and pin displayed in the
Parts window.

p.451

Pull-Up/Pull-Down window Sets connection information on pull-up/pull-down resistor pin displayed in the Parts
window.

p.453

Serial GUI window Displays I/O information on serial interface. p.455

Bitmap Entry window Registers/deletes bitmap files of the external parts displayed in the Parts window. p.457

Open dialog box Specifies file subject to operation. p.461

Save As dialog box Saves file subject to operation. p.463

Table 6-3.  List of Other Windows

Window Name Outline Page

Error/Warning dialog box Displays error/warning message. p.465
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6.2  Explanation of Windows

This section explains each window using the format shown below.

Window Name Window type

The window name and window type (mode type when dialog box) are indicated in the above frame.

General

Briefly explains the window.

Opening method

How to open the windows is explained.

Window

Shows the screen image of the configuration of the window.

Function

Explains each function of the window.

Function button

Explains the operations of the function buttons in the window.

Menu bar

Enumerates the menus pulled down from the menu bar, and explains the function of each menu.

Caution

Explains points of caution to be noted.
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Main Window

General

This window is automatically opened after the SM78K0 is started and initialization is complete.  It remains

displayed until the SM78K0 is terminated.  Various windows are opened and manipulated from this window.

Execution of the user program is also controlled in this window.  Execution of the user program can be controlled in

three modes: source mode, instruction mode, and auto mode.

• Source mode

Debugging is performed at the source level.

• Instruction mode

Debugging is performed at the instruction level.

• Auto mode

Switches automatically between the source mode and instruction mode.

When starting the SM78K0, the auto mode is assumed.

Window

Figure 6 -1.  Main Window

(1) Tool Bar

(3) Status Display Area

(2) Window Display Area
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Function

The Main window consists of the following areas.

• Tool bar

• Window display area

• Status display area

Each function is explained below.

(1) Tool bar

The tool bar consists of buttons that can execute frequently used commands with a single click.  Each button

is graphically displayed and easy to understand.  This button group can be switched between “Graphics-only

buttons” and “Graphics + Text buttons” by the Debugger Option Setting dialog box.  The function of each

button can be also executed using the menu bar in this window.  This tool bar is not shown when it is

specified not to be displayed by selecting [Option] → [Tool Bar] from the menu bar of this window.

Figure 6-2.  Tool Bar

Graphics-only tool bar

Graphics + Text tool bar

An explanation of each button is given below.

Stops execution of the user program.

The same function as [Run] → [Stop] on the menu bar.

After the emulation CPU is reset, this runs the user program simulation.

The same function as [Run] → [Restart] on the menu bar.

Runs the user program simulation without resetting the emulation CPU.

The same function as [Run] → [Go] on the menu bar.

Executes the program real-time until execution returns to the calling function.

The same function as [Run] → [Return Out] on the menu bar.

Used for step execution.

By clicking this button successively, the program is executed by as many steps as the number

of times this button is clicked.  Step execution is performed in line units in the source mode,

and in instruction units in the instruction mode.

The same function as [Run] → [Step In] on the menu bar.
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Executes the Next step (Simulates the program, regarding the function/call statement as one

step.).

By clicking this button successively, Next step execution is performed as many times as the

number of times this button is clicked.  Step execution is performed in line units in the source

mode, and in instruction units in the instruction mode.

The same function as [Run] → [Next Over] on the menu bar.

Resets the emulation CPU.

The same function as [Run] → [CPU Reset] on the menu bar.

Traces the user program in the opposite direction.

The same function as [Run] → [Step Back] on the menu bar.

Opens the Display File Load dialog box.

The same function as [File] → [Open…] on the menu bar.

Opens the Download dialog box.

The same function as [File] → [Download…] on the menu bar.

Opens the Project File Load dialog box.

The same function as [File] → [Project] → [Open…] on the menu bar.

Opens the Source window and displays the contents of the source text.

The same function as [Browse] → [SourceText] on the menu bar.

Opens the Assemble window and the user program is disassembled and displayed.

The same function as [Browse] → [Assemble] on the menu bar.

Opens the Memory window and the memory contents are displayed.

The same function as [Browse] → [Memory] on the menu bar.

Displays the watch contents.

Opens the Watch window.

The same function as [Browse] → [Watch] on the menu bar.

Opens the Register window and displays the contents of the registers.

The same function as [Browse] → [Register] on the menu bar.

Opens the SFR window and displays the contents of the SFR.

The same function as [Browse] → [Sfr] on the menu bar.

Displays the local variable contents.

Opens the Local Variable window.

The same function as [Browse] → [Local Variable] on the menu bar.

Opens the Stack window and displays the contents of the stack.

The same function as [Browse] → [Stack Trace] on the menu bar.
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Opens the Trace View window and displays the result of trace.

The same function as [Browse] → [Trace] on the menu bar.

Displays the coverage measurement results.

Opens the Coverage window.

The same function as [Browse] → [Coverage] on the menu bar.

Opens the Event Manager.

The same function as [Event] → [Event Manager] on the menu bar.

Performs event entry and settings.

Opens the Event dialog box.

The same function as [Event] → [Event…] on the menu bar.

Opens the Break dialog box and registers, sets, or displays break events.

The same function as [Event] → [Break…] on the menu bar.

Opens the Trace dialog box and registers, sets, or displays trace events.

The same function as [Event] → [Trace…] on the menu bar.

Opens the Timer dialog box, registers, sets, or displays timer events, and displays the result

of timer measurement.

The same function as [Event] → [Timer…] on the menu bar.

(a) Tool hint function

If the mouse cursor is pointed at any of the buttons on the tool bar, a tool hint pops up after a few

seconds.

Figure 6-3.  Example of a Tool Hint

(b) Moving the tool bar

By dragging tool bar with the mouse, it can be moved to any desired position within or outside the Main

window.
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(2) Window display area

This area displays various debug windows.

The displayed window can be changed in size or registered as an icon in this area.  The list of the windows

displayed in this area is as follows.

•  Source window •  Local Variable window

•  Assemble window •  Stack window

•  Watch window •  Trace View window

•  Memory window •  Coverage window

•  Register window •  Event Manager

•  SFR window

(3) Status display area

Figure 6-4.  Status Bar

This area displays the status of the simulator and debugger.

<1> Program name $ Source name # Line No.

Program name: Displays the program file name indicated by the value of the PC.

Source name: Displays the source file name shown by the PC value.

Line No.: Displays the line number shown by the PC value.

<2> Function name: Displays the function name indicated by the value of the PC.

<3> PC value: Displays the current PC value.

<4> CPU status: Displays the status of the CPU (target device).

Displays the character “|” as a delimiter if there are multiple states.

<5> IE status: Displays the status of the simulator (RUN, BREAK mode).

Displays the character “|” as a delimiter if there are multiple states.

<6> Break cause: Displays cause of break.

<7> STEP mode: Displays the step execution mode.

<8> Key input mode: Displays the key input mode.

<1> <2> <3> <4> <5> <6> <7> <8>
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The types of CPU statuses are shown below.

Table 6-4.  CPU Status Display Contents

Status Indication Meaning

STANDBY Currently in the standby mode

RESET Reset state

The types of IE statuses are shown below.

Table 6-5.  IE Status Display Contents

Status Indication Meaning

RUN Currently simulating a user program

STEP Currently simulating a step

TRC Currently operating a trace

TIM Currently operating a timer

COV Currently operating Coverage

BACK RUN Currently performing back execution

BACK STEP Currently performing back step execution

BREAK Break

The causes of a break are as follows.

Table 6-6.  Display Contents of Break Cause

Displayed Cause Meaning

Manual Break Forcibly break

Temporary Break Temporary break

Event Break Break by event

Trace Full Break Break by trace full

Non Map Break Access in non-map area

Write Protect Write access to write-protected area

SFR Illegal Illegal access to SFR

Stack Overflow Break by stack overflow

Uninitialize Mem read Read access to uninitialized memory
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The types of STEP modes are shown below.

Table 6-7.  STEP Modes

STEP Mode Meaning

SRC STEP simulation is in the source mode.  This is displayed

when [Option] → [Source Mode] in the menu bar is selected.

INST STEP simulation is in the instruction mode.  This is displayed

when [Option] → [Instruction Mode] in the menu bar is

selected.

AUTO STEP simulation is in the auto mode.  This is displayed when

[Option] → [Auto Mode] in the menu bar is selected.

The types of key input modes are shown below.

Table 6-8.  Key Input Modes

Key Input Mode Meaning

INS Displayed when key input is in the insert mode.

OVR Displayed when key input is in the overwrite mode.
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(a) Menu explanation display function

While selecting a menu item on the menu bar with the mouse, a simple explanation of the reverse

highlighted item in the menu is displayed on the left end of the status bar.  Also, when the mouse cursor

is pointed at any of the buttons on the toolbar, a menu explanation corresponding to that button is

displayed.

Figure 6-5.  Example of Menu Explanation Display
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Menu bar

(1) File

Figure 6-6.  File Menu Bar

[Open…] This loads the display file or a source file or text file.

Opens the Display File Load dialog box.

Operation differs depending on the file extension selected in the dialog box.

When a display file: Files are displayed in the Source window.

When an event setting file (.evn): The Event Manager is opened and the

event is set.

Other than above (.S, .C, .txt, .svw): Files are displayed in the Source window.

[Save As…] Saves the displayed contents of the current window in a display file under

another name.

Opens the display file save dialog box.

[Close] Closes the current window.

[Download…] Downloads the user program.

Opens the Download dialog box.

[Upload…] Uploads the user program.

Opens the Upload dialog box.

[Project ] Operates a project file.

[Open…] Reads the contents of the project file.

Opens the Project File Load dialog box.

[Save] Overwrites the current status to the project file.

The file to be overwritten is selected by selecting [File] → [Project] → [Open

Project…] from the menu bar, or [Save As…].
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[Save As…] Saves the current status in the project file.

Opens the Project File Save dialog box.

[Debugger Reset…] Resets the target CPU, symbols and debugger.

Opens the Reset Debugger dialog box.

[Exit] Terminates the debugger.  Opens the Exit Debugger dialog box.

[Open File] Displays a list of the names of files that can be downloaded.

If a file name is selected, that file is downloaded.

(2) Edit

Figure 6-7.  Edit Menu Bar

[Cut] Cuts the selected character string and places it in the clipboard buffer.

[Copy] Copies the selected character string to the clipboard buffer.

[Paste] Pastes the contents of the clipboard buffer at the text cursor position.

[Write in] Writes corrections to the target.

[Restore] Cancels the correction.

[Memory ] Manipulates the memory contents.

[Fill...] Initializes the memory contents.

Opens the Memory Fill dialog box.

[Copy...] Copies values from memory to memory.

Opens the Memory Copy dialog box.

[Compare...] Compares values between memories.

Opens the Memory Compare dialog box.

[Edit Source] When the Project Manager is operating, opens the source file displayed in an

active Source window by using the editor specified by the Project Manager.
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(3) View

The items displayed in the display menu differ according to whether the window is active or not.  An

explanation of each dependent part is given in (b) to (k).

Figure 6-8.  View Menu Bar

Source Window Register Window Local Variable Window

Stack Trace Window

Assemble Window

Memory Window

SFR Window Coverage Window

Event Manager

Watch Window

Trace Window
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(a) Common part

[Search…] Searches character strings and numeric values.  Opens the Search dialog box

according to the current window.

Performs the same operation as the  Search  button.

[Move…] This moves the display position.  It opens the Source Move dialog box,

Address Move dialog box or Frame Move dialog box corresponding to the

current window.

[Quick Watch…] Displays the contents of the specified data temporarily.  Opens the Quick

Watch dialog box.

[Add Watch…] Adds the specified data to the Watch window.  Opens the Add Watch dialog

box.

[View Watch] Adds the selected data to the Watch window.  In the case of a symbol, it adds

it in accordance with the settings in the Debugger Option Setting dialog box.

[Delete Watch] Deletes the selected watch point from the Watch window.  This menu is active

only when variables are specified in the Watch window.

[Symbol…] Displays the address of the specified variable or function and the value of the

specified symbol.  Opens the Symbol To Address dialog box.

(b) Source window dependent part

[Event?] Displays the cursor position line or the address’s event information.  If an event

is set, it opens the Event dialog box.

[Mix] Switches between assemble display mixed display and no display.

No check mark (“ ”) : There is no mixed display (default).

Check mark ( “√”): There is a mixed display.

(c) Assemble window dependent part

[Event?] Displays event information for the cursor position address.  If an event is set, it

opens the Event dialog box.

(d) Memory window dependent part

[Bin] Displays the current window in binary.

[Oct] Displays the current window in octal.

[Dec] Displays the current window in decimal.

[Hex] Displays the current window in hexadecimal (default).
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[Nibble] Displayed in 4-bit units.

[Byte] Displays data in 8-bit units (default).

[Word] Displays data in 16-bit units.

[Double Word] Displays data in 32-bit units.

[Ascii] Turns ON/OFF display of ASCII characters.

No check mark (“ ”): Not displayed.

Check mark ( “√”): Displayed (default).

(e) Watch window dependent part

[Bin] The selected item is displayed as a binary number

[Oct] The selected item is displayed as an octal number.

[Dec] The selected item is displayed as a decimal number.

[Hex] The selected item is displayed as a hexadecimal number.

[String] The selected item is displayed as a character string.

[Proper] The selected item is displayed as the standard value for each variable.  In the

case of symbols, they are displayed in accordance with the settings in the

Debugger Option Setting dialog box (default).

[Byte] The selected item is displayed in 8-bit units.

[Word] The selected item is displayed in 16-bit units.

[Double Word] The selected item is displayed in 32-bit units.

[Adaptive] The selected item is displayed as standard values for each variable.  In the

case of C language symbols, only this item is valid.  In the case of assembler

symbols, they are displayed in accordance with the settings in the Debugger

Option Setting dialog box.

[Up] The selected data is moved 1 line up.

[Down] The selected data is moved 1 line down.

[Compulsion Read] The data in the SFRs, where reading is prohibited because the values will

change if they are read, the I/O ports added in the Add I/O Port dialog box, and

the I/O protected areasNote is subjected to compulsory reading.

Note SM78K0 only.
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(f) Register window dependent part

[Bin] Displayed as a binary number.

[Oct] Displayed as an octal number.

[Dec] Displayed as a decimal number.

[Hex] Displayed as a hexadecimal number.

[Absolute Name] The register name is displayed as an absolute name.

[Functional Name] The register name is displayed as a functional name (default).

(g) SFR window dependent part

[Bin] Displayed as a binary number.

[Oct] Displayed as an octal number.

[Dec] Displayed as a decimal number.

[Hex] Displayed as a hexadecimal number (default).

[Sort by Name] Displayed in alphabetical order.

[Sort by Address] Displayed in address order (default).

[UnSort] Not sorted.

[Attribute] Selects whether to display or not to display the Attribute field.

No check mark (“ ”): Not displayed.

Check mark ( “√”): Displayed (default).

[Pick Up] Only the SFR selected in the SFR Select dialog box is displayed.

No check mark (“ ”): All are displayed (default).

Check mark ( “√”): The selected register only is displayed.

[Select…] Opens the SFR Select dialog box.

[Compulsion Read] The data in the SFRs, where reading is prohibited because the values will

change if they are read, the I/O ports added in the Add I/O Port dialog box, and

the I/O protected areas is subjected to compulsory reading.
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(h) Local Variable window dependent part, Stack Trace window dependent part

[Bin] Displayed as a binary number.

[Oct] Displayed as an octal number.

[Dec] Displayed as a decimal number.

[Hex] Displayed as a hexadecimal number.

[String] Displayed as a character string.

[Proper] Displayed as the standard value for each variable (default).

(i) Trace window dependent part

[Select…] Selects the content of the display.

Opens the Trace Select dialog box.

[Pick Up ] Performs pick up display settings.

[Off] Pick up is not displayed (default).

[Search] Picks up the frames which match the search conditions and displays

them.

[Snap] Picks up snap frames and displays them.

[BRM1] Picks up the first M1 fetch frame after a program branch and displays it.

[Mix] Switches between mixed display or no mixed display of sources.

No check mark (“ ”): No mixed display (default).

Check mark ( “√”): Mixed display.

[Window
Synchronize ]

This links together the Trace window and Source window, Assemble window,

Memory window and Coverage window.

[SourceText] Selects whether the Source window will be linked or not linked.

No check mark (“ ”): Not linked (default).

Check mark ( “√”): Linked.

[Assemble] Selects whether the Assemble window will be linked or not linked.

No check mark (“ ”): Not linked (default).

Check mark ( “√”): Linked.

[Memory] Selects whether the Memory window will be linked or not linked.

No check mark (“ ”): Not linked (default).

Check mark ( “√”): Linked.

[Coverage] Selects whether the Coverage window will be linked or not linked.

No check mark (“ ”): Not linked (default).

Check mark ( “√”): Linked.
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(j) Coverage window dependent part

[1 Byte] Displays in 1-byte units (default).

[64 Bytes] Displays in 64-byte units.

(k) Event Manager dependent part

[Select All Event] Selects all the events entered in the Event Manager.

[Delete Event] Deletes the selected event.

[Sort By Name] Displays the icons sorted by event name.

[Sort By Kind] Displays the icons sorted by event kind.

[UnSort] Icons are not sorted (default).

[Detail] Displays details.

[Overview] Displays a list.

(4) Option

Figure 6-9.  Option Menu Bar
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[Tool Bar] Selects whether the tool bar is displayed or not.

No check mark (“ ”): Not displayed.

Check mark ( “√”): Displayed (default).

[Status Bar] Selects whether the status bar is displayed or not.

No check mark (“ ”): Not displayed.

Check mark ( “√”): Displayed (default).

[Button] Selects whether the function buttons on each debug window are displayed or

not.

No check mark (“ ”): Not displayed.

Check mark ( “√”): Displayed (default).

[Source Mode] Performs step execution at the source level (line units).

[Instruction Mode] Performs step execution at the instruction level (instruction units).

[Auto Mode] Switches automatically between source level step simulation and instruction

level step simulation, and executes step simulation (default).

When the Source window is active, source level step simulation (except in the

mixed display mode) is performed, and when the Assemble window is active,

instruction level step simulation is performed.

When neither window is active, source level step simulation is performed.

[Configuration…] Sets the environment.

Opens the Configuration dialog box.

[Extended Option…] Sets the extended functions.

Opens the Extended Option dialog box.

[Debugger Option…] Sets the debugger.

Opens the Debugger Option Setting dialog box.

[Add I/O Port…] Note Adds a user defined I/O port.

Opens the Add I/O Port dialog box.

Note SM78K0 only.

[Trace Clear] Clears the trace data.

Displays the Trace window if it is active.

[Coverage ] Opens the coverage measurement related dialog boxes.

[Clear…] Initializes the coverage measurement results.

Opens the Coverage - Clear dialog box.

[Condition…] Sets the coverage efficiency measurement conditions.

Opens the Coverage - Condition Setting dialog box.

[Efficiency…] Displays the coverage efficiency results.

Opens the Coverage - Efficiency dialog box.
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[Coverage ON] Selects whether coverage measurement is turned on or off.

During emulation, this setting cannot be changed.

No check mark (“ ”): Coverage measurement is not performed (default).

Check mark ( “√”): Coverage measurement is performed.

[Timer ON] Selects whether the timer measurement is turned on or off.

During emulation, this setting cannot be changed.

No Check Mark (“ ”): Timer measurement is not performed.

Check Mark ( “√”): Timer measurement is performed (default).

Note that Run-Break event timer measurement cannot be stopped.

[Tracer ON] Selects whether the tracer is turned on or off.

During emulation, this setting cannot be changed.

No check mark (“ ”): Trace is not performed.

Check mark ( “√”): Trace is performed (default).
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(5) Run

Figure 6-10.  Run Menu Bar

[Restart] Performs program simulation after resetting the emulation CPU.

Performs the same operation as the  button.

[Stop] Forcibly stops execution of the program.

Performs the same operation as the  button.

[Go] Executes the program without resetting the CPU.

Performs the same operation as the  button.

[Return Out] Executes the program real-time until execution returns to the calling function.

Performs the same operation as the  button.

[Step In] Performs step execution.

Performs the same operation as the  button.

In the source mode, the program is executed in line units, and in the instruction

mode, it is executed in instruction units.
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[Next Over] Performs next step execution.

Performs the same operation as the  button.

Executes the program, assuming a function or subroutine statement as 1 step.

[Start From Here] Simulates the program from the cursor position in the Source window or the

Assemble window.

[Come Here] Executes the program until the cursor position in the Source window or

Assemble window.

[Step Back] Performs back step execution in the unit specified in the Extended Options

dialog box.

Performs the same operation as the  button.

[Go Back] Performs the back execution until the cursor position in the Source window or

Assemble window.

[Go & Go] Continues execution of the program.  If a break occurs because a break

condition is satisfied, updates the window and then executes the user program

again.

Performs the same operation as clicking the  button each time a break

occurs.

[Slowmotion] Continues step execution of the program.

After updating the window for each step simulation, it performs step simulation

again.

Each time step simulation is performed, it operates the same as when the 

button is clicked.

[CPU Reset] Resets the emulation CPU.

Performs the same operation as the  button.

[Change PC] Sets the address at the cursor position in the Source window or Assemble

window to PC.

[Break Point] Sets/Cancels a break point at the cursor position in the Source window or the

Assemble window.

[Uncond. Trace ON] Validates the unconditional trace function.  Always traces while the user

program is executed (default).

When the tracer is started, the trace mode cannot be changed.

[Cond. Trace ON] Validates the trace function.  Traces while the user program is executed

according to a trace condition.

When the tracer is started, the trace mode cannot be changed.
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[Coverage Start or

Coverage Stop]

When coverage measurement is stopped, this starts it.

When coverage measurement is being performed, this stops it.

The display definitions are as follows.

“Coverage Start”: Means that measurement is stopped.  If selected,

measurement will be started.

“Coverage Stop”: Measurement is in progress.  If selected, measurement will

be stopped.

If there is currently no emulation, and if there is no  “√” mark next to the

[Option] → [Coverage ON] item, this item is invalid (it appears dimmed).

Coverage measurement starts operating immediately after coverage has been

turned on and emulation is started.

[Timer Start or

Timer Stop]

When timer measurement is stopped, this starts it.

When timer measurement is being performed, this stops it.

The display definitions are as follows.

“Timer Start”: Means that measurement is stopped.  If selected,

measurement will be started.

“Timer Stop”: Measurement is in progress.  If selected, measurement will be

stopped.

If there is currently no emulation, and if there is no  “√” mark next to the

[Option] → [Timer ON] item, this item is invalid (it appears dimmed).

Timer measurement starts operating immediately after the timer has been

turned on and emulation is started.

[Tracer Start or

Tracer Stop]

When tracer measurement is stopped, this starts it.

When tracer measurement is being performed, this stops it.

The display definitions are as follows.

“Tracer Start”: Means that measurement is stopped.  If selected,

measurement will be started.

“Tracer Stop”: Measurement is in progress.  If selected, measurement will be

stopped.

If there is currently no emulation, and if there is no  “√” mark next to the

[Option] → [Tracer ON] item, this item is invalid (it appears dimmed).

Tracer measurement starts operating immediately after the tracer has been

turned on and emulation is started.

[Ignore Break Point] Selects whether to make a break point valid or invalid.  If it is made invalid, the

break point does not cause a break to occur.

No check mark (“ ”): Valid (default)

Check mark (“√”): Invalid

During emulation, this setting cannot be switched.

[Disable Back Trace] Selects whether to make a backward execution valid or invalid.

No check mark (“ “): Valid (default)

Check mark (“√”): Invalid

This setting can be switched even during emulation.
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(6) Event

Figure 6-11.  Event Menu Bar

[Event Manager] Manages each type of event condition.

Opens the Event Manager.

Performs the same operation as the  button.

[Event…] Enters event conditions.

Opens the Event dialog box.

Performs the same operation as the  button.

[Event Link…] Enters event link conditions.

Opens the Event Link dialog box.

[Break…] Enters and sets break conditions.

Opens the Break dialog box.

Performs the same operation as the  button.

[Trace…] Enters and sets trace event conditions.

Opens the Trace dialog box.

Performs the same operation as the  button.

[Snap Shot…] Performs entry and setting of snap event conditions.

Opens the Snap Shot dialog box.

[Stub…] Performs entry and setting of stub event conditions.

Opens the Stub dialog box.

[Timer…] Performs entry and setting of snap event conditions and displays the

measurement results.

Opens the Timer dialog box.

Performs the same operation as the  button.
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(7) Browse

Figure 6-12.  Browse Menu Bar

[SourceText] Displays the source text.  Opens the Source window.

Performs the same operation as the  button.

If a window exists that is already in the active state, it opens the window in the

static state.

[Assemble] Disassembles and displays the user program.  Opens the Assemble window.

Performs the same operation as the  button.

[Memory] Displays the memory contents.  Opens the Memory window.

Performs the same operation as the  button.

[Watch] Displays the watch contents (variable and other data).

Opens the Watch window.

Performs the same operation as the  button.

[Register] Displays the register contents.  Opens the Register window.

Performs the same operation as the  button.

[Sfr] Displays the contents of the SFRs.  Opens the SFR window.

Performs the same operation as the  button.

[Local Variable] Displays the local variable.  Opens the Local Variable window.

Performs the same operation as the  button.

[Stack Trace] Displays the stack contents.  Opens the Stack window.

Performs the same operation as the  button.

[Trace] Displays the result of trace.  Opens the Trace window.

Performs the same operation as the  button.
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[Coverage] Displays the result of coverage measurement.  Opens the Coverage window.

Performs the same operation as the  button.

If a window exists that is already in the active state, it opens the window in the

static state.

(8) Jump

Figure 6-13.  Jump Menu Bar

[SourceText] Sets the data selected in the current window as the jump address, and displays

the source text and source line starting from that address.  No jump can be

performed if the jump address contains no line information.  Opens the Source

window.

If the Source window is being displayed in the active state, that window is

displayed on the front plane (operation object).

[Assemble] Sets the data selected in the current window as the jump address, and displays

the disassembled text starting from that address.  Opens the Assemble

window.

If the Assemble window is being displayed in the active state, that window is

displayed on the front plane (operation object).

[Memory] Sets the data selected in the current window as the jump address, and displays

the memory contents starting from that address.  Opens the Memory window.

If the Memory window is being displayed in the active state, that window is

displayed on the front plane (operation object).

[Coverage] The data value selected in the current window is used as a jump destination

address, and the coverage measurement results from that window are

displayed.

Opens the Coverage window.

If the Coverage window is being displayed in the active state, that window is

displayed on the front plane (operation object).



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 83

(9) Window

Figure 6-14.  Window Menu Bar

[New Window] Opens a new window which displays the same contents as the current window.

This is valid only in cases where the current window is the Source window,

Assemble window, Memory window or Coverage window.

[Cascade] Cascades the windows in the Main window.

[Tile] Tiles the windows in the Main window.

[Arrange Icons] Rearranges the icons in the Main window.

[Close All] Closes all the windows except the Main window.

[Refresh] Updates the contents of the window with the latest data.

[Active] Switches the window to the active state.

If it is currently in the active state, a check mark is entered on the left of this item.

[Static] Switches the window to the static state.

If it is currently in the static state, a check mark is entered on the left of this item.

[Open window] Lists the opened windows.  The window with a check mark added at the side of

the number is the current window.  The window selected by selecting a window

name is displayed as the current window.
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(10)Help

Figure 6-15.  Help Menu Bar

[Help Topics] Displays the table of contents of the Help window.

[Main Window Help] Displays the help for the main window.

[Current Window Help] Displays the help for the current window.

[About…] Displays the version information of the debugger.
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Configuration Dialog Box Modal

General

Displays and sets the operating environment of the simulator.

This dialog box is displayed automatically after the simulator is started.  To use the simulator, the operating

environment of the simulator must be set first in this dialog box.

When a project file is read, however, it doesn’t need to be set.  The result of reading the project file is reflected in

the Configuration dialog box.

Opening method

This dialog box can be opened by the following procedure.

• When the simulator is started

automatically opened

• From the menu bar

Select [Option] → [Configuration…].

Press the  GRPH  +  O , and  C  keys in that order.

Window

Figure 6-16.  Configuration Dialog Box

(1) Emulation CPU
selection area

(2) Internal
ROM/RAM setting
area

(3) CPU clock source
selection area

(4) Mapping setting
area
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Function

The Configuration dialog box consists of the following areas.

• Emulation CPU selection area

• Internal ROM/RAM setting area

• CPU clock source selection area

• Mapping setting area

The function of each area is explained below.

(1) Emulation CPU selection area

This area selects an emulation CPU.  Note that this area can be selected only when the SM78K0 is started.

A chip name can be specified by inputting a name using the keyboard or selecting one from the Name drop-

down listNote.

Note Even if the project file of a different device to the target device is loaded after startup, that device will

not become the target device.

(2) Internal ROM/RAM setting area

This area displays the size of the internal ROM and RAM of the emulation CPU.

The default size is automatically displayed with the asterisk (*) attached at the end when the emulation CPU

is selected.

To change the size of the internal ROM and RAM, select a size from the internal ROM and RAM drop-down

list.

If the selected size cannot be realized due to simulator limitations, the simulator automatically adjusts the

size.

For that reason, if the Configuration dialog box is displayed again, it may be because the size being displayed

is greater than the size specified the previous time.

Sizes which can be set are as follows.

Internal ROM Size Internal RAM Size

Alignment

(KB)

Set Range

(KB)

Alignment

(Bytes)

Set Range

(Bytes)

4 0 to 64 128 128 to 1024
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(3) CPU clock source selection area

This area is used to select a clock source input to the emulation CPU.

The unit is MHz.

Select the clock number by inputting it from the keyboard or selecting from the drop-down list.

Main (MHz): Specifies the frequency for the main clock.

Sub (KHz): Specifies the frequency for the subclock.

(4) Mapping setting area

This area specifies the memory attribute and address, and sets mapping.

(a) Mapping attribute specification

The following types of mapping attributes can be selectedNote.  Select the appropriate one for the

application.

However, Emulation ROM and Emulation RAM cannot be selected for a device with no external space.

Note Only “Stack” can be selected with the SM78K0S.

Memory Attribute

• Emulation ROM: Selects an simulator alternate ROM (SM78K0 only).

• Emulation RAM: Selects an simulator alternate RAM (SM78K0 only).

• Stack: Selects a memory for the stack area.

(b) Mapping address specification

Mapping Address: Specify the address to be mapped.

Input the higher address and the lower address from the keyboard.
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(c) Setting of memory mapping

• To add memory mapping

After specifying the memory mapping attribute and address, click the  button.

Memory mapping corresponding to the Memory Attribute and to the Memory Mapping address range

is added.

The mapping units for attributes other than the Stack are adjusted when the  button is

clicked.  If the mapping units do not match, the minimum range subject to mapping that can be set,

which includes the specified address, is used.

The mapping unit of the Stack is 1 KB.

The mapping unit for other attributes is 8 KBNote.

Stack can be specified for the internal ROM area only (it cannot be specified for the internal expansion

RAM area).

Note SM78K0 only.

• To delete memory mapping

Select the displayed area where you desire to delete mapping, then click the  button.  The

currently selected mapping will be deleted.

Function buttons

Validates the current environments. Sets environments and closes the Configuration dialog

box.

If an error occurs when the  button is clicked, the Simulator stops because it is

impossible to continue.

Cancels change and closes this dialog box.

This returns the environmental settings to the state they were in before the Configuration

dialog box was opened.

Opens the Project File Load dialog box.

If a project file is open or if an error occurs during reading, the simulator stops because it is

impossible to continue.

Opens the Help window that explains the Configuration dialog box.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 89

Extended Option Dialog Box Modal

General

This dialog box displays and sets the various extended options of the simulator.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window

Select [Option] → [Extended Option…] from the menu bar.

Press the  GRPH  +  O , and  E  keys in that order.

Window

Figure 6-17.  Extended Option Dialog Box

<1> Trace buffer size setting area

<2> Trace time tag counter division ratio

selection area

<3> Real-time internal RAM sampling time

setting area

<4> Break mode setting area

<5> Beep sound specification area

<6> Verify specification area

<7> Back execution type selection area

<8> Project save level selection area

<8>

<6>

<4>

<3>
<2>

<1>

<5>

<7>
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Function

The Extended Option dialog box consists of the following areas.

• Trace buffer size setting area

• Trace time tag counter division ratio selection area

• Real-time internal RAM sampling time setting area

• Break mode setting area

• Beep sound specification area

• Verify specification area

• Back execution type selection area

• Project save level selection area

The function of each area is explained below.

(1) Trace buffer size setting area

Specify the size to trace when tracing user program simulation (frame units).

Select from the drop-down list.

The following sizes can be selected

Setting Units (Bytes) Frame Size

4 K to 16 M 0 to Set unit (bytes)

(2) Trace time tag counter division ratio selection area

This area is used to set the division ratio of the counter to be used as time tag display.

Select the division ratio from the drop-down list.  The following division ratios can be selected.
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Numeric Value on Drop-Down List

1 (Default value) 64 K

2 128 K

4 256 K

8 512 K

↓

16

↓

1 M

↓ 32 ↓ 2 M

64 4 M

128 8 M

256 16 M

512 32 M

↓ 1 K ↓ 64 M

2 K 128 M

4 K 256 M

8 K 512 M

16 K 1 G

↓ 32 K ↓ 2 G

When a division ratio has been set, the number of clocks necessary for counting the counter displayed by

time tag is changed.

(3) Real-time internal RAM sampling time setting area

This area specifies the sampling time of the real-time internal RAM sampling.

During emulation, the following range can be sampled in real time.

Real-time display range:  Internal RAM area

Variables, data, etc. allocated to this range can be viewed in real time in the Watch window and the Memory

window.

Sampling time can be specified from 0 to 65500 in 100-msec units.

Real-time display is not performed if the sampling time is set at 0 or is left blank.
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(4) Break mode setting area

This area sets the event mode.

• Before: Sets a RUN event as a pre-simulation event (default).

An event occurs before an instruction is executed.

• After: Sets a RUN event as a post-simulation event.

An event occurs after an instruction has been executed.

(5) Beep sound specification area

Specify whether there will be a beep sound when there is a break.

If the check box is checked, a beep sound is emitted when there is a break (the default is with the beep

sound activated).

(6) Verify specification area

This area specifies whether the memory verification check is to be performed when it is written to.  If the

check box is checked, when download, memory fill, and memory copy is to be performed the memory is

verified.  A verify check is also performed when variables or data, etc. have been changed in the Watch

window or Memory window, and even when writing to memory (the default is for the check to be performed).

(7) Back execution type selection area

This area sets the back execution type.

Select from the drop-down list.  The following types can be selected.

• Instruction: Enables all executed instructions to be back-executed (default).

• Break: Enables back execution at only those places where a program break occurred.

• Branch: Enables back execution at only those places where program execution branched due to the

CALL or BR instruction, or an interrupt.

• Event: Enables back execution at only those places where an event was established.
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(8) Project save level selection area

Specify the save level when saving a project file.

• Basic: Saves the set debugging environment (window state, event setting state, etc.) only (default).

• Normal: Saves the contents of the basic save plus the simulator’s internal instructions in the interrupted

state (project information such as instructions, memory, registers and SFRs).

• Full: Saves the contents of the normal save plus all the debugging information (trace, coverage

results, etc.) generated during simulation.

Function buttons

Makes the currently set environment active.

Sets the environment and closes the Extended Option dialog box.

Cancels the change contents and closes the Extended Option dialog box.

Returns to the environmental setting state that existed before the Extended Option dialog box

was opened.

Opens the Help window that explains the Extended Option dialog box.
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Debugger Option Dialog Box Modal

Outline

Displays and sets each type of extended option in the debugger.

Opening method

This dialog box can be opened by either of the following procedure.

• Select [Option] → [Debugger Option…] on the menu bar in the Main window.

Press the  GRPH  +  O  keys, then the  D  key, in that order.

Window

Figure 6-18.  Debugger Option Dialog Box

\

(1) Source path specification area

(2) Default source specification area

(3) Default load module specification area

(4) Open file history setting area

(5) Display font setting area

(6) Project file setting area

(7) Tool bar display button setting area

(8) Kanji code setting area

(9) Tab size setting area

(10)Startup symbol setting area

(11)Offset display setting area

(12)Register name display selection area

(13)Watch symbol setting area

(1)

(2)

(3)

(4)

(5)
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Functions

The Debugger Option dialog box consists of the following items.

• Source path specification area

• Default source specification area

• Default load module specification area

• Open file history setting area

• Display font setting area

• Project file setting area

• Tool bar display button setting area

• Kanji code setting area

• Tab size setting area

• Startup symbol setting area

• Offset display setting area

• Register name display selection area

• Watch symbol setting area

Each function is explained below.

(1) Source path specification area

Specify the directory in which the source file or text files will be searched for.

The path is specified by inputting it from the keyboard or by using the  button.

When the  button is clicked, the Source Move dialog box is displayed and the source path can be

added.

A relative path can also be specified.  The directory that is the reference for the relative path is displayed to

the right of “Base:”.  The reference directory is decided using the following procedure.

• The directory from which the project files were loaded.

• The directory from which the latest load module or hex file was loaded.

• Windows current directory.

Delimiters in path information are specified by “ ” (blank), “;” (semi-colon), or “,” (comma).

Japanese characters can be specified in the source path (Japanese version only).

Example If the source is located in the following directory,

b:\src

c:\asm

The source path specification becomes as follows.

b:\src;c:\asm
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(2) Default source specification area

When [File] → [Open…] is selected and the Source Move dialog box is opened, the file extension of the

displayed source file is set.

File extension delimiters are specified by “ ” (blank), “;” (semi-colon), or “,” (comma).

(3) Default load module specification area

Set the file extension of the load module displayed when the Download dialog box is opened.

File extension delimiters are specified by “ ” (blank), “;” (semi-colon), or “,” (comma).

(4) Open file history setting area

Set the number of items in the history displayed at the bottom of the [File] menu.

The number of items can be set in a range of 0 to 10.

When 0 is set, the history is not displayed on the menu.

The default is four items.

(5) Display font setting area

Specify the display font in the Source window.  If the button is clicked, the Font dialog box opens and the

display font can be selected.
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(6) Project file setting area

Perform the setting of project file auto save and auto load.

(a) Project file auto save

Selection can be made from among the following items.

Auto Save:

On: Performs project file auto save when closing.

Off: Does not perform project file auto save when closing.

Query: Displays the Close Confirmation dialog box when closing (default).

(b) Project file auto load

Selection can be made from among the following items.

Auto Load:

On: Performs project file auto load when starting.

Off: Does not perform project file auto load when starting (default).

(c) Auto load project file settings

Specifies the project file to be loaded during auto load.  This can be specified when “Auto Load” has

been turned “On.”  When it is turned “Off,” the specification column becomes inactive (it appears

dimmed).

Load Project File: Input the project file name from the keyboard or set it by clicking the 

button.

If the  button is clicked, the Source File Select dialog box is displayed.

(7) Tool bar display button setting area

Set the tool bar display button.

The display button can be selected from among the following items.

Pictures and Text: Displays buttons which show both graphics and text (default).

Pictures only: Displays buttons which show only graphics.
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(8) Kanji code setting area

Japanese version only.

(9) Tab size setting area

Set the tab size for each file extension when displaying files with that file extension.

(a) File extension setting

Set the file extension.

Extension: Setting of the file extension can be done by inputting it from the keyboard or by selecting

from the drop-down list.

(b) Tab size selection

The following tab sizes can be selected.

Tab Size:

2: Displays the tab code with 2 spaces.

4: Displays the tab code with 4 spaces.

8: Displays the tab code with 8 spaces.

(c) Set the tab size for each file extension.

Tab List:  Displays a list of the file extensions and tab sizes.

• If a tab size setting is added, and if a tab size is changed, set it by “Extension” and “Tab Size”, then

click the  button.

• To delete a tab size setting,

Select the file extension setting in the “Tab List,” then click the  button.

The currently selected file extension setting is deleted.
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(10) Startup symbol setting area

Set the beginning and the end symbol of the startup routine.

Be sure to set this area.  If it is left blank, the dialog box cannot be closed.

Begin label: Set the opening symbol.

The default is _@cstart.

End label: Set the end symbol.

The default is _@cend.

(11) Offset display setting area

Set whether there will be an offset display (symbol + offset) during disassemble display.

If there is no offset display, a symbol is displayed only when there is a symbol that matches the numerical

value, and when there is not a matching symbol, the numerical value is displayed as is in hex notation.

The areas where the offset display can be specified are of the following two types.

Label: Set whether or not there will be an offset display in the label column.

The default is no offset display.

Mnemonic: Set whether or not there will be offset display in the mnemonic column.

The default is offset display.

(12) Register name display selection area

Select the display method of the register name in the mnemonic during disassemble display.

Function Name: Displays the register name as the function name or another name (default).

Absolute Name: Displays the register name as an absolute name.
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(13) Watch symbol setting area

Specify watch symbol details.

(a) Default size

Set the display size of data specified as “Adaptive” in the Watch window, etc.  The size displayed can be

selected from among the following items.

Size:

Byte: Displays in 8 bits (default).

Half Word: Displays in 16 bits.

Word: Displays in 32 bits.

(b) Default radix

Set the display radix of data specified as “Proper” in the Watch window, etc.

The display radix can be selected from among the following.

Radix:

Hex: Displayed in hexadecimal (default).

Dec: Displayed in decimal.

Oct: Displayed in octal.

Bin: Displayed in binary.

String: Displayed as a character string.

(c) Display/not display variable types specification area

This area specifies whether or not to display the variable types.

On: Variable types are displayed.

Off: Variable types are not displayed.

Function buttons

After activating each type of option in the set debugger, the dialog box is closed.

Each of the options set in the debugger on this occasion are made inactive and

the dialog box is closed.

Returns to the environment setting state existing before the Debugger Option

dialog box was opened.

Opens the help window for the Debugger Option dialog box.
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Font Dialog Box Modal

Outline

This selects the display font for the Source window and sets the font size.

Opening method

This dialog box can be opened by the following procedure.

• Click the  button in the Debugger Option dialog box.

Window

Figure 6-19.  Font Dialog Box

Functions

The Font dialog box consists of the following items.

• Font name specification area

• Font size specification area

• Sample display area

Each function is explained below.
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(1) Font name specification area

Select the specified font from among the currently usable fonts.

Fixed width fonts (fonts with a constant stroke width and fixed pitch fonts) only are listed.

When the font name is selected from the list, the font name is displayed in the edit box and the font sizes with

which that font can be used are displayed in the font size specification area.

It is also possible to input the font name directly to the edit box using the keyboard.

(2) Font size specification area

The usable sizes of the font specified in the font name specification area are listed in point units.

When selecting the font size from the list, the size is displayed in the edit box.

It is also possible to input the font size directly to the edit box from the keyboard.

(3) Sample display area

A sample character string showing the specified font and font size is displayed.
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Function buttons

The font in the Source window is changed to the specified font face and font size and

the dialog box is closed.

The dialog box is closed without changing the font.
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Project File Load Dialog Box Modal

General

This dialog box restores previous debugging environments.

By loading a project file, the size of the window that displayed the environments and the position of the

environments on the window are also restored.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window

Select [File] → [Project] → [Open…] from the menu bar.

Press the  GRPH  +  F ,  J , and  O  keys in that order.

• Click the  button on the tool bar.

Window

Figure 6-20.  Project File Load Dialog Box

(3)  File kind selection area(2)  File name selection area

(1)  File location selection area
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Function

Loads project files.

This dialog box consists of the following areas.

• File location selection area

• File name selection area

• File kind selection area

The function of each area is explained below.

(1) File location selection area

Select the drive or directory.

(2) File name selection area

Specify the file name.

The file name can be input from the keyboard or it can be selected from the list in the top column of the area.

(3) File kind selection area

Displays the kind of file displayed in the list.  Project (*.prj) files are displayed.

Loaded contents

The items from each window shown in following table are saved in the project file.  However, if the files are loaded

after the debugger is started, when a project file with a different target device is loaded, the debugger itself is reset

and the project file is loaded.

(1/2)

Window Set Data

Configuration dialog box All items (Target device, clock source selection, pin mask setting, mapping information)

Main window Display position, tool bar/status bar/button display information, execution mode information,

trace On/Off information, coverage On/Off information

Download dialog box File information to be downloaded

Extended Option dialog box Setting information

Debugger Option dialog box Setting path information

Source window Display information of window, font information

Assemble window Display information of window, display start address

Memory window Display information of window, display start address

Stack window Display information of window

SFR window Display information of window

Local Variable window Display information of window

Trace View window Display information of window

Event dialog box Display information of window, event information
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(2/2)

Window Set Data

Event Link dialog box Display information of window, link event information

Break dialog box Display information of window, break event information

Trace dialog box Display information of window, trace event information

Snap Shot dialog box Display information of window, snap event information

Stub dialog box Display information of window, stub event information

Timer dialog box Display information of window, timer event information

Event Manager Display information of window

Register window Display information of window

Watch window Display information of window, watch entry information

Coverage window Display information of window

Simulator Main window Display information of window, pin status

Parts window Display information of window, pin status

Output Timing Chart window Display information of window, pin status

Caution

The project files are the same as those of the PM (project manager) (files of PM V1.42 or earlier cannot be used).

In actuality, the project files are stored in files created with the name “project-file-name.prs”.

Function buttons

Open Loads the selected file as the project file.

Closes the dialog box.

Cancel Closes this dialog box without loading the project file.

Help Opens the Help window that explains the Project File Load dialog box.
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Project File Save Dialog Box Modal

General

A project file is a file that stores debugging environments.

To save debugging environments in a project file, the size of the window that displayed the debugging

environments and the position of the environments in the window are also saved.

Opening method

This dialog box can be opened by either of the following procedures.

• In the Main window

Select [File] → [Project] → [Save As…] from the menu bar.

Press the  GRPH  +  F ,  J , and  A  keys in that order.

If a project file was loaded or saved previously, and to save a file of the same name, do as follows:

• In the main window

Select [File] → [Project] → [Save] from the menu bar.

Press the  GRPH  +  F ,  J , and  S  keys in that order.

In this way, a file of the same name as the previously loaded or saved project file can be saved without the Project

File Save dialog box being opened.
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Window

Figure 6-21.  Project File Save Dialog Box

Function

The Project File Save dialog box is used to save a new project file or a project file whose name has been changed.

This dialog box consists of the following areas.

• Save location selection area

• File name selection area

• File kind selection area

The function of each area is explained below.

(1) Save location selection area

Select the drive or directory.

(2) File name selection area

Specify the file name.

The file name can be input from the keyboard or it can be selected from the list in the top column of the area.

(3) File kind selection area

Displays the kind of file displayed in the list.

Project (*.prj) files are displayed.

Specify the project file currently being used.

(1) Save location selection area (2) File name selection area

(3) File kind selection area



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 109

Saved contents

The items from each window shown in following table are saved in the project file.

Window Set Data

Configuration dialog box All items (Target device, clock source selection, pin mask setting, mapping information)

Main window Display position, tool bar/status bar/button display information, execution mode information,

trace On/Off information, coverage On/Off information

Download dialog box File information to be downloaded

Extended Option dialog box Setting information

Debugger Option dialog box Setting information

Source window Display information of window, font information

Assemble window Display information of window, display start address

Memory window Display information of window, display start address

Stack window Display information of window

SFR window Display information of window

Local Variable window Display information of window

Event dialog box Display information of window, event information

Event Link dialog box Display information of window, link event information

Break dialog box Display information of window, break event information

Trace dialog box Display information of window, trace event information

Snap Shot dialog box Display information of window, snap event information

Stub dialog box Display information of window, stub event information

Timer dialog box Display information of window, timer event information

Event Manager Display information of window

Register window Display information of window

Watch window Display information of window, watch entry information

Coverage window Display information of window

Simulator Main window Display information of window, pin status

Parts window Display information of window, pin status

Output Timing Chart window Display information of window, pin status

Function buttons

Save Saves the project information in the selected file.

Then, closes this dialog box.

Cancel Closes this dialog box without saving the project file.

Help Opens the Help window that explains the Project File Save dialog box.
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View File Load Dialog Box Modal

General

This dialog box opens the window of the display file, source file, other text file, or event setting file to be read.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window

Select [File] → [Open…] from the menu bar.

Press the  GRPH , +  F , and  O  keys in that order.

Press shortcut keys  CTRL + O .

• Click the  button on the tool bar.

Window

Figure 6-22.  View File Load Dialog Box

(1) File location selection area

(2) File name selection area (3) File kind selection area
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Function

This dialog box opens the window of the display file, source file, other text file, or event setting file to be read.

Depending on the file loaded, the window opened and the status differ.

• Loading of a source file (files in which symbol information has been written)

If a Source window exists in the active state, it is opened in the static state, and there is no Source window in

the active state, a Source window in the active state is opened.

• Display file or some other text file

It is opened as a text format file in a Source window in the static state.

• Loading of an event setting file

The Event Manager is opened and the event setting contents are returned to the previous environment.

This dialog box consists of the following items.

• File location selection area

• File name selection area

• File kind selection area

The function of each area is explained below.

(1) File location selection area

Select the drive or directory.

(2) File name selection area

Specify the file name.  The file name can be input from the keyboard or it can be selected from the list in the

top column of the area.

(3) File kind selection area

Displays the kind of file displayed in the list.

The file kind that was previously selected is displayed here.  To select another file kind, re-select the kind

using the drop-down menu .

The file kinds are as shown below.

(1/2)

File Kind (File Extension) Meaning

Source (*.C, *.S, *.ASM)Note Source file

Text (*.TXT) Text file

Source Text (*.SVW) Source window display file

Assemble (*.DIS) Assemble window display file

Memory (*.MEM) Memory window display file

Watch (*.WCH) Watch window display file

Note The source file extension (C, S, ASM) can be changed in the Debugger Option dialog box.

Remark If you are using a previous Variable window display file, it can be used as a Watch window display file

by changing the file extension from var to wch.
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(2/2)

File Kind (File Extension) Meaning

Register (*.REW) Register window display file

SFR (*.SFR) SFR window display file

Local Variable (*.LOC) Local Variable window display file

Stack Trace (*.STK) Stack Trace window display file

Trace (*.TVW) Trace window display file

Coverage (*.COV) Coverage window display file

Event (*.EVN) Event setting file

All (*.*) All files

Function buttons

Open
After the selected file is loaded, the dialog box is closed.

Cancel Closes this dialog box without loading the display file.

Help Opens the Help window that explains the View File Load dialog box.
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View File Save Dialog Box Modal

General

This window saves the contents of the current window in a display file or event setting file.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window, make the window to be saved the current window and perform either of the following

operations.

Select [File] → [Save As…] from the menu bar.

Press the  GRPH  +  F , and  A  keys in that order.

Window

Figure 6-23.  View File Save Dialog Box (1/3)

No range (to save the Local Variable window, Stack window, SFR window,

Register window, Watch window, or Event Manager)

(1) Save location selection area

(2) File name selection area (3) File kind selection area
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Figure 6-23.  View File Save Dialog Box (2/3)

Address range (to save the Assemble window, Memory window, or Coverage window)

Frame range (to save Trace window)

(4) Save range setting area

(4) Save range setting area
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Figure 6-23.  View File Save Dialog Box (3/3)

Line range (to save the Source window)

Function

This window saves the contents of the current window in a display file.

This dialog box consists of the following areas.

• Save location selection area

• File name selection area

• File kind selection area

• Save range setting area

The function of each area is explained below.

(1) Save location selection area

Select the drive or directory.

(2) File name selection area

Specify the file name.

The file name can be input from the keyboard or it can be selected from the list in the top column of the area.

(4) Save range setting area
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(3) File kind selection area

Displays the kind of file displayed in the list.

The file kinds are as shown in the following table.

File Kind (File Extension) Current Window Name

Source Text (*.SVW) Source window

Assemble (*.DIS) Assemble window

Memory (*.MEM) Memory window

Watch (*.WCH) Watch window

Register (*.REG) Register window

SFR (*.SFR) SFR window

Local Variable (*.LOC) Local Variable window

Stack Trace (*.STK) Stack Trace window

Trace (*.TVW) Trace window

Coverage (*.COV) Coverage window

Event (*.EVN) Event Manager

(4) Save range setting area

This area is displayed only when the current window to be saved is the Assemble window, Memory window

Coverage window, Source window, or Trace View window.

All: Specifies that all the area from the first line to the last line be saved.

Screen shot: This specifies that the entire visible area from the top line of the screen to the bottom line

be saved.  However, in cases where there is a mixed display with the Source window, the

area saved is the from the source line included in the visible area of the screen.

Specify Line (in the case of the Source window),

Specify Frame (in the case of the Trace View window),

Specify Address (in the case of other windows):

This specifies the starting line and end line of the area to be saved.  When the starting

line and end line are omitted, it is regarded as if the starting line/end line were specified.

Details are as shown below.

(a) If current window is Assemble window, Memory window, or Coverage window

Specifies an address range to be saved.  Addresses can be also specified by symbols or expressions.

(The specification method is the same as in the case of the Address Move dialog box.) The default radix

when numbers are input is hexadecimal.

If an area with 256 bytes or more is specified, the following message dialog box is displayed and a

progressive grasp of the state conditions can be obtained.  If you are stopping in the middle of a save

operation, it is possible to stop by clicking the  button in the message dialog box.
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(b) If current window is Trace window

Specifies the range of trace frames to be saved.  (The specification method is the same as in the case of

the Trace Move dialog box.) The default radix when numbers are input is decimal.

If a range of more than 100 frames is specified, a dialog box indicating the saving status is displayed.  To

stop saving midway, click the  button in this dialog box.

(c) If current window is Source window

Specifies the range by line numbers.  The default radix when inputting numbers is decimal.

When the Source window is in the mixed display mode, the mixed display portion in the specified lines is

also saved.

If a range of more than 100 frames is specified, a dialog box indicating the saving status is displayed.  To

stop saving midway, click the  button in this dialog box.
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Download Dialog Box Modal

General

This dialog box selects the name and format of a file to be downloaded, and downloads the contents of the target

memory or the results of coverage to the simulator.

The files and formats of them that can be downloaded are as follows.

• NEC load module format file (XCOFF (.LNK, .LMF))

• Intel HEX format file (normal or extended)

• Motorola HEX format file S type (S0, S2, S3, S7 or S8)

• Extended Tektronix HEX format file

• Binary data format file

• Results of coverage

If a file other than an object file in the load module format is loaded, debugging cannot be executed at the source

level.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window

Select [File] → [Download…] from the menu bar.

Press the  GRPH  +  F , and  D  keys in that order.

• Click the  button on the tool bar.
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Window

Figure 6-24.  Download Dialog Box

Function

The maximum number of load module files that can be loaded is 20.

The Download dialog box consists of the following areas.

• File location selection area

• File name selection area

• File kind selection area

• Load condition specification area

• Reset conditions specification area

• Offset setting area

The function of each area is explained below.

(1) File location selection area

Select the drive or directory.

(1) File location selection area

(2) File name
selection area

(3) File kind
selection area

(4) Load condition specification area (5) Reset conditions specification area (6) Offset setting area
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(2) File name selection area

Specify the file name.  The file name can be input from the keyboard or it can be selected from the list in the

top column of the area.  This dialog box can be used to specify multiple files.

If you are specifying multiple file names, place (“ ”) (double quotation marks) on both sides of each file name.

It is also possible to specify multiple file names from the top column of the area while pressing the SHIFT key

or the CTRL key.

(3) File kind selection area

Displays the kind of file displayed in the list.

The contents displayed for “File Kind” are as shown below.

Contents (File Extension) Format

Load Module (*.LNK, *.LMF, *.D2b) Load module format

Hex Format (*.HEX) Hex format (the format is auto-judged)

Binary Data (*.BIN) Binary data format

Coverage (*.CVB) Coverage results

Remark The Hex format is judged automatically.

Note that these are the default file extensions; file extensions other than these can also be used.

(4) Load condition specification area

This area sets the download condition of the selected file.

Symbol: Specifies whether the symbol information is read (checked, default) or not.  Note that this

condition is disregarded for files other than those in the load module format.

Object: Specifies whether the object information is read (checked, default) or not.

In cases where a program configured from multiple load module files is debugged, if there are modules where

symbol information is not necessary, if the debugger is set so as not to read symbol information, the memory

use volume can be reduced.
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(5) Reset conditions specification area

Sets the reset conditions.

Symbol: Specifies whether to reset (checked, default) or not reset symbol information (this item is always

checked in the 78K Series).

CPU: Specifies whether to reset or not reset (not checked, default) the emulation CPU.

When debugging a program configured from multiple load module files, load individual load module files

without resetting the symbol information.

This setting is disregarded for files other than load module format and hex format files.

(6) Offset setting area

Specify the offset address when loading the hex format, the binary data format and the coverage results.

Address specification can also be by formula (except symbols).  The specification method is the same as in

the case of the Address Specification dialog box.  The default radix when inputting numerical values is

hexadecimal.  Offset values are disregarded for load module format files.

Function buttons

After the selected file is loaded, the dialog box is closed.

Closes this dialog box without loading the file.

Opens the Help window that explains the Download dialog box.
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Upload Dialog Box Modal

General

This dialog box selects the name and format of the file to be saved, and saves the contents of the target memory or

results of coverage in this file.

The following files and formats of them to be saved can be selected.

• Intel HEX format file (extended only)

• Motorola HEX format file

S type (S0, S2, and S8 only)

• Extended Tektronix HEX format file

• Binary data format file

• Results of coverage

Opening method

The dialog box can be opened by the following procedure.

• In the Main window

Select [File] → [Upload…] from the menu bar.

Press the  GRPH  +  F , and  U  keys in that order.

Window

Figure 6-25.  Upload Dialog Box

(1) File location selection area

(2) File name
selection area

(3) File kind
selection area

(4) Save range setting area
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Function

The Upload dialog box consists of the following areas.

• File location selection area

• File name selection area

• File kind selection area

• Save range setting area

The function of each area is explained below.

(1) File location selection area

Select the drive or directory.

(2) File name selection area

Specify the file name.  The file name can be input from the keyboard or it can be selected from the list in the

top column of the area.

(3) File kind selection area

The contents displayed for “Save as type” are as shown below.

Contents (File Extension) Format

Intel Hex (*.HEX) Intel extended hex format

Motorola Hex (*.HEX) Motorola hex format

Tektro Hex (*.HEX) Extended Tektronics hex format

Binary Data (*.BIN) Binary data format

Coverage (*.CVB) Coverage results

All (*.*) All files

These are the default file extensions; file extensions other than these can also be used.

The data format is decided by the file extension in which it is saved.  However, if “All (*.*)” is selected, the file

is saved in the default Intel extended hex format.

(4) Save range setting area

Specify the address range which is to be saved.  It is possible to specify the address by symbols or by

formula.  The specification method is the same as in the case of the Address Move dialog box.  The default

radix when numbers are input is hexadecimal.
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Function buttons

Save After saving the specified address range in the selected file, the dialog box is closed.

Cancel Closes this dialog box without saving the file.

Help Opens the Help window that explains the Upload dialog box.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 125

Browse Dialog Box Modal

General

This dialog box selects the file to be set in the Debugger Option or Source Search dialog box.

Opening method

This dialog box can be opened by either of the following procedures.

• Click the  button in the Debugger Option dialog box.

• Click the  button in the Source Search dialog box.

• Click the  button in the Source Move dialog box.

Window

Figure 6-26.  Browse Dialog Box

(1) File location selection area

(2) File name
selection area

(3) File kind
selection area
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Function

The browse dialog box consists of the following areas.

• File location selection area

• File name selection area

• File kind selection area

The function of each area is explained below.

(1) File location selection area

Select the drive or directory.

(2) File name selection area

Specify the file name.  The file name can be entered from the keyboard or it can be selected from the list in

the top column of the area.

(3) File kind selection area

Displays the types of files in the list.

The contents displayed in the “File Type” are as shown below.

Contents (File Extension) Format

Source (*.C, *.S, *.ASM) Source file (The file extension is specified in the Debugger Option dialog
box).

Text (*.TXT) Text file

All (*.*) All files

Remark The source file extension (C, S, ASM) can be changed in the Debugger Option dialog box.

Function buttons

Sets the selected file and close the dialog box.

Closes this dialog box without setting the file.

Opens the Help window that explains the Browse dialog box.
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Source Move Dialog Box Modal

General

Specifies the file displayed in the Source window and specifies the display start position.

Opening method

This dialog box can be opened by the following procedure.

• When the Source window is active

Select [View] → [Move…] from the menu bar.

Press the  GRPH  +  V , and  V  keys in that order.

Press shot-cut keys  CTRL  +  J .

Window

Figure 6-27.  Source Move Dialog Box

Function

This dialog box is displayed when [View] Menu → [Move…] is selected while the Source window is open and the

file’s display start position can be changed (a new window does not open).

The Source Move dialog box consists of the following areas.

• Input mode selection area

• File/address specification area

The function of this area is explained below.

(1) Input mode selection area

(2) File/address specification area



CHAPTER  6    WINDOW  REFERENCE

128 User’s Manual  U14611EJ1V0UM00

(1) Input mode selection area

This selects the input mode in cases where the movement destination is specified.

Address/Symbol: Specifies the movement destination by an address (or a symbol).

Line/File: Specifies the movement destination by a line No. (or file name).

(2) File/address specification area

This area specifies the display file name or display address.  With the default, the string selected in the

accessed window, or when there is no selected string, the first character string in the input history, is

displayed, but as necessary, it can be changed by entering from the keyboard.

The following two specification methods are used.

• Display address specification

• Display file name specification

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

(a) Display address specification

This specifies the address where the display starts.  It is possible to specify the address by symbols or by

formula.

The specification method is the same as in the Address Move dialog box.  When “Address/Symbol” is

selected, the default radix when inputting numerical values becomes hexadecimal.

The source text is displayed so that source line corresponding to the specified address value can be

seen.

(b) Display file name specification

This specifies the file name which is displayed in the Source window.

For the file name, it is possible to specify the file name only and to specify the absolute path or the

relative path.

If the file name only, or the relative path, is specified, search is made for the file in each of the following

directories in the order shown.  The first file to be found as a result of the search is displayed.

• The directory which is the source path specified in the Debugger Option dialog box.

The file name can also be specified by line number.  The file’s line number is specified as follows.
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• <<Path Name>File Name #> Line No.

The file name and line number are specified with the “#” used to divide them.  The line number is

specified by a decimal number.  The file name can be omitted.  When “Line/File” is selected, the default

radix when inputting numerical values is decimal.

The specified line Number is made the header line, and the specified file is displayed.  If the file name is

omitted, the file is displayed from the specified line of the currently displayed file.

When the line number is omitted, the file is displayed from the header line.

Function buttons

This opens the Browse dialog box.

After displaying the source text from the specified position, it closes the dialog box.

Invalidates the source path currently set and closes this dialog box.

Returns the input data to original value.

Opens the Help window that explains the Source Move dialog box.
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Address Move Dialog Box Modal

General

This window specifies a display start address in the Memory window, Assemble window, or Coverage window.

Opening method

This dialog box can be opened by the following procedure.

(1) In Assemble Window

• In the Main window

Select [View] → [Move…] from the menu bar.

Press the  GRPH  +  V , and  V  keys in that order.

Press shortcut keys  CTRL  +  J .

(2) In Memory Window

• In the Main window

Select [View] → [Move…] from the menu bar.

Press the  GRPH  +  V , and  V  keys in that order.

Press shortcut keys  CTRL  +  J .

(3) In Coverage window

• In the Main window

Select [View] → [Move…] from the menu bar.

Press the  GRPH  +  V , and  V  keys in that order.

Press shortcut keys  CTRL  +  J .

Window

Figure 6-28.  Address Move Dialog Box (1/2)

Address Move dialog box of Assemble window
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Figure 6-28.  Address Move Dialog Box (2/2)

Address Move dialog box of Memory window

Address Move dialog box of Coverage window

Function

The Address Move dialog box consists of the following area.

• Address specification area

The function of this area is explained below.

(1) Address specification area

This area specifies a display start address.  The default address is the string selected in the called window, or

the value of the current PC.  This value can be changed by entering from the keyboard as necessary.  An

address can also be specified by a symbol or expression.

The specification method is the same as in the case of the Symbol To Address dialog box, but the default

radix when inputting numerical values is hexadecimal.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.
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Function buttons

Displays the Memory window, Assemble window, or Coverage window from the specified address,

and closes this dialog box.

Closes this dialog box.

Returns the input data to original value.

Opens the Help window that explains the Address Move dialog box.
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Trace Move Dialog Box Modal

Outline

Specifies the Trace window display’s display start position.

Opening Method

This dialog box can be opened by the following procedure.

• When the Trace window is active,

Select [View] → [Move…] in the menu bar.

Press the  GRPH  +  V  keys, then the  V  key, in that order.

Press the shortcut keys  CTRL  +  J .

Window

Figure 6-29.  Trace Move Dialog Box

Function

This dialog box is displayed by selecting [View] → [Move…] when the Trace window is open, and it can be used to

change the trace results display starting position.

The Trace Move dialog box is configured from the following two items.

• Frame selection area

• Frame No. specification area

Each function is explained below.

Frame No. specification area

(1)  Frame selection area
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(1) Frame selection area

This selects the frame which is the move destination.

Selection Item Content

1st frame of last block Move to the first of the latest of the block frames in the trace data.

Trigger frame of last block Move to the trigger frame in the latest block frame in the trace data.

Last frame of last block Move to the last frame in the trace data.

Frame No. Move to the frame with the specified No.

When 0 is specified, move to the first frame in the trace data.

When this item is checked, shift the focus to the area specified by the frame

No.

(2) Frame No. specification area

If “Frame No.” is selected in the frame selection area, this is the area which specifies the frame No.  In the

default, the string selected in the accessed window, or “Last” is displayed, but as necessary, it can be

changed by entering from the keyboard.

The default radix when inputting numerical values is decimal.

When a “+” mark is input in front of a numerical value, the area moves forward the specified number of

frames (below the display) from the frame at the cursor position.  Conversely, when a “–” mark is input in front

of the numerical value, the area moves the specified number of frames backward (above the display).

The frame No. specification can also be specified in the following format.  It is also possible to specify it in

abbreviated form.  There is no distinction between upper case and lower case letters when inputting.

The contents are shown below.

Specification Abbreviated Form Content

First S Move to the header frame of the current trace block.

Trigger T Move to the trigger frame of the current trace block.

Last L Move to the last frame of the current trace block.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.
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Function buttons

OK After performing trace display from the specified position, the dialog box is closed.

Cancel Closes the Trace Move dialog box.

Restore Returns the input data to the original form.

Help Opens the Help window for the Trace Move dialog box.
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Symbol To Address Dialog Box Modeless

General

This dialog box displays the address of a specified variable or function, and the value of a symbol.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window

Select [View] → [Symbol…] from the menu bar.

Press the  GRPH  +  V , and  Y  keys in that order.

Window

Figure 6-30.  Symbol To Address Dialog Box

Function

The Symbol To Address dialog box consists of the following areas.

• Symbol specification area

• Conversion results display area

• Display radix specification area

The function of each area is explained below.

(1) Symbol specification area

(1)  Symbol specification area

(2) Conversion results
display area

(3)  Display radix specification area
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This area specifies the variable name, function name, symbol name, or line number whose address is to be

converted.

Other than this, an I/O port name, SFR name, register name, PSW flag name or a formula can be specified.

The I/O port name and SFR name are displayed by address values, the register name is displayed by the

register contents and the PSW flag name is displayed by the flag value.  Also, bit symbols are converted to

“Address.bit”.  Furthermore, a formula cannot be written which includes a bit symbol.

Specification methods are shown below.

Conversion Object Specification Method

Variable var

file#var  (If a static variable with a file name attached is specified)

func#var  (If a static variable with a function name attached is specified.)

file#func#var  (If a static variable with a file name and function name attached is specified.)

Function func

file#func (If a static function with a file name attached is specified.)

Label label

file#label (If a local label with a file name attached is specified.)

EQU symbol equsym

file#equsym (If a local EQU symbol with a file name attached is specified.)

Bit symbol bitsym

file#bitsym (If a local bit symbol with a file name attached is specified.)

Line number of source file file#no

I/O port portname

SFR sfrname

Register regname

PSW Flag pswname

Remark var: Variable name, file: File name, func: Function, label: Label name, equsym: EQU symbol name,

bitsym: Bit symbol name, no: Source file line number, portname: I/O port name, sfrname: SFR name,

regname: register name, pswname: PSW flag name.

A “#” (sharp) is used as the separator between the file name and variable, function name and line No.

If the specified symbol could not be found inside the scope, all symbols are searched for (static

variable, static function, local label, local EQU symbol, local bit symbol).

In the default, the symbol name has priority.  Furthermore, when desiring to change the priority order

temporarily, adding a “$” (Dollar) sign in front of the symbol causes the register name to have priority.

If you are reading multiple load modules, when specifying the load module names, use the separator

“$” between the load module name and the file name, variables, function name and symbol name.

In the default, the string selected in the accessed window is displayed, but as necessary, it is possible

to change it by inputting from the keyboard.  The radix of the default when inputting numerical values is

decimal.  When changing the contents of the symbol specification area, clicking the  button

displays the conversion results in the conversion results display area.

By clicking the  button and displaying the input history, the contents input previously can be reused.

Up to 16 items of input history can be retained.
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(2) Conversion results display area

The variables specified in the symbol specification area, the function address, symbol values, line number

addresses and formula values, etc. are displayed in this area.

(3) Display radix specification area

This specifies the display radix of the conversion results display area.

Hex: Displayed in hexadecimal (default).

Dec: Displayed in decimal.

Oct: Displayed in octal.

Bin: Displayed in binary.

Function buttons

When the contents of the symbol specification area have been changed, the symbols are

converted.  After conversion, when you are not changing the contents of the symbol specification

area, the dialog box closes.

Closes the symbol conversion dialog box.

Returns the input data to the original values.  If the  button has already been clicked,

the data return to the state they were in just after the  button was clicked.

Opens the Help window that explains the Symbol To Address dialog box.
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Source Window MDI child window

General

This window displays the source file or text file.

Also, display of disassembly of a program mixed with a source file, and simulation of online assembly on a mixed

display can be done.

There are two modes in the Source window, normal display mode and mixed display mode.

Opening method

This window can be opened by the following procedure.

• In the Main window

Select [Browse] → [SourceText] from the menu bar.

Press the  GRPH  +  B , and  S  keys in that order.

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• Click the  button on the tool bar.

• In the View File Load dialog box, select Source file or Text file, then click the  button.

Window

Figure 6-31.  Source Window (1/2)

Normal Display Mode
(1) Point mark area

(2) Current PC
mark area

(3) Line number/address display area (4) Source text display area
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Figure 6-31.  Source Window (2/2)

Mixed Display Mode

There are two modes in the Source window, normal display mode and mixed display mode.  An explanation of

each of these modes is given below.

Please refer to (4), Source text display area (p.145) for further details.

(1) Normal display mode

In the normal display mode, other than display of source files, general text files can be displayed.

(2) Mixed display mode

In the mixed display mode, disassembly of programs combined with source files is displayed.  Online

assembly cannot be performed.

The display content in the mixed display mode can be saved as a display file.

Also, in the Source window which displays the source file that read the symbol information, there are two states,

the active state and the static state.

Source windows in the active state can be opened one at a time only, and multiple windows in the static state can

be opened at a time.  Switching between states is accomplished in the [Window] menu.  Source files in which symbol

information has not been read are read as text format files and their contents are not changed.

These two states are described below.

(1) Active state

The Source window in the active state is synchronized with the current PC value and the Source window’s

display is updated continuously so that it is always displaying the current PC line.

Also, if the Source window in the active state is synchronized not only with the jump function’s jump

destination but also with the Trace window, the display in the Source window is updated in synchronization

with the Trace window.

The Source window first opened is in the active state.
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(2) Static State

Source windows in the static state are not synchronized with the current PC value and do not change the

display position, but their contents are updated.

Also, a Source window in the static state does not become a jump destination and is not synchronized with

the Trace window.

If an active Source window is already open, a Source window is open in the static state.

Function

This window displays source files or text files.  It also displays disassembled display of programs mixed with source

files and can also perform online assembly in a mixed display.  The tab size and display font can be specified in the

Debugger Option dialog box.

The Source window consists of the following areas.

• Point mark area

• Current PC mark area

• Line number/address display area

• Source text display area

The function of each area is explained below.

(1) Point mark area

This area sets or deletes breakpoints, and displays the set status of each event condition and whether the

program code exists or not.

(a) Breakpoint setting/deleting function

By clicking this area with the mouse, a breakpoint can be set or deleted.

The necessary mouse operations are as follows depending on the line where mouse is clicked.

Location Click Button Operation

Where “B” mark (red, black) is displayed Left button Deletes breakpoint.

Where blank or other marks than “B”

mark are displayed (E, L, T, mark etc.)

Left button Sets breakpoint.

Setting and deletion of break points can be performed for lines which have an “*” displayed in the point

mark area.

As for lines without an “*” displayed, setting or deletion can be done on either the line above or below the

line where an “*” is displayed.
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If a break point is set, the “B” mark is displayed in the point mark area.  However, if a mark other than the

“B” mark is displayed, the “A” mark is displayed.

The “A” mark shows that multiple events are set.

If a break point is deleted, the “B” mark in the point mark area is deleted and the area is left blank or a

mark other than the “B” mark is displayed.

The “B” mark is displayed in the following colors in accordance with the type of break point and its state.

Display Color Explanation

Red Shows that the set break point is valid.

Black Shows that the set break point is invalid.  The break point can be made valid in the

Event Manager or the Break dialog box.

If a break point is set in the point mark area, it becomes valid at the time when it is set.

(b) Event condition display function

The set status of each event is displayed.  If a simulation event or access fetch event is set to the

corresponding source line, a mark corresponding to the type of event is displayed.

Mark Meaning

E Set position of event condition

L Final stage set position of event link

B Set position of break event

T Set position of trace event

Ti Set position of timer event

S Set position of snap-shot event

U Set position of stub event

A Set position of two or more events

If a range address is specified as an event’s address condition, the lower order address of the range

becomes the object.  Also, the address condition’s mask specification is not reflected.

(c) Program code display function

Lines where an “*” is displayed in the point mark area show that program code corresponding to the line

No. exists.

Symbol Explanation

With “*” Shows that program code corresponding to the source file line No. exists.  This is

displayed only in cases where the load module is downloaded and symbol information

has been read.

Without “*” Shows that program code corresponding to the source file line No. does not exist.

Also, file other than a source file, such as a text file is displayed, all the lines have no

“*” displayed.
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(2) Current PC mark display area

This area displays the mark “>” indicating the value of the current PC (PC register value).  By clicking the

mouse at this mark, the PC register value is displayed on the pop up window.

The program is simulated up to the specified line by double clicking on the current PC mark area.

(3) Line number/address display area

                                  
Normal display mode          Mixed display mode

This area displays the line number of the source file or text file.

On lines where program code corresponding to the source file line No. exists, the line No. is displayed in red

characters and on lines where no program code exists, the line No. characters are displayed in black.

Also, the disassemble display’s address is displayed in the mixed display mode.  Address letters appear

dimmed.

The position of the line No./address display area can be selected as desired by clicking the mouse.  A

selected line No. or address is displayed in reverse highlight.

The following functions are included in line No. or address selection.
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(a) Drag and drop function

The selected reverse highlighted line No. or address can be dragged and dropped to another window or

area.

If the line No. or address position selected in the line No./address display area is dragged using the left

button of the mouse, the mouse cursor’s shape changes from an arrow to a .

If the cursor is moved into a window or area where it is possible to drop it, the shape of the mouse cursor

changes form  to .

Operation is executed toward the address determined from the dropped address or line No. in the

window where they have been dropped.

Operation after drag and drop differs depending on the window or area where the items were dropped.

Window or Area which Is The Drop Object Operation After Drop

• Event Manager

Event Manager Area in each of the setting

dialog boxes below.

• Event dialog box

• Event link dialog box

• Break dialog box

• Trace dialog box

• Snap Shot dialog box

• Stub dialog box

• Timer dialog box

With the dropped line No. or address as the address condition, the

simulation event conditions are generated automatically.

The event condition names are generated automatically, as

Evt00001, Evt00002, ... The external sense data conditions and path

count are not specified.

Address conditions are set in the form of symbol name + offset value

for the symbol which is the closest.

• Link conditions setting area and disable

conditions setting area in the Event Link

dialog box.

• Break conditions setting area in the Break

dialog box.

• Delay trigger conditions setting area,

section trace start conditions area, section

trace end conditions area and qualified

trace conditions area in the Trace dialog

box.

• Snap shot conditions setting area in the

Snap Shot dialog box.

• Stub conditions setting area in the Stub

dialog box.

• Timer conditions setting area in the Timer

dialog box.

With the dropped line No. or address as the address condition, the

simulation event conditions are generated automatically.

Furthermore, automatically generated event conditions are set in the

conditions setting area where they were dropped.

The event condition names are generated automatically, as

Evt00001, Evt00002, ... The external sense data conditions and path

count are not specified.

Address conditions are set in the form of symbol name + offset value

for the symbol which is the closest.

• Address conditions setting area and data

conditions setting area in the Event dialog

box.

• Memory snap data setting area in the Snap

Shot dialog box.

• Jump destination address setting area in

the Stub dialog box.

The line No. or the address text are set in the area where they were

dropped.

Address conditions are set in the form of symbol name + offset value

for the symbol which is the closest.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 145

(b) Window link function

This function is a function which expresses the combination relationship between the Trace window and

Source window by line No. or address.  The line No. or address which links to the Trace window is

displayed in reverse highlight.  For details, refer to the window link function under Trace View window (p.

221).

(4) Source text display area

The source text display area performs display and disassembly display of source files and text files and

online assembly.

The display contents of the source text display area can be scrolled using the vertical and horizontal scroll

bars.

By selecting [View] → [Mix] on the Menu bar, you can switch between the normal display mode and the

mixed display mode.

Examples1. Normal display mode

The normal display mode is the mode in which the contents of source files or text files are

viewed.

2. Mixed display mode

The mixed display mode is the mode where disassemble display in combination with source

file display is performed.
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• If a line of the displayed source file corresponds to program code, the disassemble line is

displayed following that source line.  In the disassemble line, the address label, code data and

disassembled mnemonic are displayed.

• The mnemonic’s display starting position is adjusted according to the tab size setting value.

• The mixed display mode is valid only in cases where a load module is downloaded and symbol

information is read into it, and a source file corresponding to the downloaded load module is

displayed.

• Even if [View] → [Mix] on the Menu bar is checked and the mixed display mode is selected, in

cases where a source file other than one corresponding to a load module is displayed, the

display mode is the normal display mode.

• The disassemble display in the mnemonic column displayed in the mixed display mode can be

changed.  In the case of a change, move the cursor to the mnemonic column of the

disassemble display line and change it.  The overwrite mode and the insert mode can be

switched during editing using the  INS  key.

If the cursor is moved to a different line after making changes in the mnemonic column, the change contents

are checked.  If the change contents are incorrect, the code data in the line where the change was made

becomes an “*”.

Even if moved to a different line, the change contents are not written to memory.  A different line can be

changed with the change contents not written to memory.

The changed contents of the mnemonic column are written to memory using the  Enter  key.  The change

contents are also checked if the  Enter  key is pressed.  If the change contents are incorrect, the code data in

the incorrect line become an “*”.  If there is even one incorrect line, the change contents are not written to

memory.  In such a case, please correct the change contents.  If you are discarding the change contents,

press the  ESC  key.  If the change contents are not incorrect, press the  Enter  key.  After the change

contents are written to memory, the cursor moves to the next line’s mnemonic column.  Then the next line

can be changed.

The current PC line and the break point setting line are displayed with different display colors and in bold

characters.

Meaning of Line Display Color Explanation

Current PC line Yellow This is the source line or the disassemble display line corresponding

to the current PC value.

It is the line where a “>“ is displayed in the current PC mark area.

When there is a mixed display, the display color of the disassemble

display line only is changed.  The source line is displayed with the

normal display color.

Break point setting line Red This is a source line or a disassemble display line where a valid

break point is set.

It is the line where a red “B” is displayed in the point mark area.

When there is a mixed display, the display color of the disassemble

display line only is changed.  The source line is displayed with the

normal display color.
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The source text display area has a number of functions, including program simulation with the line where the

cursor is positioned as the object and setting of the break point.

• Start function

• Come function

• Break point setting function

• Program counter setting function

• Jump function

With these functions, if there is a cursor located on the source text line, the header address of the program

code corresponding to the source line becomes the object and if the cursor is located on the disassemble

display line, that address becomes the object.  Also, if no program code exists on the source line, the header

address of either the line above or the line below that line, where program code exists, becomes the object.

Furthermore, these functions cannot be simulated in the following cases.  The corresponding menu appears

dimmed and it becomes impossible to select it.

• In the case where a file other than a source file is being displayed.

• In the case where a user program is being simulated.

Each function is explained below.

(a) Start function

Simulates the user program from the line where the cursor is placed.

This function runs by performing operations in the following order.

<1> Move the cursor to the line where simulation is to start.

<2> Perform one of the following operations in the Main window.

Select [Run] → [Start From Here] on the menu bar.

Press the  GRPH  +  R  keys, then the  A  key, in that order.

Press the shortcut keys  SHIFT  +  f·6 .

(b) Come function

Executes the user program up to the line where a cursor is placed.

While the user program is executed by this function, however, the currently set break event is not

generated.

This function is executed by performing the following operations in the sequential order.

<1> Move the cursor to the line at which a break is to occur.

<2> Perform either of the following operations in the Main window.

Select [Run] → [Come Here] from the menu bar.

Press the  GRPH  +  R , and  M  keys in that order.

Press the shortcut key  f·6 .
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(c) Break point setting function

Sets a break point to the line where a cursor is placed.  A simulation event is used as the break point to

be set.

This function is executed by performing the following operations in the sequential order.

<1> Move the cursor to the line on which a break point is to be set.

<2> Perform one of the following operations in the Main window.

Select [Run] → [Break Point] from the menu bar.

Press the  GRPH  +  R , and  B  keys in that order.

Press shortcut keys  f·9 .

(d) Program counter setting function

Sets the address of the line where a cursor is placed to the program counter (PC).

This function is executed by performing the following operations in the sequential order.

<1> Move the cursor to the line on which the program counter (PC) to be set.

<2> Perform either of the following operations in the Main window.

Select [Run] → [Change PC] from the menu bar.

Press the  GRPH  +  R , and  H  keys in that order.

Press shortcut keys  CTRL  +  f·9 .

(e) Jump function

Jumps to the Assemble window, Memory window, or Coverage window by using the address of the line

where a cursor is placed as a jump pointer.  The jump destination window displays the jump pointer at

the beginning.

This function is executed by performing the following operations in the sequential order.

<1> Move the cursor to the line which is the jump origin.

<2> Perform one of the following operations in the Main window.

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• If the jump destination is the Memory window

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press shortcut keys  CTRL  +  M .

• If the jump destination is the Coverage window

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press shortcut keys  CTRL  +  I .
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The text displayed in the source text display area can be selected by the following methods.

• From the desired position in the displayed text, drag the text to the desired position within the range of

one line.  Select the text from the drag start position to the end position.

• Double click on the character string.  The words in the double clicked position are selected.

In the source text display area, there are a number of functions which can be performed with the selected

text as the object, such as Watch and Quick Watch.

(f) Watch function

Adds the selected variables, etc. to the Watch window and displays their contents.  This function can be

run by performing the following operations in order.

<1> Select the text.

<2> Perform one of the following operations in the Main window.

Select [View] → [View Watch] on the menu bar.

Press the  GRPH  +  V  keys, then the  I  key, in that order.

Click the  button in the Source window.

If the assembler symbol was selected, add it to the Watch window in accordance with the settings in the

Debugger Option dialog box.

Apart from the above method, this function can also be run by performing the following operation.

<1> Select the text.

<2> Perform one of the following operations in the Main window.

Select [View] → [Add Watch…] on the menu bar.

Press the  GRPH  +  V  keys, then the  W  key, in that order.

By performing the above operation, the Add Watch dialog box is opened and the selected text is added

to the Watch window.  Furthermore, if the Watch window has not yet been opened, it will be opened.

(g) Quick watch function

This displays the contents of the selected variables, etc. temporarily in the Quick Watch dialog box.

This function is run by performing the following operation in order.

<1> Select the text.

<2> Perform one of the following operations in the Main window.

Select [View] → [Quick Watch…] on the menu bar.

Press the  GRPH  +  V  keys, then the  Q  key, in that order.

Press the shortcut keys  CTRL  +  W .

Click the  button in the Source window.

The Quick Watch dialog box will open and the contents will be displayed.
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(h) Direct quick watch function

This displays the contents of the selected variables, etc. temporarily in the selected place.

This function is run by performing the following operation in order.

<1> Select the text.

<2> Place the mouse cursor on the selected text.

The Tool Tip type frame will be displayed and the contents will be displayed.

Example   Display of contents

(i) Drag and drop function

Through a drag and drop operation, the selected text can be dragged to another window or area and

dropped.  The operation order is shown below.

<1> Drag the selected text using the left button of the mouse.  The mouse cursor’s shape will change

from an arrow to a .

<2> If the mouse cursor is moved into a window or area where it is possible to drop it, the shape of the

cursor changes form  to .

Operation after drag and drop differs depending on the window or area where the items were dropped.
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Window or Area which Is The Drop Object Operation After Drop

• Event Manager

Event Manager Area in each of the

Setting dialog boxes below.

• Event dialog box

• Event Link dialog box

• Break dialog box

• Trace dialog box

• Snap Shot dialog box

• Stub dialog box

• Timer dialog box

If it is possible to convert the dropped text to an address value as a symbol,

with the converted address value as the address condition, the Access

status (all access status) or the Execute status event conditions are

generated automatically.

The event condition names are generated automatically, as Evt00001,

Evt00002, ... The data conditions, external sense data conditions and path

count are not specified.

The dropped text is set in the address conditions.  The relationship between

the generated event conditions and the symbols is as follows.

Symbol Status

Variable Access

Function Execute

Symbols in the data section Access

Symbols in the code section Execute

Other Access

• Link conditions setting area and disable

conditions setting area in the Event Link

dialog box.

• Break conditions setting area in the

Break dialog box.

• Delay trigger conditions setting area,

section trace start conditions area,

section trace end conditions area and

qualified trace conditions area in the

Trace dialog box.

• Snap shot conditions setting area in the

Snap Shot dialog box.

• Stub conditions setting area in the Stub

dialog box.

• Timer conditions setting area in the

Timer dialog box.

If it is possible to convert the dropped text to an address value as a symbol,

with the converted address value as the address condition, the Access

status (access all status) or the Execute status event conditions are

generated automatically.  Furthermore, the automatically generated event

conditions are set in each dropped conditions setting area.

The event condition names are generated automatically, as Evt00001,

Evt00002, ... The data conditions, external sense data conditions and path

count are not specified.

14 he dropped text is set in the address conditions.  The relationship

between the generated event conditions and the symbols is as follows.

Symbol Status

Variable Access

Function Execute

Symbols in the data section Access

Symbols in the code section Execute

Other Access

• Address conditions setting area and

data conditions setting area in the Event

dialog box.

• Memory snap data setting area in the

Snap Shot dialog box.

• Jump destination address setting area in

the Stub dialog box.

Text is set in the dropped area.

Watch window If the dropped text can be recognized as a symbol, the symbol contents are

displayed.
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Function buttons

Opens the Source Search dialog box and searches for source text character strings.

If text is selected in the source text display area, the selected text is set as the search object and the

Source Search dialog box is opened.  If text has not been selected, the Source Search dialog box is

opened with the search object in the blank state.

The search method is specified in the Source Search dialog box.  The search results are displayed

as selected in the Source window.

Performs the same operation as [View] → [Search…] on the menu bar.

Searches for the text which matches the search conditions set in the Source Search dialog box in

the backward direction from the cursor position (toward the top of the display).  It changes to a

.button during a search.

Searches for the text which matches the search conditions set in the Source Search dialog box in

the forward direction from the cursor position (toward the bottom of the display).  It changes to a

 button during a search.

Interrupts a search.

During a search, the  button or the  button changes to a  button.

Adds variables and other items selected in the source text display area to the Watch window.

If the Watch window is currently not open, this button opens it.

If text is not selected in the source text display area, the Watch window is opened only.

This button operates the same as [View] → [View Watch…].

Displays the selected variables and other contents of the source text display area temporarily in the

Quick Watch dialog box.

Opens the Quick Watch dialog box.

If text is not selected in the source text display area, the Quick Watch dialog box is opened only.

This button operates the same as [View] → [Quick Watch…].

Updates the contents of the window to the latest data.

Closes this window.

Caution

If program code is described in an include file and if multiple files are included, the 1 to 1 relationship

between line numbers and addresses disappears.  In such include files, the function which uses the

relationship between the line number and the address does not function normally.
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Source Search Dialog Box Modeless

General

This dialog box searches file contents.

Opening method

This dialog box can be opened by the following procedure.

• When the Source window is active

Select [View] → [Search…] from the menu bar.

Press the  GRPH  +  V , and  S  keys in that order.

Press the shortcut keys  CTRL  +  G .

Click the  button.

Window

Figure 6-32.  Source Search Dialog Box

Function

The Source Search dialog box consists of the following areas.

• Search data specification area

• Search condition specification area

• Search direction specification area

• Search file specification area

The function of each area is explained below.

(1) Search data
specification area

(2) Search condition
specification area

(3) Search direction specification area(4) Search file specification area
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(1) Search data specification area

This area specifies the data to be searched.

Although the character string selected in the window that has called this dialog box is displayed as the default

assumption, the character string can be changed by keyboard input as necessary.

A string of up to 150 characters can be searched.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

(2) Search condition specification area

This area specifies whether the uppercase and lowercase characters of the searched data are distinguished

by using the check box before search.  As the default, uppercase and lowercase characters are

distinguished.

Does not distinguish

Distinguishes (default)

(3) Search direction specification area

This area specifies the direction of search.  Two directions, upward and downward, can be selected.

Up: Upward search.  Searches the data from the current cursor position toward the beginning

(upward on display).

Down: Downward search.  Searches the data from the current cursor position toward the end

(downward on display).

(4) Search file specification area

This is the area which specifies the search file.  If the specification is omitted, a search is made within the

accessed window.
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Function buttons

Searches the specified data under given conditions.

If a matching character string is found as a result of the search, it is displayed in reverse video.

To continue searching data, click this button again.

Sets the specified conditions as search conditions and closes the dialog box.

Stops searching the data.

The  button changes to the  button while data is being searched.

Closes the Source Search dialog box.

This button changes to the  button while data is being searched.

Opens the Help window that explains the Source Search dialog box.

Opens the Source Move dialog box.
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Assemble Window MDI child window

General

This window displays a disassemble text.  It can also execute online assemble.

Opening method

This window can be opened by the following procedure.

• In the Main window

Select [Browse] → [Assemble] from the menu bar.

Press the  GRPH  +  B , and  A  keys in that order.

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press the shortcut keys  CTRL  +  D .

• Click the  button on the tool bar.

Window

Figure 6-33.  Assemble Window

Function

Performs disassemble display and online assembly.

Online assembly is performed by moving the cursor to the mnemonic.

The online assembly results are also reflected in the Memory window.

The Assemble window has two states, the active state and the static state.

Only one Assemble window in the active state can be opened at a time, but multiple Assemble windows that are in

the static state can be opened at the same time.

These two states are described below.

(1) Point mark display
area

(2) Current PC mark
display area

(3) Address display area (4) Disassemble display area
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(1) Active state

The first Assemble window that is opened is in the active state.

The Assemble window’s display is updated when it is in the active state so that the current PC line is

displayed at all times in synchronization with the current PC value.

Also, when in the active state, the Assemble window becomes the jump destination for the Jump function

and, if it is synchronized with the Trace View window, it updates the Assemble window’s display in

synchronization with the Trace window

(2) Static state

An Assemble window in the static state is not synchronized with the current PC value and it displays a

constant address.

Also, an Assemble window in the static state cannot be made a jump destination, nor can it be synchronized

with the Trace window.

If an Assemble window has already been opened in the active state, then all subsequent windows are

opened in the static state.

The Assemble window is configured from the following items.

The Assemble window consists of the following areas.

• Point mark display area

• Current PC mark display area

• Address display area

• Disassemble display area

The function of each area is explained below.

(1) Point mark display area

This area sets or deletes breakpoints, and displays the setting status of each event.

(a) Breakpoint setting/deleting function

By clicking this area with the mouse, breakpoints can be set or deleted.  The operation when clicking the

mouse depend on the line where the mouse is click as follows.

Line Click Button Operation

Where “B” mark (red and black) is displayed Left button Deletes breakpoint.

Where a blank or marks other than “B” is

displayed (E, L, T, mark etc.)

Left button Sets breakpoint.
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If a break point is set, the “B” mark is displayed in the point mark area.  However, if a mark other than the

“B” mark is displayed, the “A” mark is displayed.

The “A” mark shows that multiple events are set.

If a break point is deleted, the “B” mark in the point mark area is deleted and the area is left blank or a

mark other than the “B” mark is displayed.

The “B” mark is displayed in the following colors in accordance with the type of break point and its state.

Display Color Explanation

Red Shows that the set break point is valid.

Black Shows that the set break point is invalid.  The break point can be made valid in the

Event Manager or the Break dialog box.

If a break point is set in the point mark area, it becomes valid at the time when it is set.

(b) Event condition display function

The set status of each event is displayed.  If the simulation event, or the fetch condition of an access

event is set, a mark indicating the type of each event condition is displayed in the corresponding

assemble line.

Mark Meaning

E Set position of event condition

L Final stage set position of event link

B Set position of break event

T Set position of trace event

Ti Set position of timer event

S Set position of snap-shot event

U Set position of stub event

A Set position of two or more events

If a range address is specified as an event’s address condition, the lower order address of the range

becomes the object.  Also, the address condition’s mask specification is not reflected.
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(2) Current PC mark display area

This area displays mark “>” indicating the value of the current PC (PC register value).  The program is

simulated up to the specified line by double clicking on the current PC mark area.

(3) Address display area

This area displays the disassemble start address.  When this field is clicked, an address is displayed in

reverse video and selected.

In addition, this area has the following functions.

(a) Drag and drop function

A selected address which is reverse highlighted can be dragged to another window or area and dropped.

If the mouse cursor is positioned on the position of the selected address in the address display area and

the left button is pressed and held down, then when the mouse is dragged, the arrow cursor form

changes to a .

If the mouse cursor is moved into a window or area where it is possible to drop it, the shape of the cursor

changes form  to .

Operation is performed with respect to the dropped address in the window where it is dropped.

Operations after an address is dropped are different depend on the respective window or area where it is

dropped.
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Window or Area which Is The Drop Object Operation After Drop

• Event Manager

Event Manager area in each of the Setting

dialog boxes below

• Event dialog box

• Event Link dialog box

• Break dialog box

• Trace dialog box

• Snap Shot dialog box

• Stub dialog box

• Timer dialog box

With the dropped address as the address condition, the simulation

event conditions are generated automatically.

The event condition names are generated automatically, as

Evt00001, Evt00002, ... The external sense data conditions and path

count are not specified.

Address conditions are set in the form of symbol name + offset value

for the symbol which is the closest.

• Link conditions setting area and disable

conditions setting area in the Event Link

dialog box

• Break conditions setting area in the Break

dialog box

• Delay trigger conditions setting area,

section trace start conditions area, section

trace end conditions area and qualified

trace conditions area in the Trace dialog

box

• Snap shot conditions setting area in the

Snap Shot dialog box

• Stub conditions setting area in the Stub

dialog box

• Timer conditions setting area in the Timer

dialog box

The simulation event conditions are generated automatically with the

dropped address as the address condition.

Furthermore, automatically generated event conditions are set in the

conditions setting area where they were dropped.

The event condition names are generated automatically, as

Evt00001, Evt00002, ... The external sense data conditions and path

count are not specified.

Address conditions are set in the form of symbol name + offset value

for the symbol which is the closest.

• Address conditions setting area and data

conditions setting area in the Event dialog

box

• Memory snap data setting area in the Snap

Shot dialog box

• Jump destination address setting area in

the Stub dialog box

The address text is set in the area where it was dropped.

Address conditions are set in the form of symbol name + offset value

for the symbol which is the closest.

(b) Window link function

This function is a function which shows the combination relationship between the Trace View window and the

disassemble display by an address.

The Trace View window and the address which is the link object is displayed in reverse highlight. For details,

refer to the window link function of the Trace View window (p.221).
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(4) Disassemble display area

The address label, code data and disassembled mnemonic are displayed in the disassemble display area.

The disassemble display in the mnemonic column can be changed.

If you are changing it, move the cursor to the mnemonic column to make the change.  During editing, the

 INS  key can be used to switch between the overwrite mode and the insert mode.

After making the desired changes in the mnemonic column, if the cursor is moved to a different line, the

contents of the change are checked.  If the change contents are incorrect, the code data in the changed line

becomes an “*”.

Even if it is moved to a different line, the change contents are not written to memory.  You can change

another line without the changes being written to memory.

The changed contents in the mnemonic column are written to memory by pressing the  Enter  key.  The

change contents are also checked when the  Enter  key is pressed.  If the change contents are incorrect, the

code data in the incorrect line become an “*”.  If even one line is incorrect, the change contents are not

written to memory.  In such a case, please correct the change contents.  If the change contents are being

discarded, press the  ESC  key.  If the change contents are not incorrect, if the  Enter  key is pressed, after

the change contents are written to memory, the cursor moves to the next line’s mnemonic column.  In this

way changes can continue to be made in the next line.

If, as a result of the change, the number of bytes in the instructions after the change is fewer than the number

of bytes in the instruction before the change, the remaining bytes are replaced by the “NOP” instruction.

Also, if, as a result of the change, the number of bytes in the instructions after the change is greater than the

number of bytes in the instruction before the change, the next instruction is overwritten.  In this case also, the

remaining bytes are replaced by the “NOP” instruction.  Even in cases where the change runs into the source

line, it is overwritten in the same way.

Caution ???

As for the current PC line and the break point setting line, the display color is changed and they are displayed

in bold.

Meaning of Line Display Color Explanation

Current PC Line Yellow This line corresponds to the current PC value.

This is the line where a “>“ is displayed in the Current PC Mark

Area.

Break Point Setting Line Red This is the line where the valid break point is set.

This is the line where a red “B” is displayed in the Point Mark

Area.
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The Disassemble Display Area includes a number of functions such as program execution with the line where

the cursor is located as the object, or setting of the break point, etc.

• Start function

• Come function

• Break point setting function

• Program counter setting function

• Jump function

Furthermore, in the following case, these functions cannot be executed.  The corresponding menu appears

dimmed and it becomes impossible to select them.

• If a user program is being executed.

Each function is explained below.

(a) Start function

Simulates a user program from the line where the cursor is placed.

This function can be executed by performing the following operations in order.

<1> Move the cursor to the line where simulation is to start.

<2> Carry out any of the following operations from the Main window.

Select [Run] → [Start From Here] on the menu bar.

Press the  GRPH  +  R  keys, then the  A  key, in that order.

Press the shortcut keys  SHIFT  +  f·6 .

(b) Come function

Executes the user program up to the line where a cursor is placed.

While the user program is being executed in this mode, however, the break event currently set is not

generated.

This function is executed by performing the following operations in the sequential order

<1> Move the cursor to the line where simulation is to start.

<2> Perform either of the following operations in the Main window.

Select [Run] → [Come Here] from the menu bar.

Press the  GRPH  +  R , and  M  keys in that order.

Press the shortcut key  f·6 .

(c) Break point setting function

Sets a break point to the line where a cursor is placed.

A simulation event is used as the break point to be set.

This function is executed by performing the following operations in the sequential order.

<1> Move the cursor to the line to which a breakpoint is to be set.

<2> Perform one of the following operations in the Main window.

Select [Run] → [Break Point] from the menu bar.

Press the  GRPH  +  R , and  B  keys in that order.

Press shortcut keys  f·9 .
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(d) Program counter setting function

Sets the address of the line where a cursor is placed to the PC (program counter).

<1> Move the cursor to the line where you desire to set the program counter (PC).

<2> Perform either of the following operations in the Main window.

Select [Run] → [Change PC] from the menu bar.

Press the  GRPH  +  R , and  H  keys in that order.

Press the shortcut keys  CTRL  +  f·9 .

(e) Jump function

Jumps to the Source window, Memory window, or Coverage window by using the address of the line

where a cursor is placed as a jump pointer.

The jump destination window displays the jump pointer at the beginning.

This function is executed by performing the following operations in the sequential order.

<1> Move the cursor to the line which is the jump origin.

<2> Perform one of the following operations on the Main window.

• If the jump destination is the Source window

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Memory window

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  M  keys in that order.

Press shortcut keys  CTRL  +  M .

• When the jump destination is the Coverage window,

Select [Jump] → [Coverage] on the Menu bar.

Press the  GRPH  +  J  keys, then the  C  key, in that order.

Press the shortcut keys  GRPH  +  I .

The text displayed in the disassemble display area can be selected by the following method.

• From the position where the desired text starts in the display, drag the mouse to the position within the

range of 1 line where the desired text ends.  The text from the starting position to the end position is

the text that is selected.

• Double click on the character string.  The words in the double clicked position are selected.

In the disassemble display area, a number of functions, such as Watch and Quick Watch with the

selected text as the object, can be performed.
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(f) Watch function

This adds the selected data to the Watch window and displays its contents.

Furthermore, if an assembler symbol is selected, it is added to the Watch window in accordance with the

settings in the Debugger Option dialog box.

This function is executed by carrying out the following procedure in order.

<1> Select the text.

<2> Perform one of the following operations in the Main window.

Select [View] → [View Watch] on the menu bar.

Press the  GRPH  +  V  keys, then the  I  key, in that order.

Select [View] → [Add Watch…] on the menu bar.

Press the  GRPH  +  V  keys, then the  W  key, in that order.

Click the  button in the Assemble window.

If any of these operations is carried out, the Add Watch dialog box opens and adding is performed.

If the Watch window is not currently open, the Watch window is opened.

(g) Quick watch function

This temporarily displays the contents of the selected data in the Quick Watch dialog box.

This function is executed by carrying out the following procedure in order.

<1> Select the text.

<2> Perform one of the following operations in the Main window.

Select [View] → [Quick Watch…] on the menu bar.

Press the  GRPH  +  V  keys, then the  Q  key, in that order.

Press the shortcut keys  CTRL  +  W .

Click the  button in the Assemble window.

The Quick Watch dialog box opens and its contents are displayed.

(h) Direct quick watch function

This temporarily displays the contents of the selected data in the selected place.

This function is executed by carrying out the following procedure in order.

<1> Select the text.

<2> Position the mouse cursor on top of the selected text.

The tool tip type frame is displayed and the contents are displayed.

Example Display of Contents
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(i) Drag and drop function

Through a drag and drop operation, the selected text can be dragged to another window or area and

dropped.  The operation order is shown below.

<1> Drag the selected text using the left button of the mouse.  The mouse cursor’s shape will change

from an arrow to a .

<2> If the mouse cursor is moved into a window or area where it is possible to drop it, the shape of the

cursor changes form  to .

Operation after drag and drop differs depending on the window or area where the items were dropped.

(1/2)

Window or Area which Is The Drop Object Operation After Drop

• Event Manager

Event Manager area in each of the

Setting dialog boxes below

• Event dialog box

• Event Link dialog box

• Break dialog box

• Trace dialog box

• Snap Shot dialog box

• Stub dialog box

• Timer dialog box

If it is possible to convert the dropped text to an address value as a symbol,

with the converted address value as the address condition, the Access

status (all access status) or the Execute status event conditions are

generated automatically.

The event condition names are generated automatically, as Evt00001,

Evt00002, ... The data conditions, external sense data conditions and path

count are not specified.

The dropped text is set in the address conditions.  The relationship between

the generated event conditions and the symbols is as follows.

Symbol Status

Variable Access

Function Execute

Symbols in the data section Access

Symbols in the code section Execute

Other Access

• Link conditions setting area and disable

conditions setting area in the Event Link

dialog box

• Break conditions setting area in the

Break dialog box

• Delay trigger conditions setting area,

section trace start conditions area,

section trace end conditions area and

qualified trace conditions area in the

Trace dialog box

• Snap shot conditions setting area in the

Snap Shot dialog box

• Stub conditions setting area in the Stub

dialog box

• Timer conditions setting area in the

Timer dialog box

If it is possible to convert the dropped text to an address value as a symbol,

with the converted address value as the address condition, the Access

status (all access status) or the Execute status event conditions are

generated automatically.  Furthermore, the automatically generated event

conditions are set in each dropped conditions setting area.

The event condition names are generated automatically, as Evt00001,

Evt00002, ... The data conditions, external sense data conditions and path

count are not specified.

14 he dropped text is set in the address conditions.  The relationship

between the generated event conditions and the symbols is as follows.

Symbol Status

Variable Access

Function Execute

Symbols in the data section Access

Symbols in the code section Execute

Other Access



CHAPTER  6    WINDOW  REFERENCE

166 User’s Manual  U14611EJ1V0UM00

(2/2)

Window or Area which Is The Drop Object Operation After Drop

• Address conditions setting area and

data conditions setting area in the Event

dialog box

• Memory snap data setting area in the

Snap Shot dialog box

• Jump destination address setting area in

the Stub dialog box

Text is set in the dropped area.

Watch window If the dropped text can be recognized as a symbol, the symbol contents are

displayed.

Function buttons

Opens the Assemble Search dialog box and searches the character string of a mnemonic.  If text

has been selected in the disassemble display area set the selected text as the search object and

open the Assemble Search dialog box.

If text has not been selected, the Assemble Search dialog box will open with the search object in the

blank state.

Specify the search method in the Assemble Search dialog box.  The search results are selectively

displayed in the Assemble window.

Operation is the same as when [View] → [Search…]  is selected on the menu bar.

Searches for the contents which match with the search conditions set in the Assemble Search

dialog box before the cursor position (toward the top of the display).

During the search, it changes to a  button.

Searches for the contents which match with the search conditions set in the Assemble Search

dialog box after the cursor position (toward the bottom of the display).

During the search, it changes to a  button.

This button interrupts the search.

During a search, the  button or the  button changes to the  button.

This adds the symbol, etc. selected in the disassemble display area to the Watch window.

If the Watch window has not been opened, it opens the Watch window.

If text has not been selected in the disassemble display area, the Watch window opens only.

Operation is the same as when [View] → [View Watch] is selected on the menu bar.

This temporarily displays the contents of symbols, etc. selected in the disassemble display area in

the Quick Watch dialog box.

It opens the Quick Watch dialog box.

If text has not been selected in the disassemble display area, the Quick Watch dialog box opens

only.

Operation is the same as when [View] → [Quick Watch…] is selected on the menu bar.
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This updates the window contents to the latest data.

This closes the Assemble window.



CHAPTER  6    WINDOW  REFERENCE

168 User’s Manual  U14611EJ1V0UM00

Assemble Search Dialog Box Modeless

Outline

Searches the contents of the Assemble window.

Opening Method

This dialog box can be opened by one of the following procedures when the Assemble window is the current

window.

• In the Main window,

Select [View] → [Search…] on the menu bar.

Press the  GRPH  +  V  keys, then the  S  key in that order.

Press the shortcut keys  CTRL  +  G .

• In the Assemble window,

Click the  button.

Window

Figure 6-34.  Assemble Search Dialog Box

Functions

This initiates a search for the disassemble contents.  Continuous blank characters in which are included input

character strings and disassemble character strings are compared as blank characters.

The Assemble Search dialog box is configured from the following items.

• Search data specification area

• Search conditions specification area

• Search direction specification area

• Search range specification area

An explanation of each of the functions is given below.

(1) Search data
specification area

(2) Search conditions
specification area

(3) Search direction specification area(4) Search range specification area
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(1) Search data specification area

This specifies the data that are to be searched for.

In the default, the string selected in the accessed window is displayed, but as necessary, it can be changed

by entering from the keyboard.

A string of up to 150 characters can be searched.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

(2) Search conditions specification area

(a)

When searching, specification is made by the check box whether or not any distinction will be made in

the search data between upper case and lower case letters.

In the default, search is made with the distinction made between upper and lower case letters.

Not distinguished.

Distinguished (default)

(b)

When searching, this check box specifies whether to search the whole range or not.  In the default, only

the remaining portion of the range is searched.

Only the remaining portion of the range is searched (default).

The whole range is searched.

(3) Search direction specification area

This specifies the search direction.

There are two types of search, search Up, and search Down.

Up: Upward search.  Searches the data from the current cursor position toward the beginning

(upward on display).

Down: Downward search.  Searches the data from the current cursor position toward the end

(downward on display) (default).
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(4) Search range specification area

This is the area where the addresses being searched are specified.  A symbol or formula can also be

specified for the address specification.

The specification method is the same as in the case of the Address Move dialog box.  The default radix when

inputting numerical values is hexadecimal.

Function buttons

Searches for the specified search data in accordance with the conditions.  As the search results, the

matching character string is displayed in reverse highlight.  If you are searching continuously, press

this button again.

Sets the specified conditions as the search conditions and closes the dialog box.

Interrupts the search for data.

During the data search, the  button changes to the  button

This closes the Assemble Search dialog box.

During a data search, it changes to the  button.

This opens the help window for the Assemble Search dialog box.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 171

Memory Window MDI child window

General

This window displays and changes the memory contents.

Opening method

This window can be opened by the following procedure.

• In the Main window

Select [Browse] → [Memory] from the menu bar.

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  B , and  M  keys in that order.

Press the  GRPH  +  J , and  E  keys in that order.

Click the  button on the tool bar.

Window

Figure 6-35.  Memory Window
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Function

The memory contents are displayed and changed.

A vertical scroll bar is always displayed so that the memory contents can be scrolled.

You can also use the  button or the  button to move the display one page up or one page down.

Also, even during emulation, the internal RAM area can be displayed in real time.

The Memory window has two states, the active state and the static state.

There can be only one Memory window in the active state at a time, but multiple windows can be opened if they

are in the static state.

Each Memory window state is explained below.

•••• Active state

The Memory window in the active state is the jump destination of the jump function and the memory window’s

display is updated in synchronization with the Trace View window if it is synchronized with the Trace View

window.  The Memory window first opened is in the active state.

•••• Static state

Memory window in the static state is not the jump destination and do not synchronize with the Trace View

window.

Except for those points, it operates in the same way as in the active state.

If an active Memory window is already open, a Memory window is open in the static state.

The Memory window consists of the following areas.

• Address display area

• Memory display area

• ASCII display area

The function of each area is explained below.

(1) Address display area

This area displays memory addresses.

Address width varies when using a memory bank (SM78K0 only).
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(2) Memory display area

This is where the memory contents are displayed and changed.  The contents to be changed are displayed in

red characters, then by pressing the  Enter  key, they are actually written to the target.  The contents prior to

the change (when in the red character state) can be erased using the  ESC  key.

Up to 256 bytes of data can be changed at one time.

This area also has the following two functions in addition to displaying the memory contents making changes.

(a) Jump function

Jumps to the Source window, Assemble window, or Coverage window by using the address at the cursor

as a jump pointer.  The jump destination window displays the jump pointer at the beginning.

This function is executed by performing the following operations in the sequential order

<1> Move the cursor to the line which is the jump origin.

<2> Perform one of the following operations in the Main window.

• If the jump destination is the Source window

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in the sequential order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• When the jump destination is the Coverage window,

Select [Jump] → [Coverage] on the menu bar.

[Press the  GRPH  +  J  keys, then the  C  key, in that order.

Press the shortcut keys  CTRL  +  I .

(b) Window connect function

Displays the connection between the Trace View window and the Memory window as memory contents.

The relevant address is displayed in reverse video.

For further information, refer to the description of the window connect function for the Trace View

window.
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(3) ASCII display area

This area displays the memory contents in ASCII.  The memory contents can be converted into ASCII

characters for display.

The display can be turned ON/OFF by selecting [View] → [Ascii] on the menu bar (display is ON as default

assumption).

This area is also a jump pointer for the jump function, just like the memory display area ((2) above).

Function buttons

Opens the Memory Search dialog box and searches for a character string in the displayed memory

contents or memory contents.  At this time, the selected data (memory value) is displayed in the

Memory Search dialog box as the subject to search.  If the dialog box is opened without data

specified, specify data by key input.  The result of the search is displayed in reverse video in the

Memory window.

Searches for the memory contents which match the search conditions set in the Memory Search

dialog box in the backward direction from the cursor position (toward the top of the display).  It

changes to a  button during a search.

Searches for the memory contents which match the search conditions set in the Memory Search

dialog box in the forward direction from the cursor position (toward the bottom of the display).  It

changes to a  button during a search.

Interrupts a search.

During a search, the  button or the  button changes to a  button.

Updates the window’s contents with the latest data.

Closes this window.
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Memory Search Dialog Box Modeless

General

This window searches the memory contents.

Opening method

This window can be opened by the following procedure.

• Set the Memory window as the current window and in the Main window;

Select [View] → [Search…] from the menu bar.

Press the  GRPH  +  V , and  S  keys in that order.

Press the shortcut keys  CTRL  +  G  keys.

• In the Memory window

Click the  button.

Window

Figure 6-36.  Memory Search Dialog Box

Function

This searches the contents of memory for the Memory window where the cursor is positioned.

If the cursor is in the memory display area, the specified data is regarded as a binary data string and the memory

display area is searched.

If the cursor is in the ASCII display area, the specified data is regarded as an ASCII character string and the ASCII

display area is searched.

Unmapped areas, SFR areas and I/O protected areas are not searched.

(1) Search data specification area

(2) Search condition specification area

(3) Search direction specification area(4) Search range specification area
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The Memory Search dialog box consists of the following areas.

• Search data specification area

• Search condition specification area

• Search direction specification area

• Search range specification area

The function of each area is explained below.

(1) Search data specification area

This area specifies the data to be searched.

Although the character string selected in the window that has called this dialog box is displayed as the default

assumption, the character string can be changed by entering from the keyboard as necessary (input cannot

be done using a symbol or formula).

A string of up to 150 characters can be searched.

When searching the memory display area, a maximum of 16 items of data can be specified at one time.

Specify each item of data using a space as a delimiter.

When searching the ASCII display area, a maximum of 256 characters of data can be specified.  Spaces in

the data are treated as blank characters.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

(2) Search condition specification area

(a)

This area specifies what bits of data each specified search data is to be regarded as by using the radio

button before search.  As the default, search as 8-bit data.

Byte: Search as 8-bit data (default)

Word: Search as 16-bit data

Double Word: Search as 32-bit data

(b)

This is a check box which specifies whether to search the whole specified region or not when conducting

search.  With the default, only the portion remaining in the range is searched.

Searches the remaining portion of the area (default).

Searches the whole area.

(a)
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(3) Search direction specification area

This area specifies the direction of search.  Two directions, upward and downward, can be selected.

Up: Upward search.  Searches the data from the current cursor position toward the beginning

(upward on display).

Down: Downward search.  Searches the data from the current cursor position toward the end

(downward on display).

(4) Search range specification area

This is the area where the addresses being searched are specified.  A symbol or formula can also be

specified for the address specification.

The specification method is the same as in the case of the Address Move dialog box.  The default radix when

inputting numerical values is hexadecimal.

Function buttons

Searches for the specified search data in accordance with the conditions.  As the search results, the

matching character string is displayed in reverse highlight.  If you are searching continuously, press

this button again.

Sets the specified conditions as the search conditions and closes the dialog box.

Interrupts the search for data.

During the data search, the  button changes to the  button

This closes the Memory Search dialog box.

During a data search, it changes to the  button.

This opens the help window for the Memory Search dialog box.
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Memory Fill Dialog Box Modal

General

This dialog box initializes the memory contents with a specified code.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window

Select [Edit] → [Memory] → [Fill…] from the menu bar.

Press the  GRPH  +  E ,  M , and  F  keys in that order.

Window

Figure 6-37.  Memory Fill Dialog Box

Function

The Memory Fill dialog box consists of the following areas.

• Address range specification area

• Data specification area

The function of each area is explained below.

(1) Address range specification area

(2) Data specification area



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 179

(1) Address range specification area

This area specifies the address range of the memory contents to be initialized.

A symbol or formula can also be specified for the address specification.  The default radix when inputting

numerical values is hexadecimal.

Specify  the start address  for initialization and then  the end address , in that order.

(2) Data specification area

This area specifies the data to be initialized.

Binary data strings (byte data strings) with up to 16 items of data can be specified.  Specify each item of data

using a space as a delimiter.

The default radix is hexadecimal and the radix can be specified for each item of data.

Function buttons

Initializes the memory contents before closing the dialog.

Closes the Memory Fill dialog box.

It changes to a  button during a search.

Stops initiating the memory.

The  button changes to the  button while memory is being initiated.

Returns the input data to the original value.

Opens the Help window that explains the Memory Fill dialog box.
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Memory Copy Dialog Box Modal

General

This dialog box copies the memory contents.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window

Select [Edit] → [Memory] → [Copy…] from the menu bar.

Press the  GRPH  +  E ,  M , and  C  keys in that order.

Window

Figure 6-38.  Memory Copy Dialog Box

Function

The Memory Copy dialog box consists of the following area.

• Address specification area

The function of this area is explained below.

(1) Address specification area

(1) Address specification area



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 181

This area specifies the copy source addresses and copy destination address.

A symbol or formula can also be specified for the address specification.  The default radix when inputting

numerical values is hexadecimal.

From: Specifies the address range of the copy source.  Specify the  copy source start address  and

 copy source end address , in that order.

To: Specifies the start address of the copy destination.

Function buttons

After making a copy of the memory, this button closes the Memory Copy dialog box.

Closes the Memory Copy dialog box.

This button changes to the  button while copying the memory.

Stops copying the memory data.

The  button changes to the  button while copying the memory.

Returns the input data to the original value.

Opens the Help window that explains the Memory Copy dialog box.
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Memory Compare Dialog Box Modal

General

This dialog box compares the memory contents.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window

Select [Edit] → [Memory] → [Compare…] from the menu bar.

Press the  GRPH  +  E ,  M , and  P  keys in that order.

Window

Figure 6-39.  Memory Compare Dialog Box

Function

The Memory Compare dialog box consists of the following area.

• Compare range specification area

The function of this area is explained below.

(1) Compare range specification area

(1) Compare range specification area
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This area specifies the compare source addresses and compare destination addresses.

A symbol or formula can also be specified for the address specification.

The default radix when inputting numerical values is hexadecimal.

Mem1: Specifies the address range of the compare source.

Specify the  compare source start address  and  compare source end address , in that order.

Do not include the guard area and areas that are not mapped in the compare area.

Mem2: Specifies the start address of the compare destination.

Function buttons

Compares the memory contents before closing the dialog.

If no difference is found as a result of comparison, a confirmation dialog box is displayed.  If a

difference is found, a Memory Compare dialog box is opened.  The confirmation dialog box that is

displayed if no difference is found as a result of comparison is shown below.

By clicking the  button in this confirmation dialog box, the Memory Compare dialog box is

closed.

Closes the Memory Compare dialog box.

It changes to  button during comparison.

Stops comparing the memory contents.

The  button changes to the  button while comparing the memory contents.

Returns the input data to the original value.

Opens the Help window that explains the Memory Compare dialog box.
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Memory Compare Result Dialog Box Modeless

General

This dialog box displays the result of comparing memory contents.

This dialog box is opened if a discrepancy is found as a result of comparing the memory contents in the Memory

Compare dialog box.  If no discrepancy is found, this dialog box cannot be opened, but a confirmation dialog box is

opened.

Window

Figure 6-40.  Memory Compare Result Dialog Box

Function

The Memory Compare Result dialog box consists of the following areas.

• Compare result display area

The function of each area is explained below.

(1) Compare result display area
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(1) Compare result display area

This area displays the result of comparing memory contents.  Only those parts where there were comparison

errors are displayed.

Mem1 Addr: Displays the compare source address at which an error has been found.

Memory: Displays the data that has caused the error.  The compare source data is displayed on

the left, and the compare destination data is displayed on the right.

Mem2 Addr: Displays the compare destination address at which an error has been found.

Address width varies when using a memory bank (SM78K0 only).

Function buttons

Closes the Memory Compare Result dialog box.

Opens the Help window that explains the Memory Compare Result dialog box.
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Watch Window MDI child window

General

This window displays the specified data and changes it.

Opening method

This window can be opened by either of the following procedures.

• In the Main window

Select [Browse] → [Watch] from the menu bar.

Press the  GRPH  +  B  keys, then the  W  key, in that order.

Click the  button on the tool bar.

• In the Source window

After selecting data, select [View] → [View Watch] from the menu bar.

Press the  GRPH  +  V  keys, then the  I  key, in that order.

Click  button.

• In the Assemble window

After selecting data, select [View → [View Watch] from the menu bar.

Press the  GRPH  +  V  keys, then the  I  key, in that order.

Click  button.

• In the Quick Watch dialog box,

Click  button.

• In the Add Watch dialog box,

Click  button.
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Window

Figure 6-41.  Watch Window

Function

Displays and changes data.

Adding of the data display is done by selecting a variable name or symbol name in the Source window or the

Assemble window and clicking  button.  Adding is also done by dragging the selected part directly to the

Watch window with the mouse.

Adding can also be done by specifying a variable name or symbol name in the Quick Watch dialog box or the Add

Watch dialog box and clicking .

To delete a data display, click a variable name or symbol name (it is also possible to select multiple items using the

 SHIFT  key and the  CTRL  key), then after reverse highlighting it, click  button.  Alternatively, make a

selection using the arrow keys, then after reverse highlighting your selection delete it by pressing the  DEL  key.

Up to 10000 lines can be displayed.

Data value update results and rewrites are reflected in the Memory window.

Also, wide area data allocated to the internal RAM area (such as global variables or public symbols) can be

displayed in real time even during emulation, just as in the Memory window.

The boundary line between the symbol name display area and data value display/setting area can be moved to the

left or right using the mouse.

To move the boundary, drag the mouse cursor at the point when it changes from “ ” to “↔”.

(1) Symbol name display area (2) data value display/setting area
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The Watch window consists of the following areas.

• Symbol name display area

• Data value display/setting area

Each function is explained below.

(1) Symbol name display area

This area displays the variable names and symbol names.

A “+” is displayed in front of arrays, pointer type variables, and structures/unions.  These variables are

expanded and displayed as shown below by double clicking them;

• For an array, all the elements of the variable are displayed in accordance with the type of array variable.

• For pointer type variables, the data indicated by the pointer is displayed.

• For structures/unions, all the members of the structure/union are displayed in accordance with the type of

member variable.

However, if a structure/union is defined within a structure/union, the members up to the tag name or

variable name in the internal structure/union are displayed.

For variables which have been expanded and displayed, the “+” display is changed to a “−” display.  If they

are double clicked in this state, the expansion display is deleted.

Note that variables with a “+” that are displayed inside a structure/union are expanded and displayed in the

same way by double clicking them.

To expand and display, or to delete an expansion display, select the variable with the arrow keys, then press

the  Enter  key.

Data that has become invalid due to the changing of the scope or optimization compilation appears dimmed.
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(2) Data value display/setting area

This area is where data values are displayed and changed.

• When the variable is a structure/union, the address is displayed.

• When the variable is an enumeration type, the member name is displayed.

• When the variable is an integer, it is displayed as follows.

XXXH: Displayed in hexadecimal.

XXXT: Displayed in decimal.

XXXQ: Displayed in octal.

XXXY: Displayed in binary.

• When the variable is a floating point, it is displayed as follows.

[+|−]  inf

[+|−]  nan

[+|−]  integer portion e [+|−] exponent

[+|−]  integer portion.  Decimal portion [e [+|−] exponent]

Values are updated when simulation is stopped.  If you desire to save values, select [File] → [Save As…] in

the Main window, then save the displayed file.  Also, if the acquisition of data values has failed, this area will

be blank.

Data that has become invalid due to the changing of the scope or optimization compilation are displayed

together with a “?”.

The contents of changes are written to the target by pressing the  Enter  key.  The contents prior to the

change can be erased using the  ESC  key.
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Function buttons

Opens the Add Watch dialog box.

In the Add Watch dialog box, if the data is specified and  button is

clicked, the specified data is added to the Watch window.

Deletes the specified data from the Watch window.  The  DEL  key also performs this

operation.

Moves the selected data one line up.

Moves the selected data one line down.

Updates the contents of the window with the latest data.

Closes the Watch window.
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Quick Watch Dialog Box Modal

General

This is where the specified data is temporarily displayed and changed.

Opening method

This dialog box can be opened by either of the following procedures.

• In the Main window

Select [View] → [Quick Watch…] from the menu bar.

Press the  GRPH  +  V  keys, then the  Q  key, in that order.

• In the Source window

Click the  button.

Press the shortcut keys  CTRL  +  W .

• In the Assemble window

Click the  button.

Press the shortcut keys  CTRL  +  W .

Window

Figure 6-42.  Quick Watch Dialog Box

(5) Display size selection area(4) Display radix selection area

(1) Symbol
specification
area

(2) Symbol name display area

(6) Number of
display items
specification area

(3) Data value display/setting area
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Functions

In this dialog box the specified data is temporarily displayed and changed.

The boundary between the symbol name display area and the data value display/setting area can be moved to the

left or right using the mouse.  To move the boundary, drag the mouse cursor at the point when it changes form “ ” to

“↔”.

The Quick Watch dialog box consists of the following areas.

• Symbol specification area

• Symbol name display area

• Data value display/setting area

• Display radix selection area

• Display size selection area

• Number of display items specification area

Each function is explained below.

(1) Symbol specification area

This is where the data to be displayed is specified.

In the default setting, the string selected in the accessed window is displayed, but as necessary, it is also

possible to change it by entering from the keyboard.  However, if the selected string does not exist, this area

becomes blank.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

When the contents of the symbol specification area have been changed, clicking  button causes

the data specified in the symbol specification area to be displayed in the symbol name display area and data

value display/setting area.

(2) Symbol name display area

In this area the variable names or symbol names are displayed.

However, data which has becomes invalid due to the changes of the scope or optimization compilation are

not displayed.
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(3) Data value display/setting area

In this area the number of data displayed is specified.

The display contents and the way to change the contents are the same as in the Watch window.

(4) Display radix selection area

In this area the radix to be displayed is selected.

The display contents are the same as in the Watch window.

(5) Display size selection area

In this area the size to be displayed is selected.

The display contents are the same as in the Watch window.

(6) Number of display items specification area

In this area the number of display items is specified.

Specify blank or a number 1 or greater.  The default is blank.

If blank, the data is displayed as a simple variable.  If a number 1 or greater is specified, it is displayed as an

array variable.  In this case, a “+” is displayed in front of the data.  By double clicking these data, all the

elements of the data are expanded and displayed in accordance with the data type.  The “+” of the expanded

and displayed data changes to “–”.  Double clicking in this state cancels the expanded display.

If the display number of variables in the C language, assembler bit symbol, or registers, etc. is fixed, the

display number cannot be specified.
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Function buttons

Displays the data specified in the symbol specification area in the symbol name display area

and the data value display/setting area.

Adds the data specified in the symbol specification area to the Watch window.

Closes this window.

Change contents that have not actually been written to the target are erased.
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Add Watch Dialog Box Modal

General

This is where data to be displayed in the Watch window is registered.

Opening method

This dialog box can be opened by either of the following procedures.

• In the Main window

Select [View] → [Add Watch…] from the menu bar.

Press the  GRPH  +  V  keys, then  W  key, in that order.

• In the Watch window

Click the  button.

Window

Figure 6-43.  Add Watch Dialog Box

Functions

The Add Watch dialog box consists of the following areas.

• Symbol specification area

• Display radix selection area

• Display size selection area

• Number of display items specification area

The function of each area is explained below.

(1) Symbol specification area(2) Display radix selection area

(4) Number of display items specification area(3) Display size selection area
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(1) Symbol specification area

Specify the data to be added in the Watch window.

In the default setting, the string selected in the accessed window is displayed, but as necessary, it is also

possible to change it by entering from the keyboard.  However, if the selected string does not exist, this area

becomes blank.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

The expressions that can be used for inputting data are as shown below.

• C language variable name

Variable expression: Variable name

: Variable expression  Array elements (decimal constant values).

: Variable expression  Member name  Structure/union actual member

: Variable expression → Member name  Member of structure/union that indicates a

pointer.

: * Variable expression  Value of pointer variable

• Register name

• SFR name, SFR bit name

• Label, EQU and immediate address

• Register name, bit

• Label name, bit, EQU symbol name. bit, immediate address. bit

• Bit symbol

(2) Display radix selection area

This area is where the display radix is selected.

The display radix can be selected from among the following.

Proper: In the case of a variable, the value specified for each variable is displayed.

In the case of a symbol, it is displayed in the radix set in the Debugger Option dialog box.

Hex: Displayed in hexadecimal (XXXH).

Dec: Displayed in decimal (XXXT).

Oct: Displayed in octal (XXXQ).

Bin: Displayed in binary (XXXY).

String: Displayed as a character string.
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(3) Display size selection area

This area is where the display size is selected.

The display size can be selected from among the following.

Adaptive: In the case of a variable, the value specified for each variable is displayed.

In the case of a symbol, the size set in the Debugger Option dialog box is displayed.

Byte: Displayed in 8 bits.

Word: Displayed in 16 bits.

Double Word: Displayed in 32 bits.

If the display size of variables in the C language, assembler bit symbols or registers, etc. is fixed, the

specified size is displayed in the Watch window regardless of the specified display size.

(4) Number of display items specification area

In this area the number of display items is specified.  Specify blank or a number 1 or greater (1 to 256).  The

default is blank.

If blank, the data is displayed as a simple variable.  If a number 1 or greater is specified, it is displayed as an

array variable.  In this case, a “+” is displayed in front of the data.  By double clicking these data, all the

elements of the data are expanded and displayed in accordance with the data type.  The “+” of the expanded

and displayed data changes to “–”.  Double clicking in this state releases the expanded display.

If the display number of variables in the C language, assembler bit symbol, or registers, etc. is fixed, the

display number cannot be specified.

Function buttons

Adds the specified data to the Watch window.  Does not close the Add Watch dialog box.

After adding the specified data to the Watch window, it closes the Add Watch dialog box.

Returns the input data to its source.

Closes the Add Watch dialog box.

Opens the Help window for the Add Watch dialog box.
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Register Window MDI child window

General

This window displays and changes the contents of the registers (general-purpose registers and control registers).

Opening method

This window can be opened by the following procedure.

•  In the Main window

Select [Browse] → [Register] from the menu bar.

Press the  GRPH  +  B , and  R  keys in that order.

Click the  button on the tool bar.

Window

Figure 6-44.  Register Window (SM78K0S)

(1) General-purpose register display area

(2) Control register display area
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Figure 6-45.  Register Window (SM78K0)

When not using a memory bank

When using a memory bank

(3) Register bank setting area
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Function

This window displays and changes the contents of registers (general-purpose registers and control registers).

The Register window can be opened only in the active state.

The Register window consists of the following areas.

• General-purpose register display area

• Control register display area

• Register bank setting area (SM78K0 only)

The boundary line between the general-purpose register display area and control register display area can be

moved up or down using the mouse.  To move the boundary, drag the mouse cursor at the point when it changes from

“ ” to “↔”.

The function of each area is explained below.

(1) General-purpose register display area

This area displays or changes the register whose bank number is displayed in Register Bank: in the register

bank setting area.  The changed contents can be written to the target memory by pressing the  Enter  key.

The contents prior to the change can be erased using the  ESC  key.

Note The register bank setting area is not provided in the SM78K0S.

In addition, this area has a jump function as a jump pointer.  Operation of the jump function is the same as in

the case of the control register.

The View item on the menu bar can be used to select display of general-purpose registers under their

absolute or functional names.  Register or register-pair display can also be selected by double clicking a

general-purpose register in the area.

[Function name, register-pair display]
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[Function name, register display]

[Absolute name, register-pair display]

[Absolute name, register display]

(2) Control register display area

• Memory bank not used
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• Memory bank used (SM78K0 only)

This area displays or changes the contents of the control registers.  The contents can be written to the target

memory by pressing the  Enter  key.  The contents prior to the change can be erased using the  ESC  key.

The flag names and flag values of the register to which “+” is prefixed are displayed by double-clicking the

register name.  The “+” then changes to “−”.  Switching can also be done by selecting a register name using

the arrow keys then pressing the  Enter  key.

In addition, this area has a jump function as a jump pointer.

In addition, this area has a jump function that jumps to the Source window, Assemble window, Memory

window, or Coverage window by using a selected control register value as a jump pointer.  The jump

destination window displays the jump pointer at the beginning.

This function is executed by performing the following operations in the sequential order

<1> Select the control register.

<2> Perform either of the following operations in the Main window.

• If the jump destination window is the Source window.

Select [Jump] → [SourceText] from the menu bar.

Press  GRPH  +  J , and  S  keys in that order.

Press the shortcut keys  CTRL  +  U .

• If the jump destination window is the Assemble window.

Select [Jump] → [Assemble] from the menu bar.

Press  GRPH  +  J , and  A  keys in that order.

Press the shortcut keys  CTRL  +  A .

• If the jump destination window is the Memory window.

Select [Jump] → [Memory] from the menu bar.

Press  GRPH  +  J , and  E  keys in that order.

Press the shortcut keys  CTRL  +  M .

• If the jump destination window is the Coverage window.

Select [Jump] → [Coverage] from the menu bar.

Press  GRPH  +  J , and  C  keys in that order.

Press the shortcut keys  CTRL  +  I .

The address width of the PC varies when using a memory bank (SM78K0 only).
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(3) Register bank setting area (SM78K0 only)

This area displays and sets the bank number for the general-purpose registers.

Register Bank: This area displays and sets the register bank displayed in the general-purpose register

display area. The bank number can be changed using the  button.

Current Bank: This area displays the register bank number (current bank) that is currently specified as

the target.

Function buttons

Updates the contents of the window to the latest data.

Closes this window.
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SFR Window MDI child windows

General

This window displays and changes the contents of the SFRs.  Also, the entered I/O port registered in the Add I/O

Port dialog box can be viewed and changed.

Opening method

This window can be opened by the following procedure.

•  In the Main window

Select [Browse] → [Sfr] from the menu bar.

Press the  GRPH  +  B , and  F  keys in that order.

Click the  button on the tool bar.

Window

Figure 6-46.  SFR Window

(1) SFR name display area

(2) Attribute display area (3) SFR contents display area
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Function

This window displays or changes the contents of SFRs.  However, in the case of the read-only SFR, the value

cannot be changed.  Also, in the case of a SFR where the device is operated by the read operation, it becomes a

read-protected object and reading is not performed.  If you desire to read this kind of SFR, select the SFR you would

like to read, then perform the operation by selecting [View] → [Compulsion Read] from the menu bar.  The I/O ports

that are entered in the Add I/O Port dialog box can be viewed and changed.

Operations with respect to read-only I/O ports or read-protected I/O ports are the same as in the case of the SFR.

The SFR window consists of the following areas.

• SFR name display area

• Attribute display area

• SFR contents display area

The function of each area is explained below.

(1) SFR name display area

This area displays the names of the SFRs and I/O port name.

The bit name and bit values of the SFR to which “+” is prefixed are displayed by double-clicking the SFR

name.  The “+” then changes to “–”.

Switching can also be done by selecting an SFR name using the arrow keys then pressing the  Enter  key.

If the I/O port address is an undefined value, the I/O port name appears dimmed.
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(2) Attribute display area

This area displays read/write attributes of each SFR and I/O port, access types, and absolute addresses.

Selection of whether to display the attribute display area can be made by selecting [View] → [Attribute] from

the menu bar.

The following read/write attributes are displayed.

Attribute Contents

R Read-only SFR or I/O port

W Write-only SFR or I/O port

R/W Read/write SFR or I/O port

The following access types are displayed.

Access Type Contents

1 SFR that can be accessed in bit units

8 SFR or I/O port that can be accessed in byte units

16 SFR or I/O port that can be accessed in word units
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(3) SFR contents display area

This area displays and changes the contents of the SFRs or I/O ports.

The contents are displayed as follows, depending on the attributes of the SFRs or I/O ports.

• Read-only SFR or I/O port: Displayed in black

• Write-only SFR or I/O port: “--” is displayed

• Read/write SFR or I/O port: Displayed in black

• SFR or I/O port whose value changes when read: “**” is displayed

The contents can be written to the target by pressing the  Enter  button.

The contents prior to the changes can be erased using the  ESC  key.

The value of a read protected SFR or I/O port can be read by executing [View] → [Compulsion Read] on the

menu bar.

Function buttons

Updates the contents of the window to the latest data.

Closes this window.
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SFR Select Dialog Box Modal

General

This dialog box is used to select an SFR or I/O port that is not being displayed in the SFR window.  The display

order is also set here.

Opening method

This window can be opened by the following procedure when the current window is the SFR window.

•  In the Main window

Select [View] → [Select…] from the menu bar.

Press the  GRPH  +  V , and  E  keys in that order.

Figure 6-47.  SFR Select Dialog Box

Functions

The SFR Select dialog box consists of the following areas.

• Display SFR selection area

• Display order specification buttons

• No display list sort buttons

The function of each area is explained below.

(1) Display SFR selection area

(2) Display order specification buttons (3) No display list sort buttons
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(1) Display SFR selection area

Select the SFRs and I/O ports that are to be displayed on the SFR window, and the SFRs and I/O ports that

are not to be displayed.

The SFRs and I/O ports displayed in the SFR window are shown on the [Display:] list, and the SFRs and I/O

ports not displayed are shown on the [No Display:] list.  The SFRs and I/O ports displayed or not displayed in

the SFR window can be changed by selecting an SFR name or I/O port name from these lists and by clicking

the    << Show    or    Hide >>    button.

If all the registers and I/O ports are to be displayed, click the  << Show All  button.  If all the registers and I/O

ports are to be hide, click the  Hide All >>  button.

The function of each button is explained below.

    << Show    Moves the SFRs and I/O ports selected in the [No Display:] list area to the cursor

position in the [Display:] list area.

    Hide >>      Moves the SFRs and I/O ports selected in the [Display:] list area to the [No

Display:] list area.

 << Show All Moves all the SFRs and I/O ports to the cursor position in the [Display:] list area.

  Hide All >>  Moves all the SFRs and I/O ports to [No Display:] list area.

Two or more SFRs and I/O ports can be selected by clicking the mouse while

holding down the control key or shift key when selecting an SFR or I/O port from the

[Display:] list or [No Display:] list.
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(2) Display order specification buttons

These set the order in which the [Display:] list is displayed.  The SFR or I/O port selected in the [Display:] list

moves to the top line of the list when  button is clicked and moves to the bottom line of the list

when  button is clicked.  It also moves one line up when  button is clicked and one

line down when  button is clicked.

The functions of each button are as shown below.

Moves the SFR or I/O port selected in the [Display:] list to the top line of the list.

Moves the SFR or I/O port selected in the [Display:] list one line up.

Moves the SFR or I/O port selected in the [Display:] list one line down.

Moves the SFR or I/O port selected in the [Display:] list to the bottom line of the list.

(3) No display list sort buttons

Select the order in which the a [No Display:] list is displayed.  When  button is clicked, the items

are displayed in alphabetical order, and when  button is clicked, the items are displayed in

address order.

The functions of each button are as shown below.

Displays the [No Display:] list in alphabetical order.

Displays the [No Display:] list in address order.
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Function buttons

After the selection results and the specified display order are reflected in the SFR window,

clicking this button closes the SFR Select dialog box.

Cancels the change and closes this window.

Cancels the change and restores the original states.

Opens the Help window that explains this window.
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Add I/O Port Dialog Box Modal

General

This is where an I/O port to be added to the SFR window is registered.

Opening method

This dialog box can be opened by either of the following procedures.

•  In the Main window

Select [Option] → [Add I/O Port…] from the menu bar.

Press  GRPH  +  O , and  P  keys in that order.

Window

Figure 6-48.  Add I/O Port Dialog Box

Functions

The Add I/O Port dialog box consists of the following areas.

• I/O port selection area

• I/O port name specification area

• I/O port address specification area

• Access size specification area

• Access attributes specification area

The functions of each area are explained below.

(2) I/O port name specification area (3) I/O port address specification area(1) I/O port selection area

(4) Access size specification area (5) Access attributes specification area
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(1) I/O port selection area

This area is where a list of the currently entered I/O ports is displayed.  If you enter a new I/O port, it is added

to this list.  Also, select an I/O port that has already been entered and it can be changed or deleted.

(2) I/O port name specification area

This is where the name of the I/O port to be added is specified.

An I/O port name with up to 15 characters can be specified.

(3) I/O port address specification area

This is where the I/O port address to be added is specified.

Addresses which can be specified are those in the SFR area.

Address specification can be done by specifying a symbol or formula.  The specification method is the same

as in the case of the Address Move dialog box.

The default radix when inputting numerical values is hexadecimal.

(4) Access size specification area

This is where the access size of the added I/O port is specified.

Byte: 8 bits (default)

Word: 16 bits

Word access can be specified for SFR and external SFRNote only.

Note External SFR is provided in the SM78K0 only.
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(5) Access attributes specification area

This is where the access attributes of the added I/O port are specified.

Read only: Sets exclusive read only.

Write only: Sets exclusive write only.

Read Protect: Sets read protect.

In the default (all unchecked state), read and write are both enabled.

Function buttons

Closes the Add I/O Port dialog box after reflecting the add results in the SFR window.

Cancels the change and closes this window.

Cancels the change and restores the original states.

Opens the Help window that explains this window.

Adds the I/O port with the specified address.

Changes the settings for the selected I/O port.

Deletes the selected I/O port.
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Local Variable Window MDI child window

General

This window displays or changes the local variable in the current function.

Opening method

This window can be opened by the following procedure.

•  In the Main window

Select [Browse] → [Local Variable] from the menu bar.

Press the  GRPH  +  B , and  L  keys in that order.

Click the  button on the tool bar.

Window

Figure 6-49.  Local Variable Window

Function

This window displays or changes the local variable.

This window automatically displays the local variable in the current function.  Variables cannot be add or deleted.

The boundary line between the local variable name display area and local variable value display/setting area can

be moved to the left or right by dragging and dropping with the mouse. The boundary can be moved by dragging when

the mouse cursor changes from “ ” to “Ù”.

(1) Local variable name display area

(2) Local variable value display/setting area
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The Local Variable window consists of the following areas.

• Local variable name display area

• Local variable value display/setting area

Each function is explained below.

(1) Local variable name display area

This area displays local variable names.

The type and variable name are shown.  These are displayed in the same way as in the Watch window.  Also,

it is possible to have an expansion display like in the Watch window.  However, variable names that have

become invalid due to optimization compilation, etc., are not displayed.

The auto variable, internal static variable and the register variable can be displayed.

(2) Local variable value display/setting area

This area displays/changes local variable values.

The variable value is displayed in the same way as in the Watch window.

Change contents are written to the target by pressing the  Enter  key.  The contents prior to the change can

be erased using the  ESC  key.

Function buttons

Updates the contents of the window to the latest data.

Closes this dialog box.
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Stack Window MDI child window

General

This window displays and changes the current stack contents of the user program.

Opening method

This window can be opened by the following procedure.

•  In the Main window

Select [Browse] → [Stack Trace] from the menu bar.

Press the  GRPH  +  B , and  K  keys in that order.

Click the  button on the tool bar.

Window

Figure 6-50.  Stack Window

(1) Stack frame number display area

(2) Stack frame contents display area (3) Stack contents display/setting area
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Function

This is where the stack contents are displayed and changed.

If the full traced contents cannot be displayed, a vertical scroll bar is displayed so that the contents can be scrolled.

The boundary between the stack frame contents display area and the stack contents display/setting area can be

moved to the left or right by the mouse.  To move the boundary, drag the mouse cursor at the point when it changes

form “ ” to “↔”.

This window has an active state only.

The Stack window consists of the following areas.

• Stack frame number display area

• Stack frame contents display area

• Stack contents display/setting area

The function of each area is explained below.

(1) Stack frame number display area

This area displays the stack frame numbers.

The stack frame number is a natural number starting from 1, and the shallower the stack nest is, the larger

this number becomes.  A stack number that is 1 larger than a certain function is the calling function of that

function.

(2) Stack frame contents display area

This area is where the stack frame contents are displayed.

The function or local variable names are displayed.

If the stack contents are functions, they is displayed by [Program name $ File name # Function name (Index

list) # Line no.].  The delimiter between the program name and the file name is a “$” and the delimiter

between the file name and the function name is a “#”.  The “#” is also used as the delimiter between the

function name and the line no.  If there are local variables in a function, the local variables are displayed on

the following and subsequent lines.
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If the contents of the stack are local variables, the type and variable name is displayed.  They are displayed in

the same way as in the Watch window.  Note that, internal static variables and register variables are not

displayed.

(3) Stack contents display/setting area

This area displays and changes the contents of the stack.  “–” or local variable values are displayed.  If the

stack contents are functions, a “–” is displayed and the contents cannot be changed.

If the stack contents are local variables, the variable values are displayed.  Variable values are displayed in

the same way as in the Watch window.  It is possible to change variable values.

Changed contents are written to the target by pressing the  Enter  key.  The contents prior to the change can

be erased using the  ESC  key.

In addition, this area has the following functions.

(a) Jump function

Jumps to the Source window, Assemble window, Memory window, or Coverage window by using the

function indicated by the stack frame number at the cursor as a jump pointer.  The jump destination

window displays the jump pointer at the beginning.

This function is executed by performing the following operations in the sequential order

<1> Position the cursor in the stack contents display/setting area.

<2> Perform one of the following operations on the Main window.

• If the jump destination is the Source window

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• When the jump destination is the Memory window,

Select [Jump] → [Memory] on the menu bar.

Press the  GRPH  +  J  and  E  key, in that order.

Press the shortcut keys  CTRL  +  M .
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• When the jump destination is the Coverage window,

Select [Jump] → [Coverage] on the menu bar.

Press the  GRPH  +  J  and  C  key, in that order.

Press the shortcut keys  CTRL  +  I .

Details of the jump destination are as follows.

Type of Function Description of Operation

• If the jump destination is the Source window, it jumps to the

current PC line.

Function with the shallowest

nest (in the case of the current

function) • If the jump destination is other than the Source window, it jumps

to the current PC address.

• If the jump destination is the Source window, it jumps to the line

where the function nested below is called.

Functions with nests below

(in the case of a function other

than the current function) • If the jump destination is other than the Source window, it jumps

to the next address of the instruction that is calling the function

nested below.

Function button

Updates the contents of the window to the latest data.

Closes this window.

Cautions

(1) If the stack trace display function has a function that does not generate a stack frame, it may not be

displayed correctly.

(2) [ERROR] may be displayed during function prologue processing or epilogue processing.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 221

Trace View Window MDI child window

General

This window displays the trace results.

Opening method

This window can be opened by the following procedure.

•  In the Main window

Select [Browse] → [Trace] from the menu bar.

Press the  GRPH  +  B , and  T  keys in that order.

Click the  button on the tool bar.

Window

Figure 6-51.  Trace View Window

(1) Point mark display area

(3) Trace result display area(2) Trace mode display area
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Functions

This is where the trace results are displayed.

The vertical scroll bar is displayed at all times and the contents can be scrolled.  It is also possible to move up one

page or down one page using the  button or  button.

There are two modes in the Trace View window, the normal display mode and the mixed display mode.

• Normal display mode: Displays the trace results only.

• Mixed display mode: Displays the source file together with the trace results.

The Trace View window can be opened only in the active state and, the window’s display is updated in a break or

during step simulation.

The tracer has a ring structure.  For that reason, if data exceeding a valid frame is written, the oldest data is

overwritten.  Also, in the display, the frames are displayed in frame order with the oldest data as frame 0.

To clear the trace contents, select [Option] → [Trace Clear].

The trace buffer size can be changed in the Extended Options dialog box.

Block information is written to the tracer in each block of user program execution.  Display of block information is

one horizontal line in each display area.  Block information is written in the following cases in accordance with the

previous and subsequent simulation modes.

Previous Simulation Mode When Block Information Is Written

In the case of real time

simulation

• When real time simulation is executed

• When step simulation is executed

In the case of step simulation • When real time simulation is executed

• When the simulation address is changed and step

simulation is executed

A tracer is made valid by selecting [Option] → [Tracer ON].

Note that, operation with respect to a tracer during program simulation is performed by selecting [Run] → [Tracer

Start/Close].

The Trace View window consists of the following areas.

• Point mark display area

• Trace mode display area

• Trace result display area

The functions of each area are explained below.
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(1) Point mark display area

This is where the setting states of various events are displayed.  If a simulation event or access fetch event is

set to the corresponding trace event, the mark corresponding to the type of the event is displayed.

Note that the marks displayed are not marks from tracing but are event marks set when the trace results are

displayed.

Mark Meaning

E Indicates that the event condition is set.

L Indicates that the final level of the event link is set.

B Indicates that the break event is set.

T Indicates that the trace event is set.

Ti Indicates that the timer event is set.

S Indicates that the snap shot event is set.

U Indicates that the stub event is set.

A Indicates that the two or more events is set.

(2) Trace mode display area

This is where the type of trace mode is displayed.

The display contents are as follows.

A: All traced or section traced frames.

Q: Qualify traced frames.

S: Step simulation frames.

T: Frames where a delay trigger has occurred.

In cases where quality trace conditions have been established while section trace conditions were being

established, a “Q” is displayed.
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(3) Trace result display area

(a) (b) (c) (d) (e) (f)

This is where the trace results are displayed.  if this area is selected, the jump function and the window linking

function can be used.

The following contents are displayed in the trace results display area.  Note that display or non-display of

each area can be selected in the Trace Data Select dialog box.

• Trace flame number display

• Time tag display

• Fetch operation access display

• Data operation access display

• Branch source address display

• Mnemonic display

(a) Trace frame number display (Frame)

This where the trace frame number is displayed.

(b) Time tag display (Time)

This is where the clocks required for the target chip before executing the current trace contents are

displayed.  The count dividing rate can be changed in the Extended Options dialog box.

Also, the time tag display can be switched between clock count display and time display in the Trace

Data Select dialog box.

(c) Fetch operation access display (Address Data Status)

This is where the fetch result of the program and the snap contents are displayed.  This field is displayed

as follows depending on the status displayed in the status display field (Status).

Item Display Contents

BRM1 Program fetch display (fetches the first byte of the first instruction after branching.)

M1 Program fetch display (fetches the first byte of the instruction)

OP Program fetch display (fetches the second and subsequent byte of the opcode)

IF Program fetch display (invalid fetch or status undefined)

SNAP Snap display

Status

Blank Fetches the 6th byte and 8th byte of the instruction.
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In the case of the program fetch display, the display is as follows.

Items Display Contents

Address Fetch address display

Data Fetch data display

In the case of the snap display, the display is as follows.

Items Snap Types Display Contents

Register Register name

SFR SFR name

Address

Memory Memory address

Register Register value

SFR SFR value

Data

Memory Memory contents

(d) Data operation access display (Address Data Status)

This is where the access result of data.

Items Display Contents

VECT Vector read

RW Data read/write

R Data read

Status

W Data write

Address Address display

Data Data display

(e) Branch source address display (Jmpaddr)

Displays the final address of the branch source.

The status of the fetch operation access display is displayed only in the case of BRM1.
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(f) Mnemonic display (DisAsm)

This is where the disassemble result is displayed.

This is displayed only when the status of the fetch operation access display is BRM1 or M1.

In the trace results display area, switching between normal display mode and mixed display mode can be

performed by selecting [View] → [Mix] from the menu bar.

• Normal display mode

Normal display mode is the mode in which only the trace results are shown.

• Mixed display mode

Mixed display mode is the mode in which the source file is displayed in combination with the trace

results.

If the program code corresponds to the displayed program fetch address line, the source file line is

displayed before that trace results line.

When the load module is downloaded and symbol information is being read, the mixed display mode

becomes valid only in cases where fetch address, fetch data, fetch status or disassemble results are

being displayed.

Even in cases where [View] → [Mix] is selected on the menu bar and mixed display mode is selected, if

one of the above items is not being displayed, the display is normal.

The source file line’s display color is changed and is highlighted in green.

The jump function and window linking function are explained below.

• Jump function

• Window linking function
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(a) Jump function

The jump function is executed by carrying out the following steps in that order.

<1> Move the cursor to the jump source line.

<2> In the Main window, do either of the following operation.

• If the jump destination window is the Source window.

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press the shortcut keys  CTRL  +  U .

• If the jump destination window is the Assemble window.

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press the shortcut keys  CTRL  +  D .

• If the jump destination window is the Memory window.

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press the shortcut keys  CTRL  +  M .

• If the jump destination window is the Coverage window.

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press the shortcut keys  CTRL  +  I .

The address used as the jump source changes according to the cursor position.

Cursor Position Jump Pointer

Access address display area Access addressNote

Access data display area Access addressNote

Access status display area Access addressNote

Other than above Fetch address

Note If the jump destination is the Source window or the Assemble window, the fetch address is made

the jump pointer.
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(b) Window linking function

The window linking function can be used by carrying out the following procedure in order.

<1> Make the Trace window the current window and select the window that you would like to

synchronize with from among the items in [View] → [Window Synchronize] on the menu bar.

When this is done, the window opens.  However, if the window you would like to synchronize with

is not open in the active state, it will open in the active state.

Items in the [Window Synchronize] Linked Window

Source Source window

Assemble Assemble window

Memory Memory window

Coverage Coverage window

<2> Move the cursor to the synchronization origin line in the trace results display area in the trace

window.

<3> The trace results address selected in <2> is used as the pointer, and the linked contents are

displayed in the corresponding window selected in <1>, or the cursor is positioned there.

In the case of window linking as well, the address which is the link origin changes as follows in

accordance with the cursor position.

Cursor Position Jump Pointer

Access address display area Access addressNote

Access data display area Access addressNote

Access status display area Access addressNote

Other than above Fetch address

Note If the linking origin is the Source window or the Assemble window, the fetch address is always

made the jump pointer.  Unlike the jump function, if the cursor’s position is moved in the Trace

window, the window linking function moves the reverse video in each linked window.
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Function buttons

Opens the Trace Search dialog box and searches trace results or performs pick up.

Search results are reverse highlighted in the Trace window.  In the pick up display modeNote,

frames which matched the search conditions are picked up and displayed.

This button cannot be selected when a snap frame or a BRM1 frame is picked up and displayed.

Trace results which match the search conditions, and which have been set in the Trace Search

dialog box, are searched for before the cursor position frame (toward the top of the display).

This button cannot be selected in the pick up display modeNote.

Trace results which match the search conditions, and which have been set in the Trace Search

dialog box, are searched for after the cursor position frame (toward the bottom of the display).

This button cannot be selected in the pick up display modeNote.

Updates the contents of the window with the latest data.

Close this window.

Note The pick up display mode is when [View] → [Pick Up] → [Search] is selected or when

“Pick Up Search Frame” is selected in the Trace Data Select dialog box.
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Trace Search Dialog Box Modeless

General

This is where trace data is searched for.

If search frame pick up is specified from the [View], or the Trace Data Select dialog box (pick up display mode),

pick up of trace data is executed.

Opening method

This dialog box can be opened by the following procedure when the current window is the Trace window.

• In the Main window

Select [View] → [Search…] from the menu bar.

Press the  GRPH  +  V , and  S  keys in that order.

• In the Trace View window

Click  button.

Press the shortcut keys  CTRL  +  G  keys.

Window

Figure 6-52.  Trace Search Dialog Box (1/2)

When pick up is not displayed.

(1) Status selection area (5) Search conditions specification area

(2) Access size selection area (6) Search direction specification area

(3) Address setting area (7) Search range specification area

(4) Data setting area

<1>

<2>

<3>

<4>

<5>

<7>

<6>



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 231

Figure 6-52.  Trace Search Dialog Box (2/2)

When pick up is displayed

Functions

Trace data is searched and pick up.

• If [View] → [Pick Up] → [Off] is selected from the menu bar, or [Pick Up Off] is selected in the Trace Data

Select dialog box, a trace data search is executed.

• If [View] → [Pick Up] → [Search] is selected on the menu bar, or [Pick Up Search Frame] is selected in the

Trace Data Select dialog box (pick up display mode), trace data pick up is executed.

Note that if pick up of a snap frame or pick up of the first M1 fetch frame after a program branch is specified from

the menu bar or the Trace Data Select dialog box, the Trace Search dialog box cannot be called.

The Trace Search dialog box consist of the following areas.

• Status selection area

• Access size selection area

• Address setting area

• Data setting area

• Search conditions specification area

• Search direction specification area

• Search range specification area

The functions of each area are explained below.
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(1) Status selection area

This is where the status conditions are set and selected.

The status conditions that can be specified are shown below.  It is possible to specify the status condition in

abbreviated form.  There is no distinction between uppercase and lowercase characters in the input status

condition.

Status Abbreviated Form Meaning

All status ALL All frames listed below (BRM1, M1, R, W, and VECT)

BRM1 Fetch BRM1 First M1 fetch after program branch

M1 Fetch M1 M1 fetch (including BRM1)

R/W RW Data read/write (including R, W)

Read R Data read

Write W Data write

Vector Read VECT Interrupt-based vector read

If the status conditions setting is omitted, all the frames becomes the search object.

(2) Access size selection area

This is where the access size conditions are set and selected.

By specifying the access size conditions, the access width for data conditions during trace data search is

decided.

The access size conditions that can be specified are shown below.  It is possible to specify the access size

conditions in abbreviated form.  There is no distinction between uppercase and lowercase characters in the

input access size condition.

Size Abbreviated Form Meaning

Byte B Search is made with an 8-bit width as the data condition.  Search

is made only during 8-bit access.

Word W Search is made with a 16-bit width as the data condition.  Search

is made only during 16-bit access.

No Condition NC An access-size search is not executed.

Bit 1 Detection is carried out with a 1-bit width as the data condition.

Detection is carried out only during 8-bit access.
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If the status condition has been specified as an opcode fetch or a vector read, the Bit alternative is not

displayed, and specifying Bit or 1 results in an error.

If Bit is specified as the access size condition, search is made with a 1-bit width as the data condition, but due

to simulator operation, since access to the bit itself cannot be traced directly, the simulator searches for a

pseudo bit access by setting the simulator’s address conditions and data conditions internally as follows.

Input Example Trace Search Setting

Address fe20.1 Address fe20

Data 1 Data 00000010B

Mask 11111101B

For that reason, for access to other bits in the same address, or even for access to all 8 bits in the same

address, if the values match the specified values (address, bit), trace data is searched for in accordance with

the specified status.

• If No Condition is specified, the data setting area appears dimmed and input cannot be done.

• If setting the access size condition is omitted, it is judged automatically from the address conditions and

data conditions and set.

• If a bit is set for the address condition, the condition becomes Bit.

• If 8 bits is set for the data condition, the condition becomes Byte.

• If 16 bits is set for the data condition, the condition becomes Word.

• If the data condition specification is omitted, the condition becomes No Condition.

(3) Address setting area

This is where the address condition is set.

The settable range is as shown below.

[SM78K0S]

Setting range: 0  ≤  Address value  ≤  0xFFFF FFFF

0  ≤  Mask value  ≤  0xFFFF FFFF

[SM78K0]

• When not using a bank

Setting range: 0  ≤  Address value  ≤  0xFFFF

0  ≤  Mask value  ≤  0xFFFF

• When using a bank

Setting range: 0  ≤  Address value  ≤  (n << 16) | 0xFFFF

0  ≤  Mask value  ≤  (n << 16) | 0xFFFF

n indicates the maximum value of the bank number used.

There are two types of address conditions:

Address, where the address value is set, and Mask, where the mask value for the address value is input.

The setting method is shown below.
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(a) Address

The setting is input in the order of  Lower address  –  Higher address .

The following 3 types of settings are possible for the address condition.

<1> Point setting

For a point setting, set a value in the lower addresses only, or set the same value in both the lower

addresses and the higher addresses.  Mask setting can be made.

<2> Range setting

For a range setting, set values in the lower addresses and the higher addresses.  Mask setting

cannot be made.  Note that if the same value is input for the lower addresses and the higher

addresses, it is not handled as a range setting.  In this case, it becomes a point setting or a bit

setting.

<3> Bit setting

For a bit setting, set a value in the lower addresses only, or set the same value in the lower

addresses and the higher addresses.  Specify the value in the address.bit format.  Mask setting

cannot be done.  The value of the bit that shows the bit position must be 0 ≤ bit ≤ 7.

For the address, it is possible to specify a symbol or a formula.  The specification method is the same as

in the Address Move dialog box.

The default radix when numerical values are input is hexadecimal.

If the address condition setting is omitted, detection of the address condition is not performed.

(b) Mask

Set the mask value with respect to the address value.

When mask setting is made, for a bit with a mask value of 1, it doesn’t matter if the address value is 0 or

1.

Examples 1. Address: 0x4000 to 0x4000

Mask: 0xFF

In this kind of setting, the conditions match up to addresses 0x4000 to 0x40FF.

2. Address: 0x4000 to 0x4000

Mask: 0x101

In this kind of setting, addresses 0x4000, 0x4001, 0x4100 and 0x4101 match the

conditions.

If the mask value setting is omitted, masking is not executed.

The default radix when numerical values are input is hexadecimal.

(4) Data setting area

Set the data conditions.  The setting range is as follows.
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Access Size Condition Setting Range

Byte 0  ≤  Data value  ≤  0xFF

0  ≤  Mask value  ≤  0xFF

Word 0  ≤  Data value  ≤  0xFFFF

0  ≤  Mask value  ≤  0xFFFF

Bit Data value = 0, 1

Mask value = Cannot be specified.

There are two settings for the data conditions: Data, where the data value is set, and Mask, where the

mask value for the data value is set.  The setting method is shown below.

(a) Data

Specify the data value.

It is also possible to set a symbol or formula for the data value.  The specification method is the same as

in the case of the Symbol To Address dialog box, but the default radix when inputting numerical values is

hexadecimal.

If the data conditions setting is omitted, data conditions are not detected.

(b) Mask

Set the mask value with respect to the data value.

When mask setting is made, for a bit with a mask value of 1, it doesn’t matter if the data value is 0 or 1.

Examples 1. Data: 0x4000

Mask: 0xFF

In this kind of setting, the conditions match when the data value is 0x4000 to 0x40FF.

2. Address: 0x4000

Mask: 0x101

In this kind of setting, when the data are 0x4000, 0x4001, 0x4100 and 0x4101, they match

the conditions.

If the mask value setting is omitted, masking is not executed.

The default radix when numerical values are input is hexadecimal.

(5) Search conditions specification area

This is a check box where it is specified whether to search the whole specified region or not when conducting

a search.  With the default, only the portion remaining in the range is searched.

Searches the remaining portion of the range (default).

Searches the whole range.



CHAPTER  6    WINDOW  REFERENCE

236 User’s Manual  U14611EJ1V0UM00

(6) Search direction specification area

Specify the search direction.

There are two search directions, an up search and a down search.

Up: Up search.  This searches before the current cursor position (toward the top of the display).

Down: Down search.  This searches after the current cursor position (toward the bottom of the display)

(default).

(7) Search range specification area

Specify the frame number that is being searched for.  The specification method is the same as in the case of

the Trace Move dialog box, but the default radix during input of numerical values is decimal.

Function buttons

Searches from the trace results in accordance with the specified conditions.

For the search results, the frames that match are displayed in reverse video in the Trace View

window.

If searching continuously, click this button again.

Sets the specified conditions as the search conditions and closes the Trace dialog box.

Search is executed by the  and  buttons in the Trace View window.

The specified search data is picked up from the trace results in accordance with the conditions.

 (During pick Only the frames that match the Trace window conditions are displayed.  For changing the

  up display) conditions and conducting pick up again, click this button again.

Closes the Trace Search dialog box.

Opens the help window that explains the Trace Search dialog box.
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Trace Data Select Dialog Box Modal

General

This window selects the items to be displayed in the Trace View window.

Opening method

This window can be opened by the following procedure when the current window is the Trace View window.

•  In the Main window

Select [View] → [Select…] from the menu bar.

Press the   GRPH  +  V , and  E  keys in that order.

Window

Figure 6-53.  Trace Data Select Dialog Box

Function

The Trace Data Select dialog box consists of the following areas.

• Trace display item selection area

• Trace display radix selection area

• Pick up selection area

The function of each area is explained below.

(1) Trace display item selection area (2) Trace display radix selection area

(3) Pick up selection area
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(1) Trace display item selection area

This is where the items to be displayed in the Trace View window are selected.

The following items can be selected to be displayed or not displayed.

If there is a check mark, that area is displayed.

Frame: Frame no. display field

Timetag: Time tag display field

· Clock: Clock display (default)

· Time: Time display

Instruction Fetch Address: Fetch address display field

Instruction Fetch Data: Fetch data display field

Instruction Fetch Status: Fetch status display field

Memory Access Address: Access address display field

Memory Access Data: Access data display field

Memory Access Status: Access status display field

Jump Address: Branch origin address display field

DisAssemble: Disassemble display field

(2) Trace display radix selection area

This is where the radix to be displayed is selected.  The display radix can be selected for the following items.

Instruction Fetch Data: Fetch data display field

Memory Access Data: Access data display field
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The display radix can be selected from the following.

Hex: Displayed in hexadecimal.

Dec: Displayed in decimal.

Oct: Displayed in octal.

Bin: Displayed in binary.

(3) Pick up selection area

This is where the pick up conditions are selected.

Pick Up Off: Pick up is not displayed.

Pick Up Search Frame: Picks up and displays frames which match the search conditions.

Pick Up Snap Frame: Picks up and displays snap frames.

Pick Up BRM1 Frame: Picks up and displays the first M1 fetch frame after a program branch.

Function buttons

Reflects the result of selection in the Trace View window and close the Trace Data Select dialog

box.

Closes this window.

Cancels the change and restore the original setting.

Opens the Help window that explains this window.
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Coverage Window MDI child window

General

Displays the coverage result.

Opening method

This window can be opened by the following procedure.

•  In the Main window

Select [Browse] → [Coverage] from the menu bar.

Press the  GRPH  +  B , and  O  keys in that order.

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press shortcut key  CTRL  +  I .

Click  button on the tool bar.

Window

Figure 6-54.  Coverage Window

(1) Address display area

(2) Coverage display area
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Function

This window displays the coverage result.

The vertical scroll bar is displayed at all times and the contents can be scrolled.  It is also possible to move up one

page or down one page using the  button or  button.

The Coverage window has two states, the active state and the static state.

There can be only one Coverage window in the active state at a time, but multiple windows can be opened in the

static state.

• Active State: The Coverage window in the active state has a display position and contents which are

synchronized with the current PC value and which are updated automatically.  Also, other

than becoming a jump destination for the jump function, if it is synchronized with the Trace

View window, the Coverage window’s display is updated in synchronization with the Trace

View window.

The first Coverage window to be opened is in the active state.

• Static State: When in the static state, the Coverage window’s contents are updated in synchronization

with the current PC value, but the display position does not move.  Also, it does not become

a jump destination and is not synchronized with the Trace View window.

If a Coverage window in the active state has already been opened, it is opened in the static

state.

Coverage measurement is enabled by selecting the check box in [Option] → [Coverage ON].  Note that operations

with respect to coverage measurement while a program is being simulated are executed by [Run] → [Coverage

Start/Stop].

The Coverage window consists of the following areas:

• Address display area

• Coverage display area

The function of each area is explained below.

(1) Address display area

Displays coverage addresses.
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(2) Coverage display area

Displays the coverage result.

The symbols displayed in this area have the following meanings.

When in the 1-byte display mode

Symbol Meaning

. Nothing has been executed

X Simulation only

R Read only

W Write only

A Read and write

$ Simulate and read

# Simulate and write

% All simulation, reading, and writing have been performed

When in the 64-/1024-byte display mode

Symbol Meaning

. None of simulate, read, and write operations concerning all addresses

within the 64-/1024-byte area were executed.

X All addresses in the 64-/1024-byte area were executed.

R All addresses in the 64-/1024-byte area were read.

W All addresses in the 64-/1024-byte area were write.

A Reading and writing were executed at all addresses in the 64-/1024-

byte area.

$ Simulation and reading were executed at all addresses in the 64-/1024-

byte area.

# Simulation and writing were executed at all addresses in the 64-/1024-

byte area.

% All simulate, read, and write operations concerning all addresses within

the 64/1024-byte area were executed.

This area has two functions besides displaying the coverage results.
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(a) Jump function

Jumps to the Source window, Assemble window, or Memory window using the address at the cursor as a

jump pointer.  The jump destination window is displayed with the jump pointer at the beginning.

This function is executed by performing the following operations in the sequential order.

<1> Position the cursor.

<2> Perform one of the following operations in the Main window.

• If the jump destination is the Source window

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] form the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• If the jump destination is the Memory window

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press shortcut keys  CTRL  +  M .

(b) Window linking function

This is a function that uses the coverage results to show the linked relationship between the Trace View

window and the Coverage window.  The coverage results that are the target of linking with the Trace

View window are positioned by the cursor.  For details, refer to the Window linking function of the Trace

View window (p.221).

Function buttons

Opens the Coverage Search dialog box and searches for coverage results.

Search results are reverse highlighted in the Coverage window

This button can be selected when in the 1-byte display mode only.

Coverage results which match the search conditions, and which have been set in the Coverage

Search dialog box, are searched for before the cursor position (toward the top of the display).

This button can be selected when in the 1-byte display mode only.

It changes to the  button during a search.

Coverage results which match the search conditions, and which have been set in the Coverage

Search dialog box, are searched for after the cursor position (toward the bottom of the display).

This button can be selected when in the 1-byte display mode only.

It changes to the  button during a search.
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Interrupt a search.

During a search, the  button and  button changes to a  button.

Updates the window’s contents with the latest data.

Closes this window.
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Coverage Search Dialog Box Modeless

General

Searches the coverage result.

This can be called only when in 1-byte mode display.

Opening method

This dialog box can be opened by the following procedure when the current window is the Coverage window.

•  In the Main window

Select [View] → [Search…] from the menu bar.

Press the  GRPH  +  V , and  S  keys in that order.

•  In the Coverage window

Click the  button.

Press the shortcut keys  CTRL  +  G .

Window

Figure 6-55.  Coverage Search Dialog Box

(1) Search data specification area

(4) Search range specification area (3) Search direction specification area

(2) Search condition
specification area
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Functions

Searches for coverage results.  Unmapped areas are not searched.

The Coverage Search dialog box consists of the following areas.

• Search data specification area

• Search condition specification area

• Search direction specification area

• Search range specification area

The functions of this area is explained below.

(1) Search data specification area

The search conditions can be specified from these 8 check boxes.  The meanings of the respective symbols

are as shown below.

Symbol Meaning

. Nothing has been executed

X Execute only

R Read only

W Write only

A Read and write

$ Execute and read

# Execute and write

% All execution, reading, and writing have been performed

If multiple search conditions have been selected, whichever one of the conditions matches is searched (an

OR search).

(2) Search condition specification area

This is a check box which specifies whether to search the whole specified region or not when conducting a

search.  With the default, only the portion remaining in the range is searched.

Searches the remaining portion of the range (default).

Searches the whole range.
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(3) Search direction specification area

Specify the search direction.

There are two search directions, an up search and a down search.

Up: Upward search.  This searches before the current cursor position (toward the top of the display).

Down: Downward search.  This searches after the current cursor position (toward the bottom of the display)

(default).

(4) Search range specification area

Specify the address that is being searched for.  Address specification can be done by specifying a symbol or

formula.  The specification method is the same as in the case of the Address Move dialog box.  The default

radix during input of numerical values is hexadecimal.  The search is not performed correctly if a mapped

area is included in the search range.

Function buttons

Searches from the coverage results in accordance with the specified conditions.

For the search results, the frames that match are displayed in reverse video.

If searching continuously, click this button again.

Sets the specified conditions as the searched conditions and closes this window.

Interrupts a search.
During a search, the  button changes to a  button.

Closes the Coverage Search dialog box.
It changes to the  button during a search.

Opens the Help window that explains this dialog box.
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Coverage - Clear Dialog Box Modal

General

Clears the coverage results.

Opening method

This dialog box can be opened by the following procedure.

• In the Main window

Select [Option] → [Coverage] → [Clear…] from the menu bar.

Press the  GRPH  +  O ,  O , and  L  keys in that order.

Window

Figure 6-56.  Coverage - Clear Dialog Box

Function

This dialog box is where the coverage measurement results in the specified address range are cleaned.

It initializes the coverage window and the contents in the Coverage - Efficiency View dialog box.

The Coverage - Clear dialog box consists of the following area.

• Address specification area

The functions of this area is explained below.

(1) Address specification area

This area is where the addresses in the coverage results to be cleared are specified.  Address specification

can also be made by symbols or a formula.  The specification method is the same as in the case of the

Address Move dialog box.  The default radix during input of numerical values is hexadecimal.

(1) Address
specification area
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Function buttons

Closes the dialog box after clearing the coverage results in the address range specified by the

address specification area.

Interrupts clearing the coverage results.

The  button changes to a  button during the coverage result clear operation.

Closes this dialog box.

It change to the  button during the coverage result clear operation.

Cancels the change and restore the original setting.

Opens the Help window that explains this window.
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Coverage - Condition Setting Dialog Box Modeless

General

Specifies the measurement range of the coverage efficiency.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Option] → [Coverage] → [Condition…] from the menu bar.

Press the  GRPH  +  O ,  O , and  O  keys in that order.

• Click the  button in the Coverage - Efficiency View dialog box.

Window

Figure 6-57.  Coverage - Condition Setting Dialog Box

(4) Coverage condition specification area

(1) Select list display
area

(2) Address specification
area

(3) Function specification
area
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Function

The Coverage - Condition Setting dialog box consists of the following areas.

• Select list display area

• Address specification area

• Function specification area

• Coverage condition specification area

The function of each area is explained below.

(1) Select list display area

Displays the currently selected lists.

Selected lists can be added by the following two methods.

Caution Describe the file name clearly when displaying a function name.

(a) When adding from the function list

<1> Specify the status conditionsNote in the status conditions specification area.

<2> Select the function to be added to the function specification area and click the  button.

The specified function can be deleted from the list by using the  button.

Note It is meaningless to select an instruction other than Execute.

(b) When specifying and adding an address

<1> Specify the status conditionsNote in the status conditions specification area.

<2> Input the address range to the address specification area and click the  button.

The specified address range can be deleted from the list by using the  button.



CHAPTER  6    WINDOW  REFERENCE

252 User’s Manual  U14611EJ1V0UM00

(2) Address specification area

This area is used to input the specifies coverage efficiency address range conditions.  Addresses can also be

specified by a symbol or expression.  The specification method is the same as in the case of the Address

Move dialog box.  The default radix during input of numerical values is hexadecimal.

(3) Function specification area

This area is used to input coverage efficiency address conditions in function units or to select the function

name from the drop-down list.

Function names registered to the load module file are displayed.

(4) Coverage condition specification area

This area selects the coverage efficiency status conditions.  The selectable status conditions are as follows:

Status Description

Execute Proportion of program simulation performed

Read Proportion of memory read performed

Write Proportion of memory write performed

All Proportion of either program simulation, memory read or memory write performed
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Function buttons

Closes the Coverage - Condition Setting dialog box.

Displays the coverage efficiency.  Opens the Coverage - Efficiency View dialog box.

Cancels the changes and restore the original setting.

Opens the Help window that explains the Coverage - Condition Setting dialog box.

Clears the contents in the select list display area.

Deletes the function name specified in the function specification area or the address range

specified in the address specification area in the select list display area.

Enters the function name specified in the function specification area or the address range

specified in the address specification area in the select list display area.
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Coverage - Efficiency View Dialog Box Modeless

General

This is where the coverage results in the range specified in the Coverage - Conditions Setting dialog box are

displayed as coverage efficiency.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Option] → [Coverage] → [Efficiency…] from the menu bar.

Press the  GRPH  +  O ,  O , and  E  keys in that order.

• Click the  button in the Coverage - Condition Setting dialog box.

Window

Figure 6-58.  Coverage - Efficiency View Dialog Box

(1) Coverage range display area

(2) Coverage efficiency display area



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 255

Function

The Coverage - Efficiency View dialog box consists of the following areas.

• Coverage range display area

• Coverage efficiency display area

The function of each area is explained below.

(1) Coverage range display area

This is where the coverage efficiency measurement range is specified.

The range specified in the Coverage - Condition Setting dialog box is displayed in this area.

If specified by a function name, it is displayed as “Program name $ File name # Function name.”

(2) Coverage efficiency display area

This is where the coverage efficiency is displayed.

The coverage efficiency displays what percentage of the measurement range the specified status (execute,

read, write) occupies.
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The status list is shown below.

Status Description

X Proportion of program simulation performed

W Proportion of memory write performed

R Proportion of memory read performed

All Proportion of either program simulation, memory read or memory write performed

Function buttons

Close the Coverage - Efficiency View dialog box.

Sets the displayed contents of the coverage efficiency.

Opens the dialog box.

Opens the Help window that explains the Coverage - Efficiency View dialog box.
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Event Manager MDI child window

General

This window displays, enables/disables and deletes various events.

Through manipulation in this window, the event conditions registered in the Event dialog box or Event Link dialog

box can be allocated to break event, trace event, snap-shot event, stub event, or timer event.

Opening method

This window can be opened by the following procedure.

•  In the Main window

Select [Event] → [Event Manager] from the menu bar.

Press the  GRPH  +  N , and  M  keys in that order.

Click the  button from the tool bar.

• In the Source window

Moves the cursor to the source line in the source text display area where the event is set, or to the

disassemble line in case of the mixed display mode, and carry out either of the following steps:

Select [View] → [Event?] from the menu bar.

Press the  GRPH  +  V , and  E  keys in that order.

• In the Assemble window

Moves the cursor to the line in the mnemonic display/change area where the event is set, and carry out either

of the following steps:

Select [View] → [Event?] from the menu bar.

Press the  GRPH  +  V , and  E  keys in that order.

•  In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  G .

•  In the Set Other dialog box

Click the  button.

Press the shortcut keys  GRPH  +  M .
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Window

Figure 6-59.  Event Manager

In list display mode

In detailed display mode

Function

This window displays, enables/disables, and deletes various events and manages event conditions for registering

or setting various event conditions (such as event link conditions, break event conditions, trace event conditions,

snap-shot event conditions, stub event conditions, and timer event conditions).

The Event Manager consists of the following areas.

• Event display area

• Event detail display area

The function of each area is explained below.

(1) Event display area

(2) Event detail display area(1) Event display area
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(1) Event display area

• In list display mode

• In detailed display mode

In the event display area, icons (event icons) for various types of event conditions of the registered event,

event link, break, trace, snap shot, stub, and timer are displayed.

The icon of the event condition consists of a mark indicating the type of each event condition and an event

name.

E. Event01
Mark Event name

The contents displayed in the event display area can be changed by the Event Info dialog box which is

opened by the [View] menu or the  button in the Event Manager.

The marks are listed below.

Mark Meaning

Indicates event condition.

Indicates event link condition.

Indicates break event.

Indicates trace event.

Indicates snap shot event.

Indicates stub event.

Indicates timer event.

The color of the character displayed in a mark indicates the setting status of each event condition.
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Character Color

in Mark

Corresponding Mark Meaning

 , 
Indicates that the event conditions using events and event

link conditions are valid.

Red

 ,  ,  ,  , 
Indicates that each event is “enabled”.  Each event is

generated when condition is satisfied

 , 
Indicates that the event conditions using events and event

link conditions are invalid.

Black

 ,  ,  ,  , 
Indicates that an event is “disabled”.  The event does not

occur even if the conditions are satisfied.

Yellow
 ,  ,  ,  ,  ,  ,

Indicates that the symbol specified in the event cannot be

recognized by the program that is currently loading, so it is

held pending.

In addition to the above function, this area also has the following four functions.

(a) Jump function

Jumps to the Source window, Assemble window, Memory window or Coverage window by using the

address condition of the selected icon as a jump pointer if the selected icon is the event condition.  The

jump destination window displays the jump pointer at the beginning.

If the address condition is a range setting, the lower address becomes the jump pointer.  If a mask is set,

the point address before the masking is executed becomes the jump pointer.

In the case of a bit setting, the address of the specified bit position becomes the jump pointer.

This function is executed by performing the following operations in the sequential order.

<1> Select an icon (  ).

<2> Perform one of the following operations in the Main window.

• If the jump destination is the Source window

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• If the jump destination is the Memory window

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press shortcut keys  CTRL  +  M .
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• If the jump destination is the Coverage window

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press shortcut keys  CTRL  +  I .

(b) Open function

This function opens the setting dialog box corresponding to the selected icon’s event.  The contents of

the selected event are displayed in each setting dialog box that is opened.

This function is executed by performing one of the following operations.

<1> Double click the icon.

<2> Select the icon, then click .

(c) Enabled state switching function

This function switches the state of the event corresponding to the selected icon between enabled and

disabled.

Except for an event and event link, it is possible to operate break, trace, snap shot, stub and timer events

by icons.

This function is executed by performing one of the following operations.

<1> Click the left button of the mouse when the mouse cursor is on the icon mark.

<2> Select an icon and click  or , or press the  GRPH  +  Enter  keys.

If an event is in the enabled state, it becomes disabled (black), and if the event is in the disabled state, it

becomes enabled (red).

The  button is displayed when an icon in the disabled state is selected, and the 

button is displayed when an icon in the enabled state is selected.

(d) Delete function

Deletes registration/set contents of the event condition of a selected icon.

Multiple icons can be selected using the  SHIFT  and  CTRL  keys.

To select all the icons, select [View] → [Select All Event] from the menu bar.

However, an event condition  and event link condition  can be deleted only when that event

condition is not used by other event condition (  ,  ,  ,  , or  ).  If the event

condition or event link condition has been already used for any other event, delete the event used.

This function is executed by performing the following operations in the sequential order

<1> Select an icon and perform one of the following operations in the Main window.

Select [View] → [Delete Event] from the menu bar.

Press the  GRPH  +  E , and  L  keys in that order.

<2> Select an icon and perform either of the following operations in the Event Manager

Click .

Press the  DEL  key.
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(2) Event detail display area

This area is displayed only when the detail display mode is selected.

This area displays the detailed information corresponding to the icon of each event.  This area displays the

contents of the status condition, access size condition, address condition, register condition, data condition,

and pass count condition, in that order, by using the information of each key as a separator, when an event

condition is specified.  The following tables show the correspondence between the information of each key

and the condition.

• In the case of event condition

Key Information Contents

[S] Status condition

[Z] Access size condition

[A] Address condition

[R] Register condition

[B] Register bank condition (SM78K0 only)

[D] Data condition

[P] Pass count condition

[M] Mask condition

• In the case of event link condition

Key Information Contents

[P1] to [P4] Event link condition of nth stage (n = 1 to 4)

[D] Disable condition

[P] Pass count condition

• In the case of break condition

Key Information Contents

[B] Break condition
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• In the case of trace conditions

Key Information Contents

[M] Trace mode

[T] Delay trigger condition

[D] Delay count

[S] Section trace start condition

[E] Section trace end condition

[Q] Qualify trace condition

• In the case of timer conditions

Key Information Contents

[S] Timer measurement start condition

[E] Timer measurement end condition

[U] Timer measurement unit

• In the case of snapshot conditions

Key Information Contents

[SN] Snap shot condition

[R] Register condition

[B] Register bank condition (SM78K0 only)

[M] Memory condition

[Z] Access size condition

[G] Peripheral I/O register condition

• In the case of stub conditions

Key Information Contents

[SU] Stub condition

[A] Jump address

If the address condition of an event condition, a data condition, the memory condition of a snap shot

condition, or the jump address of a stub condition is a symbol or a formula, the actual address is displayed

within “(  )”.
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Function buttons

This button opens the New Event dialog box.

In the New Event dialog box, by clicking each button, the setting dialog box for event, event

link, break, trace, snap shot, stub and timer events can be opened.

Each setting dialog box that is opened has the new event name set in it.

After each setting dialog box is opened, the New Event dialog box is closed.

If  is clicked or the  ESC  key is pressed, the New Event dialog box closes

and the screen returns to the Event Manager.

Opens the setting dialog box corresponding to the event condition selected in the event

display area.  The event condition contents selected in the event display area are displayed

in the setting dialog box.

If the event condition has not been selected, or if multiple conditions are selected, this button

appears dimmed and can no longer be clicked.

The  Enter  key also has the same operation.

Sets break, trace, snap shot, stub and timer events in the enabled state.

The  button is displayed in place of the  button if one disabled event or

multiple events including disabled events only are selected.

Sets break, trace, snap shot, stub and timer events in the disabled state.

The  button is displayed in place of the  button if one enabled event is

selected or multiple events including enabled events are selected.

If an event or an event link only is selected, this button appears dimmed and it can no longer

be clicked.

Deletes the event condition selected in the event display area.

When deleting an event or event link, if that event is being used by a break, trace, snap shot,

stub, timer or event link, it results in an error.  The  DEL  key also has the same operation.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 265

Deletes all the events whether they are enabled or disabled.

Opens the Event Info dialog box.

The display mode changes to the detail display mode when  is clicked and to

the list display mode when  is clicked, then closes.

The  button rearranges events in name order and displays them.

The  button rearranges events by kind and displays them.

The  button displays the events in the order in which they were entered without

rearranging them.

The  button or the  ESC  key closes the dialog box.

Closes this window.
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Event Dialog Box Modeless

General

This dialog box registers and displays event conditions.

The event conditions created (registered) on this dialog box are automatically registered to the Event Manager.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Event] → [Event…] from the menu bar.

Press the  GRPH  +  N , and  E  keys in that order.

Click the  button on the tool bar.

• Execute one of the following operations in the Break, Trace, Snap Shot, Stub, Timer, or Event Link setting

dialog boxes.

Click the  button.

Press the shortcut keys  GRPH  +  E .

• Execute one of the following operations in the event setting area or the Event Manager area of the Break,

Trace, Snap Shot, Stub, Timer, or Event Link setting dialog boxes.

Select the event condition and click .

Select the event condition and press the shortcut keys  GRPH  +  O .

Double click the event condition.

• In the Event Manager, execute one of the following operations.

Select an event condition and click .

Double click the event condition.

• Execute one of the following operations in the New Event dialog box or the Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  E .
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Window

Figure 6-60.  Event Dialog Box

When the status is Register Write or Register

(1) Event name setting area (5) Address setting area

(2) Status selection area (6) Data setting area

(3) Access size selection area (7) Pass count setting area

(4) Register setting area (8) Event Manager area

(1)

(2)

(3)

(5)

(6)

(7)

(8)

(1)

(2)

(3)

(4)

(6)

(7)

(8)
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Function

This dialog box registers and displays event conditions.

Up to 256 conditions can be entered for event conditions.  However, the number of event conditions which can be

used simultaneously in enabled break, trace, snap shot, stub and timer events is 64, even including event conditions

used via the event link.

The number of event conditions that can be used simultaneously is up to the number of event conditions given

above, but a single event condition can be set in multiple break, trace, snap shot, stub, timer and event link events.

The Event dialog box has two modes, the normal mode and the select mode.

• Normal mode

When [Event] → [Event…] from the menu bar in the Main window is selected and the Event dialog box is

opened, event conditions can be entered without restriction as to purpose.  This is the normal mode.

• Select mode

When  button in the break, trace, snap shot, stub, timer and event link setting dialog boxes is

clicked and the Event dialog box is opened, the event conditions used by these are selected.  This is the select

mode.

In the select mode, when  is clicked, the event condition selected in the event name setting area

of the Event dialog box is set in the event condition setting area of the original setting dialog box that called the

Event dialog box.

Even in the select mode, event conditions can be entered and displayed just as in the normal mode.

Depending on the mode, the title bar display on the dialog box will differ.  Refer to the section entitled [Title bar

(p.279)] described later on.

The Event dialog box consists of the following areas.

• Event name setting area

• Status selection area

• Access size selection area

• Data comparison type selection area

• Register setting area

• Address setting area

• Data setting area

• Pass count setting area

• Event Manager area

The function of each area is explained below.
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(1) Event name setting area

This area sets an event name and selects an event condition.

When entering an event condition, it is necessary to set an event name.  An event name may consist of up to

eight alphanumeric characters.

When displaying event conditions which have already been created, either type the event name of the

already created event name in the text box or select the event condition from the drop-down list in the event

name setting area.

In the select mode, the selected event condition can be set in the event condition setting area of the original

setting dialog box that called the Event dialog box.

The  mark on the left side of the event name setting area shows the use conditions of the event condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in the  Mark Condition

Red That event condition is being used by break, trace, snap shot, stub,

timer or event link and indicates that it is enabled.

Black Indicates that that event condition has not been enabled.

Gray Indicates that that event condition is currently being edited and that it

has not been entered.

Yellow Indicates that that event is an event which is in the hold state.  An

event in the hold state is in a state where the symbol specified by the

event condition by program download, etc. cannot be referred to.

(2) Status selection area

This area sets and selects a status condition.

By specifying the status condition, the distinction between the simulation event and access event is decided

at the same time.  If a simulation event is specified, the access size selection area, the mask field of the

address setting area and the data setting area appear dimmed and are in a state where input is impossible.

The status conditions that can be specified are shown below.  It is possible to specify a status condition in

abbreviated form.

There is no distinction between uppercase and lowercase letters in the input status condition.
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Status Abbr. Event Type Meaning

Execution EX Simulation event Program execution

Opcode Fetch OP Op code fetch (including prefetch)

R/W RW Data read/write

Read R Data read

Write W Data write

Vector Read VECT Interrupt-based vector read

Access AC All access statuses

Register Write REGW Register write

Register REG Register

Memory MEM

Access event

Memory

The Register (REG) and Memory (MEM) status conditions can be used as AND condition events by setting

them in [Phase 1] of the event link.

An AND condition event is a function that triggers an event at the point when the event conditions set in

[Phase 1] of the event link are established at the same time, and sets one or more Register or Memory status

event condition.  At this time, an Execution (EX) status event condition can be combined.

If only one Register or Memory status event condition is set in [Phase 1] of the event link, operation of the

Register status event condition is same as Register Write (REGW) and operation of the event condition of the

Memory status event condition is same as Write (W).

The Register and Memory status event conditions can be used only in Phase 1 of the event link.  They cannot

be used except in [Phase 1] of break, trace, snap shot, stub, timer or event link.

This area is blank in the case of newly created event conditions.

(3) Access size selection area

This is where the access size conditions are set and selected.

By specifying the access size conditions, the access width for data conditions during access event is decided.

The access size conditions that can be specified are shown below.  It is possible to specify the access size

conditions in abbreviated form.  There is no distinction between uppercase and lowercase characters in the

input access size condition.

Size Abbr. Meaning

Byte B Detection is made with an 8-bit width as the data condition.
Detection is made only during 8-bit access.

Word W Detection is made with a 16-bit width as the data condition.
Detection is made only during 16-bit access.

No Condition NC An access-size detection is not executed.

Bit 1 Detection is made with a 1-bit width as the data condition.
Detection is made only during 8-bit access.
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If the status condition has been specified as an opcode fetch or a vector read, the Bit alternative is not

displayed, and specifying Bit or 1 results in an error.

If Bit is specified as the access size condition, detection is made with a 1-bit width as the data condition, but

due to simulator operation, since access to the bit itself cannot be detected directly, the simulator detects for

a pseudo bit access by setting the simulator’s address conditions and data conditions internally as follows.

Input Example Simulator Setting

Address fe20.1 Address fe20

Data 1 Data 00000010B

Mask 11111101B

For that reason, for access to other bits in the same address, or even for access to all 8 bits in the same

address, if the values match the specified [address.bit] values, an event occurs in accordance with the

specified status.

Also, during bit writing when the device is in operation, reading and writing with a full 8 bits is executed, but if

read or read/write is specified in the status, an event occurs if the specified [address.bit] value matches with

respect to the read operation at this time.

• If No Condition is specified, the data setting area appears dimmed and input cannot be done.

• If setting the access size condition is omitted, it is judged automatically from the address conditions and

data conditions and set.

• If a bit is set for the address condition, the condition becomes Bit.

• If 8 bits is set for the data condition, the condition becomes Byte.

• If 16 bits is set for the data condition, the condition becomes Word.

• If the data condition specification is omitted, the condition becomes No Condition.

This area is blank in the case of newly created event conditions.

(4) Register setting area

This area is where the register conditions are specified.

If Register Write (REGW) or Register (REG) is specified in the status selection area, the address setting area

switches to the register setting area.

There are two types of register conditions: Register to set register names and Bank to set register banksNote.

Note Bank is provided in the SM78K0 only.

Specification of the register name is explained below.
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(a) Register

This area is where the register names are specified.

The register name can be typed directly in the text box or it can be selected from the drop-down list.

General-purpose registers can be specified both singly and in pairs, and under both absolute and

functional names.

To specify all registers, either select All from the drop-down list, or specify all the registers directly in the

text box.

There is no distinction between uppercase and lowercase letters in the input character strings.

(b) Bank (SM78K0 only)

This area is where the register banks are specified.

The register bank value can be typed directly in the text box or it can be selected from the drop-down list.

Setting range: 0 ≤ Register bank ≤ 3

To specify the current bank, either select Current from the drop-down list, or type Current or C directly in

the text box.

If the register bank specification is omitted, the current bank will be specified.

For newly created event conditions, the register name and register bank input columns are both blank.

(5) Address setting area

This area sets an address condition.

The settable range is as shown below.

[SM78K0S]

Setting range: 0 ≤ Address value ≤ 0xFFFF FFFF

0 ≤ Mask value ≤ 0xFFFF FFFF

[SM78K0]

• When not using a bank

Setting range: 0 ≤ Address value ≤ 0xFFFF

0 ≤ Mask value ≤ 0xFFFF

• When using a bank

Setting range: 0 ≤ Address value ≤ (n << 16) | 0xFFFF

0 ≤ Mask value ≤ (n << 16) | 0xFFFF

n indicates the maximum value of the bank number used.

If the address condition setting has been omitted, address condition detection is not performed.

For a newly created event condition, the address value and the mask value input columns are both blank.

There are two types of address conditions:

Address, where the address value is set, and Mask, the mask value for the address value is input.  The

setting method is shown below.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 273

(a) Address

Input  the lower-order addresses  and  the higher-order addresses  in that order.

The following three types of settings can be made in specifying an address condition.

<1> Point setting

For a point setting, set a value in the lower-order address only, or the same address value is set to

the lower- and higher-order addresses.  Mask can be set.

<2> Range setting

A range is specified by the lower- and higher-order addresses.  Mask cannot be set.

Note that if the same value is input for the lower addresses and the higher addresses, it is not

handled as a range setting.  In this case, it becomes a point setting or a bit setting.

<3> Bit setting

For a bit setting, set a value in the lower addresses only, or set the same value in the lower

addresses and the higher addresses.  Specify the value in the address.bit format.  Mask setting

cannot be done.  The value of the bit that shows the bit position must be 0 ≤  bit ≤  7.

For the address, it is possible to specify a symbol or a formula.  The specification method is the

same as in the Address Move dialog box.

The default radix when numerical values are input is hexadecimal.

(b) Mask

Set the mask value with respect to the address value.

When mask setting is made, for a bit with a mask value of 1, it doesn’t matter if the address value is 0 or

1.

Examples 1. Address: 0x4000 – 0x4000

Mask: 0xFF

In this kind of setting, the conditions match up to addresses 0x4000 to 0x40FF.

2. Address: 0x4000 – 0x4000

Mask: 0x101

In this kind of setting, addresses 0x4000, 0x4001, 0x4100 and 0x4101 match the

conditions.

If the mask value setting is omitted, masking is not executed.

The default radix when numerical values are input is hexadecimal.
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(6) Data setting area

This area sets a data condition.

The setting range is as follows.

Access Size Condition Setting Range

Byte 0  ≤  Data value  ≤  0xFF

0  ≤  Mask value  ≤  0xFF

Word 0  ≤  Data value  ≤  0xFFFF

0  ≤  Mask value  ≤  0xFFFF

Bit Data value = 0, 1

Mask value = Cannot be specified.

If the data condition setting has been omitted, data condition detection is not performed.

For a newly created event condition, the address value and the mask value input columns are both blank.

There are two types of data conditions: Data that sets a data value, and Mask that inputs a mask value of

data value.  How to set each of these types is explained below.

(a) Data

Sets a data value.

A data value can also be specified by a symbol or formula.  The specification method is the same as in

the case of the Symbol To Address dialog box, but the default radix when inputting numerical values is

hexadecimal.

(b) Mask

This area sets a mask value of a data value.

When mask setting is made, for a bit with a mask value of 1, it doesn’t matter if the data value is 0 or 1.

Examples 1. Data: 0x4000

Mask: 0xFF

In this kind of setting, the conditions match when the data value is 0x4000 to 0x40FF.

2. Data: 0x4000

Mask: 0x101

In this kind of setting, when the data are 0x4000, 0x4001, 0x4100 and 0x4101, they

match the conditions.

If the mask value setting is omitted, masking is not executed.

The default radix when numerical values are input is hexadecimal.
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(7) Pass count setting area

This area sets the pass count conditions.

The settable range is as shown below.

Setting range: 1 ≤  Pass count value ≤ 32767

For pass count conditions, this area sets the conditions for the number of times these event conditions

(address condition, status condition, access size condition, data condition, external sense data condition)

must match in order to be established during user program simulation.

If the pass count is set to 1, it will match the conditions and the conditions will be established.

The pass count is explained below.

• If the pass count condition setting is omitted, it is taken that 1 is set.

• With a newly created event condition, the pass count becomes 1.

(8) Event Manager area

This displays a list of each of the entered events, event links, breaks, trace, snap shots, stubs and timer

events.

By selecting an event and clicking , or by double clicking the event, a setting dialog box opens

corresponding to the selected event and the event setting contents can be displayed.

When the focus is on the Event Manager area, select the event icon, then click , or press the

 DEL  key and the selected event can be deleted.

By clicking , it is possible to select the Event Manager area display mode or sequencing.
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Function buttons

Closes the Event dialog box.

(When in the normal mode) If there is an event condition that is being edited, it is entered automatically and

the dialog box is closed.

The displayed event is set as the event condition in the original dialog box that

(When in the select mode) called the Event dialog box.

If the Event dialog box is already open, the select mode returns to the normal

mode only and the Event dialog box does not close.  In other cases, it closes.

If there is an event condition being edited, enter/select is performed automatically

and the program returns to the original setting dialog box.

Newly creates an event condition.

An event name is generated automatically and a newly created event condition is

prepared.  After it is created, be sure to enter the event condition using the

 or the  buttons.

Enters an event condition.

When a new event condition has been created or when the contents of an event

condition have been changed, be sure to enter the event condition using this

button.  The entered event condition is reflected in the Event Manager.

If event conditions that have already been entered are displayed, they cannot be

selected.

Clears the contents of an event condition.

If an event condition is entered but not edited, this button is displayed in place of

the  button.

Returns the contents of an event condition to the original contents.

If an event condition that has not been entered is displayed, all the area is made

blank except the event name, or the settings return to the default settings.

If an event condition is being edited, this button is displayed in place of the

 button.

Closes the Event dialog box.

(When in the normal mode) If an event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is an event condition that is being edited, the dialog box closes

without the event condition being entered.  The  ESC  key has the same

operation.
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Closes the Event dialog box.

(When in the normal mode) If an event condition is not being created/changed/deleted, this button becomes

the  button.

Even if an event condition is being edited, the dialog box closes without the event

condition being entered.  The  ESC  key has the same operation.

Returns to the original setting dialog box that called the Event dialog box without

(When in the select mode) an event condition being selected.

If an event condition is not being created/changed/deleted, the 

button becomes this button.

If the Event dialog box is already open, the select mode returns to the normal

mode only, and the Event dialog box does not close.  In other cases, the Event

dialog box closes.

Even if an event condition is being edited, it is not entered.  The  ESC  key has

the same operation.

Returns to the original setting dialog box without selecting the event condition.

(When in the select mode) If an event condition has been edited/changed/deleted, the  button

becomes this button.

If the Event dialog box is already open, the select mode returns to the normal

mode only, and the Event dialog box does not close.  In other cases, the Event

dialog box closes.

Even if an event condition is being edited, it is not entered.  The  ESC  key has

the same operation.

Opens the Help window that explain this dialog box.

Opens the Event Link dialog box.

Opens the Break dialog box.

Opens the Trace dialog box.

Opens the Snap Shot dialog box.

Opens the Stub dialog box.

Opens the Timer dialog box.

Opens the Event Manager dialog box.

Displays the Event Manager area.  Expands the size of the dialog box.

When the Event Manager area is not displayed, this button is displayed in place of

the  button.
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Does not display the Event Manager area.  Shrinks the size of the dialog box.

When the Event Manager area is displayed, this button is displayed in place of the

 button.

Opens the Event, Event Link, Break, Trace, Snap Shot, Stub or Timer setting

dialog boxes selected in the Event Manager area and displays the contents.

Deletes the event, event link, break, trace, snap shot, stub or timer conditions

selected in the Event Manager area

Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the Event Manager area to the detail display

mode.

The  button changes the Event Manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.
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Title bar

In the normal mode, [Event] is displayed as the title in the title bar.

Title Bar

Event

In the select mode, the title in the title bar becomes as follows in accordance with the original setting dialog box

that called the Event dialog box.

Title Bar Original Setting Dialog Box

Event – Break Break dialog box

Event – Trace Trace dialog box

Event – Snap Shot Snap Shot dialog box

Event – Stub Stub dialog box

Event – Timer Timer dialog box

Event – Event Link Event Link dialog box

Event – Event Link – Break Event Link dialog box

(While in the Break dialog box select mode)

Event – Event Link – Trace Event Link dialog box

(While in the Trace dialog box select mode)

Event – Event Link – Snap Shot Event Link dialog box

(While in the Snap Shot dialog box select mode)

Event – Event Link – Stub Event Link dialog box

(While in the Stub dialog box select mode)

Event – Event Link – Timer Event Link dialog box

(While in the Timer dialog box select mode)
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Event Link Dialog Box Modeless

General

This dialog box registers and displays event link conditions.

The event link conditions created (registered) in this dialog box are automatically registered to the Event Manager.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Event] → [Event Link…] from the menu bar.

Press the  GRPH  +  N , and  L  keys in that order.

• In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  L .

• Execute one of the following operations in the Break, Trace, Snap Shot, Stub, or Timer setting dialog boxes.

Click the  button.

Press the shortcut keys  GRPH  +  L .

• Execute one of the following operations in the event setting area or the Event Manager area of the Event,

Break, Trace, Snap Shot, Stub, or Timer setting dialog boxes.

Select the event link condition and click .

Select the event link condition and press the shortcut keys  GRPH  +  O .

Double click the event link condition.

• In the Event Manager, execute one of the following operations.

Select an event link condition and click .

Double click the event link condition.

• Execute one of the following operations in the New Event dialog box or the Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  L .
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Window

Figure 6-61.  Event Link Dialog Box

When the Event Manager area is displayed

When the Event Manager area is not displayed

(1) Event link name setting area (4) Disable condition setting area

(2) Pass count setting area (5) Event Manager area

(3) Link condition setting area

(2)

(1)

(3)

(4)

(5)

(1)

(3)

(4)
(2)
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Function

This dialog box registers and displays event link conditions.

If the event link conditions are satisfied, an event occurs only if the user program is executed as the specified order

of the event conditions that have been set.

Event link conditions can be set up to four stages.

If a disable condition is detected midway, the event conditions that have been satisfied until that point are

initialized, and the search is started at the first event condition.  Note that if the link condition and the disable condition

are detected at the same time, the disable condition is given priority.

Up to 256 event link conditions can be registered.  However, the number of event link conditions which can be

used simultaneously in enabled break, trace, snap shot, stub and timer events is 16, even including event link

conditions used via the event link.

The number of event conditions that can be used simultaneously is up to the number of event link conditions given

above, but a single event link condition can be set in multiple break, trace, snap shot, stub, and timer events.

The Event Link dialog box has two modes, the normal mode and the select mode.

• Normal mode

When [Event] → [Event Link…] from the menu bar in the Main window is selected and the Event Link dialog

box is opened, event link conditions can be entered without restriction as to purpose.  This is the normal mode.

• Select mode

When  in the break, trace, snap shot, stub, and timer setting dialog boxes is clicked and the Event

Link dialog box is opened, the event conditions used by these are selected.  This is the select mode.

In the select mode, when  is clicked, the event link condition selected in the event link name

setting area of the Event Link dialog box is set in the event condition setting area of the setting dialog box that

originally called the Event Link dialog box.

Even in the select mode, event conditions can be entered and displayed just as in the normal mode.

Depending on the mode, the title bar display on the dialog box will differ.  Refer to the section entitled [Title bar]

described later on.

The Event Link dialog box consists of the following areas.

• Event link name setting area

• Pass count setting area

• Link condition setting area

• Disable condition setting area

• Event Manager area

The function of each area is explained below.
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(1) Event link name setting area

This area sets event link names and selects event link conditions.

When entering an event link condition, it is necessary to set an event link name.

An event link name may consist of up to eight alpha-numeric characters.

When displaying event link conditions which have already been created, either type the event link name of

the already created event link condition in the text box or select the event link condition from the drop-down

list in the event link name setting area.

In the select mode, the selected event link condition can be set in the event link condition setting area of the

original setting dialog box that called the Event Link dialog box.

The  mark on the left side of the event link name setting area shows the use status of the event link

condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in the  Mark Condition

Red Indicates that event link condition is being used by break, trace, snap

shot, stub, or timer and indicates that it is enabled.

Black Indicates that that event link condition has not been enabled.

Gray Indicates that that event link condition is currently being edited and

that it has not been entered.

Yellow Indicates that that event is an event which is in the hold state.  An

event in the hold state is in a state where the symbol specified by the

event condition by program download, etc. cannot be referred to.

(2) Pass count setting area

This area sets a pass count condition.  The range which can be set is as follows.

Setting range: 1 ≤ pass count ≤ 32767

A pass count condition specifies how many times the event link condition set in this dialog box must be

matched while the user program is executed, in order that a given condition is satisfied.

If 1 is set as the pass count, the condition is satisfied when each condition is matched.

The pass count is explained below.

• When inputting a value directly to the text box, input a decimal character string.

• If the pass count condition is omitted, it is taken that 1 is set.

• With a newly created event link condition, the pass count becomes 1.
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(3) Link condition setting area

This area sets the sequence of event detection as a link condition.

Event conditions are set in three steps, from Phase 1 to Phase 4.  Event conditions need not be set up to

Phase 4.  If event conditions are not set up to Phase 4, an event occurs when the event condition set to the

last Phase is detected.

Event conditions can be set in only Phase 1, and same event conditions can be set in two or more Phases.

The number of event conditions that can be set to each Phase in the link condition setting area is up to 10.

When setting a Register (REG) or Memory (MEM) status event condition in Phase 1, it becomes an AND

condition event.

The AND condition event sets one or more of either the Register status or the Memory status event

conditions in Phase 1.  At this time, it is possible to combine with the Execution (EX) status event conditions.

The event occurs at the point when the event conditions set in Phase 1 are established simultaneously.

Register and Memory status event conditions cannot be set except in Phase 1.

Also, if only one Register status event condition was set in Phase 1, operation is the same as Register Write,

and if only one Memory status event condition was set in Phase 1, operation is the same as that of Write.

To set an event condition, use one of the following methods.

• Click  and open the Event dialog box in the “Select mode”, then select the event conditions

to be set.

• In the Event Manager area, select one (or more than one) event condition, then click  or set

it by drag and drop.

Setting of an event condition by drag and drop is possible even from outside the Event Link dialog box’s

Event Manager area; event conditions can be set from the Event Manager area of each setting dialog box

and from the Event Manager.

When the focus is on each Phase of the link conditions setting area, click  and the event

condition selected by the Phase which caused the focus will be deleted.

It can also be deleted by pressing the  DEL  key.

Each Phase of the link conditions setting area and the event conditions in the disable conditions setting area

can be copied mutually or moved by drag and drop.  The contents are shown below.

• If an event condition is dropped only by the mouse, it is moved.

• If it is dropped while pressing the  SHIFT  key, the event condition is moved.

• If it is dropped while pressing the  CTRL  key, the event condition is copied.

Selecting only one event condition in the link conditions setting area and clicking  or double

clicking it opens the Event dialog box and displays the contents of the event condition.
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(4) Disable condition setting area

This area is used to specify an event condition that invalidates the event conditions that have been

established until that point.

The number of event conditions that can be set in the disable conditions setting area is up to 10.

Carry out setting of the disable conditions by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Select an event condition in the Event Manager area and click , or make the setting by drag

and drop.

When setting the event condition by drag and drop, besides the Event Manager area in the Event Link

dialog box, it is possible to set it from the Event Manager area and Event Manager in each setting dialog

box.

When the focus is on the disable conditions setting area, if  is clicked, the selected event

condition is deleted.

It can also be deleted by pressing the  DEL  key.

It is possible to copy and move event conditions in each Phase in the disable conditions setting area and link

conditions setting area by drag and drop.  The contents of this operation are shown below.

• If an item is dropped with a mouse only, the event condition is moved.

• If it is dropped while holding down the  SHIFT  key, the event condition is moved.

• If it is dropped while holding down the  CTRL  key, the event condition is copied.

If only one event condition in the disable conditions setting area is selected and  is clicked or

the item is double clicked, the Event dialog box is opened and the event condition contents are displayed.
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(5) Event Manager area

This displays a list of each of the entered events, event links, breaks, traces, snap shots, stubs and timer

events.

An event condition that is displayed in the Event Manager area can be set in the link conditions setting area

or disable conditions setting area by clicking .

By dragging and dropping it from the Event Manager area in the Event Link dialog box, it can be set in the

event setting area in each setting dialog box for break, trace, snap shot, stub and timer.

When the focus is on the Event Manager area, select the Event icon, then click , or press the

 DEL  key and the selected event can be deleted.

Also, when the focus is on the Event Manager area, select one event icon, then click , or

double click the event icon to open the setting dialog box corresponding to the selected event and display the

event’s setting contents.

By clicking , it is possible to select the Event Manager area display mode or sequencing.

Function buttons

Closes the Event Link dialog box.

(When in the normal mode) If there is an event link condition that is being edited, it is entered automatically

and the dialog box is closed.

The displayed event link condition is set as the event link condition in the original

(When in the select mode) dialog box that called the Event Link dialog box.

If the Event Link dialog box is already open, the select mode returns to the normal

mode only and the Event Link dialog box does not close.  In other cases, it closes.

If there is an event link condition being edited, enter/select is performed

automatically and the program returns to the original setting dialog box.

Newly creates an event link condition.

An event link name is generated automatically and a newly created event link

condition is prepared.  After it is created, be sure to enter the event link condition

using the  or the  button.

Enters an event link condition.

When a new event link condition has been created or when the contents of an

event link condition have been changed, be sure to enter the event link condition

using this button.  The entered event link condition is reflected in the Event

Manager.

If event link conditions that have already been entered are displayed, they cannot

be selected.
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Clears the contents of an event link condition.

If an event link condition is entered but not edited, this button is displayed in place

of the  button.

Returns the contents of an event link condition to the original contents.

If an event link condition that has not been entered is displayed, all the area is

made blank except the event link name, or the settings return to the default

settings.

If an event link condition is being edited, this button is displayed in place of the

 button.

Closes the Event Link dialog box

(When in the normal mode) If an event link condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is an event link condition that is being edited, the dialog box closes

without the event link condition being entered.  The  ESC  key has the same

operation.

Closes the Event Link dialog box.

(When in the normal mode) If an event link condition is not being created/changed/deleted, this button

becomes the  button.

Even if an event link condition is being edited, the dialog box closes without the

event link condition being entered.  The  ESC  key has the same operation.

Returns to the original setting dialog box that called the Event Link dialog box

(When in the select mode) without an event link condition being selected.

If an event link condition is not being created/changed/deleted, the 

button becomes this button.

If the Event Link dialog box is already open, the select mode returns to the normal

mode only, and the Event Link dialog box does not close.  In other cases, the

Event Link dialog box closes.

Even if an event link condition is being edited, it is not entered.  The  ESC  key

has the same operation.

Returns to the original setting dialog box without selecting the event link condition.

(When in the select mode) If an event link condition has been edited/changed/deleted, the 

button becomes this button.

If the Event Link dialog box is already open, the select mode returns to the normal

mode only, and the Event Link dialog box does not close.  In other cases, the

Event Link dialog box closes.

Even if an event link condition is being edited, it is not entered.  The  ESC  key

has the same operation.

Opens the Help window.
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Opens the select mode in the Event dialog box and makes additional settings in

the link conditions setting area or disable conditions setting area.  The area where

additional settings are made becomes the selected area when  is

clicked.

Opens each setting dialog box for the event selected in the link conditions setting

area, disable conditions setting area or Event Manager area and displays the

contents.

If an event is not selected, or if multiple events are selected, selection cannot be

made.

Operation is the same as double clicking the event icon.

Deletes the event selected in the link conditions setting area, disable conditions

setting area or Event Manager area.

The same operation is performed by pressing the  DEL  key.

Displays the Event Manager area.  Expands the size of the dialog box.

When the Event Manager area is not displayed, this button is displayed in place of

the  button.

Does not display the Event Manager area.  Shrinks the size of the dialog box.

When the Event Manager area is displayed, this button is displayed in place of the

 button.

Adds an event condition or event link condition selected in the Event Manager

area to the link conditions setting area or disable conditions setting area and sets

it.  The area where it is added becomes the selected area when  is

clicked.
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Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the Event Manager area to the detail display

mode.

The  button changes the Event Manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.

Opens the Set Other dialog box.

Clicking each button opens the Event Manager area and the Event, Break, Trace,

Snap Shot, Stub or Timer setting dialog box, and closes the dialog box.

Close the dialog box by clicking  or  and return to the

Event Link dialog box.
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Title bar

In the normal mode, [Event Link] is displayed as the title in the title bar.

Title Bar

Event Link

In the select mode, the title in the title bar becomes as follows in accordance with the original setting dialog box

that called the Event Link dialog box.

Title Bar Original Setting Dialog Box

Event Link – Break Break dialog box

Event Link – Trace Trace dialog box

Event Link – Snap Shot Snap Shot dialog box

Event Link – Stub Stub dialog box

Event Link – Timer Timer dialog box
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Break Dialog Box Modeless

General

This dialog box registers, sets, and displays break event conditions.

The break event conditions registered in this dialog box are automatically registered to the Event Manager.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Event] → [Break…] from the menu bar.

Press the  GRPH  +  N , and  B  keys in that order.

Click the  button on the tool bar.

• In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  B .

• Execute one of the following operations in the Event Manager area in the Event, Event Link, Trace, Snap Shot,

Stub or Timer setting dialog box.

Select the break event condition and click .

Select the break event condition and press the shortcut keys  GRPH  +  O .

Double click the break event condition.

• In the Event Manager, execute one of the following operations.

Select an break event condition and click .

Double click the break event condition.

• Execute one of the following operations in the New Event dialog box or the Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  B .
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Window

Figure 6-62.  Break Dialog Box

When the Event Manager area is displayed

When the Event Manager area is not displayed

(1) Break event name setting area (3) Event Manager area

(2) Break condition setting area

(1)

(2)

(3)

(1)

(2)
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Function

This dialog box registers, sets, and displays break event conditions.

Up to 256 break event conditions can be entered.  However, the number of break event conditions that can be

used simultaneously is 64.

Break event conditions become valid automatically when they are entered.  However, if the number of break event

conditions exceeds the number that can be used simultaneously, or if the number of event conditions or event link

conditions in use exceeds the number that can be used simultaneously, the break event conditions are entered in the

disabled state.  Also, in this case, a break event condition cannot be enabled.

Note that if [Run] → [Ignore Break Point] is selected, the break event condition will not operate even if it is enabled.

The Break dialog box consists of the following areas.

• Break event name setting area

• Break condition setting area

• Event Manager area

The function of each area is explained below.

(1) Break event name setting area

This area sets break event names and selects break event conditions.  When entering an event condition, it is

necessary to set a break event name.  The break event name that can be set must be of 8 alpha-numeric

characters or less.

When displaying break event conditions which have already been created, either type the break event name

of the already created break event condition in the text box or select the break event condition from the drop-

down list in the break event name setting area.

Clicking the  mark in the break event name setting area switches between enabling or disabling the break

event condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in the  Mark Condition

Red Indicates that the break event condition has been enabled.

A break event occurs if the condition is satisfied.

Black Indicates that the break event condition has not been enabled.

No break event occurs if the condition is satisfied.

Gray Indicates that the break event condition is currently being edited and

that it has not been entered.

Yellow Indicates that the break event is an event which is in the hold state.

An event in the hold state is in a state where the symbol specified by

the event condition by program download, etc. cannot be referred to.
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(2) Break condition setting area

This sets an event condition for a break.

The number of event conditions that can be set in the break condition setting area is up to 64.

Also, the number of event link conditions that can be used simultaneously is up to 16, as long as the number

of event conditions in use does not exceed the number of event conditions that can be used simultaneously.

Carry out setting of the disable conditions by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select an event link condition in the Event Manager area and click , or make the setting by

drag and drop.

When setting the event link condition by drag and drop, besides the Event Manager area in the Event Link

dialog box, it is possible to set it from the Event Manager area and Event Manager in each setting dialog box.

When the focus is on the break condition setting area, clicking  deletes the selected event

condition or event link condition.

It can also be deleted by  DEL  key.

If only one event link condition in the disable conditions setting area is selected and  is clicked

or the item is double clicked, the Event Link dialog box is opened and the event link condition contents are

displayed.
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(3) Event Manager area

This displays a list of each of the entered events, event links, breaks, traces, snap shots, stubs and timer

events.

An event or event condition that is displayed in the Event Manager area can be set in the break conditions

setting area by clicking .

Also, event conditions or event link conditions in the Event Manager area can be dragged directly to the break

conditions setting area.

When the focus is on the Event Manager area, select the event icon, then click , or press the

 DEL  key and the selected event can be deleted.

Also, when the focus is on the Event Manager area, you can select one event icon, then click ,

or double click the event icon to open the setting dialog box corresponding to the selected event and display

the event’s setting contents.

By clicking , it is possible to select the Event Manager area display mode or sequencing.

Function buttons

Closes the Break dialog box.

If there is a break event condition that is being edited, it is entered automatically

and the dialog box is closed.

Break event conditions are enabled at the same time as it is entered.

Newly creates a break event condition.

A break event name is generated automatically and a newly created break event

condition is prepared.  After it is created, be sure to enter the event condition

using the  or the  buttons.

Enters the break event condition.

This button is displayed when a new break event condition is created or when the

contents of a break event condition have been changed.  In this case, be sure to

enter the break event condition.

If a break event condition that has already been entered is displayed, this button
changes to either the  button or the  button.

A break event condition is enabled as soon as it is entered.

Enables a break event condition.

This button is displayed in cases where a break event condition is in the disabled

state.

This button is displayed in place of either the  button or the

 button.
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Disables a break event condition.

This button is displayed in cases where a break event condition is in the enabled

state.

This button is displayed in place of either the  button or the

 button.

Clears the contents of a break event condition.

This button is displayed if a break event condition is entered but not edited.

This button is displayed in place of the  button.

Restores the contents of a break event condition to its original contents.

If a break event condition that has not been entered is displayed, the display area

is restored to the blank state except for the break event name.

This button is displayed in the case where a break event condition is being edited.

This button is displayed in place of the  button.

Closes this dialog box.

If a break event condition is not being created/changed/deleted, the 

button becomes this button.

Even if a break event condition is being edited, this dialog box is closed without

entering the condition.

The  ESC  key has the same operation.

Closes this dialog box.

If a break event has being created/changed/deleted, the  button

becomes this button.

Even if a break event condition is being edited, this dialog box is closed without

entering the condition.

The  ESC  key has the same operation.

Opens the Help window that explains this dialog box.

Opens the Event dialog box in the select mode and selects the event condition to

be set.

Opens the Event Link dialog box in the select mode and selects the event link

condition to be set.

Displays the contents of an event selected in the break condition setting area or

the Event Manager area by opening each setting dialog box.  Its operation is the

same as double clicking the event icon.

When the event icon is not selected, or if multiple icons have been selected, this

button is disabled.
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Deletes an event selected in the break conditions setting area or the Event

Manager area.

The  DEL  key has the same operation.

Displays the Event Manager area.  Expands the size of the dialog box.

When the Event Manager area is not displayed, this button is displayed in place of

the  button.

Does not display the Event Manager area.  Shrinks the size of the dialog box.

When the Event Manager area is displayed, this button is displayed in place of the

 button.

Adds the event condition or event link condition selected in the Event Manager

area to the break condition setting area.

An event other than an event condition or an event link condition cannot be added.

Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in order in which they were entered

without rearranging them.

The  button changes the Event Manager area to the detail display

mode.

The  button changes the Event Manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.
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Opens the Set Other dialog box.

Clicking each button opens the Event Manager and the Event, Event Link, Trace,

Snap Shot, Stub or Timer setting dialog box, and closes the dialog box.

Close the dialog box by clicking  or  and return to the

Break dialog box.
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Trace Dialog Box Modeless

General

This dialog box registers, sets, and displays trace event conditions.

The trace event conditions registered in this dialog box are automatically registered to the Event Manager.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Event] → [Trace…] from the menu bar.

Press the  GRPH  +  N , and  T  keys in that order.

Click the  button on the tool bar.

•  In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  T .

• Execute one of the following operations in the Event Manager area in the Event, Event Link, Break, Snap Shot,

Stub, or Timer setting dialog box.

Select the trace event condition and click the  button.

Select the trace event condition and press the shortcut keys  GRPH  +  O .

Double click the trace event condition.

• Execute one of the following operations in the Event Manager.

Select the trace event condition and click the  button.

Double click the trace event condition.

• Execute one of the following operations in the New Event Type Select dialog box or Event Type Select dialog

box.

Click the  button.

Press the shortcut keys  GRPH  +  T .
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Window

Figure 6-63.  Trace Dialog Box

When the Event Manager area is displayed

When the Event Manager area is not displayed

(1) Trace event name setting area (6) Section trace starting condition setting area

(2) Trace stop mode setting area (7) Section trace ending condition setting area

(3) Trace stop type setting area (8) Qualify trace condition setting area

(4) Delay count setting area (9) Event Manager area

(5) Delay trigger condition setting area
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Function

This dialog box sets various types of trace operation, and registers, sets, and displays trace event conditions.

The trace operation settings shown in (a) to (c) below can be executed.

(a) Operation when trace data is written to entire trace memory overall.

The trace frame makes a scan of the trace memory and when it arrives at the oldest frame, it is possible to

select from the following three modes as the next operation.

1. Continue the trace operation and overwrite the oldest trace frame.

2. Stop the trace operation.  Program simulation continues.

3. Stop program simulation.

In the default state, the overwrite mode is selected.

(b) Operation when the trace delay count is ended.

It is possible to select from the following 3 modes as the next operation when a trace delay count is ended by

a trace delay trigger.

1. Not execute the delay count.

2. After ending the delay count, stop the trace operation.  Program simulation continues.

3. After ending the delay count, stop program simulation.

In the default state, delay count is not executed.

(c) Setting trace event conditions

The following 4 types of trace event conditions can be set.

• Delay trigger event condition.

• Section trace starting event condition.

• Section trace ending event condition.

• Qualify trace event condition.

Up to 256 trace event conditions can be entered.  However, the number of trace event conditions that can be

used simultaneously is 1.

Trace event conditions become valid automatically when they are entered.  However, if the enabled trace

event conditions exist, or if the number of event conditions or event link conditions in use exceeds the number

that can be used simultaneously, the trace event conditions are entered in the disabled state.  Also, in this

case, a trace event condition cannot be enabled.

A trace is performed only when the tracer is in the enabled state.  Set it by the procedure shown below.

<1> Select [Option] → [Tracer ON] from the menu bar in the main window.

<2> When performing a section trace or a qualify trace, select [Run] → [Cond. Trace ON], and in other

cases, select [Run] → [Uncond. Trace ON].

If you are to make the tracer disabled without adding a check to [Option] → [Tracer ON] on the menu

bar in the main window, the trace will not be executed.
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During emulation, in order to stop the currently operating tracer, select [Run] → [Tracer Stop] from the menu

bar.  Also, during emulation, in order to run the currently stopped tracer, select [Run] → [Tracer Start] from

the menu bar.  These two menus toggle and their display changes according to the current tracer state.

This dialog box consists of the following areas.

• Trace event name setting area

• Trace stop mode setting area

• Trace stop type setting area

• Delay count setting area

• Delay trigger condition setting area

• Section trace starting condition setting area

• Section trace ending condition setting area

• Qualify trace condition setting area

• Event Manager area

The function of each area is explained below.

(1) Trace event name setting area

This area sets trace event names and selects trace event conditions.

When entering a trace event condition, it is necessary to set a trace event name.

A trace event name that can be set is 8 alphanumeric characters or less.

When displaying trace event conditions which have already been created, either type the created trace event

name in the text box or select trace event condition from the drop-down list in the trace event name setting

area.

Clicking the  mark in the trace event name setting area switches between enabling or disabling the trace

event condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in the  Mark Condition

Red Indicates that the trace event condition has been enabled.

A trace event occurs if the condition is satisfied.

Black Indicates that the trace event condition has not been enabled.

No trace event occurs even though the condition is satisfied.

Gray Indicates that the trace event condition is currently being edited and

that it has not been entered.

Yellow Indicates that the trace event is an event which is in the hold state.

An event in the hold state is in a state where the symbol specified by

the event condition by program download, etc. cannot be referred to.
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(2) Trace stop mode setting area

The trace stop mode selects the operation when the trace frame makes a scan of the trace memory and

arrives at the oldest frame, or when a delay count by the trace delay trigger is ended.

Selectable from the following three modes.

Mode Radio Button Setting Operation Description

Overwrite Continues with program simulation and the trace

operation and overwrites the oldest trace frame.

Trace Stop Stops the trace operation only after trace full or the

end of a delay count.

Emulation Break Stops program simulation after trace full or the end

of a delay count.

Overwrite is in the selected state in the newly created trace event conditions.

(3) Trace stop type setting area

Trace stop type selects the cause when a trace operation is stopped.  Selectable from the following two

causes.

Type Radio Button Setting Operation Description

Trace Full The trace operation stops when the trace frame

scans the trace memory once and arrives at the

oldest frame.

Delay Count The trace operation stops when a delay count is

ended by a trace delay trigger.

If Overwrite is selected in the trace stop mode, the trace stop type cannot be selected.  It appears dimmed

when there is a newly created trace event condition.

(4) Delay count setting area

This area sets a delay count condition.

The settable range is as shown below.

Setting Range:  0 ≤ delay count ≤ 32767

By setting a delay count condition, when a delay event occurs, the tracer can operate by the number of delay

counts and then stop.  If the delay count condition is set to 0, tracing is stopped when the delay event occurs.
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If a delay count which exceeds the trace buffer size is specified, the trace delay continues the trace operation

until the delay count ends.

If a delay count which exceeds the trace buffer size is specified, the trace delay traces the amount of the

trace buffer size only, then stops.

When typing a value directly to the text box, input decimal character strings.

Except in cases where delay count is selected in the trace stop type, the delay count cannot be set.

If the delay count condition setting is omitted, it is taken as 0.

This area appears dimmed when there is a newly created trace event condition.

(5) Delay trigger condition setting area

This sets an event condition for a delay trigger.

The number of event conditions that can be set in the delay trigger condition setting area is 64.

Also, the number of event link conditions that can be used simultaneously is up to 16, as long as the number

of event conditions in use does not exceed the number of event conditions that can be used simultaneously.

Carry out setting of the delay trigger conditions by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select one or several event conditions or event link conditions in the Event Manager area and click

, or make the setting by drag and drop.

When setting the event condition or event link condition by drag and drop, besides the Event Manager area in

the Trace dialog box, it is possible to set it from the Event Manager area and Event Manager in each setting

dialog box.

When the focus is on the delay trigger condition setting area, then click the  button, or press the

 DEL  key and the selected event condition or event link condition can be deleted.

It is possible to move and copy event conditions and event link conditions in the delay trigger conditions

setting area back and forth among the different setting areas in the Trace dialog box by drag and drop

operations.  The following contents are shown.

• If an event condition or event link condition is dropped only by the mouse, it is moved.

• If it is dropped while pressing the  SHIFT  key, the event condition or event link condition is moved.

• If it is dropped while pressing the  CTRL  key, the event condition or event link condition is copied.

Selecting an event condition or event link condition in the delay trigger condition setting area and clicking

 or double clicking it opens the Event dialog box or Event Link dialog box and displays the

contents of the event condition or event link condition.

If Overwrite is selected in the trace stop mode, the delay trigger type cannot be selected, and it appears

dimmed when there is a newly created trace event condition.
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(6) Section trace starting condition setting area

This sets an event condition for starting a section trace.

The number of event conditions that can be set in the trace starting condition setting area is 64.

Also, the number of event link conditions that can be used simultaneously is up to 16, as long as the number

of event conditions in use doss not exceed the number of event conditions that can be used simultaneously.

Carry out setting of the section trace starting conditions by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select one or several event conditions or event link conditions in the Event Manager area and click

, or make the setting by drag and drop.

When setting the event condition or event link condition by drag and drop, besides the Event Manager area in

the Trace dialog box, it is possible to set it from the Event Manager area and Event Manager in each setting

dialog box.

When the focus is on the section trace starting condition setting area, then click the  button, or

press the  DEL  key and the selected event condition or event link condition can be deleted.

It is possible to move and copy event conditions and event link conditions ins the section trace starting

condition setting area back and forth among the different setting areas ins the Trace dialog box by drag and

drop operations. The following contents are shown.

• If an event condition or event link condition is dropped only by the mouse, it is moved.

• If it is dropped while pressing the  SHIFT  key, the event condition or event link condition is moved.

• If it is dropped while pressing the  CTRL  key, the event condition or event link condition is copied.

Selecting an event condition or event link condition in the section trace starting condition setting area and

clicking  or double clicking it opens the Event dialog box or Event Link dialog box and displays

the contents of the event condition or event link condition.

The section trace starting condition setting area is left blank when there is a newly created trace event

condition.
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(7) Section trace ending condition setting area

This sets an event condition for ending a section trace.

The number of event conditions that can be set in the section trace ending condition setting area is 64.

Also, the number of event link conditions that can be used simultaneously is up to 16, as long as the number

of event conditions in use doss not exceed the number of event conditions that can be used simultaneously.

Carry out setting of the section trace ending conditions by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select one or several event conditions or event link conditions in the Event Manager area and click

, or make the setting by drag and drop.

When setting the event condition or event link condition by drag and drop, besides the Event Manager area in

the Trace dialog box, it is possible to set it from the Event Manager area and Event Manager in each setting

dialog box.

When the focus is on the section trace ending condition setting area, then click the  button, or

press the  DEL  key and the selected event condition or event link condition can be deleted.

It is possible to move and copy event conditions and event link conditions ins the section trace ending

condition setting area back and forth among the different setting areas ins the Trace dialog box by drag and

drop operations. The following contents are shown.

• If an event condition or event link condition is dropped only by the mouse, it is moved.

• If it is dropped while pressing the  SHIFT  key, the event condition or event link condition is moved.

• If it is dropped while pressing the  CTRL  key, the event condition or event link condition is copied.

Selecting an event condition or event link condition in the section trace ending condition setting area and

clicking  or double clicking it opens the Event dialog box or Event Link dialog box and displays

the contents of the event condition or event link condition.

The section trace starting condition setting area is left blank when there is a newly created trace event

condition.
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(8) Qualify trace condition setting area

This area sets event conditions for a qualify trace.

A qualify trace is executed only when the trace condition is satisfied.

If two or more event conditions are set, the trace is executed when each event condition is satisfied.

The number of event conditions that can be set in the qualify trace condition setting area is 64.

Also, the number of event link conditions that can be used simultaneously is up to 16, as long as the number

of event conditions in use doss not exceed the number of event conditions that can be used simultaneously.

Carry out setting of the qualify trace condition by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select one or more event conditions or event link conditions in the Event Manager area and click

, or make the setting by drag and drop.

When setting the event condition or event link condition by drag and drop, besides the Event Manager area in

the Trace dialog box, it is possible to set it from the Event Manager area and Event Manager in each setting

dialog box.

When the focus is on the qualify trace condition setting area, then click the  button, or press the

 DEL  key and the selected event condition or event link condition can be deleted.

The following contents are shown.

• If an event condition or event link condition is dropped only by the mouse, it is moved.

• If it is dropped while pressing the  SHIFT  key, the event condition or event link condition is moved.

• If it is dropped while pressing the  CTRL  key, the event condition or event link condition is copied.

It is possible to move and copy event conditions and event link conditions ins the qualify trace condition

setting area back and forth among the different setting areas ins the Trace dialog box by drag and drop

operations.

Selecting an event condition or event link condition in the qualify trace condition setting area and clicking

 or double clicking it opens the Event dialog box or Event Link dialog box and displays the

contents of the event condition or event link condition.

The section trace starting condition setting area is left blank when there is a newly created trace event

condition.
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(9) Event Manager area

This area lists each event of event, event link, break, trace, snap shot, stub, and timer.

By selecting an event condition or event link condition displayed in the Event Manager area and clicking

, the event condition or event link condition can be set in the delay trigger condition setting area,

section trace starting condition setting area, section trace ending condition setting area, qualify trace

condition setting area.

Also the event condition or event link condition in the Event Manager area can be directly dragged and

dropped in each event condition setting area.

When the focus is on the Event Manager area, select the event icon, then click the  button, or

press the  DEL  key and the selected event condition can be deleted.

By clicking  or double clicking one of the event icons, the setting dialog box corresponding to

the selected events opens, and displays the contents of the event condition.

By clicking , it is possible to select the Event Manager area display mode or sequencing.

Function buttons

Closes the Trace dialog box.

If there is a trace event condition that is being edited, it is entered automatically

and the dialog box is closed.

The snap shot event condition becomes enabled as soon as it is entered.

Newly creates a trace event condition.

A trace event name is generated automatically and a newly created trace event

condition is prepared.  After it is created, be sure to enter the trace event condition

using the  or the  buttons.

Enters a trace event condition.

When a new trace event condition has been created or when the contents of a

trace event condition have been changed, be sure to enter the trace event

condition using this button.

If trace event conditions that have already been entered are displayed, it changes

to either the  button or  button.

The trace event condition becomes enabled as soon as it is entered.

Enables a trace event condition.

This button is displayed in cases where a trace event condition is in the disabled

state.

It changes to either the  button or the  button.
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Disables a trace event condition.

This button is displayed in cases where a trace event condition is in the enabled

state.

It changes to either the  button or the  button.

Clears the contents of a trace event condition.

If a trace event condition is entered but not edited, this button is displayed.  It

changes to the  button.

Returns the contents of a trace event condition to the original contents.

If a trace event condition that has not been entered is displayed, all the area is

made blank except the trace event name, or the settings return to the default

settings.

If a trace event condition is being edited, the  button is displayed in

place of this button.

Closes the Trace dialog box.

If a trace event condition is not being created/changed/deleted, this button

becomes the  button.

Even if a trace event condition is being edited, the dialog box closes without the

trace event condition being entered.  The  ESC  key has the same operation.

Closes the Trace dialog box.

If a trace event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is a trace event condition that is being edited, the dialog box closes

without the trace event condition being entered.  The  ESC  key has the same

operation.

Opens the Help window that explain this dialog box.

Opens the Event dialog box and adds an event condition to the selected position

in the delay trigger condition setting area, section trace starting condition setting

area, section trace ending condition setting area, or qualify trace condition setting

area.

The area where the event condition is added becomes the selected area when

 is clicked.

Opens the Event Link dialog box and adds an event link condition to the selected

position in the delay trigger condition setting area, section trace starting condition

setting area, section trace ending condition setting area, or qualify trace condition

setting area.

The area where the event condition is added becomes the selected area when

 is clicked.
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Displays the event contents selected in the trace delay condition setting area,

section trace starting condition setting area, section trace ending condition setting

area, qualify trace condition setting area, or Event Manager area by opening each

setting dialog box.

Its operation is the same as double clicking the event icon.

When the event icon is not selected, or if multiple icons have been selected, this

button is disabled.

Opens the Event Link dialog box and deletes an event condition from the selected

position in the delay trigger condition setting area, section trace starting condition

setting area, section trace ending condition setting area, qualify trace condition

setting area, or Event Manager area.

The  DEL  key has the same operation.

Displays the Event Manager area.  Expands the size of the dialog box.

When the Event Manager area is not displayed, the  button is

displayed in place of this button.

Does not display the Event Manager area.  Shrinks the size of the dialog box.

When the Event Manager area is displayed, the  button is displayed

in place of this button.

Adds the event condition or event link condition selected in the Event Manager

area to the selected position in the delay trigger condition setting area, section

trace starting condition setting area, section trace ending condition setting area, or

qualify trace condition setting area.

The area where the event condition is added becomes the selected area when

 is clicked.
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Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the Event Manager area to the detail display

mode.

The  button changes the Event Manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.

Opens the Set Other dialog box.

Clicking each button opens the setting dialog box of Event, Event Link, Break,

Snap Shot, Stub, or Timer and the Event Manager area, and closes the Set Other

dialog box.

Close the dialog box by clicking  or  and return to the

Trace dialog box.
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Snap Shot Dialog Box Modeless

General

This dialog box registers, sets, and displays snap shot event conditions.

The snap shot event condition registered in this dialog box is automatically registered to or managed by the Event

Manager.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Event] → [Snap Shot…] from the menu bar.

Press the  GRPH  +  N , and  S  keys in that order.

•  In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  S .

• Execute one of the following operations in the Event, Event Link, Break, Snap Shot, Stub, or Timer setting

dialog box.

Select the snap shot event condition and click the  button.

Select the snap shot event condition and press the shortcut keys  GRPH  +  O .

Double click the snap shot event condition.

• Execute one of the following operations in the Event Manager.

Select the snap shot event condition and click the  button.

Double click the snap shot event condition.

• Execute one of the following operations in the New Event dialog box or Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  S .
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Window

Figure 6-64.  Snap Shot Dialog Box (1/2)

Selection of register snap data

Selection of peripheral SFR register snap data

(1) Snap shot event name setting area (5) SFR snap data setting area

(2) Snap shot condition setting area (6) There is no relevant area in the above state

(3) Snap data selection area (7) Snap data display area

(4) Register snap data setting area (8) Event Manager area

(1)

(4)

(2)

(7)

(3)

(8)

(1)

(2)

(7)

(3)

(8)

(5)
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Figure 6-64.  Snap Shot Dialog Box (2/2)

Selection of memory snap data

Non-display of the Event Manager area

(1) Snap shot event name setting area (5) There is no relevant area in the above area

(2) Snap shot condition setting area (6) Memory snap data setting area

(3) Snap data selection area (7) Snap data display area

(4) Register snap data setting area (8) Event Manager area

(7)

(6)

(2)

(1)

(3)

(8)

(1)

(2)

(7)

(3)

(4)
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Function

This dialog box registers, sets, and displays snap shot event conditions.

Snap shot is for saving the contents of the register, memory, and SFRs when the program is executed in the trace

buffer.  The timing at which snap shot is to be performed is specified by a snap shot event condition.

Up to 256 items of snap shot event conditions can be set.  However, the number of snap shot event conditions that

can be used simultaneously is 8.

Snap shot event conditions become valid automatically when they are entered.  However, if the number of snap

shot event conditions exceeds the number that can be used simultaneously, or if the number of event conditions or

event link conditions in use exceeds the number that can be used simultaneously, the snap shot event conditions are

entered in the disabled state.  Also, in this case, a snap shot event condition cannot be enabled.

Up to 16 items of snap shot can be set for each of the registers, SFRs, and memory, for a total of up to 48 items.

This dialog box consists of the following areas.

• Snap shot event name setting area

• Snap shot condition setting area

• Snap data selection area

• Register snap data setting area

• SFR snap data setting area

• Memory snap data setting area

• Snap data display area

• Event Manager area

The function of each area is explained below.

(1) Snap shot event name setting area

This area sets a snap shot event name and displays a snap shot event condition.

When entering a snap shot event condition, it is necessary to set a snap shot event name.  A snap shot event

name may consist of up to eight alphanumeric characters.

When displaying snap shot event conditions which have already been created, either type the snap shot

event name of the already created snap shot event name in the text box or select the snap shot event

condition from the drop-down list in the snap shot event name setting area.

Clicking the  mark in the snap shot event name setting area switches between enabling or disabling the

snap shot event condition.

The relationship between the color of the character in the  mark and the status is shown below.
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Color of Character in the  Mark Condition

Red Indicates that the snap shot event condition has been enabled.

A snap shot event occurs if the condition is satisfied.

Black Indicates that the snap shot event condition has not been enabled.

No snap shot event occurs if the condition is satisfied.

Gray Indicates that the snap shot event condition is currently being edited

and that it has not been entered.

Yellow Indicates that the snap shot event is an event which is in the hold

state.  An event in the hold state is in a state where the symbol

specified by the event condition by program download, etc. cannot

be referred to.

(2) Snap shot condition setting area

This area sets a snap shot event condition.

Only one event condition or event link condition can be set in the snap shot condition setting area.

Carry out setting of the snap shot condition by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select an event condition or event link condition in the Event Manager area and click , or

make the setting by drag and drop.

If an event condition or event link condition is already set in the snap shot conditions setting area, it is

replaced in newly set event conditions or event link conditions.

When setting the event condition or event link condition by drag and drop, besides the Event Manager area in

the Snap Shot dialog box, it is possible to set it from the Event Manager area and Event Manager in each

setting dialog box.

When the focus is on the snap shot condition setting area, then click the  button, or press the

 DEL  key and the selected event condition or event link condition can be deleted.

Selecting an event condition or event link condition in the snap shot condition setting area and clicking

 or double clicking it opens the Event dialog box or Event Link dialog box and displays the contents

of the event condition or event link condition.

The snap shot event condition setting area is left blank when there is a newly created snap shot event

condition.
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(3) Snap data selection area

This area selects the type of snap data.

The following three types of snap data are available.

Item Contents

Register A register can be registered.

Sfr SFR can be registered.

Memory Memory can be registered.

The following displays are switched by selection in the snap data selection area.

• Register snap data setting area

• SFR snap data setting area

• Memory snap data setting area

Also, if snap data is selected in the snap data display area, the selection items in the snap data select area

change in accordance with the type of snap data selected.

(4) Register snap data setting area

Enter, change, or delete register snap data.

This area is displayed by selecting Register in the snap data selection area.

Snap data which is entered/changed/deleted here is reflected in the snap data display area.  If register snap

data is selected in the snap data display area, the contents of the selected register snap data are displayed.

The number of items of register snap data that can be entered is up to 16.

The register snap data setting area consists of the following items.
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(a) Register name setting area

This specifies the register name.

Specification of a register name is accomplished by selecting the register name from a drop-down list.

A program register or system register can be specified.  Uppercase and lowercase letters are not

distinguished (in the Trace window, all the characters are standardized to uppercase letters and

displayed).

Names that can be specified are function names, and it is possible to specify absolute names.  They are

displayed in “Absolute name (Function name)” format.

For a newly created snap shot event condition, this area is blank.

When entering register snap data, it is necessary to specify a register name.

(b) Register bank setting area (SM78K0 only)

This area is where the register banks are specified.

The register bank value can be typed directly in the text box or it can be selected from the drop-down list.

Setting range: 1 ≤ Register bank ≤ 3

To specify the current bank, either select Current from the drop-down list, or type Current or C directly in

the text box.

If the register bank specification is omitted, the current bank will be specified.

For newly created snap shot event conditions, the register bank input column is blank.

(c)

Enters register snap data.

Entered snap data is inserted in the snap data display area’s select position and displayed.

(d)

Changes the contents of snap data selected in the snap data display area to the specified register snap

data.

(e)

Deletes the snap data selected in the snap data display area.

If the focus is on the snap data display area, the same kind of operation can be performed using the

 DEL  key.

(f)

Restores the contents of the snap data display area to the original contents.
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(5) SFR snap data setting area

Enter, change, or delete SFR snap data.

This area is displayed by selecting Sfr in the snap data selection area.

Snap data which is entered/changed/deleted here is reflected in the snap data display area.  If SFR snap

data is selected in the snap data display area, the contents of the selected SFR snap data are displayed.

The number of items of SFR snap data that can be entered is up to 16.

The SFR snap data setting area consists of the following items.

(a) SFR name setting area

This specifies the SFR name.  Only SFR names that are possible to read can be specified.

Also, an SFR bit name and an I/O port name that is entered in the Add I/O Port dialog box cannot be

specified.

Setting of the SFR name is accomplished by inputting the SFR name directly in the text box or by

selecting the SFR name from the drop-down list.

Uppercase and lowercase letters are not distinguished for an SFR name (in the Trace window, all the

characters are standardized to uppercase letters and displayed).

For a newly created snap shot event condition, this area is blank.

When entering SFR snap data, it is necessary to specify an SFR name.

(b)

Enters SFR snap data.

Entered snap data is inserted in the snap data display area’s select position and displayed.

(c)

Changes the contents of snap data selected in the snap data display area to the specified SFR snap

data.

(d)

Deletes the snap data selected in the snap data display area.

If the focus is on the snap data display area, the same kind of operation can be performed using the

 DEL  key.

(e)

Restores the contents of the snap data display area to the original contents.
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(6) Memory snap data setting area

This area specifies the range of the memory data for the snap-shot and access size.

This area is displayed only when Memory is selected in the snap data selection area.

Snap data which is entered/changed/deleted here is reflected in the snap data display area.  If register snap

data is selected in the snap data display area, the contents of the selected memory snap data are displayed.

The number of items of memory snap data that can be entered is up to 16.

The memory snap data setting area consists of the following items.

(a) Memory address setting area

This area specifies the memory address range.

It is set by inputting  Start address  –  End address  in order.

The settable range is as shown below.

Setting range: 0 ≤  Address ≤ 0xFFFF

If a value is input in the start address only and the end address is omitted, it is regarded as if the value

specified in the end address was the same as that specified in the start address.

If the specified address range cannot be divided by the access size, the address range is rounded up

and corrected to a range that can be divided by the access size.

For the address range specification, it is possible to specify a symbol or formula.  The specification

method is the same as in the Address Move dialog box.  The default radix when numerical values are

input is hexadecimal.

If a formula or symbol is specified in the memory address setting area and entered and changed, the

converted address value is displayed together with the specified formula or symbol in the snap data

display area.

The converted address value only of snap data displayed in the Trace window is displayed.

For a newly created snap shot event condition, this area is blank.

When entering memory snap data, it is necessary to specify a starting address.
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(b) Memory display size setting area

This area specifies the memory snap data access size.

To specify the access size, the access size can be input directly in the text box or it can be selected from

the drop-down list.

The following can be specified.

Access Size Abbreviated Form Contents

Byte B Memory snap shot is executed in 8-bit units.

Word W Memory snap shot is executed in 16-bit units.

DWord DW Memory snap shot is executed in 32-bit units.

Remark The specified uppercase and lowercase letters are not distinguished from each other.

For a newly created snap shot event condition, this area is blank.

When entering memory snap data, it is necessary to specify a access size.

(c)

Enters memory snap data.

Entered snap data is inserted in the snap data display area’s select position and displayed.

(d)

Changes the contents of snap data selected in the snap data display area to the specified memory snap

data.

(e)

Deletes the snap data selected in the snap data display area.

If the focus is on the snap data display area, the same kind of operation can be performed using the

 DEL  key.

(f)

Restores the contents of the snap data display area to the original contents.
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(7) Snap data display area

This area lists the registered snap data.

Snap data, including registers, SFRs, and memory data, can be registered.

The registered snap data is written to the tracer when a snap shot event occurs.

If snap data is selected in the snap data list, the contents of the selected snap data are displayed in the

setting areas for the register, the SFR, and memory.

Each respective type of snap data is displayed as follows.

(a) Register snap data

Register name

Example

R1

R3(SP)

(b) SFR snap data

SFR name

Example

P0

P1

(c) Memory snap data

Starting address <Symbol, formula> – End address <Symbol, formula>, Access size

Example

0xffe000, HW

0xffe100 - 0xffe10f, B

Remark If a symbol or formula is specified in the address specification, it is displayed inside “< >”.
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(8) Event Manager area

This displays a list of each of the entered events, event links, breaks, trace, snap shot, stub, and timer

events.

An event or event link condition that is displayed in the Event Manager area can be set in the snap shot

condition setting area by clicking the  button.

Also, event conditions or event link conditions in the Event Manager area can be dragged and dropped

directly to the snap shot condition setting area.

When the focus is on the Event Manager area, then click the  button, or press the  DEL  key and

the selected event condition can be deleted.

Also when the focus is on the Event Manager area, you can select one event icon, then click 

or double click the event icon, the setting dialog box corresponding to the selected events opens, and

displays the contents of the event condition.

By clicking , it is possible to select the Event Manager area display mode or sequencing.

Function buttons

Closes the Snap shot dialog box.

If there is a snap shot event condition that is being edited, it is entered

automatically and the dialog box is closed.

The snap shot event condition becomes valid as soon as it is entered.

Newly creates a snap shot event condition.

A snap shot event name is generated automatically and a newly created snap

shot event condition is prepared.  After it is created, be sure to enter the snap shot

event condition using the  or  button.

Enters a snap shot event condition.

When a new snap shot event condition has been created or when the contents of

a snap shot event condition have been changed, be sure to enter the snap shot

event condition using this button.

If snap shot event conditions that have already been entered are displayed, it

changes to either the  or  button.

The snap shot event condition becomes valid as soon as it is entered.

Enables a snap shot event condition.

This button is displayed in cases where a snap shot event condition is in the

disabled state.

It changes to either the  or  button.
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Disables a snap shot event condition.

This button is displayed in cases where a snap shot event condition is in the

enabled state.

It changes to either the  or  button.

Clears the contents of a snap shot event condition.

If a snap shot event condition is entered but not edited, this button is displayed.  It

changes to the  button.

Returns the contents of a snap shot event condition to the original contents.

If a snap shot event condition that has not been entered is displayed, all the area

is made blank.

If a snap shot event condition is being edited, the  button is displayed

in place of this button.

Closes the Snap Shot dialog box.

If a snap shot event condition is not being created/changed/deleted, the

 button becomes this button.

Even if a snap shot event condition is being edited, the dialog box closes without

the snap shot event condition being entered.  The  ESC  key has the same

operation.

Closes the Snap Shot dialog box.

If a snap shot event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is a snap shot event condition that is being edited, the dialog box

closes without the snap shot event condition being entered.  The  ESC  key has

the same operation.

Opens the Help window that explain this dialog box.

Opens the Event dialog box in the select mode and select the event condition to

be set.

Opens the Event Link dialog box in the select mode and select the event link

condition to be set.

Displays the event contents selected in the snap shot condition setting area or

Event Manager area by opening the corresponding setting dialog box.

The  button is enabled only when the focus is on the snap shot

conditions setting area or the Event Manager area, and when a single event is

selected.  In cases other than that, it appears dimmed and cannot be clicked.
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Deletes the event contents selected in the snap shot condition setting area or

Event Manager area.

The  button is enabled only when the focus is on the snap shot

conditions setting area or the Event Manager area, and when a single event is

selected.  In cases other than that, it appears dimmed and cannot be clicked.

The  DEL  key has the same operation.

Displays the Event Manager area.  Expands the size of the dialog box.

When the Event Manager area is not displayed, the  button is

displayed in place of this button.

Does not display the Event Manager area.  Shrinks the size of the dialog box.

When the Event Manager area is displayed, the  button is displayed

in place of this button.

Adds the event condition or event link condition selected in the Event Manager

area to the selected position in the snap shot event condition setting area.

Events other than the event condition or event link condition cannot be added.

Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the Event Manager area to the detail display

mode.

The  button changes the Event Manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.
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Opens the Set Other dialog box.

Clicking each button opens the Event Manager and the Event, Event Link, Break,

Trace, Snap Shot, Stub, or Timer Setting dialog box, and closes the Set Other

dialog box.

Close the dialog box by clicking the  or  and return to

the Snap Shot dialog box.
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Stub Dialog Box Modeless

General

This dialog box registers, sets, and displays stub event conditions.

The stub event condition created (registered/set) in this dialog box is automatically registered to or managed by the

Event Manager.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Event] → [Stub…] from the menu bar.

Press the  GRPH  +  N , and  U  keys in that order.

•  In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  U .

• Execute one of the following operations in the Event, Event Link, Break, Trace, Snap Shot, or Timer setting

dialog box.

Select the stub event condition and click the  button.

Select the stub event condition and press the shortcut keys  GRPH  +  O .

Double click the stub event condition.

• Execute one of the following operations in the Event Manager.

Select the stub event condition and click the  button.

Double click the snap shot event condition.

• Execute one of the following operations in the New Event dialog box or Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  U .
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Window

Figure 6-65.  Stub Dialog Box

When the Event Manager area is displayed

When the Event Manager area is not displayed

(1) Stub event name setting area (3) Jump address setting area

(2) Stub condition setting area (4) Event Manager area

Function

This dialog box registers, sets, and displays stub event conditions.

The stub function is to execute the user program that has been downloaded to a vacant area of the memory or

written by means of online assemble, when an event is established.  The timing at which this stub function is to be

executed is specified by a stub event condition.

Up to 256 stub event conditions can be entered.  However, the number of stub event conditions that can be used

simultaneously is 1.

(1)

(2)

(3)

(4)

(1)

(2)

(3)
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Stub event conditions become valid automatically when they are entered.  However, if the number of stub event

conditions exceeds the number that can be used simultaneously, or if the number of event conditions or event link

conditions in use exceeds the number that can be used simultaneously, the stub event conditions are entered in the

disabled state.  Also, in this case, a stub event condition cannot be enabled.

This dialog box consists of the following areas.

• Stub event name setting area

• Stub condition setting area

• Jump address setting area

• Event Manager area

The function of each area is explained below.

(1) Stub event name setting area

This area sets a stub event name and selects a stub event condition.

When entering a stub event condition, it is necessary to set a stub event name.

The stub event name that can be set is 8 alphanumeric characters or less.

When displaying stub event conditions which have already been created, either type the stub event name of

the already created stub event name in the text box or select the stub event condition from the drop-down list

in the stub event name setting area.

Clicking the  mark in the stub event name setting area switches between enabling or disabling the stub

event condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in the  Mark Condition

Red Indicates that the stub event condition has been enabled.

A stub event occurs if the condition is satisfied.

Black Indicates that the stub event condition has not been enabled.

No stub event occurs although the condition is satisfied.

Gray Indicates that the stub event condition is currently being edited and

that it has not been entered.

Yellow Indicates that the stub event is an event which is in the hold state.

An event in the hold state is in a state where the symbol specified by

the event condition by program download, etc. cannot be referred to.
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(2) Stub condition setting area

This area sets a stub event condition.

This can set only one event condition and event link condition for starting a stub condition setting area.

Carry out setting of the stub condition by one of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select an event condition or event link condition in the Event Manager area and click , or

make the setting by drag and drop.

If an event condition or event link condition is already set in the stub condition setting area, it is replaced in

newly set event conditions or event link conditions.

When setting the event condition or event link condition by drag and drop, besides the Event Manager area in

the Stub dialog box, it is possible to set it from the Event Manager area and Event Manager in each setting

dialog box.

When the focus is on the stub condition setting area, then click the  button, or press the

 DEL  key and the selected event condition or event link condition can be deleted.

Selecting an event condition or event link condition in the stub condition setting area and clicking 

or double clicking it opens the Event dialog box or Event Link dialog box and displays the contents of the

event condition or event link condition.

The stub event condition setting area is left blank when there is a newly created stub event condition.

(3) Jump address setting area

This area sets a first address of the function to be inserted and executed if a stub event occurs.

When a stub event occurs, if it returns to the origin from the specified function, it is necessary to describe the

“BR[r31] instruction” in the function.

The first address of the function can also be specified by a symbol.

The specification method is the same as in the case of the Symbol To Address dialog box, but the default

radix when inputting numerical values is hexadecimal.

If the data condition setting is omitted, data conditions are not detected.

Specify the function’s header address in the following setting range.

Setting range: 0 ≤  Header address of function ≤ 0xFFFF

The stub condition setting area is left blank when there is a newly created stub event condition.
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(4) Event Manager area

This displays a list of each of the entered events, event links, breaks, trace, snap shot, stub, and timer events.

An event condition or event link condition displayed in the Event Manager area can be set in the stub

conditions setting area by clicking .

Also, an event condition or event link condition in the Event Manager area can be dragged and dropped

directly to the stub conditions setting area.

When the focus is on the Event Manager area, the selected event can be deleted by selecting the event icon

and then clicking  or by pressing the  DEL  key.

Also when the focus is on the Event Manager area, you can select one event icon, then click  or

double click the event icon, the setting dialog box corresponding to the selected events opens, and displays

the contents of the event.

By clicking , it is possible to select the Event Manager area display mode or sequencing.

Function buttons

Closes the Stub dialog box.

If there is a stub event condition that is being edited, it is entered automatically

and the dialog box is closed.

The stub event condition becomes enabled as soon as it is entered.

Creates a new stub event condition.

A stub event name is generated automatically and the created stub event

condition is prepared.  After it is created, be sure to enter the stub event condition

using the  or the  buttons.

Enters a stub event condition.

When a new stub event condition has been created or when the contents of a stub

event condition have been changed, be sure to enter the stub event condition

using this button.

If stub event conditions that have already been entered are displayed, it changes

to either the  or  button.

The stub event condition becomes enabled as soon as it is entered.

Enables a stub event condition.

This button is displayed in cases where a stub event condition is in the disabled

state.

It changes to either the  or  button.
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Disables a stub event condition.

This button is displayed in cases where a stub event condition is in the enabled

state.

It changes to either the  or the  button.

Clears the contents of a stub event condition.

If a stub event condition is entered but not edited, this button is displayed.  It

changes to the  button.

Returns the contents of an stub event condition to the original contents.

If a stub event condition that has not been entered is displayed, all the area is

made blank except the stub event name.

If a stub event condition is being edited, the  button is displayed in

place of this button.

Closes the Stub dialog box.

If an event condition is not being created/changed/deleted, the  button

becomes this button.

Even if a stub event condition is being edited, the dialog box closes without the

stub event condition being entered.  The  ESC  key has the same operation.

Closes the Stub dialog box.

If a stub event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is a stub event condition that is being edited, the dialog box closes

without the stub event condition being entered.  The  ESC  key has the same

operation.

Opens the Help window that explain this dialog box.

Opens the Event dialog box in the select mode and select the event condition to

be set.

Opens the Event Link dialog box in the select mode and select the event link

condition to be set.

Displays the event contents selected in the stub condition setting area or Event

Manager area by opening the corresponding setting dialog box.

Operation is the same as double clicking the event icon.

If an event is not selected, or if multiple events are selected, selection cannot be

made.

Deletes the event contents selected in the stub condition setting area or Event

Manager.

The  DEL  key has the same operation.
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Displays the Event Manager area.  Expands the size of the dialog box.

When the Event Manager area is not displayed, the  button is

displayed in place of this button.

Does not display the Event Manager area.  Shrinks the size of the dialog box.

When the Event Manager area is displayed, the  button is displayed

in place of this button.

Adds the event condition or event link condition selected in the Event Manager

area to the selected position in the stub condition setting area.

Events other than the event condition or event link condition cannot be added.

Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the Event Manager area to the detail display

mode.

The  button changes the Event Manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.
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Opens the Set Other dialog box.

Clicking each button opens the Event Manager and the Event, Event Link, Break,

Trace, Snap Shot, or Timer setting dialog box, and closes the Set Other dialog

box.

Close the dialog box by clicking  or  and return to the

Snap Shot dialog box.
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Timer Dialog Box Modeless

General

This dialog box displays the result of measuring simulation time, and registers and sets timer event conditions.

The timer event condition registered in this dialog box is automatically registered to the Event Manager.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Event] → [Timer…] from the menu bar.

Press the  GRPH  +  N , and  I  keys in that order.

Click the  button on the tool bar.

•  In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  I .

• Execute one of the following operations in the Event, Event Link, Break, Trace, Snap shot, or Stub setting

dialog box.

Select the timer event condition and click the  button.

Select the timer event condition and press the shortcut keys  GRPH  +  O .

Double click the timer event condition.

• Execute one of the following operations in the Event Manager.

Select the timer event condition and click the  button.

Double click the timer event condition.

• Execute one of the following operations in the New Event dialog box or Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  I .
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Window

Figure 6-66.  Timer Dialog Box (1/2)

When the Event Manager area is displayed

When the Event Manager area is not displayed

(1) Timer event name setting area (4) Simulation time display area

(2) Timer condition setting area (5) Event Manager area

(3) Timer display unit selection area

(1)

(2)

(3)

(5)

(1)

(2)

(3)

(4)

(4)



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 337

Figure 6-66.  Timer Dialog Box (2/2)

When in Run-Break

(1) Timer event name setting area (4) Simulation time display area

(2) Timer condition setting area (5) Event Manager area

(3) Timer display unit selection area

Function

This dialog box displays the result of measuring simulation time, and registers and sets timer event conditions.

The result of measuring simulation time is displayed by selecting the set timer event condition.

Up to 256 timer event conditions can be entered.  However, the number of timer event conditions that can be used

simultaneously is 8 (except for Run-Break).

Timer event conditions become valid automatically when they are entered.  However, if the number of timer event

conditions exceeds the number that can be used simultaneously, or if the number of event conditions or event link

conditions in use exceeds the number that can be used simultaneously, the timer event conditions are entered in the

disabled state.  Also, in this case, a timer event condition cannot be enabled.

The simulation time from the start of the program to occurrence of a break can be displayed as well as the timer

event conditions.  It can be displayed by selecting “Run-Break” in the timer event name setting area

A timer event condition is performed only when the timer is in the enabled state.  Set it by the procedure below.

<1> Select [Option] → [Timer ON] from the menu bar in the Main window.

If the timer disabled without checking [Option] → [Timer ON] on the menu bar in the main window, the timer will not

be executed.  However, “Run-Break” is always enabled irrespective of whether “Run-Break” is set with timer on or off.

During emulation, in order to stop the currently operating timer, select [Run] → [Timer Stop] from the menu bar.

Also, during emulation, in order to run the currently stopped timer, select [Run] → [Timer Start] from the menu bar.

These two menus toggle and their display changes according to the current timer state.

(1)
(4)

(2)

(3)

(5)
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This dialog box consists of the following areas

• Timer event name setting area

• Timer condition setting area

• Timer display unit selection area

• Simulation time display area

• Event Manager area

The function of each area is explained below.

(1) Timer event name setting area

This area sets a timer event name and selects a timer event condition.

When entering a timer event condition, it is necessary to set a timer event name.

The timer event name that can be set is 8 alphanumeric characters or less.

The timer event name “Run-Break”, which displays the simulation time from the start of execution to

occurrence of a break, is registered from the beginning (this timer event name, however, is not displayed in

the Event Manager).

When displaying timer event conditions which have already been created, either type the timer event name of

the already created timer event condition in the text box or select the drop-down list in the timer event name

setting area.

Clicking the  mark in the timer event name setting area switches between enabling or disabling the timer

event condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in the  Mark Condition

Red Indicates that the timer event condition has been enabled.

A timer event occurs if the condition is satisfied.

Black Indicates that the timer event condition has not been enabled.

No timer event occurs if the condition is satisfied.

Gray Indicates that the timer event condition is currently being edited and

that it has not been entered.

Yellow Indicates that the timer event is an event which is in the hold state.

An event in the hold state is in a state where the symbol specified by

the event condition by program download, etc. cannot be referred to.
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(2) Timer condition setting area

This area sets a event condition for a timer.

Start Event: Sets event condition to start time measurement or event link condition

End Event: Sets event condition to end time measurement or event link condition

The number of event conditions and event link conditions that can be entered in the timer condition setting

area is one condition each of a starting condition and an end condition.

Carry out setting of the timer condition by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select an event condition in the Event Manager area and click , or make the setting by drag

and drop.

If an event condition or event link condition is already set in the timer condition setting area, it is replaced in

newly set event conditions or event link conditions.

When setting the event condition or event link condition by drag and drop, besides the Event Manager area in

the Timer dialog box, it is possible to set it from the Event Manager area and Event Manager in each setting

dialog box.

When the focus is on the timer condition setting area, then click the  button, or press the

 DEL  key and the event condition or event link condition selected in [Start Event:] or [End Event:] can be

deleted.

It is possible to move the event condition and event link condition in [Start Event:] and [End Event:] in the

timer condition setting area by a drag and drop operation.

Selecting an event condition or event link condition selected in [Start Event:] or [End Event:] in the timer

condition setting area and clicking  or double clicking it opens the Event dialog box or Event Link

dialog box and displays the contents of the event condition or event link condition.

The timer event condition setting area is left blank when there is a newly created timer event condition.
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(3) Timer display unit selection area

This area selects the timer measuring results display units.

The units can be selected from the following five types.

nsec: Measuring results are displayed in nanosecond units.

usec: Measuring results are displayed in microsecond units.

msec: Measuring results are displayed in millisecond units.

sec: Measuring results are displayed in second units.

min: Measuring results are displayed in minute units.

nsec is selected for a newly created timer event condition.

(4) Simulation time display area

This area displays the simulation time and the number of execution of the program.

Simulation time can be measured up to 7 minutes and 9 seconds (with a resolution of 0.1 microsecond).  The

number of executions can be measured up to a maximum of 4,294,967,295 times.

Measuring results displayed include the cumulative simulation time of the measuring period specified by the

starting event and closing event conditions, the number of passes, the maximum simulation time, the

minimum simulation time and the average simulation time.

Also, if “Run-Break” is selected in the timer event name setting area, only the cumulative simulation time from

simulation start to simulation end is displayed.

Measuring

Results

Contents Remarks

Pass Displays the number of passes. In the case of “Run-Break,” this is not measured.

Total Displays the cumulative simulation time.

Average Displays the average simulation time.

Max Displays the maximum simulation time.

Min Displays the minimum simulation time.

In the case of “Run-Break,” this is not measured.
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If measurement is not conducted or if the measuring results are cleared, it is shown as a blank.

If the measuring results overflow, the message “Result of timer measurement overflowed” is displayed.

The following functions can be used by operating each button.

• By clicking , the measuring results can be cleared.

• “Run-Break” measuring results cannot be cleared.  They are cleared automatically when simulation starts.

• By clicking , the measuring results can be copied to the clipboard in text format.

• By clicking , the Timer Results dialog box, which displays the selected timer event

conditions or the “Run-Break” measuring results, is displayed.

(5) Event Manager area

This displays a list of each of the entered events, event links, breaks, trace, snap shot, stub and timer events.

An event condition or event link condition displayed in the Event Manager area can be set in the timer

conditions setting area by clicking .

Also, an event condition or event link condition in the Event Manager area can be dragged and dropped

directly to the timer condition setting area.

When the focus is on the Event Manager area, the selected event can be deleted by selecting the event icon

and then clicking  or by pressing the  DEL  key.

Also when the focus is on the Event Manager area, you can select one event icon, then click  or

double click the event icon, the setting dialog box corresponding to the selected events opens, and displays

the contents of the event condition..

By clicking , it is possible to select the Event Manager area display mode or sequencing.

Function buttons

Closes the Timer dialog box.

If there is a timer event condition that is being edited, it is entered automatically

and the dialog box is closed.

The timer event condition becomes enabled as soon as it is entered.

Newly creates a timer event condition.

A timer event name is generated automatically and a newly created timer event

condition is prepared.  After it is created, be sure to enter the timer event condition

using the  or the  buttons.
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Enters a timer event condition.

When a new timer event condition has been created or when the contents of a

timer event condition have been changed, be sure to enter the timer event

condition using this button.

If timer event conditions that have already been entered are displayed, it changes

to either the  button or  button.

The timer event condition becomes enabled as soon as it is entered.

Enables a timer event condition.

This button is displayed in cases where a timer event condition is in the disabled

state.

It changes to either the  button or the  button.

Disables a timer event condition.

This button is displayed in cases where a timer event condition is in the enabled

state.

It changes to either the  button or the  button.

Clears the contents of a timer event condition.

If a timer event condition is entered but not edited, this button is displayed.  It

changes to the  button.

Returns the contents of a timer event condition to the original contents.

If a timer event condition that has not been entered is displayed, all the area is

made blank except the timer event name, or the settings return to the default

settings.

If a timer event condition is being edited, this button is displayed in place of the

 button.

Closes the Timer dialog box.

If a timer event condition is not being created/changed/deleted, this button

becomes the  button.

Even if a timer event condition is being edited, the dialog box closes without the

timer event condition being entered.  The  ESC  key has the same operation.

Closes the Timer dialog box.

If a timer event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is a timer event condition that is being edited, the dialog box closes

without the timer event condition being entered.  The  ESC  key has the same

operation.

Opens the Help window that explains this dialog box.
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Opens the Event dialog box in the select mode and adds to set the event condition

either in [Start Event:] or in [End Event:] in the timer condition setting area.

The area where the event condition is added becomes the selected area when

 is clicked.

Opens the Event Link dialog box in the select mode and adds to set the event link

condition either in [Start Event:] or in [End Event:] in the timer condition setting

area.

The area where the event condition is added becomes the selected area when

 is clicked.

Displays the event contents selected in [Start Event:] or in [End Event:] in the

timer condition setting area or Event Manager area by opening the corresponding

setting dialog box.

Operation is the same as double clicking the event icon.

If an event is not selected, or if multiple events are selected, selection cannot be

made.

Deletes the event contents selected in [Start Event:] or in [End Event:] in the timer

condition setting area or Event Manager.

The  DEL  key has the same operation.

Displays the Event Manager area.  Expands the size of the dialog box.

When the Event Manager area is not displayed, this button is displayed in place of

the  button.

Does not display the Event Manager area.  Shrinks the size of the dialog box.

When the Event Manager area is displayed, this button is displayed in place of the

 button.

Adds the event condition or event link condition selected in the Event Manager

area to the selected position in [Start Event:] or in [End Event:] in the timer

condition setting area.

The area where the event condition is added becomes the selected area when

 is clicked.
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Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the Event Manager area to the detail display

mode.

The  button changes the Event Manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.

Opens the Set Other dialog box.

Clicking each button opens the Event Manager and the Event, Event Link, Break,

Trace, Snap Shot, or Stub setting dialog box, and closes the Set Other dialog box.

Close the dialog box by clicking  or  and return to the

Timer dialog box.
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Clears the measuring results.

When measurements are not being taken, it appears dimmed and cannot be

clicked.

It also appears dimmed and cannot be pressed when a user program is being

simulated.

Copies measuring results to the clipboard in text format.

Displays the Timer Result dialog box, which displays the selected timer event

condition or “Run-Break” measuring results.
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Timer Result Dialog Box Modeless

General

This dialog box displays the simulation time measuring results.

Opening method

This dialog box can be opened by the following procedure.

• Select a timer event condition or “Run-Break” in the Timer dialog box and execute one of the following

operations.

Click the  button.

Press the shortcut keys  GRPH  +  V .

Window

Figure 6-67.  Timer Result Dialog Box

Function

This dialog box displays the simulation time measuring results.

This displays the simulation time measuring results for the timer event condition or “Run-Break” set in the Timer

dialog box.

The Timer Result dialog box corresponds 1 to 1 with a timer event condition or “Run-Break” and multiple dialog

boxes can be opened simultaneously.  The number that can be opened simultaneously is 256 for timer event

conditions and 1 corresponding to “Run-Break”, for a total of 257.  However, the number of measurements that can be

taken simultaneously is 8 timer event conditions and 1 “Run-Break.”

The Timer Result dialog box consists of the following area.

• Simulation time display area

The function of this area is explained below.

(1) Simulation time display area
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(1) Simulation time display area

This area displays the measuring results of the simulation time and the number of execution of the program.

Measuring results displayed include the cumulative simulation time of the measuring period specified by the

starting event and closing event conditions, the number of passes, the maximum simulation time, the

minimum simulation time, and the average simulation time.

Also, the simulation time is displayed in the units set for the timer event condition.

Also, if “Run-Break” is selected in the timer event name setting area, only the cumulative simulation time from

simulation start to simulation end is displayed.

Measuring

Results

Contents Remarks

Pass Displays the number of passes. In the case of “Run-Break,” this is not measured.

Total Displays the cumulative simulation time.

Average Displays the average simulation time.

Max Displays the maximum simulation time.

Min Displays the minimum simulation time.

In the case of “Run-Break,” this is not measured.

If measurement is not conducted or if the measuring results are cleared, it is shown as a blank.

If the measuring results overflow, the message “Result of timer measurement overflowed” is displayed.

Function

Clears the timer measuring results.

When timer measurements are not being taken, it appears dimmed and cannot be

clicked.

It also appears dimmed and cannot be pressed when a user program is being

simulated.

A “Run-Break” cannot be cleared.  It is cleared automatically when program

simulation starts.

Copies timer measuring results to the clipboard in text format.

Closes the Timer Result dialog box.  It becomes the default button.  The  ESC.

key has the same operation.

Opens the Help window that explain this dialog box.
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Reset Debugger Dialog Box Modal

General

Initializes the debugger, emulation CPU, and symbol information.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [File] → [Debugger Reset…] from the menu bar.

Press the  GRPH  +  F , and  R  keys in that order.

Window

Figure 6-68.  Reset Debugger Dialog Box

Function

This dialog box specifies, by using a check box, whether the debugger, emulation CPU, or symbol information is

initialized.  As the default, only the debugger is initialized.

The Reset Debugger dialog box consists of the following area.

• Reset subject selection area

The function of this area is explained below.
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(1) Reset subject selection area

This area selects the subject to be reset from the following.

The contents are shown below.

Selected Item Contents

Debugger Initializes and restarts the debugger (default).

Symbol Resets symbol information.

Target CPU Resets emulation CPU.

Function buttons

Initializes the selected subject.

Ignores the setting and closes this dialog box.

Opens the Help window.
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About Dialog Box Modal

General

This dialog box displays the version information of the debugger and simulator.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [Help] → [About…] from the menu bar.

Press the  GRPH  +  H , and  A  keys in that order.

Window

Figure 6-69.  About Dialog Box

Function

This dialog box displays the version of the simulation, and the version of the device files, GUI, project manager tool

DLLs, debugger DLLs, assembler DLLs, and executer.

Function button

Closes this dialog box.
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Exit Debugger Dialog Box Modal

General

This dialog box terminates the simulator.

When terminating the debugger, the debugging environments can be saved in a project file.

Opening method

This dialog box can be opened by the following procedure.

•  In the Main window

Select [File] → [Exit] from the menu bar.

Press the  GRPH  +  F , and  X  keys in that order.

• In the 78K/0 Simulator GUI window.

Select [File] → [Exit] from the menu bar.

Press the  GRPH  +  F , and  X  keys in that order.

Also, the Exit Debugger dialog box opens when a compulsory close is executed, such as when Windows is closed

or when an application is closed in the task list.

Window

Figure 6-70.  Exit Debugger Dialog Box
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Function

This dialog box specifies, by using a check box, whether the current debugging environments are saved in a

project file or not when the simulator is terminated.  As the default, the debugging environments are not saved in a

project file.  If the project file has been saved or loaded during a debugging operation, the default is to save the

debugging environments.

When the check box is checked and the  button is clicked, the Project File Save dialog box is opened,

the current debugging environments are saved in the project file, and all the windows are closed.  The simulator then

is terminated.

If the project file has been saved or loaded during a debugging operation, however, the Project File Save dialog

box is not opened, and the debugging environments are saved in the project file.

If the  button is clicked without checking the check box, all the windows are closed, and the debugger is

terminated.

Note that the Exit Debugger dialog box can be set not to open in the Debugger Option dialog box.

Function buttons

When the check box is checked, the Project File Save dialog box is opened, the

current debugging environments are saved in the project file, and all the window

are closed.  The simulator is then terminated.  When the check box is not

checked, all the windows are closed, and the simulator is terminated.

Closes this dialog box without performing anything.

Opens the Help window that explains the Exit Debugger dialog box.
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78K/0 Simulator GUI Window

General

This is the Main window of the simulator.

The windows peculiar to the simulator, such as the windows related to peripheral simulation and external parts, are

started from this window.

This window is opened when the SM78K0 is started, and exists on the screen until the simulator is terminated.

When this window is closed, the SM78K0 is terminated.

Opening method

This window can be opened by either of the following procedures.

Double click the desktop GUI icon .

Click the  on the task bar.

Window

Figure 6-71.  78K/0 Simulator GUI Window

Function

The 78K/0 Simulator GUI window consists of the following areas.

• Message area

• Simulation subject file name display area

The function of this area is explained below.

(1) Message area

(2) Simulation subject file name display area
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(1) Message area

This area displays the default value messages when initialization processing has been executed without input

data having been set.

In the simulator, if, during simulation, there was a request to read the input data from a pin to which neither

input data had been set nor a pull-up resistor had been connected, the pin’s value is initialized to 0.  In such a

case, a message is displayed in this area.

(2) Simulation subject file name display area

Down Load File: Displays the currently downloaded input data file names.  The identifier is .i_x.

To specify a file, select [File] → [Download…] on the menu barNote.

Note Can also be specified by the download button of Input timing Chart Editor

window, Input 0/1 Editor window, and SFR Event & Action window.

Output Data File: Displays the name of the file to which data output by the simulator are saved.  The

identifier is .out.  To specify a file, select [File] → [Output…] on the menu bar.

Menu bar

(1) File

This item is selected to create a data file (.i_x) or event condition file (.evn) to be input to an SFR, download

these files, specify output from the simulator, and terminate the simulator.

[New] Opens a new window.

If this menu item is selected when the Input 0/1 Editor window or Input timing Chart

Editor window has been already opened, the file specified in the existing window is

displayed.

[0/1…] Opens the Input 0/1 Editor window (p.361).

[Timing…] Opens the Input timing Chart Editor window (p.367).

[Event…] Opens the SFR Event & Action window (p.357).
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[Open] Opens the previously saved file.

Specifies a file in the file Open dialog box (p.461).

If this menu item is selected when the Input 0/1 Editor window or Input timing Chart

Editor window has been already opened, the file specified in the existing window is

displayed.

[0/1...] Opens the Input 0/1 Editor window.

[Timing...] Opens the Input timing Chart Editor window.

[Event...] Opens the SFR Event & Action window.

[DownLoad...] Opens the Down Load dialog box (p.374).  Downloads a specified input data file (.i_x)

and event condition file (.evn).  When the OK  button in the Down Load dialog

box is clicked, the specified file is downloaded.

However, this function cannot be executed while the CPU operates.

[Output...] Opens the Output Setting dialog box (p.376).  If “ Output to file” in the Output

Setting dialog box is checked on the check box and a file name is specified, the

output data is output to the file.  If “ Enable timing chart” is checked, the Output

Timing Chart window (p.378) is opened.

[Exit...] Opens the Exit Debugger dialog box (p.351).  When OK  is selected, the

SM78K0 is terminated.

(2) External Parts

This function is selected to open the Parts window (p.385)

[Panel Window...] Opens the Parts window.

(3) External Circuit

Cannot be selected.
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(4) Help

[Help Topics] Displays the table of contents of the Help window.

[This Window] Displays the Help window that explains this window.

[Version...] Cannot be selected.
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SFR Event & Action Window

General

This window sets or displays an event for an SFR or address, and the operation to be performed after the event

has occurred.

Opening method

This window can be opened by either of the following procedures.

• Select [File] → [New] → [Event…] on the menu bar of the 78K/0 Simulator GUI window.

• Select [File] → [Open] → [Event…] on the menu bar of the 78K/0 Simulator GUI window.

Window

Figure 6-72.  SFR Event & Action Window

Function

This window sets and displays an event condition for an SFR and an operation (action: such as occurrence of an

interrupt at any timing and data input)  to be performed when an event occurs.

The created event condition and action can be saved to an event condition file (.evn) and can be downloaded while

the CPU does not operate.  By downloading the event condition file, the event in the file is registered to the simulator,

enabling event check.

Up to 20 events and actions can be registered to one event condition file.

(2)  Event condition file name display area(1)  Event number setting area

(4)  Action setting area(3)  Event setting area
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The SFR Event & Action window consists of the following areas.

• Event number setting area

• Event condition file name display area

• Event setting area

• Action setting area

The function of each area is explained below.

(1) Event number setting area (Event No.)

This area selects the ID number of an event and action (0 to 19) from a drop-down list.

If there are any events that have not been set yet, the input field is displayed as the default state.  Also, if the

ID of an event that has already been set is selected, its contents are displayed in each area.

Valid: When the check box is checked, the event of current Event No becomes valid.

(2) Event condition file name display area (File Name:)

This area displays the name of the file currently opened or saved.
This area is not displayed if a file is newly created.  When the file is saved (by clicking the Save  button),

a name is given to the file.

To read the contents of the previously saved file, specify a file by using the Open  button.

(3) Event setting area (Event Set)

This area sets an event condition by specifying the following items.

Address, Sfr: Specifies a memory area in which an event occurs.  Either of the following is selected

by using an option button.

Address: Inputs an address.  When this address is accessed, an event occurs.  All the memory

addresses can be specified.

Sfr: Specifies an SFR name.  When this SFR name is accessed, an event occurs.  Select

an SFR from the drop-down list, or input from the keyboardNote (default).

Note For the pin name, interrupt name, and SFR name to be specified, refer to

the User’s Manual of the device used.

Status: Specifies an access status in which an event occurs. Select an access status from

FETCH (default), READ, WRITE, and READ/WRITE from the drop-down list, or input

from the keyboard.

Access Size: Specifies access size at which an event occurs. Select an access size from NO DATA

(default), 1BYTE, 2BYTE, and 4BYTE from the drop-down list, or input from the

keyboard.

Data: Specifies a data condition under which an event occurs. This setting is invalid if

Access Size is NO DATA.  This can be set in the range of the set condition if it is

1BYTE, 2BYTE, or 4BYTE.
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Data Mask: Specifies the mask condition of data under an event occurs.  A value up to 4 bytes

can be specified.  This setting is invalid if Access Size is NO DATA.

Pass Count: Specifies the number of times the above event condition for Event Set area must be

satisfied so that an event occurs.  A value of up to 2 bytes can be specified.  If 1

(default) is set, an event condition is regarded as established when the condition is

satisfied once.

(4) Action setting area (Action Set)

This area sets an operation to be performed when an event occurs.  The timing to start an action and the

details (action) are specified.

Timing Val: Specifies the start timing of the action (the unit is specified by Timing Unit).  A value of

up to 2 bytes can be specified.  The default value is 0.  The specified action is started

immediately after an event has occurred.

Timing Unit: Specifies the unit of Timing Val.

Select the following unit from the drop-down list (shown below), or input a unit from

the keyboard.

CLOCK: CPU clock unit (default).

M-CLK: Main clock unit

IST: Instruction unit

Interrupt: When the check box is checked, an interrupt signal is generated as an action.

Specify the name of the interrupt signal by selecting from the drop-down list, or

inputting from the keyboardNote.

Note For the pin name, interrupt name, and SFR name to be specified, refer to the

User’s Manual of the device used.

Set Data: When the check box is checked, a value to any one of a specified address, SFR, and

pin is input as an action.

Specify a value by using an option button.

Address: Specifies an address to which data is to be input.  All the memory addresses can be

specified.

Sfr: Specifies an SFR to which data is to be input.  Select a register from the drop-down

list, or input from the keyboardNote.

Pin: Specifies the name of the pin through which data is to be input.  Select a pin from the

drop-down list, or input from the keyboardNote.

Note For the pin name, interrupt name, and SFR name to be specified, refer to

the User’s Manual of the device used.

Data: Specifies the data to be input to a specified address, SFR, and pin.  If Address or Sfr

is selected, a value of up to 4 bytes can be specified.  If Pin is selected, 0 or 1 can be

specified.
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Function buttons

Open Opens the Open dialog box (p.461).  Reads a specified event condition file (.evn).

Save Opens Save As dialog box (p.463).  Saves the contents of the set window to an event condition file

(.evn).

DownLoad Opens the Down Load dialog box (p.374).  Downloads the specified file to the simulator.

Clear Opens a dialog box that asks you whether data should be initialized.  When the OK  button is

selected, the contents being created and not saved to the file are initialized.

Used to start editing again from the status of the file saved last.

Cancel Opens a window that asks you whether this window should be closed.  When the OK  button

is selected, the window is closed.

Help Displays the Help window.
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Input 0/1 Editor Window

General

This window is one of the input editor windows and sets input data as numeric value to input pins at any timing.

This window can display the following data:

• Newly created input data

• Previously created input data file (to be edited)

• File simulated previously and saved to output file

Opening method

This window can be opened by either of the following procedures.

• Select [File] → [New] → [0/1…] on the menu bar of the 78K/0 Simulator GUI window.

• Select [File] → [Open] → [0/1…] on the menu bar of the 78K/0 Simulator GUI window.

Window

Figure 6-73.  Input 0/1 Editor Window

Function

This window sets 1-bit data to be set to an input pin as a numeric data at any timing.

This setting is saved to an input data file (.i_x).  By downloading this file, an input signal from a pin can be

generated during simulation.

(1)  Input data file name display area (2)  Wait display selection area

(3)  Input data setting table
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The Input 0/1 Editor window consists of the following areas.

• Input data file name display area

• Wait display selection area

• Input data setting area

The function of each area is explained below.

(1) Input data file name display area (File Name:)

This area displays the names of the file currently subjected to opening/saving.  A newly created file is not

displayed, and a name is given when the file is saved (by clicking the Save  button).

(2) Wait display selection area (Wait Count Type:)

This area consists of buttons that selects timing (wait) to input data during simulation.  The wait start time is

selected by using an option button.

Rel. (relative display) ...  Assumes the previous data input as the wait start time.

Abs. (absolute display) ...  Assumes the start of simulation as the wait start time.

If wait is displayed in the absolute display (Abs), the carry from the top level of the edit/display area is

displayed in the form XXXXXXxxxxx at the bottom of the Wait column.

(3) Input data setting table (Mark, Wait, Pin)

This table sets or displays the data to be input to a specified pin.

If the wait time on shown on the Wait column has elapsed, the data set on the Pin column is input from each

pin.

As default, eight pins are displayed in 10 stages.  Up to 48 pins can be specified.  This window can be re-

sized.

Mark: Displays/sets loop information.

The loop information is set by using the following symbols that are displayed by

clicking this column (X indicates orders by ABC, and Y indicates numeric value).

Consequently, information in a specified range can be repeatedly input.

X-S  ...  Start position of loop X.

X-Y  ...  End position of loop X.  This loop is repeated Y times (1 ≤ Y ≤ 99)Note.

X-F  ...  End position of loop X.  This loop is repeated until simulation ends.

Note Actually, the loop is repeated Y + 1 times.

The display changes from X-S to X-F and from X-F to X-Y each time the left mouse button is clicked.  The

value of Y increases by one each time the right mouse button is clicked when X-Y is selected, and decreases

by one each time  SHIFT  key + right mouse button is clicked.

Wait: Sets the timing at which the data on the Pin column is input to a specified pin, as a

wait value.  An integer of 1 to 65536 can be specified . If the value exceeds 65535,

use one more level to set it.  Setting is done by writing numerical values directly to this

column from the keyboard.
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The unit of Wait is selected from the following (the file is saved by clicking the Save  button).

 .i_0 ...  ist (instruction unitNote)

 .i_1 ...  clock (CPU clock unit)

 .i_2 ...  1/4m-clk (1/4 main clock unit)

 .i_3 ...  m-clk (main clock unit)

Note In this file, the set value is ignored.

If abs. is specified as Wait Count Type, a carry of wait at the top line in the Wait column is displayed at the

bottom of this column in the form of XXXXXXxxxxxx.

Example In the case of the following figure, the wait value in the top level is 108001.  Accordingly, the wait

value in the bottom level is 108010.

Pin: Specifies the name of a pin that inputs data and the data to be input at the timing

specified on the Wait column.

A pin name is newly created by opening the Pin Setting dialog box (p.372) by using

the Pin Set  button, or by reading the pin setting information file (.pin) by using the

Read  button on this dialog box.  To edit the previously input data file (.i_x),

specify and read a file name by using the Read  button.

If the left button of the mouse is clicked when the cursor is pointed at the pin name

display area where the pin name is set, the pin name display color changes from

black to violet, indicating that that pin has been selected.

If this input data file is downloaded, the data for the selected pin only is downloaded.

If the display name is set, the display name is displayed and not the pin nameNote.

Note   For the display name, refer to the Pin Setting dialog box.
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(a) Setting input data

Any of the value 0 (LOW), 1 (HIGH), and Z (high impedance) can be assigned to the input data setting

table in the case of an input pin.  In the case of an analog input pin, a numeric value can be assigned in a

range of the number of bits of the A/D converterNote.

If a pin name is specified in the Pin column when new input data is to be assigned, ‘EOF’ is assigned in

the first line of the data setting table.  If a previously created file is read, ‘EOF’ is assigned in the last line

of the setting data.  By clicking on this ‘EOF’, one line of input data can be inserted.

Note Differs depending on the device.

Caution Because data cannot be entered in the Wait column for the line following the last line of

input data (the EOF line), the holding time for that data cannot be specified, making the

data invalid.  It is therefore necessary to enter dummy data in the final line.

• Setting of input pin

Mouse Operation Content of Operation

Left click Values changed in the order of “0” → “1” → “Z”.

• Setting of analog input pin

Mouse Operation Content of Operation

Left click Value increments by 1.

Right click Value decrements by 1.

(Left/Right) click while

pressing the SHIFT key.

Value changes by 10.

• Analog output pin Note

If the output signal does not change, ‘^’ is displayed indicating that the signal is the same as the data

on the above line.

Note   This is the display when an output data file (.out) is read.

Even in cases where an existing input data file is read and edited, input data is added and changed by

the same kind of operation as that above.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 365

(b) Selection of the pin that downloads the data

When a pin name displayed in the Pin column is clicked, the display color of the clicked pin changes from

black to purple, indicating that the pin has been selected.

By saving and downloading this input data file, the data for only the selected pin (displayed in purple) can

be downloaded.

Example

If the above file is downloaded, data is input to pin P10 as shown below.

Value of P10

Wait
(Relative)

B - S
First time

B - S
Second time

Repeat

Simulation begins after the input data file has
been downloaded.

A - S   A - F
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Function buttons

Pin Set Opens the Pin Setting dialog box (p.372).

Sets a specified pin to the Pin column.

Generation This button is invalid.

Search Opens the Search window (p.382).

Can be used to search the data in the input data file.

Clear Initializes any contents being created and not yet saved to a file.  Used to start editing again from

the status of the file saved last.

Read Opens the Open dialog box (p.461).  Reads a specified input data file (.i_x).

Save Opens the Save As dialog box (p.463).  Saves the contents of the set window to an input data file

(.i_x).  Specifies wait unit when saving the window contents.

DownLoad Opens the Down Load dialog box (p.372). Downloads a specified file to the simulator.

Help Displays the Help window that explains the Input 0/1 Editor window.

Cancel Ignores setting and closes the window.
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Input timing Chart Editor Window

General

The Input timing Chart Editor window is one of the input editor windows and sets input timing and input data in 1-bit

units as a timing chart to input pins.

This window can display the following data:

• Newly created input data

• Previously created input data file (to be edited)

• File simulated previously and saved to output file

Opening method

This window can be opened by either of the following procedures.

• Select [File] → [New] → [Timing…] on the menu bar of the 78K/0 Simulator GUI window.

• Select [File] → [Open] → [Timing…] on the menu bar of the 78K/0 Simulator GUI window.

Window

Figure 6-74.  Input timing Chart Editor Window

(1)  Input data file name display area

(2)  Wait value setting area (3)  Information display area

(4)  Timing chart setting area
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Function

This window sets 1-bit input to a pin input by timing chart.

By downloading this setting in an input data file (.i_x), the input signal from the pin can be generated during

simulation.

The Input timing Chart Editor window consists of the following areas.

• Input data file name display area

• Wait value setting area

• Information display area

• Timing chart setting area

The function of each area is explained below.

(1) Input data file name display area (File Name:)

This area displays the names of the file currently subjected to opening/saving.  A newly created file is not

displayed, and a name is given when the file is saved.

(2) Wait value setting area (Wait Value:)

This area sets the timing (wait) to input data during simulation.

Wait Value: Selects a wait value (data input timing) from the drop-down list.  This value is one

division of Scale.

Values in the Drop-down List

1 32↓

2

↓

64

↓ 4 ↓ 128

8 256

↓ 16 ↓ 512

The unit of Wait is selected from the following (the file is saved by clicking the Save  button).

 .i_0 ... ist (instruction unitNote)

 .i_1 ... clock (CPU clock unit)

 .i_2 ... 1/4m-clk (1/4 main clock unit)

 .i_3 ... m-clk (main clock unit)

Note In this file, the set value is ignored.
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(3) Information display area (Information:)

Information: Displays the first wait value if the time axis is not displayed.

If the vicinity of the character string Scale is double-clicked, time axis cursor S and

time axis marker E are displayed in the timing chart setting area, and the information

display area displays the following value.

S: Wait value from the beginning of file to the location indicated by S.

E: Wait value from the beginning of file to the location indicated by E.

S(PC): PC value of address at which the output value of the location indicated by S is

generated (when .out file is read).

E-S: Wait value from the location indicated by S to the location indicated by E.

Remark The time axis can be moved by dragging characters S and E.

(4) Timing chart setting area

Sets the input timing and input data for a specified pin in the form of a timing chart.  Only the data of input

pins can be edited.

The number of pins to be displayed is 9 by default, and 48 at maximum.

The window can be resized.

Pin: Specifies the name of a pin that inputs data. A pin name is newly created by opening

the Pin Setting dialog box (p.372) by using the Pin Set  button, or by reading the

pin setting information file (.pin) by using the Read  button on this dialog box.  To

edit the previously input data file (.i_x), specify and read a file name by using the
Read  button.

If the left button of the mouse is clicked when the cursor is pointed at the pin name

display area where the pin name is set, the pin name display color changes from

black to violet, indicating that that pin has been selected.

If this input data file is downloaded, the data for the selected pin only is downloaded.

If the display name is set, the display name is displayed and not the pin nameNote.

Note For the display name, refer to the Pin Setting dialog box.

Time axis cursor and

time axis marker: Double clicking near the character Scale causes a solid line and a dotted line to be

displayed.  The solid line is the time axis cursor (S) and the dotted line is the time axis

marker (E).  After the time axis cursor and time axis marker are displayed, if each is

dragged with the mouse, they can be moved.

If the time axis cursor and time axis marker are moved to the left side of the timing

chart setting area and are not displayed in the area, S and E are displayed at the top

left of the Scale column.  If they are moved to the right side of the timing chart setting

area and not displayed in the area, they are displayed at the top right of the Scale

column.
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(a) Setting input data/timing

To set new data, waveforms can be input by double-clicking at any location of the timing chart setting

area after setting a pin name in the Pin column.  If data is set fully in the timing chart setting area, data of

one division of the Scale can be added by clicking ‘EOF’ displayed on the right of the Scale column with

the right mouse buttonNote.

The set waveform can be changed through the following mouse operation in the timing chart setting area.

Note Horizontal scroll bar is also displayed.

[Input pin]

Operation Results

Double-clicks the left button Input data is turned to HIGH in one scale.

Double-clicks the right button Input data is turned to LOW in one scale.

Double-clicks the left button with the SHIFT key

pressed.

Input data is turned to high impedance in one

scale

[Analog pin]

Operation Results

Double-clicks the left button One scale increases by one.

Double-clicks the right button One scale decreases by one.

Double-clicks the left button with the SHIFT key

pressed.

One scale increases by ten.

Drags the horizontal line in the timing chart up

and down using the mouse.

The value changes according to the length the

line is moved up and down.

If the right mouse button is clicked while the cursor is in this area, the pin name at the clicked location

and its value are displayed at the lower right of the information view area (Information).

Even if an existing input data file is read and edited, data can be added or changed by the same

operation as above.

(b) Selecting pins for which the data is to be downloaded

When a pin name displayed in the Pin column is clicked, the display color of the clicked pin changes from

black to purple, indicating that the pin has been selected.

By saving and downloading this input data file, the data for only the selected pin (displayed in purple) can

be downloaded.
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Function buttons

Pin Set Opens the Pin Setting dialog box (p.372).

Sets a specified pin to the Pin column.

Generation This button is invalid.

Search Opens the Search window (p.382).

Can be used to search the data in the input data file.

Clear Initializes any contents being created and not yet saved to a file.  Used to start editing again from

the status of the file saved last.

Read Opens the Open dialog box (p.461).  Reads a specified input data file (.i_x).

Save Opens the Save As dialog box (p.463).  Saves the contents of the set window to an input data file

(.i_x).

DownLoad Opens the Down Load dialog box (p.374).  Downloads a specified file to the simulator.

Help Displays the Help window that explains the Input timing Chart Editor window.

Cancel Ignores setting and closes the window.
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Pin Setting Dialog Box

General

This window is opened to set pins to be displayed on the Input 0/1 Editor window (p.361), Input timing Chart Editor

window (p.367), or Output Timing Chart window (p.378).

The set pins can be saved to or read from a file (.pin).

Any name (display name) can be specified to a pin.

Opening method

This window can be opened by either of the following procedures.

• Click Pin Set  button on Input 0/1 Editor window

• Click Pin Set  button on Input timing Chart Editor window

• Click Pin Set  button on Output Timing Chart window

• Click Pin Set  button on Data Search window

Window

Figure 6-75.  Pin Setting Dialog Box

Function

The Pin Setting dialog box consists of the following areas.

• Pin number display area

• Pin name setting area

The function of each area is explained below.

(2)  Pin name setting area

(1)  Pin number display area



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 373

(1) Pin number display area

This area displays pin numbers.

When setting more than five pins, click Next  button and update the pin number.  Up to 48 pins can be

set.

(2) Pin name setting area

This area specifies pin names corresponding to the pin numbers.

The pin name is selected from the drop-down list, or input with the keyboard

To finalize a specified pin name, use the  TAB  key, or Previous  or Next  button.

If pin name PXX is specified on the column immediately before, the pin name next to PXX is displayed on the

drop-down list of the next column.  A pin name that has been specified once is not displayed on the drop-

down list.

• Assigning display name to pin

The user can assign any name (display name) to the pin.  The pin to which a display name has been

assigned is displayed on the Pin column of the window that is called from this dialog box.

• Display name setting

If, for example, to make “XXXXXXXX” the display name, after setting the pin name in the pin name setting

area, erase that pin name and input “@XXXXXXXX.” Note that single byte katakana cannot be used for

the display name.

• Display name reference

Even if the display name is set for the pin, the display name is not displayed in the pin name setting area.

Erase the pin name, input “@@” and move the input focus using the  TAB  key, etc.

• Deleting the display name

Erase the pin name in the pin name setting area and input “@.”

Function buttons

Previous Displays setting information of four pins preceding the currently displayed pins.

Next Displays setting information of four pins succeeding to the currently displayed pins.

OK Validates setting and closes the dialog box.  Pin names (or display names) are set to the Pin

column of the window that has called this window.

Save Opens the Save As dialog box (p.463).  Saves the displayed contents to a specified file.  Adds

extension “.pin” to the file and saves it.

Open Opens the Open dialog box (p.461).  Reads the pin setting information from a specified file (.pin).

Clear Initializes the setting contents not saved to a file.  Used to start editing again from the status of the

file saved last.

Cancel Ignores setting and closes the dialog box.
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Down Load Dialog Box

General

This dialog box specifies the file name and type of the file to be downloaded, and downloads the file.

Up to five files whose file names, except the extensions, are the same can be downloaded at the same time if the

CPU is not operating.

The data input to the simulator has the higher priority if it is specified laterNote.

Note If an input data file is downloaded when an external part for input is displayed, input from the input data file

takes precedence.  If an external part for input is displayed while an input data file is downloaded, input

from an external part is enabled.  At this time, an information dialog box is opened to indicate connection

destination is to be changed.

Opening method

This window can be opened by either of the following procedures.

• Select [File] → [DownLoad…] on the menu bar of the 78K/0 Simulator GUI window.

• Select the DownLoad  button on the SFR Event & Action window.

• Select the DownLoad  button on the Input 0/1 Editor window.

• Select the DownLoad  button on the Input timing Chart Editor window.

Window

Figure 6-76.  Down Load Dialog Box

(1)  File name specification area

(2)  File type specification area
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Function

The Down Load dialog box consists of the following areas.

• File name specification area

• File type specification area

The function of each area is explained below.

(1) File name specification area (Down Load)

This area inputs the name of a file to be downloaded.

The file Open dialog box (p.461) is opened by keyboard input or by using the Browse , and a file is

selected from this dialog box.

(2) File type specification area (Down Load File:)

This area specifies the type of the file to be downloaded by using a check box.

Up to five files can be downloaded at the same time.  If two or more files are specified, they are sequentially

downloaded from the top.  If the same pin is used for input in two or more files, input of the file loaded later is

valid.

If no file type is selected, a message box is popped up to indicate that all data previously downloaded will be

cleared, and clicking the OK  button results in the state in which no data has been downloaded.

Function buttons

Browse    Opens the Open dialog box. Selects a file to be downloaded.

OK    Validates setting and downloads a specified file before closing the dialog box.

Cancel    Ignores the setting and closes the dialog box.
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Output Setting Dialog Box

General

This dialog box performs setting for the data in the process of simulation which are output to an output file.

It also selects whether an Output Timing Chart window (p.378) is displayed.

Opening method

This window can be opened by the following procedure.

• Select [File] → [Output] on the menu bar of the 78K/0 Simulator GUI window.

Window

Figure 6-77.  Output Setting Dialog Box

Function

The Output Setting dialog box consists of the following areas.

• File output specification area

• Output timing chart specification area

The function of each area is explained below.

(1)  File output specification area

(2)  Output timing chart specification area
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(1) File output specification area

Select whether or not to save the pin data currently undergoing simulation in a file.

Output to file: Saves the data by checking the check box.

To specify a file name (.out), search and specify a file name by clicking the
Browse  button, or input a file name from the keyboard.

To not save output data to a file, or to stop output to a file in progress, turn OFF the

check.

All the pin information is output to the file (there is no relationship to the following timing chart output).

(2) Output timing chart specification area

Select whether or not to output the pin data currently undergoing simulation in a timing chart.

Enable timing chart: If data is being output in the timing chart format, check the check box.  The data will

be displayed in the data timing chart window.

If not displaying the data in timing chart format, remove the check.

Contents: Set the contents of the timing chart display using the option buttons.

Output only  ...  Saves output pin information.

Input/output  ...  Saves I/O pin information.

Caution

(.out) files can be edited as input data files.  The editing procedure is shown below.

<1> Click the  Read  button in the Input Editor window of either the Input 0/1 Editor window or the Input timing

Chart window, and read the (.out) file.

<2> If a file is only being read, the data is not displayed.  Using the  Pin Set  button in the Input 0/1 Editor

window, set the pin name for the data saved in the (.out) file.  When this is done, the contents will be

displayed.

<3> After editing the data, press the  Save  button and save it as an input data file.   At that time, make the file

identifier .i_2.

Function buttons

Browse Opens the Save As dialog box (p.463).  The specified file is used as the output destination file.

OK Validates setting and closes the dialog box.

If “ Output to file” is selected, the pin information are saved to a specified file.  If “ Enable

timing chart” is selected, the Output Timing Chart window (p.378) is opened, and the specified

contents are displayed.

Cancel Ignores setting and closes the dialog box.
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Output Timing Chart Window

General

This window displays the data output from pins, related input data, and interrupt signals to a timing chart.

This window corresponds to the debugger’s project file.

This window displays the data from all the SFRs in a single window.

Opening method

This window can be opened by either of the following procedures.

<1> Select [File] → [Output] on the menu bar of the 78K/0 Simulator GUI window.

<2> Select “Enable timing chart” in the Output Setting dialog box.

Window

Figure 6-78.  Output Timing Chart Window

(1)  Wait value setting area (2)  Information display area

(3)  Timing chart display area
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Function

This window displays the data output from the program currently simulated, and related input data and interrupt

signals.  It also displays data from all the SFRs on one window.

The Output Timing Chart window consists of the following areas.

• Wait value setting area

• Information display area

• Timing chart display area

The function of each area is explained below.

(1) Wait value setting area

Wait Value: Selects a wait value (data display timing) from the drop-down list.  This value is one

division of Scale.  The unit of wait is 1/4 main clock.

Values in the Drop-down List

16 512↓

32

↓

1024

↓ 64 ↓ 2048

128 4096

↓ 256 ↓ 8192

(2) Information display area

Information:Note Displays the wait values from the first wait value to the last location of simulation and

change points of a pin if the time axis is not displayed.  If the vicinity of the character

string Scale is double-clicked, time axis cursor S and time axis marker E are

displayed in the timing chart display area, and the information display area displays

the following value.

S ... Wait value from the beginning of simulation to the location indicated by S.

E ... Wait value from the beginning of simulation to the location indicated by E.

E-S ... Wait value from the location indicated by S to the location indicated by E.

Note If this display column is double-clicked, “Display Off” (not display) is selected,

and the simulation execution speed increases.  To display this column again,

double-click it again.

Remark Wait values are always displayed in 1/4 main clock (1/4 m-clk) units.

The numeral at the lower right of this column indicates the number of change pointsNote of the pin.  Up to 1350

change points of a pin can be displayed.  If this is exceeded, the latest information is written over the currently

information sequentially starting from the first in the buffer (however, if this is exceeded, the displayed number

of them remains 1350).

If two or more pins change at the same time, it is counted as one change point.

Note Change points are places where the pin data has been changed (H → L, L → H, H/L ↔ Z).
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(3) Timing chart display area Note

This area displays changes in the data of the specified pin on a timing chart.

A scroll bar which can scroll up, down, left and right is provided.

The HIGH and LOW signals are displayed in green.  The high-impedance signal is displayed in red at the

center, and the information in the range not buffered is displayed in blue at the center.

The number of pins to be displayed is 9 as default condition and 48 max.

The window can be re-sized.

Note If this display column is double-clicked, “Display Off” (not display) is selected, and the simulation

execution speed increases.  To display this column again, double-click it again.

Pin: Displays the name of the pin that generates the timing chart and interrupt signal

names.  A pin name is newly created by opening the Pin Setting dialog box

(p.372) by using the Pin Set  button, or by reading the pin setting information

file (.pin) by using the Open  button on this dialog box.

Time axis cursor and

time axis marker: Double clicking near the character Scale causes a solid line and a dotted line to

be displayed.  The solid line is the time axis cursor (S) and the dotted line is the

time axis marker (E).  After the time axis cursor and time axis marker are

displayed, if each is dragged with the mouse, they can be moved.

If the time axis cursor and time axis marker are moved to the left side of the timing

chart display area and are not displayed in the area, S and E are displayed at the

top left of the Scale column.  If they are moved to the right side of the timing chart

display area and not displayed in the area, they are displayed at the top right of

the Scale column.

The time axes can be moved by dragging character S and E.  If a time axis has been moved to the location

without data,  is displayed above S or E.

If INT is specified as a pin name, an interrupt waveformNote is displayed.  If an interrupt occurs, the waveform

turns HIGH.

Note If interrupt INTP0 occurs, for example, “+P0” is displayed for an interrupt waveform.  If the interrupt

has been serviced, “–P0” is displayed.  If two interrupts occur at the same time, “+P0+P1” is displayed.

When two or more interrupts occur, the color of the waveform changes from green to red.

(a) Selecting pin to be buffered

By selecting either All Pins or Selected Pins displayed at reset, the information to be output to the output

buffer during execution can be specified.

With All Pins selected: The information on all the pins existing in the target device is output to

the output buffer (default).

With Selected Pins selected: The information on only the pins displayed on the Pin column of the

Output Timing Chart window (p.378) is output to the output buffer.
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(b) Turning off function buttons and information display area

The double square at the lower left of the window is a toggle switch that is used to change the display of

the object displayed on the Output Timing Chart window.

By using this switch, the Output Timing Chart window can be displayed reduced.

Timing chart setting area and not displayed in the area, they are displayed at the top right of the Scale

column.

Clicking the double square at the bottom left of the window while in the state where the function buttons

and the information display area are displayed causes the display to change to the following.

Clicking once: The function buttons are not displayed.

Clicking twice: The function buttons and information display area are not displayed.

Clicking three times: Both are displayed (the original display is restored).

Function buttons

Pin Set Opens the Pin Setting dialog box.  Sets a specified pin to the Pin column.

Search Opens the Search Window (p.382).  Can search the data in the output data buffer.

Cancel Opens a dialog box that asks you whether it is all right to close this window.  If the OK

button is selected, the window is closed.

Help Displays the Help window that explains the Output Timing Chart window.
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Search Window

General

This window is used to search data in an input data file or output buffer.

Interrupt signals and analog I/O signals cannot be searched.

Opening method

This window can be opened by either of the following procedures.

• Click the Search  button in the Input 0/1 Editor window.

• Click the Search  button in the Input timing Chart Editor window.

• Click the Search  button in the Output Timing Chart window.

Window

Figure 6-79.  Search Window

Function

In this window, data displayed in the Input 0/1 Editor window, the Input timing Chart Editor window, and the Output

Timing Chart window can be searched for.

Setting data which has once been searched for is stored until the simulator is closed, so the information from the

previous time will be displayed if the window is closed, then reopened later.
To set search data newly, click the Clear  button and erase the displayed data.

This window has an area that displays eight pins in five stages by default.  This window can be resized.  However,

two or more instances of this window cannot be opened at the same time.

The Search window consists of the following areas.

• Search data setting table

The function of each area is explained below.

(1)  Search data setting table
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(1) Search data setting table

This area is used to set the pattern of the data to be searched for each pin.

Pin: Specifies the name of a pin whose data is to be searched for.

Either create a new pin name by opening the Pin Setting dialog box (p.372) with the
Pin Set  button, or read the pin setting information file (.pin) by using the Open

button on the above dialog box.  If a display name has been set for the pin, the display

name is displayed.

1 (HIGH), Z (high impedance), 0 (LOW), and − (don’t care) can be assigned to the search data setting table.

Analog input pins, analog output pins, and interrupt signals cannot be searched for.

(a) Searching data

<1> Set the data to be searched.

If a pin name is assigned in the Pin column, ‘EOF’ is set in the data setting table.  By clicking on this

‘EOF’, one line of data to be searched for can be inserted.  At this time, the status of the pin on the line

immediately before changed (in the order 1→ Z → – → 0) when the column is clicked.  In the other

columns, data of the same status as that on the lines immediately before is set.

The data to be searched for can be changed in the order of 1, Z, 0, and – by clicking the mouse

button.

<2> Start search.

• On Input timing Chart Editor window, Output Timing Chart window

Searching is started by clicking the B Search  or F Search  button.

Then the location that matches with the search data is displayed in red.
At this time, the time axis can be set at this location by clicking the  S Mark Set  or  E Mark Set

button.

To search data in the same direction after a match has been found once, the search can be

executed again from the location of the match, unless the data to be searched has been changed

or the display has been scrolled.

• On Input 0/1 Editor window

Searching is started by clicking the U Search  or D Search  button.

The places in which the search data has been found are displayed at the top.

The red line is not displayed.
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Function buttons

B Search Searches for data that matches specified data from the end of the currently displayed part toward

the beginning.

If you are searching in the Input 0/1 Editor Window, this button changes to U Search

F Search Searches for data that matches specified data from the beginning of the currently displayed part

toward the end.

If you are searching in the Input 0/1 Editor Window, this button changes to D Search

Pin Set Opens the Pin Setting dialog box.

Specified pins are set on the Pin column.

Clear Clears all the set contents.

S Mark Set This button can be selected if a location at which data matching the specified data has been found

as a result of searching.

When this button is selected, the time axis cursor S moves to the location of the match (valid only

during search on the Input timing Chart Editor window and Output Timing Chart window).

E Mark Set This button can be selected if a location at which data matching the specified data has been found

as a result of searching.

When this button is selected, the time axis cursor E moves to the location of the match (valid only

during search on the Input timing Chart Editor window and Output Timing Chart window).

Help Displays the Help window that explains the Search window.

Cancel Closes this dialog box.
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Parts Window

General

This window is used to organize a pseudo-target system.  Displays external parts.

Opening method

This window can be opened by either of the following procedures.

• Select [External Parts] → [Panel Window…] on the menu bar of the 78K/0 Simulator GUI window.

Window

Figure 6-80.  Parts Window

Function

The Parts window organizes a pseudo-target system by setting external parts.

The set external parts are displayed on this window, and serve as the inlet for signals during simulation in the

execution mode.

Button Key matrix LED Level gauge

7 seg LED DC motor Buzzer Reset button 14 seg LED Internal interrupt button
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The name of this window changes depending on the parts displayed.

• LCD Panel window: Custom display for the internal LCD

(When Customize is selected in the LCDs window opened by selecting [Parts] → [built in

LCD].)

• FIP Panel window: Custom display for the internal FIP

(When Customize is selected in the FIPs window opened by selecting [Parts] → [built in

FIP].)

• Parts window: Displaying other parts.

For details of the LCD Panel window and FIP Panel window, refer to LCD Panel window (p.407) and FIP Panel

window (p.422).

These parts can be moved inside the window in edit mode.

The information on the parts located in the window can be saved to a file (.pnl).  The contents saved to the file can

also be read.

The function of each area is explained below.

(1) Tool bar

Select this tool bar to open the setting window (except the serial GUI window) for each external part.  The

same operation can be also performed by selecting [Parts] menu.

Selection of whether to display the tool bar or not can be made in the [Option]→[Tool Bar] menu.

Opens the Buttons window (p.398).

Opens the Key Matrixes window (p.401).

Opens the LCDs window (p.404).

Opens the FIPs window (p.419).

Opens the LEDs window (p.434).

Opens the 7seg LEDs window (p.437).

Opens the Level Gauges window (p.440).

Opens the DC Motors window (p.443).

Opens the Buzzers window (p.446).
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Displays the reset buttons in window.

Opens the 14seg LEDs window (p.448).

Opens the Internal Interrupt Button window (p.451).

Opens the Pull-Up/Pull-Down window (p.453).

Opens the PLL Information window.

Arbitrary character strings can be described.

This cannot be selected when the Parts window is active.

Straight lines of arbitrary length can be drawn.

This cannot be selected when the Parts window is active.

Rectangles of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

Ellipses of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

Pies of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

Polygons of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

(2) External parts input operation

When the Parts window is in the simulation mode, an input operation from external parts is possible.  For

details, refer to the setting dialog box page for each part.

(3) Displaying external parts

The external parts set on the setting dialog of each external part are displayed on the Parts window according

to the following rules.

(a) If parts overlap in the display, the part displayed first is displayed in front.  Therefore, a newly created

part may be hidden below the part displayed first.  In this case, move the part in front.

(b) If overlapping parts are saved to the information file (.pnl) or project file (.prj) in the Parts window, and

then information is read from the file and the parts are displayed, the parts are displayed in the order:

buttons > key matrixes > LEDs > 7 seg LEDs > level gauges > DC motors > buzzers > reset buttons > 14

seg LEDs > internal interrupt buttons > LCD/FIP Panel window.
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(4) Scroll bar

If all the parts no longer fit in the Parts window as a result of connecting a large number of parts, a scroll bar

is displayed.  This scroll bar is used to create a system bigger than the screen in size. Also by reducing the

screen it can be used to display only the desired part.

Note that the scroll bar can be operated in any mode.

(5) Editing Parts window

Editing in the Parts window described below is carried out with all the windows set in the edit mode.  When in

the layout mode, the following window showing the mouse position in the coordinate system is displayed.

(a) Moving external parts, characters, lines, and rectangles

<1> Click the part (external partNote, character, line, or rectangle) to be moved.

→ The selected external part is indicated by a blue dotted frame.  The color of the character, line, or

rectangle changes from black to blue.

Note Movement in units of connected pins.  The 7 seg LEDs and 14 seg LEDs are moved as a

single part.

<2> Move (drag) the selected part with the left mouse button held down to the destination, and release the

mouse button.

→ The selected part moves to the specified position.

To move two or more parts at the same time, click the second part or those that follow while holding down the

 SHIFT  key, and drag and drop the part while holding down the  SHIFT  key.  The maximum number of parts

that can be selected at the same time is 16.

(b) Deleting external parts, characters, lines, and rectangles

<1> Click the part to be deleted (external partNote, character, line, or rectangle).

→ The selected external part is indicated by a blue dotted frame.  The color of the character, line, or

rectangle changes from black to blue.

Note This deletes the connected pin units.  The 7 seg LEDs and 14 seg LEDs are deleted as a

single part.

<2> Select [Edit] → [Delete] from the menu bar.

→ The selected part is deleted.

To delete two or more parts at the same time, click the second part or those that follow to be deleted

while holding down the  SHIFT  key, and perform <2>.
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(c) Restoring changed contents

If any change has been made on the Parts window, the status before change can be restored.

To do this, select [Edit] → [Undo] from the menu bar.  Retroactive restoration cannot be executed.

(d) Inputting characters

<1> Select [Edit] → [TeXt] from the menu bar.

→ A dialog box requesting to input characters will be opened.

<2> Click the location to which characters are to be input in the Parts window.

→ The clicked location will be marked.

<3> Move the cursor to the window of character input, then input character strings from the keyboard.  The

number of characters that can be input at one time is 20.

<4> Click the OK  button.

→ The character strings will be written to the location specified in <2>.

The total number of character strings that can be written in a window is up to 20.

(e) Inputting lines

<1> Select [Edit] → [Line] from the menu bar, and select the line type from the cascade menu.

<2> Specify the start position of the line by clicking the left mouse button.

<3> Move the mouse.  The orbit will be drawn as a straight line.

<4> Specify the end position of the line by clicking the left mouse button.

→ A straight line will be drawn between the start position and end position (the thickness of the line is

fixed).

The total number of lines that can be drawn in the window is 20.
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(f) Inputting rectangles

<1> Select [Edit] → [Rectangle] from the menu bar, and select the line type from the cascade menu.

<2> Specify the position of the upper left corner of the rectangle by clicking the left mouse button.

<3> Move the mouse.  The current position of the mouse will be assumed to be the lower right corner of

the rectangle, and a rectangle will be displayed.

<4> Specify the lower right corner of the rectangle by clicking the left mouse button.

→ A rectangle will be drawn between the specified upper left corner and lower right corner (the

thickness of the line is fixed).

The total number of rectangles that can be drawn in the window is 20.

(g) Changing bitmap

The bitmap of an external part (only button and DC motor) can be changed to an other bitmapNote that has

been already registered.

Note For how to register a bitmap file, refer to Bitmap Entry window (p.457).  Furthermore, the Bitmap

Box window shown below and the Bitmap Entry window cannot be operated at the same time.

<1> Select [Edit] → [Bitmap] from the menu bar.

→ The Bitmap Box window will be opened.

<2> Select the bitmap to be changed from the opened bitmap window by clicking the mouse button.

→ The selected bitmap will be displayed in reverse video.

<3> Click the external part to be changed on the Parts window.

→ The external part on the Parts window will be changed to the bitmap selected in <2>.

The function name of a button is not displayed if the button is changed to an other bitmap.
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(h) Stopping editing

To move, delete, or restore a part after inputting a character, line, or rectangle, or after changing the

bitmap, select [Edit] → [Suspend] from the menu bar.  A check mark will appear on the left of Suspend on

the pull-down menu, and the part being edited can be moved, deleted, or restored.

The check mark also appears immediately after the mode has been changed to the edit mode.

(i) Other operations

When inputting a character, line, or rectangle, or changing the bitmap is selected, the currently selected

edit function is assumed until another input is selected, the bitmap is changed, or the editing operation is

stopped.

Menu bar

Whether the menu bar is displayed or not can be specified by selecting [Menu Valid] in the control menu box of this

window.

(1) File

Selected to save the information to a file (.pnl) or open for reading information from the file of the Parts window.

[Open…] Opens the file Open dialog box (p.461).  Reads a specified file information (.pnl) of the Parts

window.

[Save] Overwrites and saves the current information in the Parts window to the currently read file

(.pnl).

[Save As…] Opens the Save As dialog box (p.463).  Saves the information in the Parts window to a

specified file (.pnl).

[eXit…] Closes this window.
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(2) Mode

In the case of the Parts window, specified to set the window in the mode for simulation execution (simulation

mode) or a mode in which connection between external parts and pins or the external parts can be relocated

(edit mode).

In the case of the LCD Panel or FIP Panel window, this menu can be used to move, group, or modify the size

of graphics (edit mode), draw graphics (draw mode), or connect pins to the customized FIP or LCD graphics

(set mode).  Also, by selecting [Simulation], the window is changed to the Parts window at the moment the

simulation mode is set.

[Edit] Displays a dialog box that indicates the mouse cursor position (x coordinate and y

coordinate), and sets the window in the edit mode.  The parts pasted in the window can be

moved and edited.  [Edit] can be selected.

[Simulation] Sets the window in the simulation mode in which the parts can be simulated (default).

[Draw] Cannot be selected.

[seT] Cannot be selected.

(3) Edit

This menu can be used to move or edit the external parts displayed in the Parts window, so that the user can

create the image of the system at will.

This mode can be selected only in the edit mode.

[Undo] Restores changes in the window, such as movement of parts, to the status immediately

before.

[Delete] If a part is selected with the mouse and this item is selected, the selected part is

deleted.
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[cuT] Cannot be selected.

[Copy] Cannot be selected.

[Paste] Cannot be selected.

[Import from File…] Cannot be selected.

[TeXt] Displays a dialog box to type characters.

Type characters, click the position in the window to which the characters are to be
input, and click the OK  button.  The characters will be input (placed) to the

specified position.

[Line] Selected to draw a straight line in the window.

[Solid] Draws a solid line.

[Dash] Draws a dashed line.

[dOt] Draws a dotted line.

[dAshdot] Draws an alternate long and short dashed line.

[Rectangle] Used to draw a rectangle in the window.

Select one of the items shown below from the Cascade menu.

[Solid] Draws a solid line.

[Dash] Draws a dashed line.

[dOt] Draws a dotted line.

[dAshdot] Draws an alternate long and short dashed line.

[Bitmap] Selected to change the bitmap of the part displayed in the window (button or DC motor).

After selecting a bitmap from the displayed bitmap window (the selected bitmap is

displayed in reverse video), click the part whose bitmap is to be changed.

[Suspend] Selected to suspend editing operation such as input, and to restore the movements,

deletion, and changes of parts.
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(4) Parts

This item is selected to set connection relation among the external parts supplied.  When specification is

completed, the corresponding parts will be displayed in the window, and trigger signal input/output during

simulation.

When the cascade menu is selected, the setting window is displayed, and the connection relation between a

pin and external part can be set.

[Button...] Opens the Buttons window (p.398).  Performs the same operation as  .

[Key Matrix...] Opens the Key Matrixes window (p.401).  Performs the same operation as  .

[built in LCD...] Cannot be selected.  This can be selected only for devices with an LCD.

[built in FIP...] Cannot be selected.  This can be selected only with devices with an FIP.

[LED...] Opens the LEDs window (p.434).  Performs the same operation as  .

[7Seg LED...] Opens the 7seg LEDs window (p.437).  Performs the same operation as  .

[Level Gauge...] Opens the Level Gauges window (p.440).  Performs the same operation as .

This can be selected only with a device with an on-chip A/D converter.

[DC Motor...] Opens the DC Motors window (p.443).  Performs the same operation as  .

[BuZzer...] Opens Buzzers window (p.446).  Performs the same operation as  .

[Reset] Displays the reset button in a window.

If the Reset button is clicked during simulation, the reset signal is input to the

Simulator.

Only the CPU status can be initialized with this button; the status of the parts in the

Parts remain unchanged.

Performs the same operation as .
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[14Seg LED...] Opens the 14seg LEDs window (p.448).  Performs the same operation as  .

[Internal Interrupt...] Opens the Internal Interrupt Button window (p.451).  Performs the same operation as

 .

[Pull Up/Pull DoWn...] Opens the Pull-Up/Pull-Down window (p.453).  Performs the same operation as

 button.

[PLL...] Cannot be selected.

[Serial GUI...] By selecting the cascade menu, the Serial GUI window (p.455) of the corresponding

channel is opened (the cascade menu differs depending on the device).

(5) Bitmap

[Bitmap EN try] Opens the Bitmap Entry window (p.457).

(6) Customize

Selected to load a file (.dll) necessary for using the external parts created by the user Note.

Note If the Parts window is closed with the user DLL information saved to the project file or loaded, the

positions of the user’s custom parts displayed on the Parts window are not restored to the positions at

which the information was saved even if the user DLL is read by loading or opening the project file.

[Load] Opens the file Open dialog box (p.461) and reads a specified DLL file.  Up to 6 files

can be read.

[Unload] Invalidates the user DLL file currently loaded.

(7) Draw

Cannot be selected.
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(8) Option

[Tool Bar] Specifies whether the tool bar is displayed or not.

Displays the tool bar if the check mark is displayed (default).

[Group] Cannot be selected.

[Ungroup] Cannot be selected.

[Pen...] Cannot be selected.

[Brush...] Cannot be selected.

[Font...] Cannot be selected.

[Raise] Cannot be selected.

[Lower] Cannot be selected.

(9) Help

[Help Topics] Displays the table of contents of the Help window.

[This Window] Displays the Help window.
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Caution

The operation of the external parts when back execution occurs is shown below.

External Part Operation When CPU Is Reset

Buttons Enters the pressed/released state at the point where the pin value is changed.

Keys Enters the pressed/released state at the point where the pin value is changed.  In this

case, the wait state is not entered.  The locked-state key turns green.

LCD, FIP, LED The display state changes at the point where the pin value is changed.

7/14-segment LEDs The display state changes at the point where the pin value is changed.

Level gauge The input value is calculated based on the value of the pin.  The scroll sum of the scroll

bar and the operation point of the dial are moved in accordance with the input value.

DC motors The total number of clocks is reduced and the state of the DC motor changes at the point

where the pin value is changed.

Internal interrupt buttons No change.

PLL The display state changes with the change of the state of the PLL function.

Serial GUI The display state changes with the change of the state of the serial function.

The operation of the external parts when the CPU is reset is shown below.

External Part Operation When CPU Is Reset

Buttons All the buttons enter the inactive state.

Keys All the keys enter the not-pressed state.

LCD, FIP All enter the white display state when Bit Image is selected, and all enter the no-display

state when Customize is selected.

LED All the LEDs enter the inactive state.

7/14-segment LEDs All enter the white display state.

Level gauge The input value becomes 0, the scroll bar’s scroll sum moves to the left end and the dial’s

operation point moves to the bottom left position.

DC motors All the DC motors enter the inactive state and the total number of clocks becomes 0.

Internal interrupt buttons All the internal interrupt buttons enter the inactive state.

PLL Initialized to the default status except for the setting information that was input.

Serial GUI The serial GUI returns to the initialization state.
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Buttons Window

General

This window sets or displays the connection information on the buttons displayed on the Parts window (p.385).

Data can be input from the displayed buttons to the simulator.

The connection information can be saved to a file (.btm).  The saved information can be read.

Opening method

This window can be opened by either of the following procedures.

<1> Select [External Parts] → [Panel Window…] on the menu bar of the 78K/0 Simulator GUI window.

<2> Click  button, or select [Parts] → [Button] on the menu bar of the Parts window.

Window

Figure 6-81.  Button Window

Function

The Buttons window consists of the following areas.

• Button ID display area

• Connection information setting area

• Hold time setting area

The function of each area is explained below.

(2)  Connection information setting area(1)  Button ID display area

(3)  Hold time setting area
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(1) Button ID display area

This area displays the ID numbers assigned to the set buttons.

When setting more than five buttons, click Next  button to clear the setting information and the ID

number is updated.

Up to 32 ID numbers can be set.

(2) Connection information setting area

This area sets or displays the connection information on the buttons and pins.

Set the respective areas.

T/P: This check box specifies whether the buttons are used as toggle switches or pushbutton

switches.  When this check box is checked, the buttons are used as toggle switches.  If not,

push function is specified and the hold time should be set.

BMP ID: Specifies the register number of the bitmap to be displayed on the Parts window by a

numeric character.

If the ID number doesn’t exist, or no ID number is specified, the default is the bitmap (button)

of registration number 3 (Bitmap Entry window (p.457)).

Name: Specifies a character string to be displayed on a button. Up to six characters can be input.

Pin: Specifies any pin name to connect to the buttonNote.  Up to eight characters can be input.

Note For the pin names that can be specified, refer to the User’s Manual of the device

used.

Active: Specifies the active status of the set button by using an option button.  The default is active

high (H).

(3) Hold time setting area

This area sets the hold time of the button specified as a pushbutton switch.

The setting range is 0.001 ms to 999 ms, and the default value is 0.5 ms.

Caution

(1) When setting a button, carry out operation in the following order:

<1> Set pull-up or pull-down (refer to “Pull-Up/Pull-Down window (p.453)”)

<2> Set button.

If the button was set previously, open the Buttons window again after setting Pull Up/Pull Down, then click the
OK  button.

When the button is active, the value specified by the [Active] Option button in the connection information area

is input to the input pin connected to the button.

When the button is inactive, the value becomes the value specified in the Pull-Up/Pull-Down window.

If the Pull Up/Pull Down setting is not performed, processing in the simulator is carried out with the value

when the key is not pressed taken as 0.
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(2) Button

By clicking a button, data can be input to the pin corresponding to the button.

               
When inactive    When active

When setting a button, it can be specified whether the button functions as a toggle switch or pushbutton

switch.

(a) Toggle switch function

When a button is used as a toggle switch, information displayed on the screen when the button is clicked

is input to the simulator.  Simulation is executed with the input information retained, until the button is

clicked again.

(b) Pushbutton switch function

When a button is used as a pushbutton switch, information displayed on the screen when the button is

clicked is input to the simulator.  Simulation is executed with the input information retained for specific

time.  When the specific time has elapsed, the original information is restored.

Function buttons

Previous Displays the set contents of the four ID numbers preceding the currently displayed ID number.

Next Displays the set contents of the four ID numbers following the currently displayed ID number.

OK Checks the error of the set connection information.

If an error occurs, an error or warning message is displayed in the dialog box.  If no error occurs,

transfers control to the Parts window, and displays the set external parts.

Open Opens the file Open dialog box (p.461).  Reads the connection information from the previously

saved file (.btm).

Save Opens the Save As dialog box (p.463).  Saves the displayed connection information to a file (.btm).

Clear Erases the set contents.

Cancel Ignores the setting and closes the window.

Help Displays the Help window that explains the Buttons window.
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Key Matrixes Window

General

This window sets or changes the connection information on the button displayed on the Parts window (p.385).

Data can be input from the displayed button to the simulator. A key matrix, consisting of input and output pins, can

be set in 4 × 4 units, up to 16 × 16.

The connection information can be saved to a file (.key).  The information saved to the file can be read.

Opening method

This window can be opened by either of the following procedure.

<1> Select [External Parts] → [Panel Window…] on the menu bar of the 78K/0 Simulator GUI window.
<2> Click  button, or select [Parts] → [Key Matrixes] on the menu bar of the Parts window.

Window

Figure 6-82.  Key Matrixes Window

Function

The Key Matrixes window consists of the following areas.

• I/O pin setting area

• Key name setting area

• Hold time setting area

• Continuous setting area

• Setting position display area

The function of each area is explained below.

(4)  Continuous setting area (3)  Hold time setting area

(1)  I/O pin setting area (2)  Key name setting area (5)  Setting position display area
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(1) I/O pin setting area

This area specifies the input pin names (pins input to the simulator) and output pin names (pins output by the

simulator) constituting a key matrixNote.

Up to eight characters can be input.

Setting number Ix or Ox (x is a number) is assigned to each setting area (default).

Note For the pin names that can be specified, refer to the User’s Manual of the device used.

(2) Key name setting area

This area specifies a character string displayed on a key when a key matrix is displayed on the Parts window.

Up to five characters can be input.

Setting number Nx (x is a number) is assigned to each setting area (default).

(3) Hold time setting area

This area specifies the time during which the input value is held.  The time range that can be specified is

0.001 to 999 ms, and the default value is 0.5 ms.

If two or more keys that input data to the same input pin in the specified hold time are clicked, the key clicked

last becomes valid.

(4) Continuous setting area

This area is used to continuously set pins or key names.

Select a default setting number (Ix, Ox, Nx) assigned to each setting area from the pull-down menu, and input

the corresponding pin name or key name to the text area shown on the right followed by the return key.  The

selected setting number and pin or key name will be reflected on the bottom setting area.

(5) Setting position display area

This area indicates in white the position of the key matrix currently displayed in the setting area of the 16 × 16

key matrix.

The setting position can be moved by using the following four buttons.

Up Displays the setting contents with the pins set in the input mode shifted four positions up without

changing the pins set in the output mode.

Down Displays the setting contents with the pins set in the input mode shifted four positions down without

changing the pins set in the output mode.

Right Displays the setting contents with the pins set in the input mode shifted four positions to the right

without changing the pins set in the output mode.

Left Displays the setting contents with the pins set in the input mode shifted four positions to the left

without changing the pins set in the output mode.
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Caution

(1) When setting a key matrix, carry out operation in the following order:

<1> Set pull-up or pull-down (refer to “Pull-Up/Pull-Down window (p.453)”)

<2> Set button.

If the key matrix setting is done in advance, open the Key Matrixes window again after setting Pull Up/Pull
Down, then click the OK  button.

When a key is pressed, the output value of the output pin connected to that key is input to the input pin

connected to that key.

The value when a key is not pressed becomes the value specified in the Pull-Up/Pull-Down window.  If the

Pull Up/Pull Down setting is not performed, processing in the Simulator is carried out with the value when the

key is not pressed taken as 0.

(2) To input two or more keys at the same time

Click one of the two keys to be input at the same time with the right mouse button to set it in the wait status

(indicated in red).  By clicking the other keys with the left mouse button, the preceding wait status is released,

and both the keys can be input at the same time.  By setting two or more keys in the wait status, two or more

keys can be input at the same time.  If input is to be made to the same input pin, the later key input is valid.

(3) To lock input value of key

The input value of a key is locked (indicated in green) if the left mouse button is clicked while the right button

is held down.  If a key is clicked in the lock status that makes input to the same input pin corresponding to the

locked key, the input value of the key input later is valid.  If specific time has elapsed, however, input is made

by the key in the locked status again.

If the left button of the mouse is clicked when the cursor pointed at a key in the locked state, the lock state is

canceled.  If the right button of the mouse is clicked, it enters the hold state (displayed in red).

(4) When a key matrix already exists

When a key matrix already exists, if a key matrix with a larger number of keys than the existing matrix is set,

the previous key matrix will be deleted, and the new key matrix will be displayed below all the parts.

Function buttons

OK Checks errors of the set connection information.  If an error occurs, an error message or warning

message is displayed in the dialog box.  If no error occurs, control is passed to the Parts window

and the external parts set are displayed.

Open Opens the file Open dialog box (p.461). Reads the connection information from a previously saved

file (.key).

Save Opens the Save As dialog box (p.463). Saves the displayed connection information to a file (.key).

Clear Deletes the setting contents.

Cancel Ignores the setting and closes the window.

Help Displays the Help window that explains the Key Matrixes window.
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LCDs Window Modal

General

This window makes settings related to the LCD.

Either the LCD Display window or the LCD Panel window can be displayed by selecting the appropriate LCD

display image (Bit Image/Customize).

The setting information can be saved to a file (.sld), and information saved to a file can be read.

Opening method

This window can be opened by the following procedure.

<1> Select [External Parts] → [Panel Window…] on the menu bar of the 78K/0 Simulator GUI window.

<2> Select [Parts] → [built in LCD...] on the menu bar of the Parts window.

Window

Figure 6-83.  LCDs Window

Function

The LCDs window consists of the following areas.

• LCD display image selection area

• Bias method selection area

• Time division count selection area

• Display segment number setting area

The function of each area is explained below.

(1)

(2)

(3)

(4)
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(1) LCD display image selection area

This area selects the LCD display image.

Bit Image: Displays a bit image.

Select Bit Image and click the  button.  The LCD Display window is then

opened displaying a bit image of the common and segment signal matrix.

Customize: Customized display.

Select Customize and click the  button.  The LCD Panel window is then

opened.

(2) Bias method selection area

This area selects the bias method.  Setting this allows the displayed image to be changed.

The default is “-“ (hyphen), which fixes the displayed image.

(3) Time division count selection area

This area selects the number of time divisions.  Setting this allows the display timing of the common signals

to be changed.

The default is “static”.

(4) Display segment number setting area

This area sets the range of the segment numbers that are to be displayed.  Setting this allows display of only

the desired segments.  Either of the text boxes can be used to specify the number of the segment from which

display will start.
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Function buttons

Displays the LCD Display window as a bit image of the common and segment signal matrix when

Bit Image is selected in the LCD display image area.

Opens the LCD Panel window when Customize is selected in the display area.

Opens the Open dialog box (p.461).

Reads the connection information from a previously saved file (.sld).

Opens the Save As dialog box (p.463).

Saves the displayed connection information to a file (.sld).

Deletes the setting contents.

Ignores the setting and closes the window.

Displays the Help window that explains the LCDs window.
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LCD Panel Window

General

This window displays the output of the pins connected to the device’s internal LCD controller/driver as bit and

graphic images.

Opening method

This window can be opened by the following procedure.

<1> Select [Parts] → [built in LCD...] on the menu bar of the Parts window.

<2> Select Customize under Disp in the LCDs window.

Window

Figure 6-84.  LCD Panel Window

Test mode

Customized LCD display image
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Function

The LCD Panel window creates and edits LCD images.

During simulation, return to the Parts window by selecting [Mode] → [Simulation] on the menu bar.

The functions of the LCD Panel window are explained below.

(1) Tool bar

Whether the tool bar is displayed or not can be specified by selecting [Option] → [Tool Bar] on the menu bar.

Arbitrary character strings can be described.

This cannot be selected when the Parts window is active.

Straight lines of arbitrary length can be drawn.

This cannot be selected when the Parts window is active.

Rectangles of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

Ellipses of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

Pies of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

Polygons of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

(2) Editing in LCD Panel window

All of the following LCD Panel window editing procedures are performed in the edit mode.

(a) Moving graphics

<1> Click the graphic to be moved.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Drag the selected graphic to the desired position.

→ The selected graphic is moved to the specified position.
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(b) Cutting, copying and deleting graphics

<1> Click the graphic to be cut, copied, or deleted.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [cuT], [Delete], or [Copy] from the [Edit] menu.

→ The selected part will be cut, copied, or deleted.

Alternatively, if there is more than one part to be edited, click the relevant parts while holding down the

 SHIFT  key, and then cut, copy, or delete using procedure <2> above.

(c) Pasting graphics

<1> Select either the Windows paintbrush, or [cuT]/[Copy] from the [Edit] menu.

→ The selected graphic is copied to the clipboard.

<2> Select [Paste] from the [Edit] menu.

→ The data on the clipboard is pasted to the lower right of the cut or copied graphic.

(d) Importing graphic from file

<1> Create a bitmap file using the image editor (etc.).

<2> Select [Import from File...] from the [Edit] menu.

→ The Open dialog box (p.461) is opened.

<3> Select the bitmap file to be imported from the dialog box.

→ The bitmap image of the selected bitmap file is pasted to the upper left corner of the LCD Panel

window.

(e) Changing graphic size

<1> Click the graphic whose size is to be changed.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Click the mouse on a mark and drag the graphic until the desired size is reached.

→ The graphic is enlarged/reduced.

(f) Character insertion

<1> Select [Text] from the [Draw] menu.

→ A dialog box for inputting characters opens when the mouse is clicked at the desired display

position.

<2> Type the character string to be displayed in this dialog box and click anywhere outside the text box

in the LCD Panel window.
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(g) Drawing 7/14 segments

<1> Select [7Segment] or [14seGment] from the [Draw] menu.

<2> Click the mouse at the desired display position in the LCD Panel window.

→ The selected segment image is displayed at the position where the mouse was clicked.

(h) Drawing lines

<1> Select [Line] from the [Draw] menu.

<2> Click the mouse where the line is to start.

<3> Move the mouse.  A straight line appears where the mouse is moved.

<4> Click the mouse button where the line is to end.

→ The start and end points are connected by a straight line.

(i) Drawing rectangles, circles, and pies

<1> Select [Rectangle], [Ellipse], or [Pie] from the [Draw] menu.

<2> Click the mouse where the rectangle, circle, or pie is to be drawn and hold the button down on a

vertex.

<3> Drag the mouse.  A rectangle appears from the vertex from which the mouse is dragged.

<4> Release the mouse button when the rectangle has reached the desired size.  In the case of circles

or pies, these will be drawn inside this rectangle.

(j) Drawing polygons

<1> Select [POlygon] from the [Draw] menu.

<2> Click the mouse where the polygon is to be drawn and set a vertex.

<3> Move (or drag) the mouse to the next vertex.  A line (curve) appears from the vertex from which the

mouse is moved (dragged).

<4> Click the mouse after arriving back at the original vertex.  A polygon will be drawn with the lines

connected in the order clicked.
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(k) Grouping

<1> Click the graphics to be grouped (to select two or more graphics, click the relevant graphics while

holding down the  SHIFT  key).

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [Group] from the [Option] menu.

→ The selected graphics become one, and marks appear at the vertices and midpoints of the box

around the grouped graphics.

(l) Ungrouping

<1> Click the graphic to be ungrouped.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [Ungroup] from the [Option] menu.

→ The selected graphic returns to its pregrouped state, and marks appear at the vertices and

midpoints of the boxes around each graphic.

(m) Raising

<1> Click the graphic to be displayed in front of the cascaded graphics.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [Raise] from the [Option] menu.

→ The selected graphic is displayed in the front.  The order of the other cascaded graphics does

not change.

(n) Lowering

<1> Click the graphic to be displayed at the back of  the cascaded graphics.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [Lower] from the [Option] menu.

→ The selected graphic is displayed at the back.  The order of the other cascaded graphics does

not change.
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Menu bar

Whether the menu bar is displayed or not can be specified by selecting [Menu View] in the control menu box in this

window.

(1) File

Select File to save LCD Panel window data to a file (.lcd) or open a file for reading data.

[Open…]  Opens the Open dialog box (p.461).  Reads LCD Panel window data from the

specified file (.lcd).

[Save]  Overwrites and saves the current data in the LCD Panel window to the file

currently open (.lcd).

[Save As…]  Opens the Save As dialog box (p.463).  Saves the current LCD Panel window

data to a specified file (.lcd).

[eXit…]  Closes this window (Parts window).

(2) Mode

In the case of the LCD Panel window, this menu can be used to move, group, or modify the size of graphics

(edit mode), to draw graphics (draw mode), or to connect pins to the customized LCD graphics (set mode).

Also, by selecting [Simulation], the window is changed to the Parts window at the moment the simulation

mode is set.

[Edit]  Displays a dialog box that indicates the mouse cursor position (x and y

coordinates), and sets the window in the edit mode, in which the graphics pasted

in the window can be moved and edited using the [Edit] menu.

[Simulation]  Sets the window in the simulation mode in which the parts can be simulated

(default).

[Draw]  Sets the window in the draw mode, in which LCD display image graphics can be

drawn using the [Draw] menu.

[seT]  Sets the window in the set mode, in which the display timing and display segment

connections can be set for the LCD display image graphics.

If this mode is selected, the [Edit], [Draw], and [Option] menus become

unselectable.
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(3) Edit

This menu can be used to move or edit the graphics displayed in the LCD Panel window, so that the user can

freely create an image of the system.

This menu can be selected only in the edit mode.

[Undo]  Restores changes in the window, such as movement of graphics or character

strings, to the status immediately before.

[Delete] If a graphic or character string is selected with the mouse and [Delete] is clicked,

the selected graphic or character string is deleted.

[cuT]  If a graphic or character string is selected with the mouse and [cuT] is clicked, the

selected graphic or character string is deleted and copied to the clipboard.

[Copy]  If a graphic or character string is selected with the mouse and [Copy] is clicked,

the selected graphic or character string is copied to the clipboard.

[Paste]  The data copied to the clipboard is pasted to the upper left corner of the LCD

Panel window.

[Import from File…] Opens the Open dialog box (p.461). Pastes the specified bitmap file (.bmp) to the

upper left corner of the LCD Panel window.

[TeXt]  Cannot be selected.

[Line]  Cannot be selected.

[Rectangle]  Cannot be selected.

[Bitmap]  Cannot be selected.

[Suspend]  Cannot be selected.

(4) Parts

Refer to the description of the [Parts] menu in the Parts window (p.463) for an explanation of this menu.

(5) Bitmap

Cannot be selected.
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(6) Customize

Cannot be selected.

(7) Draw

This menu can be used to draw LCD display image graphics in the LCD Panel window.

This menu can be selected only in the draw mode.

[Text]  Arbitrary character strings of up to 40 characters per string can be described.

This has the same function as clicking the  button.

[7Segment]  Displays a 7-segment numerical LED.  Each of these segments becomes an LCD

display segment.

[14seGment]  Displays a 14-segment alphanumerical LED.  Each of these segments becomes

an LCD display segment.

[Line]  Straight lines of arbitrary length can be drawn.

This has the same function as clicking the  button.

[Rectangle]  Rectangles of arbitrary size can be drawn.

This has the same function as clicking the  button.

[Ellipse]  Circles of arbitrary size can be drawn.

This has the same function as clicking the  button.

[Pie]  Pies of arbitrary size can be drawn.

This has the same function as clicking the  button.

[POlygon]  Polygons of arbitrary size can be drawn.

This has the same function as clicking the  button.

[EDit] Drawn graphics can be selected.  This function can be selected when graphic

drawing is aborted in the draw mode.
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(8) Option

[Tool Bar]  Specifies whether the tool bar is displayed or not.  Displays the tool bar if the

check mark is displayed (default).

[Group]  Several LCD graphics can be edited as a single graphic (grouping).  This function

is not available for 7- and 14-segment LEDs.

[Ungroup]  Returns grouped graphics to their original state.

[Pen...]  Changes the status of the line being drawn or the graphic currently selected.  The

color, width, and type of the line can be specified in the opened dialog box.

[Brush...]  Changes the brush of the graphic being drawn or the graphic currently selected.

The style, color, and size of the brush can be specified in the opened dialog box.

[Font...]  Changes the font of the character string being typed or the character string

currently selected.  The font and font size can be specified in the opened dialog

box.

[Raise]  Places the selected graphic in the front of the cascaded graphics.

[Lower]  Places the selected graphic at the back of the cascaded graphics.

(9) Help

Refer to the description of the [Help] menu in the Parts window (p.385) for an explanation of this menu.
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Set LCD Pin Dialog Box

General

This dialog box connects the bitmaps and graphics in the LCD Panel window to the LCD output pins.

If LCD output pin signals are already connected to the selected graphic, this connection information will be

displayed in the dialog box, enabling the user to check the graphic/signal connections.  Note that the active status of

each signal is active high.

Opening method

This dialog box can be opened by the following procedure.

<1> Select [Mode] → [seT] from the menu bar in the LCD Panel window.

<2> Click the graphic or bitmap to be connected.

Window

Figure 6-85.  Set LCD Pin Dialog Box

When selected graphic is other than 7-or 14-segment LED

Function

The Set LCD Pin dialog box consists of the following areas.

• Segment signal setting area

• Common signal setting area

• Segment display image display area

The function of each area is explained below.
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(1) Segment signal setting area

This area specifies the name of the LCD output pin to be set as the segment pin.

If the specified segment output signal data is “1” during simulation, a bitmap is displayed.  When more than

one pin is selected, if the signal data from any of the pins is “1”, a bitmap is displayed.

To specify the LCD output pin name, click in the text box on the left, and after positioning the cursor, select

the name from the drop-down list on the right.  The name will then be added and displayed in the text box

(multiple specifications are automatically displayed delimited with a comma “,”).  Names can also be typed

directly into the text box.  In this case, be sure to delimit multiple specifications with a comma “,”.  Up to 20 pin

names can be set.

(2) Common signal setting area

This area specifies the LCD output pins to be set as common pins.

If the result of ANDing the output signal data of the specified common and segment is “1”, a bitmap is

displayed.  Up to 20 pin names can be set.

Names are specified in the same way as in the segment signal setting area.

(3) Segment display image display area

The graphic selected in the LCD Panel window is displayed as a 7-segment display image in the case of a 7-

segment LED, and a 14-segment display image in the case of a 14-segment LED.  If graphics other than

these are selected, nothing will be displayed.

When the data is set by clicking the  OK  button, the red part of the 7-segment display image/14-segment

display image is moved, and that segment enters the setting input wait state.

Caution

(1) Use the following procedure to connect LCD output pins to the graphics (including bitmaps and

characters) in the LCD Panel window.

<1> Select [seT] from the [Mode] menu.

<2> Click the graphic to be connected.  The Set LCD Pin dialog box will open.

<3> Specify the LCD output pins to be set as the segment and common pins in the Set LCD Pin dialog box.

Click in the text box on the left, and after positioning the cursor, select the name from the drop-down list

on the right.  The selected name will then be added and displayed in the text box.  Names can also be

typed directly into the text box.  In this case, be sure to delimit multiple specifications with a comma “,”.

<4> Click the  OK  button to set the data.

→ The data and graphics in the Set LCD Pin dialog box are connected, and the dialog box closes.  If a

7-or 14-segment LED has been connected, the red part of the segment display image is moved, and

that segment enters the setting input wait state.
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(2) LCD display

There are two types of LCD display: the one in the LCD display window when a bit image is selected, and the

customized LCD display when a custom is selected in the LCD Panel window.

(a) LCD Display window

A bit image is displayed as vertical common signals and horizontal segment signals.  The segment

signals that are active for the active common signals are black.  Inactive signals are white.

(b) Customized LCD display

Selecting [Simulation] from the [Mode] menu in the LCD Panel window starts a simulation operation.  At

this time, the customized LCD display in the LCD Panel window is not displayed because the connected

pins are inactive.  A customized LCD display not connected to segment pins is also not displayed.

The display timing for a customized LCD is as follows.

• When values of the common pin and segment pin signals set in the Set LCD Pin dialog box are both

“1”, the corresponding graphic is displayed.

• The graphic retains the same display status (displayed/not displayed) as long as the value of the

segment signal corresponding to the current common signal does not change.

• Cascaded graphics are displayed in order of small segment signals to large segment signals.

• Graphics not connected to segment pins are displayed continuously.

Function buttons

Sets the specified data.  Connects the data in the Set LCD Pin dialog box to the graphic and

closes the dialog box.  If a 7- or 14-segment LED has been connected, the red part of the

segment display image is moved, and that segment enters the setting input wait state.

Ignores the setting and closes the dialog box.

Deletes the setting contents.

Displays the Help window.

Test mode
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FIPs Window Modal

General

This window makes settings related to the FIP.

Either the FIP Display window or the FIP Panel window can be displayed by selecting the appropriate FIP display

image (Bit Image/Customize).

The setting information can be saved to a file (.sfp), and information saved to a file can be read.

Opening method

This window can be opened by the following procedure.

<1> Select [External Parts] → [Panel Window…] on the menu bar of the 78K/0 Simulator GUI window.

<2> Select [Parts] → [built in FIP...] on the menu bar of the Parts window.

Window

Figure 6-86.  FIPs Window

Function

The FIPs window consists of the following areas.

• FIP display image selection area

• Display segment number setting area

• Display timing number setting area

The function of each area is explained below.

(1)

(2)

(3)
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(1) FIP display image selection area

This area selects the FIP display image.

Bit Image: Displays a bit image.

Select Bit Image and click the  button.  The FIP Display window is then opened

displaying a bit image of the timing and segment signal matrix.

Customize: Customized display.

Select Customize and click the  button.  The FIP Panel window is then opened.

(2) Display segment number setting area

This area sets the range of the segment numbers that are to be displayed.  Setting this allows display of only

the desired segments.  Either of the text boxes can be used to specify the number of the segment from which

display will start.

(3) Display timing number setting area

This area sets the range of the timing numbers that are to be displayed.  Setting this allows display of only the

desired timings.  Either of the text boxes can be used to specify the number of the timing from which display

will start.
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Function buttons

Displays the FIP Display window as a bit image of the timing and segment signal matrix when Bit

Image is selected in the FIP display image area.

Opens the FIP Panel window when Customize is selected in the display area.

Opens the Open dialog box (p.461).

Reads the connection information from a previously saved file (.sfp).

Opens the Save As dialog box (p.463).

Saves the displayed connection information to a file (.sfp).

Deletes the setting contents.

Ignores the setting and closes the window.

Displays the Help window that explains the FIPs window.
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FIP Panel Window

General

This window displays the output of the pins connected to the device’s internal FIP controller/driver as bit and

graphic images.

Opening method

This window can be opened by the following procedure.

<1> Select [Parts] → [built in FIP...] on the menu bar of the Parts window.

<2> Select Customize under Display in the FIPs window.

Window

Figure 6-87.  FIP Panel Window

Function

The FIP Panel window creates and edits FIP images.

During simulation, return to the Parts window by selecting [Mode] → [Simulation] on the menu bar.

The functions of the FIP Panel window are explained below.

Test mode
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(1) Tool bar

Whether the tool bar is displayed or not can be specified by selecting [Option] → [Tool Bar] on the menu bar.

Arbitrary character strings can be described.

This cannot be selected when the Parts window is active.

Straight lines of arbitrary length can be drawn.

This cannot be selected when the Parts window is active.

Rectangles of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

Ellipses of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

Pies of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

Polygons of arbitrary size can be drawn.

This cannot be selected when the Parts window is active.

(2) Editing in FIP Panel window

All of the following FIP Panel window editing procedures are performed in the edit mode.

(a) Moving graphics

<1> Click the graphic to be moved.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Drag the selected graphic to the desired position.

→ The selected graphic is moved to the specified position.

(b) Cutting, copying and deleting graphics

<1> Click the graphic to be cut, copied, or deleted.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [cuT], [Delete], or [Copy] from the [Edit] menu.

→ The selected part will be cut, copied, or deleted.

Alternatively, if there is more than one part to be edited, click the relevant parts while holding down the

 SHIFT  key, and then cut, copy, or delete using procedure <2> above.



CHAPTER  6    WINDOW  REFERENCE

424 User’s Manual  U14611EJ1V0UM00

(c) Pasting graphics

<1> Select either the Windows paintbrush, or [cuT]/[Copy] from the [Edit] menu.

→ The selected graphic is copied to the clipboard.

<2> Select [Paste] from the [Edit] menu.

→ The data on the clipboard is pasted to the lower right of the cut or copied graphic.

(d) Importing graphic from file

<1> Create a bitmap file using the image editor (etc.).

<2> Select [Import from File...] from the [Edit] menu.

→ The Open dialog box (p.461) is opened.

<3> Select the bitmap file to be imported from the dialog box.

→ The bitmap image of the selected bitmap file is pasted to the upper left corner of the FIP Panel

window.

(e) Changing graphic size

<1> Click the graphic whose size is to be changed.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Click the mouse on a mark and drag the graphic until the desired size is reached.

→ The graphic is enlarged/reduced.

(f) Character insertion

<1> Select [Text] from the [Draw] menu.

→ A dialog box for inputting characters opens when the mouse is clicked at the desired display

position.

<2> Type the character string to be displayed in this dialog box and click anywhere outside the text box

in the FIP Panel window.

(g) Drawing 7/14 segments

<1> Select [7Segment] or [14seGment] from the [Draw] menu.

<2> Click the mouse at the desired display position in the FIP Panel window.

→ The selected segment image is displayed at the position where the mouse was clicked.
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(h) Drawing lines

<1> Select [Line] from the [Draw] menu.

<2> Click the mouse where the line is to start.

<3> Move the mouse.  A straight line appears where the mouse is moved.

<4> Click the mouse button where the line is to end.

→ The start and end points are connected by a straight line.

(i) Drawing rectangles, circles, and pies

<1> Select [Rectangle], [Ellipse], or [Pie] from the [Draw] menu.

<2> Click the mouse where the rectangle, circle, or pie is to be drawn and hold the button down on a

vertex.

<3> Drag the mouse.  A rectangle appears from the vertex from which the mouse is dragged.

<4> Release the mouse button when the rectangle has reached the desired size.  In the case of circles

or pies, these will be drawn inside this rectangle.

(j) Drawing polygons

<1> Select [POlygon] from the [Draw] menu.

<2> Click the mouse where the polygon is to be drawn and set a vertex.

<3> Move (or drag) the mouse to the next vertex.  A line (curve) appears from the vertex from which the

mouse is moved (dragged).

<4> Click the mouse after arriving back at the original vertex.  A polygon will be drawn with the lines

connected in the order clicked.

(k) Grouping

<1> Click the graphics to be grouped (to select two or more graphics, click the relevant graphics while

holding down the  SHIFT  key).

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [Group] from the [Option] menu.

→ The selected graphics become one, and marks appear at the vertices and midpoints of the box

around the grouped graphics.
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(l) Ungrouping

<1> Click the graphic to be ungrouped.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [Ungroup] from the [Option] menu.

→ The selected graphic returns to its pregrouped state, and marks appear at the vertices and

midpoints of the boxes around each graphic.

(m) Raising

<1> Click the graphic to be displayed in front of the cascaded graphics.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [Raise] from the [Option] menu.

→ The selected graphic is displayed in the front.  The order of the other cascaded graphics does

not change.

(n) Lowering

<1> Click the graphic to be displayed at the back of the cascaded graphics.

→ Marks appear at the vertices and midpoints of the box around the selected graphic.

<2> Select [Lower] from the [Option] menu.

→ The selected graphic is displayed at the back.  The order of the other cascaded graphics does

not change.

Menu bar

Whether the menu bar is displayed or not can be specified by selecting [Menu View] in the control menu box in this

window.

(1) File

Select File to save FIP Panel window data to a file (.fip) or open a file for reading data.

[Open…]  Opens the Open dialog box (p.461).  Reads FIP Panel window data from the

specified file (.fip).

[Save]  Overwrites and saves the current data in the FIP Panel window to the file currently

open (.fip).

[Save As…]  Opens the Save As dialog box (p.463).  Saves the current FIP Panel window data

to a specified file (.fip).

[eXit…]  Closes this window (Parts window).
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(2) Mode

In the case of the FIP Panel window, this menu can be used to move, group, or modify the size of graphics

(edit mode), to draw graphics (draw mode), or to connect pins to the customized FIP graphics (set mode).

Also, by selecting [Simulation], the window is changed to the Parts window at the moment the simulation

mode is set.

[Edit]  Displays a dialog box that indicates the mouse cursor position (x and y

coordinates), and sets the window in the edit mode, in which the graphics pasted

in the window can be moved and edited using the [Edit] menu.

[Simulation] Sets the window in the simulation mode in which the parts can be simulated

(default).

[Draw]  Sets the window in the draw mode, in which FIP display image graphics can be

drawn using the [Draw] menu.

[seT]  Sets the window in the set mode, in which the display timing and display segment

connections can be set for the FIP display image graphics.

If this mode is selected, the [Edit], [Draw], and [Option] menus become

unselectable.

(3) Edit

This menu can be used to move or edit the graphics displayed in the FIP Panel window, so that the user can

freely create an image of the system.

This menu can be selected only in the edit mode.

[Undo] Restores changes in the window, such as movement of graphics or character

strings, to the status immediately before.

[Delete]  If a graphic or character string is selected with the mouse and [Delete] is clicked,

the selected graphic or character string is deleted.
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[cuT]  If a graphic or character string is selected with the mouse and [cuT] is clicked, the

selected graphic or character string is deleted and copied to the clipboard.

[Copy]  If a graphic or character string is selected with the mouse and [Copy] is clicked,

the selected graphic or character string is copied to the clipboard.

[Paste]  The data copied to the clipboard is pasted to the upper left corner of the FIP Panel

window.

[Import from File…]  Opens the Open dialog box (p.461). Pastes the specified bitmap file (.bmp) to the

upper left corner of the FIP Panel window.

[TeXt]  Cannot be selected.

[Line]  Cannot be selected.

[Rectangle] Cannot be selected.

[Bitmap]  Cannot be selected.

[Suspend]  Cannot be selected.

(4) Parts

Refer to the description of the [Parts] menu in the Parts window (p.385) for an explanation of this menu.

(5) Bitmap

Cannot be selected.

(6) Customize

Cannot be selected.

(7) Draw

This menu can be used to draw FIP display image graphics in the FIP Panel window.

This menu can be selected only in the draw mode.

[Text]  Arbitrary character strings of up to 40 characters per string can be described.

This has the same function as clicking the  button.

[7Segment]  Displays a 7-segment numerical LED.  Each of these segments becomes an FIP

display segment.
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[14seGment]  Displays a 14-segment alphanumerical LED.  Each of these segments becomes

an FIP display segment.

[Line]  Straight lines of arbitrary length can be drawn.

This has the same function as clicking the  button.

[Rectangle]  Rectangles of arbitrary size can be drawn.

This has the same function as clicking the  button.

[Ellipse]  Circles of arbitrary size can be drawn.

This has the same function as clicking the  button.

[Pie]  Pies of arbitrary size can be drawn.

This has the same function as clicking the  button.

[POlygon]  Polygons of arbitrary size can be drawn.

This has the same function as clicking the  button.

[EDit]  Drawn graphics can be selected.  This function can be selected when graphic

drawing is aborted in the draw mode.

(8) Option

[Tool Bar]  Specifies whether the tool bar is displayed or not.  Displays the tool bar if the

check mark is displayed (default).

[Group]  Several FIP graphics can be edited as a single graphic (grouping).  This function

is not available for 7- and 14-segment LEDs.

[Ungroup]  Returns grouped graphics to their original state.

[Pen...] Changes the status of the line being drawn or the graphic currently selected.  The

color, width, and type of the line can be specified in the opened dialog box.

[Brush...]  Changes the brush of the graphic being drawn or the graphic currently selected.

The style, color, and size of the brush can be specified in the opened dialog box.
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[Font...]  Changes the font of the character string being typed or the character string

currently selected.  The font and font size can be specified in the opened dialog

box.

[Raise]  Places the selected graphic in front of the cascaded graphics.

[Lower]  Places the selected graphic at the back of the cascaded graphics.

(9) Help

Refer to the description of the [Help] menu in the Parts window (p.385) for an explanation of this menu.
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Set FIP Pin Dialog Box

General

This dialog box connects the bitmaps and graphics in the FIP Panel window to the FIP output pins.

If FIP output pin signals are already connected to the selected graphic, this connection information will be

displayed in the dialog box, enabling the user to check the graphic/signal connections.  Note that the active status of

each signal is active high.

Opening method

This dialog box can be opened by the following procedure.

<1> Select [Mode] → [seT] from the menu bar in the FIP Panel window.

<2> Click the graphic or bitmap to be connected.

Window

Figure 6-88.  Set FIP Pin Dialog Box

When selected graphic is other than 7-or 14-segment LED

Function

The Set FIP Pin dialog box consists of the following areas.

• Segment signal setting area

• Timing signal setting area

• Segment display image display area

The function of each area is explained below.
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(1) Segment signal setting area

This area specifies the name of the FIP output pin to be set as the segment pin.

If the specified segment output signal data is “1” during simulation, a bitmap is displayed.  When more than

one pin is selected, if the signal data from any of the pins is “1”, a bitmap is displayed.

To specify the FIP output pin name, click in the text box on the left, and after positioning the cursor, select the

name from the drop-down list on the right.  The name will then be added and displayed in the text box

(multiple specifications are automatically displayed delimited with a comma “,”).  Names can also be typed

directly into the text box.  In this case, be sure to delimit multiple specifications with a comma “,”.  Up to 20 pin

names can be set.

(2) Timing signal setting area

This area specifies the FIP output pins to be set as timing pins.

If the result of ANDing the output signal data of the specified timing or the output signal of the specified timing

and segment is “1”, a bitmap is displayed.  Up to 20 pin names can be set.

Names are specified in the same way as in the segment signal setting area.

(3) Segment display image display area

The graphic selected in the FIP Panel window is displayed as a 7-segment display image in the case of a 7-

segment LED, and a 14-segment display image in the case of a 14-segment LED.  If graphics other than

these are selected, nothing will be displayed.

When the data is set by clicking the  OK  button, the red part of the 7-segment display image/14-segment

display image is moved, and that segment enters the setting input wait state.

Caution

(1) Use the following procedure to connect FIP output pins to the graphics (including bitmaps and

characters) in the FIP Panel window.

<1> Select [seT] from the [Mode] menu.

<2> Click the graphic to be connected.  The Set FIP Pin dialog box will open.

<3> Specify the FIP output pins to be set as the segment and timing pins in the Set FIP Pin dialog box.

Click in the text box on the left, and after positioning the cursor, select the name from the drop-down list

on the right.  The selected name will then be added and displayed in the text box.  Names can also be

typed directly into the text box.  In this case, be sure to delimit multiple specifications with a comma “,”.

<4> Click the  OK  button to set the data.

→ The data and graphics in the Set FIP Pin dialog box are connected, and the dialog box closes.  If a

7-or 14-segment LED has been connected, the red part of the segment display image is moved, and

that segment enters the setting input wait state.
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(2) FIP display

There are two types of FIP display: the one in the FIP display window when a bit image is selected, and the

customized FIP display when a custom is selected in the FIP Panel window.

(a) FIP Display window

A bit image is displayed as vertical timing signals and horizontal segment signals.  Only the active timing

signals light up in blue in the timing output numbers. The segment signals that are active for the timing

signals are black.  Inactive signals are white.

(b) Customized FIP display

Selecting [Simulation] from the [Mode] menu in the FIP Panel window starts a simulation operation.  At

this time, the customized FIP display in the FIP Panel window is not displayed because the connected

pins are inactive.  A customized FIP display not connected to segment pins is also not displayed.

The display timing for a customized FIP is as follows.

• When values of the timing pin and segment pin signals set in the Set FIP Pin dialog box are both “1”,

the corresponding graphic is displayed.

• The graphic retains the same display status (displayed/not displayed) as long as the value of the

segment signal corresponding to the current timing signal does not change.

• Cascaded graphics are displayed in order of small segment signals to large segment signals.

• Graphics not connected to segment pins are displayed continuously.

Function buttons

Sets the specified data.  Connects the data in the Set FIP Pin dialog box to the graphic and closes

the dialog box.  If a 7- or 14-segment LED has been connected, the red part of the segment display

image is moved, and that segment enters the setting input wait state.

Ignores the setting and closes the dialog box.

Deletes the setting contents.

Displays the Help window.

Test mode
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LEDs Window

General

This window sets or displays the connection information of the LED displayed on the Parts window (p.385).

The displayed LED indicates the output status of the simulator by turning ON/OFF.

The connection information can be saved to a file (.led).  The information saved to a file can be read.

Opening method

This window can be opened by either of the following procedures.

<1> Select [External Parts] → [Panel Window…] on the menu bar of the 78K/0 Simulator GUI window.
<2> Click  button, or select [Parts] → [LED…] on the menu bar of the Parts window.

Window

Figure 6-89.  LEDs Window

Function

The LEDs window consists of the following areas.

• LED ID display area

• Display format setting area

• Connection information display area

The function of each area is explained below.

(2)  Display format setting area

(3)  Connection information display area

(1)  LED ID display area
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(1) LED ID display area

This area displays the ID number assigned to the set LEDs.  When setting more than five LEDs, click
Next  button and the ID number is updated.

Up to 32 ID numbers can be set.

(2) Display format setting area

This area specifies the format in which the LEDs are displayed on the Parts window.  A graphic or bitmap can

be selected.

The default is bitmap display of electric bulbs.

B/P: If this box is checked, data is displayed in the format specified in Picture.  If it is not checked,

data is displayed as the bitmap specified by BMP ID.

BMP ID: If the B/P box is not checked, specifies the registration number of the bitmap to be displayed

by a numeric character.  If the ID No. does not exist, or if no ID No. is specified, the bitmap at

default entry No. 1 (Bulb Pattern) is displayed (See the Bitmap Entry window (p.457)

concerning bitmap entry.)

Picture: If B/P is checked, specifies the figure to be displayed. Six patterns are available in

combinations of rectangle and circle, and red, green, and yellow.  These patterns are

selected from the drop-down list.

(3) Connection information setting area

This area specifies the connection information of pins.

Name: Specifies a character string to be displayed.  Up to eight characters can be input.

Pin: Specifies the name of an output pin to be connectedNote.  Up to eight characters can be input.

Note For the pin names to be specified, refer to the User’s Manual of the device used.

Active: Specifies the active status of a set LED by using an option button.  The default status is

active high (H).

Caution

(1) LED

An LED displays the output status (active or inactive) from a pin real-time by using two types of bitmaps.

If a figure such as rectangle or circle is selected for the display format, the picture is displayed in the specified

colour in the active status, and the flame of the picture is only displayed in the inactive status.
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Function buttons

Previous Displays the four LED ID numbers preceding the one currently displayed.

Next Displays the four LED ID numbers following the one currently displayed.

OK Checks errors of the set connection information.

If an error occurs, an error message or warning message is displayed in the dialog box.  If no error

occurs, transfers control to the Parts window and displays the set external parts.

Open Opens the file Open dialog box (p.461).

Reads the connection information from a previously saved file (.led).

Save Opens the Save As dialog box (p.463).

Saves the displayed connection information to a file (.led).

Clear Deletes the setting contents.

Cancel Ignores the setting and closes the window.

Help Displays the Help window that explains the LEDs window.
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7seg LEDs Window

General

This window sets or displays the connection information on the 7segment LED pin displayed on the Parts window

(p.385).

The displayed 7-segment LED indicates the output condition of the simulator.

The connection information can be saved to a file (.seg).  The information saved to the file can be read.

Opening method

This window can be opened by either of the following procedures.

<1> Select [External Parts] → [Parts Window…] on the menu bar of the 78K/0 Simulator GUI window.
<2> Click  button, or select [Parts] → [7Seg LED…] on the menu bar of the Parts window.

Window

Figure 6-90.  7seg LEDs WIndow

(1)  Segment signal setting area (3)  Digit signal setting area

(2)  Segment signal active status specification area (4)  Digit signal active status specification area
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Function

The 7seg LEDs window consists of the following areas.

• Segment signal setting area

• Segment signal active status specification area

• Digit signal setting area

• Digit signal active status specification area

The function of each area is explained below.

(1) Segment signal setting area

This area specifies the name of the pin to be connected to the segment signal of a 7-segment LEDNote.

Up to eight characters can be input.

Note For the pin name to be specified, refer to the User’s Manual of the device used.

(2) Segment signal active status specification area

Segment H/L: This area specifies the active status of the segment signal by using an option button.

The default status is active high (H).

(3) Digit signal setting area

This area specifies the name of the pin to be connected to the digit signal of a 7-segment LEDNote.  Up to eight

characters can be input.
When setting more than nine digits, click Next  button and update digits. Up to 16 digits can be set.

Specify successive pins from the lowest digit as the setting signal.

Note For the pin name to be specified, refer to the User’s Manual of the device used.

(4) Digit signal active status specification area

Digit H/L: This area specifies the active status of the digit signal by using an option button.

The default status is active high (H).
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Caution

(1) 7-segment LED

A 7-segment LED receives result of one simulation and the output status of a pin and displays in accordance

with the value of the pin.

Lighted segments remain lighted and extinguished segments remain extinguished to maintain display until the

value of the digit signal changes.  If the value of the digit signal changes, the display is updated according to

the change of the segment signal.

A segment that is light is indicated in red, and those that remain dark are indicated in white (only the frame is

displayed).

Function buttons

Previous Displays the setting information on the eight digit signals preceding the one currently displayed in

each area.

Next Displays the setting information on the eight digit signals following the one currently displayed in

each area.

OK Checks errors of the set connection information.

If an error occurs, an error message or warning message is displayed in the dialog box.  If no error

occurs, transfers control to the Parts window and displays the set external parts.

Open Opens the file Open dialog box (p.461).

Reads the connection information from a previously saved file (.seg).

Save Opens the Save As dialog box (p.463).

Saves the displayed connection information to a file (.seg).

Clear Deletes the setting contents.

Cancel Ignores the setting and closes the window.

Help Displays the Help window that explains the 7seg LEDs window.
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Level Gauges Window

General

This window sets or changes the connection information in the level gauge displayed in the Parts window (p.385).

Data can be input from the displayed level gauge (scroll bar or dial) to the simulator.

However, only the analog input pins can be connectedNote.

The connection information can be saved to a file (.lev).  In addition, a saved file can be read.

Note Only devices with an internal A/D converter can be selected.  Refer to the user’s manual for the device you

are using concerning the name of the pin to be connected to.

Opening method

This window can be opened by either of the following procedures.

<1> Select [External Parts] → [Panel Window…] on the 78K/0 Simulator GUI window.
<2> Click the button or select [Parts] → [Level Gauge…] in the Parts window.

Window

Figure 6-91.  Level Gauges Window

(1)  Level gauge ID display area (4)  Input pin setting area

(5) Reference voltage

setting area

(3) Function name

setting area

(2) Display format

setting area
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Function

The Level Gauge window consists of the following areas.

• Level gauge ID display area

• Display format setting area

• Function name setting area

• Input pin setting area

• Reference voltage setting area

The function of each area is explained below.

(1) Level gauge ID display area

This area displays the ID numbers assigned to the level gauges to be set.  To set eight or more level gauges,

click the Next  button to update the ID number.  Up to 16 level gauges can be set.

(2) Display format setting area

These check boxes are used to specify the types of the level gauges to be displayed.  If these boxes are

checked, the level gauges are displayed in dial format; if they are not checked, the level gauges are displayed

in scroll bar format.

(3) Function name setting area

Specifies the character string to be displayed at the side of the level gauge.  Up to eight  characters can be

input.

(4) Input pin setting area

This area specifies an analog input pin to be connected.  The pin name consists of up to eight charactersNote.

Note For the pin name to be specified, refer to the User’s Manual of the device used.

(5) Reference voltage setting area

Sets the reference voltage of the A/D converter in the range of the operating supply voltages, to one place

below the decimal point (the default value is 5.0 V).  This reference value determines the operating range of

the scroll bar or dial displayed in the Parts window.

Caution

(1) Input from level gauge

By manipulating the displayed scroll bar or dial, analog signals are input from the level gauge.  At this time,

the value specified by AVref is the maximum value that can be input.

A level gauge can be displayed in two formats: scroll bar and dial.

Scroll bar format Dial format
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(a) Input with scroll bar

By moving the scroll box, the analog value is displayed in black and changes.  When this analog value

reaches the value to be input, click the right mouse button with the cursor on the scroll bar.  In this way,

the displayed analog value can be input.  At this time, the analog value is displayed in red.  The scroll

box can be moved to any position by dragging it or clicking the left mouse button.  The input value is

displayed in red.

(b) Input with dial

By moving the ‘red’ mark (operating point) on the dial, the analog value is displayed in black and

changes.  When this analog value reaches the value to be input, click the right mouse button with the

cursor on the dial.  In this way, the displayed analog value an be input.  At this time, the analog value is

displayed in red.  The operating point can be moved to any position by dragging it or clicking the left

mouse button.

Function buttons

Previous Displays the setting details for the eight ID numbers before the currently displayed ID number.

Next Displays the setting details for the eight ID numbers after the currently displayed ID number.

OK Checks for errors of the set connection information.

If an error or warning occurs, the message is displayed on the dialog box.  If no error or warning

occurs, control is transferred to the Parts window and the set external parts are displayed.

Open Opens the file Open dialog box (p.461).

Saves the displayed connection information to a file (.lev).

Save Opens Save As dialog box (p.463).

Saves the displayed connection information to a file (.lev).

Clear Erases the set contents.

Cancel Ignores the settings and closes the window.

Help Displays the Help window that explains the Level Gauges window.
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DC Motors Window

General

This window sets or changes the connection information on the DC motor displayed on the Parts window (p.385).

The displayed DC motor displays the output status from the connected pin in the number of revolutions.

The connection information can be saved to a file (.mtr).  The information saved to the file can also be read.

Opening method

This window can be opened by the following procedure.

<1> Select [External Parts] → [Panel Window…] on the menu bar of the 78K/0 Simulator GUI window.
<2> Click  button, or select [Parts] → [DC Motor…] on the menu bar of the Parts window.

Window

Figure 6-92.  DC Motors Window

Function

The DC Motors window consists of the following areas.

• DC motor ID display area

• Connection information setting area

The function of each area is explained below.

(1)  DC motor ID display area (2)  Connection information setting area
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(1) DC motor ID display area

This area displays the ID numbers assigned to a set DC motor.

When setting more than five DC motors, click Next  button and the ID number is updated.  Up to 32 ID

numbers can be set.

(2) Connection information setting area

This area sets or displays the connection information on the DC motor and pins.

BMP ID: Specifies the registration number of a bitmap displayed on the Parts window in number.

If no ID number exists or is specified, the default assumption is bitmap (motor) of

registration number 4 (refer to Bitmap Entry window (p.457)).

Name: Specifies the character string to be displayed.  Up to eight characters can be input.

Pin: Specifies port pins or multiplexed pins connecting DC motorNote.  Up to eight characters

can be input.

Note For the pin name to be specified, refer to the User’s Manual of the device used.

Active: Specifies the active status of the set DC motor by using an option button.

The default status is active high (H).

Caution

(1) DC motor

The values of the output pins connected to the DC motor are displayed on the bitmap.  When the output pin is

active, it is displayed in brown.  When the pin is not active, it is displayed in black.

The total number of clocks during which the output pin remains in the active status starting from the beginning

of simulation is also displayed.  The total number of clocks is counted up to 10 digits.  If the 10th digit is

exceeded, the counting is started from 0 again.

Inactive Active
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Function buttons

Previous Displays the setting information of the ID number preceding the currently displayed one.

Next Displays the setting information of the ID number following the one currently displayed.

OK Checks errors of the set connection information.

If an error occurs, an error message or warning message is displayed in the dialog box.  If no error

occurs, transfers control to the Parts window and displays the set external parts.

Open Opens the Open dialog box (p.461).

Reads the connection information from a previously saved file (.mtr).

Save Opens the Save As dialog box (p.463).

Saves the displayed connection information to a file (.mtr).

Clear Deletes the setting contents.

Cancel Ignores the setting and closes the window.

Help Displays the Help window that explains the DC Motors window.
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Buzzers Window

General

This window sets or changes the connection information of the buzzer displayed on the Parts window (p.385).

The output status is indicated by a bitmap or buzzer.

The connection information can also be saved to a file (.buz).  In addition, a saved file can be also read.

Opening method

This window can be opened by the following procedure.

<1> Select [External Parts] → [Panel Window…] on the 78K/0 Simulator GUI window.
<2> Click  button, or select [Parts] → [BuZzer…] on the Parts window.

Window

Figure 6-93.  Buzzers Window

Function

The Buzzers window consists of the following areas.

• Buzzer output format setting area

• Buzzer connection pin setting area

The function of each area is explained below.

(1)  Buzzer output format setting area

(2)  Buzzer connection pin setting area



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14611EJ1V0UM00 447

(1) Buzzer output format setting area

Specifies the output format of the buzzer by using check boxes.  Both the following formats can be specified

at the same time.

Beep: Indicates the output from a pin by a buzzer sound when this box is checkedNote.

Bitmap: Indicates the output from a pin on the bitmap when this box is checked.

Note When the sound output check box is checked, a sound board and a speaker are necessary.

(2) Buzzer connection pin setting area

Sets the pin connection information for the buzzer.

Pin: Inputs the name of a pin to be connected to the buzzer from the keyboardNote.  The pin

name can consist of up to eight characters.

Note For the pin name to be specified, refer to the User’s Manual of the device used

Active: Selects the active status of the set buzzer by using option buttons.  The default status is

active-high (H).

Caution

(1) Buzzer indication

The active level of the connected pin is indicated by the bitmap or buzzer sound (or both).  The bitmap

indicates the output value of the pin (active/inactive) as follows.

The buzzer sounds when the connected pin outputs the value of active level (when the pin status changes

from inactive to active).

Function buttons

OK Validates the setting and transfers control to the Parts window.

When bitmap display is specified, the output status is indicated by a bitmap.

Open Opens the Open dialog box (p.461).

Reads the connection information from a previously saved file (.buz).

Save Opens the Save As dialog box (p.463).

Saves the displayed connection information to a file (.buz).

Clear Deletes the setting contents.

Cancel Ignores the settings and closes the window.

Help Displays the Help window that explains the Buzzers window.

Inactive Active
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14seg LEDs Window

General

This window sets or displays the connection information on the 14-segment LED displayed on the Parts window

(p.385).

The displayed 14-segment LED indicates the output condition of the simulator.

The connection information can be saved to a file (.s14).  The information saved to the file can be read.

Opening method

This window can be opened by the following procedure.

<1> Select [External Parts] → [Panel Window…] on the menu bar of the 78K/0 Simulator GUI window.
<2> Click  button, or select [Parts] → [14seg LED…] on the menu bar of the Parts window.

Window

Figure 6-94.  14seg LEDs Window

(1)  Segment signal setting area

(2)  Segment signal active status specification area (4)  Digit signal active status specification area

(3)  Digit signal setting area
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Function

The 14seg LEDs window consists of the following areas.

• Segment signal setting area

• Segment signal active status specification area

• Digit signal setting area

• Digit signal active status specification area

The function of each area is explained below.

(1) Segment signal setting area

This area specifies the name of the pin to be connected to the segment signal of a 14-segment LEDNote.

Up to eight characters can be input.

Note For the pin name to be specified, refer to the User’s Manual of the device used.

(2) Segment signal active status specification area

Segment H/L: This area specifies the active status of the segment signal by using an option button.

The default status is active high (H).

(3) Digit signal setting area

This area specifies the name of the pin to be connected to the digit signal of a 14-segment LEDNote.  Up to

eight characters can be input.
When setting more than six digits, click Next  button and the digits are updated.  Up to 10 digits can be

set.

Specify successive pins from the lowest digit as the setting signal.

Note For the pin name to be specified, refer to the User’s Manual of the device used.

(4) Digit signal active status specification area

Digit H/L: This area specifies the active status of the digit signal by using an option button.

The default status is active high (H).
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Caution

(1) 14-segment LED

A 14-segment LED receives the output status of the pin connected to it, and performs display according to

the value of the pin.

Lighted segments remain lighted and extinguished segments remain extinguished to maintain display until the

value of the digit signal changes.  If the value changes, the display is updated according to the change of the

segment signal.

A segment that is light is indicated in red, and those that remain dark are indicated in white (only the frame is

displayed).

Function buttons

Previous Displays the setting contents on the five digit signals preceding the one currently displayed in each

area.

Next Displays the setting contents on the five digit signals following the one currently displayed in each

area.

OK Checks errors of the set connection information.

If an error occurs, an error message or warning message is displayed in the dialog box.  If no error

occurs, transfers control to the Parts window and displays the set external parts.

Open Opens the Open dialog box (p.461).

Reads the connection information from a previously saved file (.s14).

Save Opens the Save As dialog box (p.463).

Saves the displayed connection information to a file (.s14).

Clear Deletes the setting contents.

Cancel Ignores the setting and closes the window.

Help Displays the Help window that explains the 14seg LEDs window.
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Internal Interrupt Button Window

General

This window sets or changes the connection information on the interrupt buttons displayed on the Parts window

(p.385).

The displayed buttons can be used to generate an internal interrupt in the simulator.

The connection information can be saved to a file (.itr).  The information saved to the file can be read.

Opening method

This window can be opened by the following procedure.

<1> Select [External Parts] → [Panel Window…] on the menu bar of the 78K/0 Simulator GUI window.
<2> Click  button, or select [Parts] → [Internal Interrupt…] on the menu bar of the Parts window.

Window

Figure 6-95.  Internal Interrupt Button Window

Function

The Internal Interrupt Button window consists of the following areas.

• Internal interrupt button ID display area

• Internal interrupt name setting area

The function of each area is explained below.

(1)  Internal interrupt button ID display area

(2)  Internal interrupt name setting area
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(1) Internal interrupt button ID display area

This area displays the ID numbers of the buttons added to a set button.

When setting more than five interrupt buttons, click Next  button and the ID number is updated.

Up to 20 ID numbers can be set.

(2) Internal interrupt name setting area

Interrupt: Selects an internal interrupt nameNote to be connected from the dropdown list.

Note For the interrupt name to be specified, refer to the User’s Manual of the

device used.

Caution

(1) Internal interrupt button

By clicking a displayed internal interrupt button, the interrupt can be generated.

If the button is clicked when the interrupt can be acknowledgedNote, the interrupt is generated.  Note that this

button does not have a function for setting input timing.

Note For the timing at which the interrupt cannot be acknowledged, refer to the manual of the device used.

Function buttons

Previous Displays the setting contents of the four ID numbers preceding the one currently displayed.

Next Displays the setting contents of the four ID numbers following the one currently displayed.

OK Checks errors of the set connection information.

If an error occurs, an error message or warning message is displayed in the dialog box.  If no error

occurs, transfers control to the Parts window and displays the set external parts.

Open Opens the Open dialog box (p.461).

Reads the connection information from a previously saved file (.itr).

Save Opens the Save As dialog box (p.463).

Saves the displayed connection information to a file (.itr).

Clear Deletes the setting contents.

Cancel Ignores the setting and closes the window.

Help Displays the Help window that explains the Internal Interrupt Button window.
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Pull-Up/Pull-Down Window

General

This window is used to set information on pins to be connected to pull-up/pull-down resistors.

When connecting a pull-up or pull-down resistor to a pin that sets an external button/key matrix part, set the pull-

up/pull-down resistor in this window before setting pin connections in the other connection dialog boxes.

The connection information can also be saved to a file (.pud).  In addition, a saved file can be also read.

Opening method

This window can be opened by the following procedure.

<1> Select [External Parts] → [Panel Window…] on the 78K/0 Simulator GUI window.
<2> Click  button, or select [Parts] [Pull Up/Pull DoWn…] on the Parts window.

Window

Figure 6-96.  Pull-Up/Pull-Down Window

Function

The Pull-Up/Pull-Down window consists of the following areas.

• Pull-up/pull-down ID display area

• Connection information setting area

The function of each area is explained below.

(1)  Pull-up/pull-down ID display area

(2)  Connection information setting area
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(1) Pull-up/pull-down ID display area

This area displays the ID number to be assigned to the pin to which a pull-up/pull-down resistor is connected.

If a pull-up/pull-down resistor is to be connected to five or more pins, update the ID number by clicking the
Next  button.  Up to 40 ID numbers can be set.

(2) Connection information setting area

This area is used to set/display the connection information on the pull-up/pull-down resistors and pinsNote.

Pin: Specifies the name of the pin to be connected to a pull-up/pull-down resistorNote.  The

pin name can consist of up to eight characters.

Note For the pin names to be specified, refer to the User’s Manual of the device

used.

PULL-UP/DOWN: Specifies whether a pull-up resistor (default) or pull-down resistor is connected to the

pin in the initial status, by using option buttons.

Function buttons

Previous Displays the setting details for the four ID numbers before the currently displayed ID number in

each area.

Next Displays the setting details for the four ID numbers after the currently displayed ID number in each

area.

OK Checks for errors if the set connection information.

If an error or warning occurs, a message is displayed on the dialog box.  If no error or warning

occurs, control is transferred to the Parts window and the set external parts are displayed.

Open Opens the Open dialog box (p.461).

Reads connection information from a previously saved file (.pud).

Save Opens Save As dialog box (p.463).

Saves the displayed connection information to a file (.pud).

Clear Erases the set contents.

Cancel Ignores the settings and closes the window.

Help Displays the Help window that explains the Pull-Up/Pull-Down window.
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Serial GUI Window

General

This window displays the operation mode and I/O information of the serial interface.

Opening method

This window can be opened by the following procedure.

<1> Select [External Parts] → [Panel Window…] on the 78K/0 Simulator GUI window.

<2> Select [Parts] → [Serial GUI…] → [Cascade menu (differs depending on device)] on the Parts window.

Window

Figure 6-97.  Serial GUI Window

Function

This window displays the operation mode and I/O information of a serial interface channel selected on the cascade

menu.  The Serial GUI windows of different channels can be opened at the same time.

The Serial GUI window consists of the following areas.

• Operation information display area

• I/O information display area

The function of each area is explained below.

(1) Operation information display area

The operation mode of the serial interface is displayed at the top of this area.  Depending on the operation of

the serial interface, “Operation” or “Stop” is displayed.

The second line shows whether the serial interface operates as a master or slave.  If the interface operates

as a master, the number of operating clocks is also displayed.

(1)  Operation information display area

(2)  I/O information display area
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(2) I/O information display area

Displays the data input to (received by) the serial interface, or the data output (transmitted) by the serial

interface.  The display timing is when all the bits of the data have been received or transmitted.

The number of digits displayed is five by default, and can be increased up to 20 by resizing the windowNote.

The display format of the data can be changed between hexadecimal or binary by using the [View] menu.

Note The number of digits displayed can be also referenced through manipulation of the scroll bar.  Note,

however, that the scroll bar must be manipulated while the simulation is stopped.

Menu bar

(1) File

[Exit] Closes this window.

(2) Digit

[Hex] Displays the data in the I/O information display area in hexadecimal (default).

[Binary] Displays the data in the I/O information display area in binary.

(3) Help

[Help Topics] Displays the table of contents of the Help window.

[This Window] Displays the Help window.
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Bitmap Entry Window

General

This window registers a bitmap file for the external parts displayed on the Parts window (p.385).

This window can be used to register a new bitmap file created by the user or delete the registration of any

unnecessary bitmap files.

Opening method

This window can be opened by the following procedure.

<1> Select [External Parts] → [Panel Window…] on the 78K/0 Simulator GUI window.

<2> Select [Bitmap] → [Bitmap ENtry] on the menu bar of the Parts window.

Window

Figure 6-98.  Bitmap Entry Window

Function

This window can register any bitmap file in addition to the default bitmaps (five types).

A registration number is assigned to a registered bitmap file.

This bitmap file can be used for bitmap display of the external parts whose bitmap display can be changed.

Up to 384 bitmap files can be registered.

The registered contents can be saved to a file (.bit).

The Bitmap Entry window consists of the following areas.

• Bitmap file name specification area

• Registered bitmap file display area

The function of each area is explained below.

(1) Bitmap file name

specification area

(2) Registered bitmap

file display area
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(1) Bitmap file name specification area

Bitmap File Name: This area specifies the name of a bitmap file in the active or inactive status.

Which bitmap (i.e., active or inactive bitmap) is to be registered is selected by using

an option button, search a file name by using the Search  button, or input a file

name directlyNote.

Note If a full path is specified, the path is ignored.

(2) Registered bitmap file display area

LIST: This area displays the names of the bitmap files already registered in the following

format.

  1. lampact.bmp : lampoff.bmp

<1>       <2>                <3>

<1>  Registration number

<2>  File name in active status

<3>  File name in inactive status

As default, five (registration numbers 1 through 5) bitmap files are registered.

When a file is selected using the mouse and displayed in reverse video, a sample is displayed in the lower

area in the dialog box as follows.

Relationships between the registration number and the bitmap file

Registration Number Active Status Inactive Status

1 lampact.bmp lampoff.bmp

2 scract.bmp scroff.bmp

3 btmact.bmp btmoff.bmp

4 motact.bmp motoff.bmp

5 buzact.bmp buzoff.bmp

Examples of bitmaps displayed as samples

1 2

Active             Inactive Active             Inactive

3 4

Active             Inactive Active             Inactive

5

Active             Inactive
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Cautions

(1) Registration of bitmap

Bitmaps should be registered in the following order.

<1> Click the Path  button.  In the dialog box that is opened, specify the path of the directory where

the bitmap file to be registered exists.  Up to 128 characters can be input.

If a path is not set, it is assumed that the file exists in the directory where the simulator exists.

To finalize a path, click the OK  buttonNote 1.  Only one path can be setNote 2.

Notes  1. To invalidate the set path, click the Cancel  button.

 2. If a new path is set for the previously set path, the previously set path becomes invalid.  If
the OK  button is clicked with the field remained blank, the previously set path

becomes valid.

<2> Click an active option button, and search and specify the file name to be used as an active bitmap

from the keyboard or by using the Search  button.  Similarly, register an inactive bitmap file.  If no

file is registered, nothing is displayed in the inactive statusNote.

Note A bitmap file cannot be registered in the inactive status.

<3> By clicking the Add  button, a registration number is assigned to a specified bitmap file and the

file is displayed as a sample.  If a bitmap file does not exist when the registration information is read

from the project file (.prj) or the [Open] button, it is replaced by the error bitmap prepared by the

system.

Active Inactive

(2) Deleting a bitmap file entry

Delete a bitmap file entry using the procedure shown below.

<1> Click the number of the entry you desire to delete from the entry list.

<2> Click the Remove  button

The bitmap entry number where the file was deleted will become blank.  Note that, entries No. 1 to 5

cannot be deleted.

Active Inactive
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Function buttons

OK Validates registration/deletion, and transfers control to the Parts window.

Save Opens the Save As dialog box (p.461).

Saves the displayed registration information to a file (.bit).

Open Opens the Open dialog box (p.463).

Reads registration information from a previously saved file (.bit).

Search Opens reference dialog box. Searches and specifies the bitmap file name to be registered.

Add Registers the specified bitmap file, and displays a sample.

Remove Deletes the specified bitmap file from the registration list.

The deleted bitmap number will be missing.

The default registration file cannot be deleted.

Clear Ignores the setting and closes the window.

Path Sets a certain path in a directory bitmap file registered exist.

Help Displays the Help window that explains the Bitmap Entry window.
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Open Dialog Box

General

This dialog box specifies or selects a file subject to operation.  This dialog box uses the standard Windows dialog

box.

Window

Figure 6-99.  Open Dialog Box

Function

This dialog box searches and opens a specified file.  The file is specified by specifying a drive name, directory

name, and a file type.

The Open dialog box consists of the following areas.

• File location selection area

• File name specification area

• File type selection area

The function of each area is explained below.

(1) File location selection area

(2) File name specification area (3) File type selection area
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(1) File location selection area

Look in: Selects the drive or directory where the specified file exists from the drop-down list.

The files in the specified path are displayed at the lower part of the area.

(2) File name specification area

File name: Inputs a specified file name from the keyboard.

A file name can be also searched by selecting a file name from the list displayed at

the upper part of this area, or by specifying a wild card.

(3) File type selection area

Files of type: Selects the type of the specified file from the drop-down list.

The specified file is displayed at the upper part of the file name specification area.

Function buttons

Open Opens the specified file.

Cancel Ignores the setting and closes the dialog box.
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Save As Dialog Box

General

This dialog box specifies or selects the file to be saved.  This dialog box uses the standard Windows dialog box.

Window

Figure 6-100.  Save As Dialog Box

Function

This dialog box assigns a name to a specified file and saves the file to a specified directory.

The Save As dialog box consists of the following areas.

• Save in selection area

• File name specification area

• File type selection area

The function of each area is explained below.

(1) Save in selection area

(2) File name specification area (3) File type selection area
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(1) Save in selection area

Save in: Selects the drive or directory to which the file to be saved is to be placed from the

drop-down list.

The files in the specified path is displayed at the lower part of the area.

(2) File name specification area

File name: Inputs the name of a file to be specified from the keyboard.  Displays the extension in

the format suitable for the dialog box that is opened by this dialog box.  To overwrite

an already existing file, select a file name from the list displayed at the upper part of

this area, or search a file name by using a wild card.

(3) File type selection area

Save as type: Selects the type of the file to be saved from the drop-down list.

If this dialog box is opened from the input editor window, the unit of wait is specified in

this area.

Function buttons

Save Saves the file to a specified area in the file name specifies the contents.

Cancel Ignores the setting and closes the dialog box.
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Error/Warning Dialog Box Display dialog

(Modal)

General

This dialog box is opened if an error occurs, to inform the user to check the message.

Window

Figure 6-101.  Error/Warning Dialog Box

Function

Contents of the error or warning are displayed in the message display area.

Refer to the list of error messages, if an error occurs.

Function button

OK Closes this dialog box.
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[MEMO]
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APPENDIX  A    DEBUGGING  WITH  SM78K0

This appendix explains the basic debugging operation using the SM78K0.

For the details of each window and dialog box mentioned in this section, refer to CHAPTER 6  WINDOW

REFERENCE.

(1) Setting debug environment

Set the operating environment of debugger.

If a previous debug environment has been loaded to the project file, the debug environment can be restored

by loading that file.  The procedure differs as follows depending on whether the project file is used or not.

(a) When project file is not used

<1> Set all the items in the Configuration dialog box (p.85).

<2> Set the extended options in the Extended Option dialog box (p.89).

<3> Set the debug options in the Debugger Option dialog box (p.94).

Caution Always specify the startup symbol.

(b) When project file is used

• When project file is used at startup

<1> Click  Project  in the Configuration dialog box (p.85).

→ The Project File Load dialog box will open.

<2> Specify the project file name and click  OK .

→ The project file will be loaded.

The following procedure can also be used.

<1> Select [Run] from the Start menu.

<2> Use the  Browse  button to specify the file to be executed, smk032.EXE.

<3> After smk032.EXE, specify the name of the project file to be used

(eg. C:\nectools32\bin\smk032.EXE∆B:\Test\Test1.prj (∆ = space)).

<4> Click  OK .

• When project file is used during debugging

<1> Select [File] → [Project] → [Open…] in the main window, or click the        button.

→ The Project File Load dialog box will open.

<2> Specify the project file name and click  OK .

→ The project file will be loaded.

(2) Download load module file

• Down load the load module file to be debugged.

→ Download dialog box (p.118)

(3) Display disassemble result

Display the result of disassembling the user program downloaded.

→ Assemble window (p.156)

The method of displaying the disassemble display label column and mnemonic column can be changed.

→ Debugger Option dialog box (p.94)
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(4) Display source program

Display the source program.  The program whose source can be debugged must have debug information

compiled with the -g option specified.

→ Source window (p.139)

(a) Setting source path information, display font, and source file extension

→ Debugger Option dialog box (p.94)

(b) Selecting source file

→ Browse dialog box (p.125)

(c) Source file and disassembly

→ Select [View] → [Mix] when the source text file is the current window.

(5) Setting of event

(a) Registering event conditions and event link conditions

→ Event dialog box (p.266)

Event Link dialog box (p.280)

(b) Setting of event conditions

Set event conditions by using the event icons in the Event Manager (p.257) or in the Event Manager area

of various event setting dialog boxes (however, break points can be set in the Source window/Assemble

window).

• Trace event condition

→ Trace dialog box (p.299)

• Break event condition

→ Break dialog box (p.290)

• Timer event condition

→ Timer dialog box (p.335)

• Snap event condition

→ Snap Shot dialog box (p.312)

• Stub event condition

→ Stub dialog box (p.327)

(c) Checking setting of event conditions

→ Event Manager (p.257), the Event Manager area in each event setting dialog box.

(6) Executing user program

By executing the user program, the value of the PC advances to the set break point, break event, or forced

break.

• Types of execution

→ Execution control buttons on the toolbar on Main window (p.59), or [Run] menu
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(7) Checking trace data

→ Trace View window (p.221)

(8) Editing, checking, and changing the contents of memory

→ Memory window  (p.171)

Memory Copy dialog box (p.180)

Memory Fill dialog box (p.178)

Memory Compare dialog box (p.182)

Memory Compare Result dialog box (p.184)

(9) Registering, checking, and changing variables

→ Quick Watch dialog box (p.191)

Add Watch dialog box (p.195)

Watch window (p.186)

Local Variable window (p.215)

(10)Checking the contents of stack

→ Stack window (p.217)

(11)Checking and changing of registered contents of register value

→ Register window (p.198)

SFR window (p.204)

The PC register value can also be confirmed in the Source and Assemble windows.

(12)Checking and changing SFR value

→ SFR window (p.204)

SFR Select dialog box (p.208)

(13)Registering, checking, and changing I/O port value

→ Add I/O Port dialog box (p.212)

SFR window (p.204)

(14)Changing mnemonics and executing online assemble

→ Assemble window (p.156)

Source window (p.139)

(15)Checking simulation time of user program

→ Timer dialog box (p.335)

Timer Result dialog box (p.346)

Trace View window (p.221)

(16)Checking coverage measurement result

→ Coverage window (p.240)

Coverage - Clear dialog box (p.248)

Coverage - Condition Setting dialog box (p.250)

Coverage - Efficiency View dialog box (p.254)
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(17)Searching character string in each window

→ Source Search dialog box (p.153)

Assemble Search dialog box (p.168)

Memory Search dialog box (p.175)

Trace Search dialog box (p.230)

Coverage Search dialog box (p.245)

(18)Referencing “display file” saved in previous debugging process

→ View File Load dialog box (p.110)

(19)Saving screen contents to “display” file during debugging

→ View File Save dialog box (p.113)

(20)Uploading memory contents, coverage results

→ Upload dialog box (p.122)

(21)Saving debug environment to project file

→ Project File Save dialog box (p.107)

(22)Configuring pseudo target system

Set and display the external parts (buttons connected to pins, LEDs, etc.).

→ External Parts Setting dialog box

Parts window (p.385)

(23)I/O data of pins during simulation

(a) Creating, editing input data

→  Input 0/1 Editor window (p.361)

Input timing Chart Editor window (p.367)

(b) Downloading input data

→ Down Load dialog box (p.374)

(c) Outputting to file and displaying output data

→ Output Setting dialog box (p.376)

Output Timing Chart window (p.378)

(24)Initiating action after establishing event conditions

(a) Setting events and actions (creating event condition file)

→  SFR Event & Action window (p.357)

(b) Downloading event condition file

→  Down Load dialog box (p.374)

(25)Terminating SM78K0

→  Exit Debugger dialog box (p.351)
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APPENDIX  B    TERMINOLOGY

Words and window types (refer to CHAPTER 6  WINDOW REFERENCE) used in this document are described

below.

B.1  Terminology

The following words are described in this document.

• Debugging mode

• Current window

• Delimiter symbol (separator)

• Program

• Current program

• File

• Current file

• Function

• Current function

• Structure

• Stack frame number

• Line

• Register name

• Numeric value

• Address

• Symbol

• Expression and operator

• Character set

Each word and the input conventions is explained below.
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(1) Debugging mode

Execution of the user program can be controlled in the following three debugging modes.

• Source mode

Step execution is performed in units of one line of a source text.

• Instruction mode

Step execution is performed in instruction units.

• Auto mode

This mode automatically switches between source mode and instruction mode.

In this mode, when the Source window is active, step execution is performed in units of 1 line of source text

(instruction units for mixed display), and when the Assemble window is active, step execution is performed in

instruction units.  When neither window is active, this mode becomes instruction mode.

These three debugging modes are selected from the “Option menu” of the Main window (p.59).  When

starting the debugger, the automatic mode is selected as the default.

(2) Current window

The current window is the window in which an operation is currently being performed.  In this window,

information can be input from the keyboard and menus can be selected.

(3) Delimiter symbol

A file, function, variable, or line can be specified by using the delimiter symbols listed in Table B-1.

Table B-1.  Delimiter Symbols

Symbol Specification

# Used as a separator between file names and variable/function names and line numbers.

$ Used as a separator between load module names and file, variable, and function names.

(4) Program

A program is the executable unit that is subject to debugging. The SM78K0 deals with each load module file

specified when downloading as one program.  The name of a program is specified by using the name of the

load module file that is downloaded.

(5) Current program

The current program is the program that contains the instruction for a break currently taking place (i.e., the

instruction indicated by the program counter (PC)).

When specifying a file in the current program, specifying the program may be omitted.
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(6) File

The allowable number of characters in a file name are as follows.

• Debugger section: Up to 127 characters in a full pathNote

• Simulator section: Up to 79 characters in a full pathNote

Note Depending on the file type, it may be possible to specify a file name whose length exceeds the

allowable number of characters described above.

(7) Current file

The current file is the source file that has the instruction for a break currently taking place (i.e., the instruction

indicated by the program counter (PC)).

When specifying a line or function in the current file by using a command, the file name can be omitted.

(8) Function

Functions constitute a C source program.

(9) Current function

The current function is the function that has the instruction for a break currently taking place (i.e., the

instruction indicated by the program counter (PC)).  To access a local variable in the current function,

specifying the function name can be omitted.

(10)Structure

Structures and unions of the C language are generically referred to as “structures”.  When a structure or

union variable is used without explicitly specifying a member, the term “structure” is used.

(11)Stack frame number

A stack frame number is a decimal number starting from 1.  The stack contents are displayed numbered.  The

shallower the nesting of the stack, the higher the number.  Therefore, a function having a stack number 1 less

than the stack number of another function calls that function.

(12)Line

A line is specified to identify a certain line in the source file.

Line numbers are specified by an integer constant that starts from 1.

(13)Register name

A register name is specified by the absolute name of a system register or general-purpose register of the

78K/0 Series microprocessors listed in Table B-2, or by the byname of a register.
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Table B-2.  Register Set of 78K/0 Series

Register NameRegister Type

Absolute Name Byname

PC

PSW

Control registers

SP

r0 zero

r1

r2

r3 sp

r4 gp

r5 tp

r6

General-purpose

registers

r7

(14)Numeric value

The following four types of numeric values can be used.

• Binary input format: nY

n…nY (n = 0, 1)

• Octal input format: nO

n…nO (n = 0 to 7)

nQ

n…nQ (n = 0 to 7)

• Decimal input format: n

n…n

nT

n…nT (n = 0 to 9)

• Hexadecimal input format: n

n…n

nH

n…nH

0xn

0xn…n (n = 0 to F)

Cautions 1. Suffixes (Y, O, Q, T, H, 0x) and the alphabet letters in hexadecimal numbers are not case

sensitive.

2. If the first character is one of A to F, a 0 must be affixed in front.

3. The radix in the input column switches between decimal and hexadecimal in

accordance with the default radix.



APPENDIX  B    TERMINOLOGY

User’s Manual  U14611EJ1V0UM00 475

(15)Address

• An address is specified by directly specifying a numeric value.

• An address can also be specified by using a symbol or expression.

• When specifying an address by using a numeric value, hexadecimal, decimal, octal, or binary numbers

can be used.

(16)Symbol

• A symbol consists of characters A to Z, a to z, @, _ (underline), and 0 to 9.

• A symbol must begin with a character other than numerals 0 through 9.

• This software distinguishes between uppercase (A to Z) and lowercase (a to z) characters.

• A symbol can consist of up to 256 characters.

• If a symbol exceeding 256 characters is specified, the first 256 characters are valid.

• A symbol is defined by loading a load module file.

• Symbols can be classified into the following types by the valid range.

(a) Global symbols (assembly language, C language)

(b) Static symbols (C language)

Static symbols in files

Static symbols in functions

(c) Local symbols (C language)

Local symbols in file

Local symbols in function

Local symbols in block

• The following symbols exist in each of the languages used.

(a) Assembly language

Label name

(b) C language

Variable name (including pointer variable name, enumerate type variable name, array name, structure

name, and union name)

Function name, label name

Array element, structure element, union element (if the symbol is an array, structure, or union)

• A symbol can be described instead of an address and numeric value.

• The valid range of symbols is determined based on the source debugging information when the source file

is assembled or compiled.

• A global symbol only describes a symbol name.

• A local symbol is expressed as a pair with a file name.
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(17)Expression and operator

Expression

• An expression consists of constants, register names, SFR name, and symbols combined by operators.

• If an SFR name, label name, function name, or variable name is described as a symbol, an address is

calculated as the value of the symbol.

• Elements constituting an expression, other than operators, are called terms (constants and labels).  Terms

are called the first term, second term, and so on, in the sequence they are described, starting from the one

on the left.

Operator

• The following operators of C language can be used.

Arithmetic operators

Symbol Meaning Remark

+ Addition Returns sum of values of first and second terms.

− Subtraction Returns difference in value between first and second terms.

* Multiplication Returns product of values of first and second terms.

/ Division Divides value of first term by value of second term, and returns integer of

result.

MOD, % Remainder Divides value of first term by value of second term, and returns remainder

of result.

− sign Unary operation (negative) Returns two’s complement of value of term.

+ sign Unary operation (positive) Returns two’s complement of value of term.

Logical operators

Symbol Meaning Remark

NOT

~

Negation NOTs each bit of term, and returns result.

AND

&

Logical product ANDs each bit of values of first and second terms, and returns result.

OR

|

Logical sum ORs each bit of values of first and second terms, and returns result.

XOR

^

Exclusive logical sum Exclusive-ORs each bit of values of first and second terms, and returns

result.

Shift operators

Symbol Meaning Remark

SHR

>>

Right shift Right shifts the first term the amount of the value (bit number) expressed by

the second term and returns the result.  The number of higher bits shifted are

replaced with 0.

SHL

<<

Left shift Left shifts the first term the amount of the value (bit number) expressed by

the second term and returns the result.  The number of lower bits shifted are

replaced with 0.



APPENDIX  B    TERMINOLOGY

User’s Manual  U14611EJ1V0UM00 477

Byte resolution operators

Symbol Meaning Remark

HIGH Higher byte The higher 8 bits of the item’s lower 16 bits are returned.

LOW Lower byte The lower 8 bits of the item’s lower 16 bits are returned.

Word resolution operators

Symbol Meaning Remark

HIGHW Higher word The higher 16 bits of the item’s 32 bits are returned.

LOWW Lower word The lower 16 bits of the item’s 32 bits are returned.

Others

Symbol Meaning Remark

( Left parenthesis

) Right parenthesis

Executes operation in (  ) before operations outside (  ).

Cautions 1. Parentheses “(” and “)” must be always used in pairs.

2. Operations are performed in compliance with the following rules.

• The operation sequence is in accordance with the priority of the operator.

• When the priority of operators is the same, the operation sequence is from left to

right.

• The operation within parentheses is executed before the operations outside the

parentheses.

• Each term of an operation is treated as unsigned 32-bit data.

• All the operation results are treated as unsigned 32-bit data.

• If an overflow occurs as a result of an operation, the lower 32 bits are treated as valid,

and the overflow is not detected.

3. The priority of the operator is as follows.

Priority Operator

1 ↑ (, )

2 Higher + sign, – sign, NOT, ~, HIGH, LOW, HIGHW, LOWW

3 *, /, MOD, %, SHR, >>, SHL, <<

4 +, –

5 Lower AND, &

6 ↓ OR, I, XOR, ^

Term

• The following numeric values can be described when a constant is described as a term.
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(a) Binary

0Y ≤ numeric value ≤ 11111111111111111111111111111111Y (32 digits)

(b) Octal

0O ≤ numeric value ≤ 37777777777O

(c) Decimal

−2147483648 ≤ numeric value ≤ 4294967295

A negative decimal number is internally converted into two’s complement.

(d) Hexadecimal

0H ≤ numeric value ≤ 0FFFFFFFFH

(18)Character set

With the SM78K0, the following character set can be used.

Character set

Symbol Description

Uppercase characters A B C D E F G H I J K L M N O P Q R S T U V W X Y ZAlphabet

character Lowercase characters a b c d e f g h i j k l m n o p q r s t u v w x y z

Numerals 0 1 2 3 4 5 6 7 8 9

Alphabet equivalent characters @ _

Special characters . , : ; * / % + − ‘ “ < > ( ) ! [ ] & \ ^ | − # = $ ? ‘ { }

Other character set

Character Name Main Usage

. Period Direct member operator, bit position specifier

, Comma Delimiter of operands

* Asterisk Multiplication operator or indirect reference operator

/ Slash Division operator

% Percent Remainder operator

+ Plus Addition operator

− Minus Negative sign or subtraction operator

( Left parenthesis Changes operation sequence.

) Right parenthesis Changes operation sequence.

[ Left bracket Array subscript operator base register specification symbol

] Right bracket Array subscript operator base register specification symbol

& Ampersand Address operator or bit product operator

^ Control Bit difference operator

| Vertical line Bit sum operator

– Tilde Complement operator
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B.2  Window Type and Configuration

The SM78K0 debugger consists of windows and dialog boxes.

Basically, a window can be opened by using an icon, while a dialog box cannot.

B.2.1  Windows

Windows are broadly divided into the following 2 types.

• Main windows

• MDI child windows

MDI child windows cannot be displayed outside of the main window frame.

B.2.2  Dialog boxes

Dialog boxes can be classified into the following two types.

• Modal dialog boxes

• Modeless dialog boxes

(1) Modal dialog boxes

When this type of dialog box is open, the user cannot access other windows or dialog boxes until the dialog

box is exited.

When the dialog box is closed after the operation in the dialog box has been completed or by selecting the

 Cancel  button of the dialog box, other windows and dialog boxes can be accessed.

(2) Modeless dialog boxes

Unlike a modal dialog box, the user can access other windows and dialog boxes even if the operation in the

dialog box has not been completed.
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APPENDIX  C    ERROR  MESSAGE  LIST

The SM78K0 displays the following two types of error messages.

Each error message is made up as follows:

• Error of debugger:  Error No.  +  Type  +  Message  .

• Error of simulator:  Message .

Figure C-1.  Display Format of Error Message of Debugger

When the  button is clicked, the Error Message window is closed, and the operation is performed in

accordance with the message.

The error type is identified by the following three uppercase characters.

Table C-1.  Error Message Type

Type Meaning

A Fatal error (Abort Error).

The processing is aborted and the simulator is terminated.  If this error occurs, the

debugging work cannot be continued.

F Syntax error (Fatal Error).

The processing is aborted, and all the windows and dialog boxes are closed.

W Warning.

The processing is aborted.  All the windows and dialog boxes are not closed.

Table C-2 lists the Error Messages of the debugger.

Error number Type Message
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Table C-2.  Error Messages of Debugger (1/20)

Error No. Type Error Message/Meaning

0002 F This feature is not supported.

This function is not supported.

0101 A Cannot find Initialization file (expc.ini).

An initialization file (expc.ini) cannot be found.

0102 A Host name not found.

No host name is found.

0105 A Failed in reading device file (d0xxx.78k).

The device file (d0xxx.78k) could not be correctly read.

0106 A Illegal data received.

Received data is abnormal.

01a0 A No response from the evachip.  Please conform the signal of the CLOCK or RESET, WAIT,

HLDRQ and so on.

There was no response from the evaluation chip.  Check that the RESET, WAIT, HLDRQ (etc)

signals or the clock signal are not abnormal.

01a2 A Break board is not connected.

The BK board is not connected.

01a6 A Executor is running.

The executor is running.

01a8 A Failed in reading initialization file (expc.ini).

The initialize file (expc.ini) has not been correctly read.

01d0 A Failed in starting simulator.

Simulator startup has failed.

01d1 A Not enough memory in starting simulator.

There is not enough memory in starting simulator.

0200 F Verification error.

A verify error.

02a0 F Bus hold error.

The bus is in the hold status.

0300 F User program is running.

The user program is being executed.

0301 F User program is being breaked.

The user program is in break state.

0302 F User program is being traced.

The tracer is operating.

0303 F Not traced.

Tracer measurement is not performed.

0304 F Trace memory is not set.

The tracer is off.

0306 F No trace block exists.

The trace block is missing.

0307 F No event condition exists.

There is no event condition.

0308 F No timer measurement is done.

Timer measurement is not performed.
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Table C-2.  Error Messages of Debugger (2/20)

Error No. Type Error Message/Meaning

0309 F No trigger frame exists.

There is no trigger frame.

030a F Tracer is being stopped.

An attempt is stopped.

030b F Specified snap-event has not been registered.

The snap event to be referenced/deleted is not registered.

030c F Specified stub-event has not been registered.

The snap event to be referenced/deleted is not registered.

030d F Timer is running.

The timer is operating.

030e F Memory copy area is overlapped.

The memory copy range has been overlapped.

030f F Trace has been already set.

Trace is already in the ON status.

0310 F Event condition is not set.

No event condition is set.

0311 F Too many valid timer event conditions.

The number of valid timer event conditions exceeds the maximum settable number.

0312 F Specified timer event is not set.

This timer event not set.

0313 F Illegal map range.

The map setting is wrong.

03a1 F Step execution is being done.

This command is under step execution.

03a2 F Timer and Tracer are running.

The timer and tracer are operating.

03a3 F Linking events and BRS events are mixed.

Linking events and execution events are mixed.

03d0 A Backtrace is being executed.

Back trace is under execution.

03d1 A Backtrace is being stopped.

Back trace is stopped.

03d2 A Backtrace execution point overrun oldest frame.

The back execution stop position exceeds the oldest frame.

03d3 A Illegal AND condition.

AND condition is illegal.

03d4 A No backtrace information exists.

The back trace information does not exist.

03d5 A Last command cannot be backstepped.

Back step of the last instruction could not be performed.

0400 F Illegal condition.

The specified condition is illegal.

0401 F Result of timer measurement overflowed.

The timer measurement result has overflow.
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Table C-2.  Error Messages of Debugger (3/20)

Error No. Type Error Message/Meaning

0402 F Too many event conditions with path count.

Too many event conditions that set path count have been used simultaneously.

0403 F Too many address range conditions.

The maximum value of the address range specification condition is exceeded.

0404 F Too many simultaneously-usable-event conditions.

The maximum number of event conditions that can be used simultaneously is exceeded.

0405 F Too many snap-events.

The maximum number of snap events that can be registered is exceeded.

0406 F Too many stub-events.

The maximum number of stub events that can be registered is exceeded.

0407 F Too many initialization data.

The number of initialized data exceeds the initialization area.

0408 F Too large search data (>16 byte).

The searched data exceed 16 bytes.

0409 F Too large search data (>search range).

The size of the searched data exceeds the size of the search range.

040a F Too many Linking-event conditions.

The maximum number of linking events that can be set is exceeded.

04a0 F Too many software breaks (>100).

The number of software breakpoints exceeds 100.

04a1 F Not enough memory for emulation.

The memory for emulation is insufficient.

04a2 F Too many partition of bus size.

The maximum number of delimiters of bus size has been exceeded.

04a3 F Too many execution-event conditions.

The maximum number of simulation event conditions has been exceeded.

04a4 F Too many bus-event conditions.

The maximum number of bus event conditions has been exceeded.

0600 A Cannot allocate buffer.

A buffer could not be allocated.

1001 A No entry exists for specified number.

The entry of the specified number does not exist.

1002 A Cannot relocate internal RAM.

The internal RAM cannot be relocated.

1003 F Illegal relocation address.

The relocation address is illegal.

1004 F Illegal condition.

The specified condition is illegal.

1005 A Invalid attribute.

The attribute is invalid.

1006 F Illegal address.

The address is illegal.

1008 A Cannot allocate memory for tables.

Memory for tables cannot be allocated.
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Table C-2.  Error Messages of Debugger (4/20)

Error No. Type Error Message/Meaning

1009 A Already initialized.

Already initialized.

100a A Not initialized.

Not initialized yet.

100b F User program is running.

The user program is being executed.

100c F Different bus size has been already specified.

An attempt was made to set in duplicate an area with different bus size.

100d F Too large bus size.

The bus size exceeds the maximum value able to be defined.

100e F Too large bus partition size.

The delimiter of bus size has exceeded the maximum value.

1011 F Failed in setting internal ROM and RAM.

Setting the internal ROM and RAM has failed.

1012 F This feature is not supported.

This function is not supported.

1013 F No terminal name.

This pin name does not exist.

1dbe A Internal error.

Internal error of the debugger.

2000 F Illegal sfr name.

The SFR name is illegal.

2001 A Illegal address.

The address is illegal.

2002 F User program is running.

The user program is being executed.

2003 F Illegal sfr number.

An illegal number of SFRs were specified.

2004 F Illegal bit number.

The bit position is illegal.

2005 W Redraw sfr name.

An SFR that must not be redrawn is specified.

2006 F This sfr is hidden sfr.

An SFR with a hidden attribute was specified.

2007 F Can’t read/write.

A read/write disabled SFR was specified.

2008 F Too big number.

The specified SFR does not exist.

2009 A Error in device file.

A device file error.

200a F Illegal value specified for sfr.

An illegal value was specified for the SFR.
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Table C-2.  Error Messages of Debugger (5/20)

Error No. Type Error Message/Meaning

200b A Cannot copy.

Copying has failed.

200c A Cannot allocate memory.

Memory allocation has failed.

2222 A Illegal condition.

The specified condition is illegal.

3000 F Illegal address.

The address is illegal.

3001 F Memory has different value.

The memory contents do not match.

3002 F Illegal source address.

The source address is illegal.

3003 F Illegal destination address.

The destination address is illegal.

3004 F Illegal address (source & destination).

Both source address and destination address are illegal.

3005 F Illegal condition.

The specified condition is illegal.

3006 F User program is running.

The user program is being executed.

3007 A Verification error.

Verify error.

3008 F No condition specified.

A condition has not been specified.

3009 F Parameter size does not align with access size alignment.

The size of the parameter is not access size alignment.

300a F Specified address does not align with access size alignment.

The specified address is not access size alignment.

300b F Source address does not align with access size alignment.

The specified address (Source) is not access size alignment.

300c F Destination address does not align with access size alignment.

The specified address (Destination) is not access size alignment.

300d F Illegal end address.

The end address is illegal.

300e F Different access size in specified area.

The access size differs in the specified range.

300f F Different access size both in source and destination areas.

The access size differs in the specified range (Source and Destination).

3010 F Different access size in destination area.

The access size differs in the specified range (Destination).

3011 F Different access size, source & destination.

The access size differs between the specified range (source) and specified range (destination).
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Table C-2.  Error Messages of Debugger (6/20)

Error No. Type Error Message/Meaning

3012 A Cannot allocate memory.

Memory allocation has failed.

3013 A Failed in writing DMM.

Writing DMM has failed.

3014 F Overflowed mapping area.

The mapping area is exceeded.

3015 A Interrupted.

Processing is aborted.

3016 F This feature is not supported.

This function is not supported.

4000 F Cannot delete specified event number.

The specified event number cannot be deleted.

4001 F Illegal table number.

The specified table number is illegal.

4002 F Illegal start address.

The start address is illegal.

4003 F Illegal end address.

The end address is illegal.

4004 F Illegal status.

The status is illegal.

4005 F Illegal data.

The data is illegal.

4006 F Specified event number has been already used.

An attempt was made to specify an event number that has already been used.

4007 F Too many same events are registered.

The maximum of the number of registered events of the same type is exceeded.

4008 F Specified event has not been registered.

The specified event is not registered.

4009 F Illegal data size.

The data size is illegal.

400a F Illegal mode.

The mode is illegal.

400b F Illegal condition.

The specified condition is illegal.

400c F Illegal type.

The type is illegal.

400d F Too many identical events are registered (> = 32767).

An attempt was made to make registration exceeding 32,767 of the same registered events.

400e F Specified event condition does not exist.

The specified event condition does not exist.

400f F Illegal event link condition.

An event condition is illegal.
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Table C-2.  Error Messages of Debugger (7/20)

Error No. Type Error Message/Meaning

4010 F Function not found.

The specified function was not found.

4011 F Not enough memory.

Application has run out of memory.

4012 F Timer is being disabled.

The timer is invalid.

4013 W Access size is different from its mapped bus size.

The access size and mapped bus size differ.

4014 F Cannot use software break.

Software break cannot be used.

4015 F Cannot use event condition specifying address range.

An  event condition with a range specified cannot be used for an address condition.

4016 F Cannot change event condition.

The event condition cannot be changed.

4017 F Cannot access word at odd address.

Word access to an odd address cannot be performed.

4018 A Not enough memory.

Application has run out of memory.

4019 F Not support.

This function is not supported.

401a F No Event.

There is no event.

401b F Cannot use tag-event.

A tag event cannot be used.

4318 F Illegal memory bank setting.

The setting of the memory bank is illegal.

5000 A Illegal type.

The type is illegal.

5001 A Cannot allocate memory.

Memory allocation has failed.

5002 A Cannot open device file.

Opening the device file has failed.

5003 A Cannot seek device file.

Seeking the device file has failed.

5004 A Cannot close device file.

Closing the device file has failed.

5005 A Illegal device file format.

The format of the device file is wrong.

5007 A Device information does not exist.

Device information is missing.

5008 F Cannot open device file.

The specified device file cannot be opened.

500a F Specified device file is illegal version.

The version of the device file is illegal.
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Table C-2.  Error Messages of Debugger (8/20)

Error No. Type Error Message/Meaning

500b W Specified device file does not relocate IRAM.

The device file that was specified does not relocate IRAM.

500c A Failed in reading expc.ini.

The initialization file (expc.ini) cannot be correctly read.

500d A Not enough memory.

The memory has run short.

5300 A Illegal type.

The type is illegal.

5301 A Cannot allocate memory.

Memory allocation has failed.

5302 A Cannot open database file.

The database file could not be opened.

5303 A Cannot seek database file.

The database file could not be searched.

5304 A Cannot close database file.

The database file could not be closed.

5305 A Illegal device format.

The format of the database file is illegal.

5306 A Database information has been already initialized.

Initialization of the database information is already finished.

5307 A Database information does not exist.

There is no database information.

5308 F Cannot open specified database file.

The specified database file could not be opened.

5309 F Specified database file is illegal version.

This version of the database file is illegal.

6000 F Current function does not exist.

The current function does not exist.

6001 F Illegal symbol name.

The symbol name is illegal.

6002 F Illegal condition.

The specified condition is illegal.

6003 F Illegal function name.

The function name is illegal.

6004 F Overflowed output buffer size.

The data size exceeds that of the output buffer.

6005 F Illegal expression.

The expression is illegal.

7000 F Illegal mode.

The specified mode is wrong.

7001 F User program is running.

The user program is being executed.
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Table C-2.  Error Messages of Debugger (9/20)

Error No. Type Error Message/Meaning

7002 F User program has been stopped.

The user program is being stopped.

7003 F Trace enabled.

Trace is being executed.

7004 F Trace memory is not set.

The trace memory is OFF.

7005 F Function return address does not exist, cannot do step execution.

The return address of the function does not exist.  Step execution is not performed.

7010 W No Source information exists.

The source information is missing.

7011 W Unknown result of step execution.

The result of step execution is unknown.

7012 A Not enough memory.

Application has run out of memory.

70fe A Bus hold error.

The bus is in the hold status.

7801 F Canceled step wait.

The wait status following completion of step execution has been cancelled.

7802 F Interrupted step execution.

Step execution processing was aborted.

7f00 F Aborted step execution.

Step execution processing was forcibly terminated.

7f02 F Suspended step execution.

Step execution was aborted.

7f03 A Failed in canceling RUN/STEP.

Canceling RUN/STEP has failed.

7f04 F Cannot execute non-mapped area.

An attempt is made to execute from an area not mapped.

7f05 F This feature is not supported.

This function is not supported.

8000 F File not found.

The specified file is not found.

8001 F Illegal line number.

The line number is illegal.

8002 F Current information is not set.

The current information is not set.

8003 F Illegal address.

The address is illegal.

8004 F This feature is not supported.

This function is not supported.

9000 A Specified register symbol does not exist.

The specified register symbol does not exist.
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Table C-2.  Error Messages of Debugger (10/20)

Error No. Type Error Message/Meaning

9001 A Specified register symbol ID does not exist.

The specified register symbol ID does not exist.

9002 F Illegal value.

The specified value is illegal.

9003 A Illegal condition.

The specified condition is illegal.

9004 A Too large register size.

The register size is too big.

9005 F This feature is not supported.

This function is not supported.

a001 F Illegal expression.

The expression is illegal.

a002 F Start address is bigger than the end address.

The start and end address specifications have been reversed.

a003 F Illegal source path.

The specified source path information is illegal.

a004 F Too long expression.

The expression is too long.

a005 A Not enough memory.

Application has run out of memory.

a006 F Illegal argument.

The argument is illegal.

a007 A Illegal program number.

The program number is wrong.

a008 F Source path is not set.

The source path is not set.

a009 F File not found.

The file is not found.

a00a F Cannot open file.

Opening the file has failed.

a00b A Cannot close file.

Closing the file has failed.

a00c A Failed in reading file.

Reading the file has failed.

a00d F Not source file of load module.

This is not the load module’s source file.

a00e F Illegal line number.

The line number is illegal.

a00f F Variable does not exist.

The variable does not exist.

a011 F Cannot access register.

The register cannot be accessed.
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Table C-2.  Error Messages of Debugger (11/20)

Error No. Type Error Message/Meaning

a012 F Cannot access memory.

The memory (variable) cannot be accessed.

a013 A Cannot seek file.

Seeking a file has failed.

a014 F This is binary file.

This is a binary file.

a015 F Cannot get temporary path.

A temporary path could not be allocated.

a016 F Cannot create temporary file.

A temporary file could not be created.

a017 F Cannot remove temporary file.

A temporary file could not be deleted.

a020 F This feature is not supported.

This function is not supported.

a021 F Specified symbol is assigned to register

The specified symbol has already been assigned to a register.

b000 F Illegal command line.

The command line is illegal.

b001 F Program information does not exist in specified load module file.

The load module file does not have program information.

b002 F File not found.

The file is not found.

b003 F Function not found.

The function is not found.

b004 F Illegal magic number.

The magic number is illegal.

b005 F Symbol not found.

The symbol is not found

b008 F Illegal expression.

The expression is illegal.

b009 A Not enough memory.

Application has run out of memory.

b00a F Illegal symbol in load module file.

An illegal symbol exists in the load module file.

b00b F Current program does not exist.

The current program does not exist.

b00c F Current file does not exist.

The current file does not exist.

b00d A Current function does not exist.

A current function does not exist.

b00e A Current line does not exist.

A current line does not exist.
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Table C-2.  Error Messages of Debugger (12/20)

Error No. Type Error Message/Meaning

b00f A Tag not found.

No tag is found.

b010 A Failed in loading symbol table.

Loading the symbol table has failed.

b011 A Illegal line number.

The line number is illegal.

b012 F Too large line number.

The line number is too large.

b015 A Failed in reading file.

Reading the file has failed.

b016 A Cannot open file.

Opening the file has failed.

b017 A Failed in writing file.

Writing the file has failed.

b019 A Cannot seek file.

Seeking the file has failed.

b01a A Cannot close file.

Closing the file has failed.

b01b A Too long load module file name.

The file name of the load module is too long.

b01c A Too many entries of the task kind.

There are too many task classification entries.

b01d F Address not found.

The address does not exist.

b01e W No line information (not compile with -g).

There is no line information (it was not compiled using –g).

b01f F Cannot find structure member.

The member of the structure cannot be found.

b020 F Cannot find value.

The value could not be found.

b021 F No symbol information exists in load module file.

The load module file does not have symbol information.

b022 F Illegal line number.

The line number is illegal.

b023 A Current stack frame is not active.

The current stack frame is not active.

b024 A Different section.

The section is wrong.

b026 F Too many array dimensions (>4).

The displayed dimension exceeds the fourth dimension.

b027 F Found end of file.

The file ends in the middle.
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Table C-2.  Error Messages of Debugger (13/20)

Error No. Type Error Message/Meaning

b028 F This feature is not supported.

This function is not supported.

b029 F Illegal address.

The address is illegal.

b02b F Cannot stack with current PC value.

Stack trace cannot be executed with the current PC value.

b02c F Too many blocks for one function.

The maximum number of blocks allowable in 1 function has been exceeded.

b02d F Illegal argument.

The argument passed to the function is illegal.

b02e A Path not found.

The specified path is not found.

b02f A Information has been deleted because of optimization.

Information has been deleted as a result of optimization.

b030 A Monitor timed out.

Time out of the monitor.

b031 A Already set in memory.

Already set on the memory.

b032 A Out of scope.

Out of scope.

b033 A LP is not stored.

LP has not been stored.

b034 A Inside of prologue or epilogue.

Within the prologue or epilogue.

b036 W Out of variable region.

The specified variable cannot be referenced by the current PC.

b037 F Too Many Line-Numbers Information.

There is too much line information.

b038 F Compiler version mismatch.

Because this compiler version is not supported, the debug information could not be loaded.

b039 A Failed in loading debug information.

The debug information could not be loaded.

b03a A No more section information.

There is no section information.

b040 A Specified file is not load module.

The specified file is not in a load module format.

b041 A Too many files in load module to download.

The number of files in the load module exceeds the maximum number the debugger can handle.

b042 W Symbol module is not initialized.

The SYM module has not been initialized.

b32e F Illegal port number.

An illegal port number.
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Table C-2.  Error Messages of Debugger (14/20)

Error No. Type Error Message/Meaning

b32f F Illegal port name.

An illegal port name.

b330 F Illegal port position.

The bit position of the specified port is illegal.

b331 F Illegal increment number.

The specified increment count is illegal.

b332 F Port for memory bank is not set.

The number of ports for memory bank is not set.

b333 F Illegal bank number.

An illegal bank number is specified.

b334 F Area for memory bank is not set.

An area for memory bank is not set.

b335 W Too long symbol name.

The symbol name is longer than the maximum allowable length.

c001 F Cannot open file.

Opening the file has failed.

c002 A Cannot close file.

Closing the file has failed.

c003 A Failed in reading file.

Reading the file has failed.

c004 A Cannot seek file.

Seeking the file has failed.

c005 F Illegal file type.

A non-existent file type has been specified.

c006 F Illegal magic number.

The magic number is illegal.

c007 F Specified file is not load module.

The specified file is not a load module file.

c008 F Specified load module file (ELF) is old version.

The version of the load module file (ELF) is old.

c009 F Not enough memory.

Application has run out of memory.

c00a F Illegal address.

The address is illegal.

c00b F Load Module is not loaded.

The load module is not loaded.

c00c F Illegal argument.

This is an internal error.

c00d F User program is being emulated.

The user program is being emulated.

c00e F User program is being traced.

The use program is being traced.
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Table C-2.  Error Messages of Debugger (15/20)

Error No. Type Error Message/Meaning

c00f A Interrupted.

Under processing.

c011 F Illegal load module file format.

The format of the load module file is wrong.

c012 F Check sum error.

A check sum error has occurred.

c013 F Too wide address range to upload (>1 Mbyte)

The address range to be uploaded exceeds 1 Mbyte.

c014 F Failed in writing file.

Writing the file has failed.

c015 F Illegal program number.

The program number is illegal.

c016 F Load information is full.

The load information is full.

c017 W Symbol information is duplicated, please reset symbols.

The symbol information overlaps.  Reset the symbol.

c018 F Specified file is not load module.

The specified file is not in a load module format.

c019 F Failed in writing memory.

Memory could not be written to.

c100 F This feature is not supported.

This feature is not supported.

d000 A Internal error.

An error occurs inside the debugger.

d001 A Not enough memory.

Application has run out of memory.

d002 A Failed in reading initialization file (expc.ini).

The initialization file (expc.ini) cannot be read correctly.

d004 A Cannot find Dynamic Link Library.

The dynamic link library could not be found.

e000 F Illegal argument.

The argument is illegal.

e001 F Illegal start address.

The start address is illegal.

e002 F Illegal end address.

The end address is illegal.

e003 F Too large size.

The address size is too large.

e004 F Cannot open file.

Opening the file has failed.

e005 F Failed in reading file.

Reading the file has failed.



APPENDIX  C    ERROR  MESSAGE  LIST

User’s Manual  U14611EJ1V0UM00 497

Table C-2.  Error Messages of Debugger (16/20)

Error No. Type Error Message/Meaning

e006 F Cannot seek file.

Seeking the file has failed.

e007 F Failed in writing file.

Writing the file has failed.

e008 F Not enough memory.

Application has run out of memory.

e009 F Illegal file format.

The file format is wrong.

e00a F Verification error.

Verify error.

e010 F This feature is not supported.

This feature is not supported.

f000 F Not enough memory

Application has run out of memory

f001 F XXX not found.

XXX could not be found.

f002 F XXX not found.  Search from the beginning?

XXX could not be found.  Do you want to search from the beginning?

f003 W Already exceed search region.

The search range has already been exceeded.

f004 F Missing parameter.

Missing parameter.

f005 F Illegal name.

The name is illegal.

f006 F Illegal number.

The number is illegal.

f007 F Start address is bigger than end address.

Start address is bigger than end address.

f008 F Illegal expression

The expression is illegal.

f009 F XXX This file is illegal type.

XXX This file is an illegal type.

f100 F Disk cannot write or full.

Either the disk could not be written to or it is full.

f101 F File not found.

This file could not be found.

f102 F File not Create.

This file could not be created.

f103 F Old file version.

This file is an old version.

f104 F Illegal file type.

The file format is illegal.
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f105 F This file is a project file for XXX.  Please select a correct file.

This project file is a file for XXX.  Specify a correct file.

f200 W No differences encountered.

There were no differences found.

f201 F Memory mapping error.

The memory could not be mapped.

f202 F Verify error.

Verify error.

f300 F Would you like to save the changes made in XXX?

Do you want the changes made in XXX to be saved?

f301 F The symbol being used on the event condition can’t be evaluated.

The symbol being used in the event condition could not be evaluated.

f302 F Delete XXX?

Do you want XXX to be deleted?

f303 F XXX is edited.  Delete YYY?

XXX is being edited; do you want YYY to be deleted?

f304 F XXX is edited.  Save YYY?

XXX is being edited; do you want YYY to be saved?

f305 F XXX is already exist.  Do you replace it?

Do you want to replace the existing XXX?

f306 F This name is too long.

This name is too long.

f307 F There is the same name in other kinds.

The same name is being used in other conditions.

f308 F An address can’t be omitted.

An address cannot be omitted.

f309 F Illegal address mask.

The address mask is illegal.

f30a F Illegal data mask.

The data mask is illegal.

f30b F Illegal ext. probe mask.

The external probe mask is illegal.

f30c F Illegal ext. probe data.

The external probe data is illegal.

f30d F Illegal pass count.

The pass count is illegal.

f30e F Illegal register name.

The register name is illegal.

f30f F Illegal register bank.

The register bank is illegal.

f310 F Illegal delay count.

The delay count is illegal.
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Table C-2.  Error Messages of Debugger (18/20)

Error No. Type Error Message/Meaning

f311 F Only one XXX can be enabled.  Do you make this YYY to enable?

Only one XXX can be enabled; do you want to enable YYY?

f312 F XXX is already there.

XXX already exists.

f313 F Event number already exist.

This event number already exists.

f314 F Event name is not set.

The event name has not been set.

f315 F XXX is already there.

XXX already exists.

f316 F Max number of XXX enabled event is over.  Please disable other enabled event.

The maximum allowable number of valid event conditions has been exceeded. Disable all other

event conditions.

f317 F Max number of set event is over.

The maximum number of settable event conditions has been exceeded.

f318 F Max number of set event link is over.

The maximum number of settable event link conditions has been exceeded.

f319 F Max number of set break event is over.

The maximum number of settable break conditions has been exceeded.

f31a F Max number of set trace event is over.

The maximum number of settable trace conditions has been exceeded.

f31b F Max number of set snap event is over.

The maximum number of settable snap conditions has been exceeded.

f31c F Max number of set stub event is over.

The maximum number of settable stub conditions has been exceeded.

f31d F Max number of set timer event is over.

The maximum number of settable timer conditions has been exceeded.

f31e F Illegal start address.

The start address is illegal.

f31f F Illegal end address.

The end address is illegal.

f320 F Illegal bit address.

The bit address is illegal.

f321 F Specified read-protect sfr.

A read-protected SFR has been specified.

f322 F Illegal count rate.

The resolution is illegal.

f323 F Illegal time out break count.

The value set for time-out break is illegal.

f324 F Section and qualify can not be specified at the same time.

Section and Qualify cannot be specified at the same time.

f350 F There is a phase which event are not in the middle.

An event condition setting is missing from the middle of a phase.
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f351 F The same event is contained in Link and Disable.

The same event condition is already being used.

f352 F An event isn’t specified.

An event condition has not been set.

f353 F Incompatible event is specified in phase 1.

An incompatible event condition has been set in Phase 1.

f354 F AND event is in Phase 1.  Can’t specify event with exception of phase 1.

An AND condition event has already been set in Phase 1.  Event conditions cannot be set

anywhere except in Phase 1.

f355 F REG/MEM event in Disable.

The REG/MEM status event has been set to disable.

f356 F AND event is in Disable.

The AND event has been set to disable.

f400 F Coverage mapping error.

Coverage mapping could not be performed.

f401 F Clear coverage?

Do you want to clear the coverage clear?

f500 F Illegal symbol.

The symbol is illegal.

f501 F Illegal value.

The value is illegal.

f502 F Illegal parameter.

The parameter is illegal.

f503 F Max number of symbol is over.

The maximum number of variables that can be displayed has been exceeded.

f600 F Save project file?

Do you want to save the project file?

f700 F Download failed.

Data could not be downloaded.

f800 F Configuration of Memory Bank is not set.

The memory bank setting has not been made.

f801 F BANK address must be in target memory.

The address of the memory bank must be inside the target memory.

f802 F All events are deleted because the use of external probe was changed.

All event conditions have been deleted because the external probe has changed.

f803 F This event address is invalid on current configuration.

The address of this event condition is illegal.

f804 F Invalid PC value.

The PC value is illegal.

f805 F Cannot set temporary break on this address.

A temporary break cannot be set to this address.

f806 F External data is being used by Debugger.

External data is being used by the debugger.
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Error No. Type Error Message/Meaning

f900 F Missing parameter.

The name is illegal.

f901 F Memory mapping error.

There is a fault with the memory mapping

f902 F Illegal access size.

The access size is illegal.

f903 F Illegal access type.

The access type is illegal.

f904 F There is the same name.

The same name has already been registered.

f905 W XXX is already exist.  Do you replace it?

Do you want to replace the existing XXX?

f906 W Would you like to register the change made in XXX?

Do you want to register the changes made to XXX?

fa00 F The “main(  )” function of current program on PC position not found.

The function “main(  )” of the PC position program could not be found.

fa01 F The line information on PC position not found.

The line information of the PC position could not be found.

fe0b F It shift to the flash mode.  Is it completely cleared but is the present event. Doesn’t it care?

Shifts to Flash self mode.  All of the present events will be disabled. Is this OK?

A list of the simulator section error messages is shown in Table C-3.
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Error Message Description/Action

AVref is above/under operating

voltage range

Set AVref to within the operating supply voltage range.

AVref is not set.  AVref is set

5.0V, continue?

AVref has not been set.

Set AVref.

An error occurred during DC

Motor Port Setting window

creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Could not create DC Motor

Display window

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

An error occurred during FIPs

window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Could not allocate FIP display

table

Memory could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

An error occurred during GDI

object creating

A bitmap could not be drawn correctly in configure mode in the Parts window.

Delete unnecessary applications, then restart.

SFR name (xxxxxxxx) is not

correct

The SFR name entered in the SFR Event & Action window is invalid.

Enter a valid SFR name.

An error occurred during LCD Port

Setting window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Could not allocate LCD display

table

Memory could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

An error occurred during LED Port

Setting window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Could not create LED Display

window

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Could not allocate LED display

table

Memory could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

An error occurred during PLL

Information Window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

This will end SFR Event & Action

Setting Dialog

The cancel button was clicked.

Check the message and operation.

An error occurred during 7

Segment LED Port Setting

window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

An error occurred during covering

of the 7 segment LED

The 7-segment display could not be drawn correctly.

Delete unnecessary applications, then restart.

An error occurred during drawing

of the 7 segment LED

The 7-segment display could not be drawn correctly.

Delete unnecessary applications, then restart.

An error occurred during the

creation of the brush for the 7

segment LED

The handle of the brush could not be allocated.

Delete unnecessary applications, then restart.

An error occurred during the

selection of the brush for the 7

segment LED

The 7-segment display could not be drawn correctly.

Delete unnecessary applications, then restart.
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Table C-3.  Simulator Section Error Message List (2/7)

Error Message Description/Action

An error occurred during the

creation of the pen for the 7

segment LED

The handle of the pen could not be allocated.

Delete unnecessary applications, then restart.

An error occurred during the

selection of the pen for the 7

segment LED

The 7-segment display could not be drawn correctly.

Delete unnecessary applications, then restart.

Could not create 7 Segment LED

Display window

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Cannot Group 7/14 Segment An attempt was made to select and group a 7/14 segment LED

Remove the 7/14 segment LED then group.

An error occurred during 14

Segment LED Port Setting

window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

An error occurred during covering

of the 14 segment LED

The 14-segment display could not be drawn correctly.

Delete unnecessary applications, then restart.

An error occurred during drawing

of the 14 segment LED

The 14-segment display could not be drawn correctly.

Delete unnecessary applications, then restart.

An error occurred during the

creation of the brush for the 14

segment LED

The handle of the pen could not be allocated.

Delete unnecessary applications, then restart.

An error occurred during the

selection of the brush for the 14

segment LED

The 14-segment display could not be drawn correctly.

Delete unnecessary applications, then restart.

An error occurred during the

creation of the pen for the 14

segment LED

The handle of the pen could not be allocated.

Delete unnecessary applications, then restart.

An error occurred during the

selection of the pen for the 14

segment LED

The 14-segment display could not be drawn correctly.

Delete unnecessary applications, then restart.

An error occurred during drawing

of the 14 segment LED

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Access size (xxxxxxxx) is not

correct

The access size entered in the SFR Event & Action window is invalid.

Enter a valid access size.

No settings exist for the active

bitmap file

No active bitmap file has been set in the Bitmap Entry window.

Set an active bitmap file.

The active and inactive bitmap file

names are the same, continue?

In the Bitmap Entry window, the same name is specified for both an active bitmap file and

inactive bitmap file.

Specify different names for the active bitmap and inactive bitmap files.

Accessed a port used as

address/data bus.  Do you want to

continue simulation?

A pin used for an address/data bus was accessed as a port.

Access a pin that can be used as a port.

Address (xxxxxxxx) is not correct The address entered in the SFR Event & Action window falls outside the specifiable range.

Enter an address that falls within the specifiable range.

Editing the analog output data is

not permitted

An attempt was made to edit the data of an analog output signal.

Check the message and operation.
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Table C-3.  Simulator Section Error Message List (3/7)

Error Message Description/Action

Cannot search analog output data An attempt was made to use the Search window to edit the retrieval data of an analog

output signal.

Check the message and operation.

Cannot search analog output data An attempt was made to edit the retrieval data of an analog output signal.

Check the message and operation.

Cannot search analog input data An attempt was made to use the Search window to edit the retrieval data of an analog input

signal.

Check the message and operation.

Search window is already

displayed

An attempt was made to open two instances of the Search window at the same time.

Cancel the instance of the Search window that already exists, and then open a new one.

An error occurred during Key Port

Setting window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

No key matrix present Either no input pin or no output pin has been set in the Key Matrices dialog box.

Set one or more input pins, and one or more output pins.

Column signal setting is invalid No pin name has been described for column signals.

Alternatively, the pin names for column signals are missing.

Make pin settings for column signals consecutively starting from the lowest column.

Could not find searching data No matching data was found during retrieval using the Search window.

Check the message.

Data during creation was lost The  Open  button was clicked during data editing.

Check the message and operation.

The selected pin name is already

set

An attempt was made to set a pin that has already been set in the Buttons window again.

Do not set an already set pin again.

Set a bitmap file.

The selected bitmap file is invalid The bitmap file name specified in the Bitmap Entry window does not represent a bitmap

file.

Set a bitmap file.

The selected bitmap file does not

exist

Neither an active nor inactive bitmap file name can be found in the Bitmap Entry window.

Set an existing bitmap file name.

A pin not supported in the chip

under simulation was accessed.

Do you want to continue

simulation?

A pin that does not exist on the chip being simulated was accessed.

Use a pin that exists on the chip undergoing simulation.

Editing the output data is not

permitted

An attempt was made to edit output signal data.

Check the message and operation.

Cannot search output signal An attempt was made to use the Search window to edit the retrieval data of an output

signal.

Check the message and operation.

This will close output timing chart The  Cancel  button was clicked in the Output Timing Chart window.

Check the message and operation.

Could not allocate output data

buffer

Output data buffer space could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

An error occurred in output data

display.  Simulation stopped

An error occurred during output data display in the Output Timing Chart window.

Check and correct the state of the disk to ensure that a file can be created normally.
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Error Message Description/Action

An error occurred during output

file operation.  Simulation stopped

An output file manipulation error occurred.

Check and correct the state of the disk to ensure that a file can be created normally.

Failed to write to output file Output file write failed.

Check and correct the state of the disk to ensure that a file can be created normally.

Failed to open output file Output file open failed.

Check and correct the state of the disk to ensure that a file can be created normally.

Status (xxxxxxxx) is not correct The status entered in the SFR Event & Action window is invalid.

Enter a valid status.

An error occurred during Serial

Data window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

This will initialize all data The  Clear  button was clicked.

Check the message and operation.

Accessed a port used as control

signal output.  Do you want to

continue simulation?

A pin used for the control signal output function was accessed as a port.

Access a pin that can be used as a port.

Segment signal setting is invalid No pin names have been described for segment signals.

Alternatively, the pin names for segment signals are missing.

Set all of the 8 (or 15) pin names for segment signals.

The selected pin is not an analog

input pin

A pin that does not support analog input has been set.

Set a pin for analog input.

Setting Data is invalid An invalid frequency was set in the PLL information window.

Set a valid frequency.

Timing value (xxxxxxxx) is not

correct

The timing value entered in the SFR Event & Action window falls outside the specifiable

range.

Enter a timing value that falls within the specifiable range.

Timing unit (xxxxxxxx) is not

correct

The timing unit entered in the SFR Event & Action window is invalid.

Enter a valid timing unit.

This will initialize all download

data

None of the types of the files to be loaded was selected in the Down Load dialog box.

Check the message and operation.

The connection to pin (xxxx) will

change

An event occurred that changes the object that feeds data to the pin; or an external part

was connected to the pin.

Check the message.

This will overwrite download data

of pin (xxxx)

Data for a single pin has been set in more than one file, by using the Down Load dialog

box.

Check the message and operation.

Pin name (xxxxxxxx) has already

been specified

The same pin name has been specified more than once in the Pin Setting dialog box.

Set a pin at one point only.

Pin name (xxxxxxxx) is not correct An invalid pin name has been set.

Set a valid pin name.

The data is empty An attempt was made to save an empty file.

Create data.

Data (xxxxxxxx) is not correct The data value entered in the SFR Event & Action window falls outside the specifiable

range.

Enter a data value that falls within the specifiable range.
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Accessed a port used as data

bus.  Do you want to continue

simulation?

A pin used for a data bus was accessed as a port.

Access a pin that can be used as a port.

Data mask (xxxxxxxx) is not

correct

The data mask value entered in the SFR Event & Action window falls outside the

specifiable range.

Enter a data mask value that falls within the specifiable range.

Please start from the debugger Started from SM78K0.EXE.

Start from ID78K0S.EXE.

An error occurred during Internal

Interrupt Button Setting window

creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

This will close Input 0/1 Editor The  Cancel  button was clicked in the Input 0/1 Editor window.

Check the message and operation.

This will close Input timing Chart

Editor

The  Cancel  button was clicked in the Input timing Chart Editor window.

Check the message and operation.

Failed to load input data Input data could not be loaded.

Allocate sufficient memory by deleting unnecessary applications.

Could not allocate input data

buffer

Input data buffer space could not be allocated at download.

Allocate sufficient memory by deleting unnecessary applications.

There is no data for loading in

input data file

An input data file was loaded in its entirety.

Add desired input data to the input data file.

Could not open input data file.  Do

you want to continue simulation?

Input data file open failed.

Check whether the file exists, or check the contents of the file.

Could not allocate system

memory for input data loading

System memory for loading input data could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

Pass count (xxxxxxxx) is not

correct

The pass count value entered in the SFR Event & Action window falls outside the

specifiable range.

Enter a pass count value that falls within the specifiable range.

The path is illegal An invalid path was specified when a bitmap was registered.

Specify a correct path.

Failed to restore output file pointer

during backtrace execution.  Do

you want to continue simulation?

An attempt to restore an output file pointer during backward trace failed.

Check and correct the state of the disk to ensure that a file can be created normally.

Failed to restore input file pointer

during backtrace execution.  Do

you want to continue simulation?

An attempt to restore an input file pointer during backward trace failed.

Check and correct the state of the disk to ensure that a file can be created normally.

Data cannot be input from

external devices during backtrace

execution

An attempt was made to enter data from an external part during backward trace.

Never enter data from an external part during backward trace.

Could not allocate bitmap

association table

Memory required for the Bitmap Entry window could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

The number of registered bitmaps

exceeds 384

More than 384 bitmaps have been registered in the Bitmap Entry window.

Register no more than 384 bitmaps.



APPENDIX  C    ERROR  MESSAGE  LIST

User’s Manual  U14611EJ1V0UM00 507

Table C-3.  Simulator Section Error Message List (6/7)

Error Message Description/Action

The bitmap ID is a 2-byte ID A bitmap number has been described using two-byte characters in the Bitmap Entry

window.

Set the bitmap number using single-byte characters.

LCD segment/grid setting is

above/under the range

FIP segment/grid setting is

above/under the range

The Display range of the display segment or the display timing output range has not been

set.

Specify the display range of the display segment or display timing output range.

LCD segment/grid setting is

invalid

FIP segment/grid setting is invalid

An illegal value has been set for the display segment or display timing output range.

Set the correct display segment or display timing output range.

Cannot overwrite file File write failed.

Check and correct the state of the disk to ensure that a file can be created normally.

Cannot create file File creation using the Down Load dialog box failed.

Check and correct the state of the disk to ensure that a file can be created normally.

The file type is not correct An attempt was made to save a file with an incorrect extension.

Save the file with a correct extension specified.

Cannot read file File read failed.

Check whether the file exists, or check the contents of the file.

This file is renamed to (xxxxxxxx) The format of a file name entered in the Down Load dialog box is invalid.

Check the message and operation.

The file name is not correct An invalid file name has been specified.

Specify a valid file name.

The file name or the path is not

correct

A nonexistent file name has been specified.

Specify a valid file name or path name.

Please input file name The  OK  button was pressed without entering a file name in the Down Load dialog box.

Enter a file name.

Could not make buzzer sound A soundboard and a speaker are not provided.

Install a soundboard and a speaker.

An error occurred during Buzzer

Select window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Could not create Buzzer Display

window

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Illegal pin name (xxxxxxxx) exists An invalid pin name has been set in the Pin Setting dialog box.

Set a valid pin name.

An error occurred during Button

Port Setting window creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Hold time is invalid A hold time falling outside the specifiable range has been set, or a value other than a

number has been specified.

Set a hold time of between 0.001 ms and 999 ms.

Hold time is not set.  Hold time is

set to 0.5 msec

No hold time has been set.

Set a hold time.

This function is not supported in

this version

An attempt was made to use a function that is currently not supported.

Check the message and operation.
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Table C-3.  Simulator Section Error Message List (7/7)

Error Message Description/Action

The main clock and sub clock

cannot be set to 0Hz at the same

time

0 Hz has been set for both the main clock and subclock.

Set a value other than 0 Hz for either the main clock or the subclock.

An error occurred during memory

allocation

Memory could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

Cannot allocate memory Memory could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

Could not allocate memory Memory required for the SFR Event & Action window could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

The number of registered

text/line/rectangles exceeded 20

The number of character strings, lines, or rectangles entered in the Parts window exceeded

20.

Terminate the input of characters, lines, or rectangles.

Could not get address of user’s

function

A user DLL called a function (UpCallFuncName, UpLoadProjName, UpSaveProjName, or

UpResetFuncName), but it could not be found.

Alternatively, no EXPORTS declaration has been made for the function.

Create a function name specified in the simulation call function, or make an EXPORTS

declaration in the def file.

An error occurred during user’s

DLL loading

The user DLL to be opened was invalid.

Use a correct user DLL.

An error occurred during user DLL

reading

The user DLL to be read was invalid.

Use a correct user DLL.

Could not create Reset Button

window

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Allocation error Memory could not be allocated.

Allocate sufficient memory by deleting unnecessary applications.

An error occurred during Port

Level Gauge Setting window

creation

There are insufficient window handles.

Allocate sufficient window handles by deleting unnecessary applications, then restart.

Editing the interrupt data is not

permitted

An attempt was made to edit interrupt signal data.

Check the message and operation.

Cannot search interrupt data An attempt was made to use the Search window to edit the retrieval data of an interrupt

signal.

Check the message and operation.

Interrupt name (xxxxxxxx) is not

correct

The interrupt request name entered in the SFR Event & Action window is invalid.

Enter a valid interrupt request name.
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APPENDIX  D    KEY  FUNCTION  LIST

Efficient debugging can be realized by performing operations using the special function keys.

Note that because the key explanations differ depending on the type of keyboard in IBM PC/AT compatible

machines, the key inscriptions employed here are general or generic key inscriptions.

D.1  Special Function Key Function List

A list of the special function key functions of the PC-9821 series and IBM PC/AT compatibles is shown in the table

below.

Table D-1.  Special Function Key Function List (1/2)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  BS  .   BackSpace  . Deletes the character preceding the cursor and moves the cursor to the position of the

deleted character.  At this time, the string of characters following the cursor moves

back one space.

  DEL  .   Delete  . • Deletes the character at the cursor position and moves the following characters back

one space.

• Deletes the event conditions selected in the Event Manager and each event dialog

box.

• Deletes the data selected in the Watch window.

  INS  .   Insert  . Switches the modes between insert mode and overwrite mode in the Source and

Assemble windows.  However, this key is disabled in the Memory, Register, and SFR

windows, where the input mode is overwrite mode only.

  COPY  .   PrintScreen  . Places the entire screen display on the clipboard as a bitmap image (Windows

function).

  ESC  .   Esc  . • Closes a pull-down menu.

• Closes a modal dialog box.

• Restores input data.

  GRPH  .   Alt  . Moves the cursor on the menu bar.

  HELP  .   End  . Moves the cursor to the end of the line.

  HOME CLR  .   Home  . Moves the cursor to the start of the line.

  ROLL DOWN  .   PageUp  . Scrolls the screen up one screen.

Simultaneously moves the cursor to the top of the screen.

  ROLL UP  .   PageDown  . Scrolls the screen down one screen.

Simultaneously moves the cursor to the top of the screen.

  SPACE  .   Space  . Inserts a 1-character space.

  TAB  .   Tab  . Moves the cursor to the next item.

  ↑  .   ↑  . Moves the cursor up.

When the cursor is at the top of the screen, the screen is scrolled down one line at a

time.
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Table D-1.  Special Function Key Function List (2/2)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  ↓  .   ↓  . Moves the cursor down.

When the cursor is at the bottom of the screen, the screen is scrolled up one line at a

time.

  ←  .   ←  . Moves the cursor to the left.

When the cursor is on the far left of the screen, the screen is scrolled to the right one

item at a time.

  →  .   →  . Moves the cursor to the right.

When the cursor is on the far right of the screen, the screen is scrolled to the left one

item at a time.

  ↵  .   ↵  . Sets the input data.

D.2  Function Key Function List

A list of the function key functions of the PC-9821 series and IBM PC/AT compatibles is shown in the table below.

Table D-2.  Function Key Function List (1/2)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  f·1  .   F1  . Opens the Help window.

  f·2  .   F2  . Forcibly stops program execution.

The same function as [Run] → [Stop] on the menu bar.

  f·3  .   F3  . Resets the emulation CPU.

The same function as [Run] → [CPU Reset] on the menu bar.

  f·4  .   F4  . Executes the program after resetting the emulation CPU.

The same function as [Run] → [Restart] on the menu bar.

  f·5  .   F5  . Executes the program.

The same function as [Run] → [Go] on the menu bar.

  f·6  .   F6  . Executes the program as far as the cursor position in the Source or Assemble window.

The same function as [Run] → [Come Here] on the menu bar.

  f·7  .   F7  . Executes the program in real-time until execution returns to the calling origin.

The same function as [Run] → [Return Out] on the menu bar.

  f·8  .   F8  . Performs step execution.

The same function as [Run] → [Step In] on the menu bar.

  f·9  .   F9  . Sets/Cancels a breakpoint at the cursor position in the Source or Assemble window.

The same function as [Run] → [Break Point] on the menu bar.
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Table D-2.  Function Key Function List (2/2)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  f·10  .   F10  . Performs next step execution.

The same function as [Run] → [Next Out] on the menu bar.

  vf·2  .   F12  . Enables/disables a breakpoint.

The same function as [Run] → [Ignore Break Point] on the menu bar.

D.3  Special Function Key Function List (  SHIFT   + Key)

A list of the special function key functions (  SHIFT   + key) of the PC-9821 series and IBM PC/AT compatibles is

shown in the table below.

Table D-3.  Special Function Key Function List (  SHIFT   + Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  HELP  .   End  . Extends the selected range to the end of the line.

  HOME CLR  .   Home  . Extends the selected range to the start of the line.

  ←  .   ←  . Extends the selected range one character to the left.

  →  .   →  . Extends the selected range one character to the right.

D.4  Function Key Function List (  SHIFT   + Key)

A list of the function key functions (  SHIFT   + key) of the PC-9821 series and IBM PC/AT compatibles is shown in

the table below.

Table D-4.  Function Key Function List (  SHIFT   + Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  f·6  .   F6  . Executes the program from the cursor position in the Source or Assemble window.

The same function as [Run] → [Start From Here] on the menu bar.
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D.5  Special Function Key Function List (  CTRL   + Key)

A list of the special function key functions (  CTRL   + key) of the PC-9821 series and IBM PC/AT compatibles is

shown in the table below.

Table D-5.  Special Function Key Function List (  CTRL   + Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  HELP  .   End  . Displays the last line.  Simultaneously moves the cursor to the start of the last line.

  HOME CLR  .   Home  . Displays the first line.  Simultaneously moves the cursor to the start of the first line.

  ←  .   ←  . Moves the cursor one word to the left.  When the cursor is on the far left of the screen,

the screen is scrolled one item to the right.

  →  .   →  . Moves the cursor one word to the right.  When the cursor is on the far right of the

screen, the screen is scrolled one item to the left.

D.6  Function Key Function List (  CTRL   + Key)

A list of the function key functions (  CTRL   + key) of the PC-9821 series and IBM PC/AT compatibles is shown in

the table below.

Table D-6.  Function Key Function List (  CTRL   + Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  f·9  .   F9  . Sets the address of the cursor position in the Source or Assemble window in the PC.

The same function as [Run] → [Change PC] on the menu bar.

D.7  Control Key Function List (  CTRL   + Key)

A list of the control key functions (  CTRL   + key) of the PC-9821 series and IBM PC/AT compatibles is shown in

the table below.

Table D-7.  Control Key Function List (  CTRL   + Key) (1/2)

Key Type

PC-9821 Series

IBM PC/AT Compatibles

Function

  D  . Shows a disassemble display from the jump destination address of the data value selected in the

current window.  Opens the Assemble window.

The same function as [Jump] → [Assemble] on the menu bar.

  C  . Copies the selected character string and places it in the clipboard buffer.

The same function as [Edit] → [Copy] on the menu bar.
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Table D-7.  Control Key Function List (  CTRL   + Key) (2/2)

Key Type

PC-9821 Series

IBM PC/AT Compatibles

Function

  G  . Performs a search.  Opens the search dialog box appropriate to the current window.

The same function as [View] → [Search…] on the menu bar.

  I  . Displays the memory contents from the jump destination address of the data value selected in the

current window.  Opens the Coverage window.

The same function as [Jump] → [Coverage] on the menu bar.

  J  . Moves the display position.  Opens the Source Move, Address Move, and Trace Move dialog box

appropriate to the current window.

The same function as [View] → [Move…] on the menu bar.

  M  . Displays the memory contents from the jump destination address of the data value selected in the

current window.  Opens the Memory window.

The same function as [Jump] → [Memory] on the menu bar.

  O  . Loads a display, source, or text file.

Opens the Display File Load dialog box.  Operations differ depending on the file extension.

For display files: Displayed in corresponding window.

For other files: Displayed in Source Text window.

Same as [File] → [Open…] on the menu bar.

  U  . Displays the corresponding source text and source line from the jump destination address of the

data value selected in the current window.  Opens the Source Text window.

The same function as [Jump] → [SourceText] on the menu bar.

  V  . Pastes the contents of the clipboard buffer at the cursor position.

Same function as [Edit] → [Paste] on the menu bar.

  W  . Temporarily displays the contents of the specified data.  Opens the Quick Watch dialog box.

The same function as [View] → [Quick Watch…] on the menu bar.

  X  . Removes the selected character string and places it on the clipboard.

Same function as [Edit] → [Cut] on the menu bar.

D.8  Special Function Key Function List (  CTRL   +   SHIFT   Key)

A list of the special function key functions (  CTRL   +   SHIFT   key) of the PC-9821 series and IBM PC/AT

compatibles is shown in the table below.

Table D-8.  Special Function Key Function List (  CTRL   +   SHIFT   Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  ←  .   ←  . Extends the selected range one word to the left.

  →  .   →  . Extends the selected range one word to the right.
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